6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
24 %define name wx
-%{portname}-unicode
25 %define wxbasename wx
-base
-unicode
27 %define name wx
-%{portname}
28 %define wxbasename wx
-base
32 %define wxconfigname wx
%{portname}u-%{ver2}-config
34 %define wxconfigname wx
%{portname}-%{ver2}-config
38 Summary: The GTK
+ %{gtkver} port of the wxWindows library
41 License: wxWindows Licence
43 Source: wxGTK
-%{ver}.tar.bz2
44 URL: http
://www.wxwindows.org
45 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
47 BuildRoot: /var
/tmp
/%{name}-root
49 # all packages providing an implementation of wxWindows library (regardless of
50 # the toolkit used) should provide the (virtual) wxwin package, this makes it
51 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
55 # in addition, we should provide libwx_gtk as automatic generator only notices
56 # libwx_gtk-%{ver}-%{rel}
57 Provides: libwx_gtk.so
58 Provides: libwx_gtk
-%{ver2}.so
60 Requires: %{wxbasename} = %{ver}
63 wxWindows is a free C
++ library
for cross
-platform GUI development.
64 With wxWindows
, you can create applications
for different GUIs
(GTK
+,
65 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
68 Summary: The GTK
+ %{gtkver} port of the wxWindows library
70 Requires: %{name} = %{ver}
71 Requires: %{wxbasename}-devel = %{ver}
75 Header files
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
78 Summary: The GTK
+ %{gtkver} port of the wxWindows library
, OpenGL add
-on.
80 Requires: %{name} = %{ver}
83 OpenGL add
-on library
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
86 Summary: wxGTK static libraries
87 Group: Development
/Libraries
88 Requires: %{wxbasename}-static
91 Static libraries
for wxGTK. You need them
if you want to link statically against wxGTK.
94 Summary: The GTK
+ %{gtkver} port of the wxWindows library
, contributed libraries.
96 Requires: %{name} = %{ver}
99 Contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
101 %package contrib
-devel
102 Summary: The GTK
+ %{gtkver} port of the wxWindows library
104 Requires: %{name}-contrib = %{ver}
105 Requires: %{name}-devel = %{ver}
107 %description contrib
-devel
108 Header files
for contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
111 %setup -q
-n wxGTK
-%{ver}
114 if [ "$SMP"
!= ""
]; then
115 export MAKE
="
make -j$SMP"
122 ..
/configure
--prefix
=%{pref} \
139 ..
/configure
--prefix
=%{pref} --disable
-shared \
153 rm -rf $RPM_BUILD_ROOT
154 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
155 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
157 # Remove headers that are part of wx-base-devel:
159 # --- wxBase headers list begins here ---
160 cat
<<EOF
>wxbase
-headers
-list
274 wx
/protocol
/protocol.h
287 # --- wxBase headers list ends here ---
288 for f
in `cat wxbase
-headers
-list`
; do
289 rm -f $RPM_BUILD_ROOT
%{_includedir}/$f
292 # list of all core headers:
293 find $RPM_BUILD_ROOT
/usr
/include
/wx
-type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
296 (cd obj
-shared
/contrib
/src
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
297 (cd obj
-shared
/contrib
/utils
/wxrc
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
300 rm -rf $RPM_BUILD_ROOT
315 # Install wx-config if there isn't any
316 if test ! -f
%{_bindir}/wx
-config
; then
317 ln
-sf
%{wxconfigname} %{_bindir}/wx
-config
321 # Remove wx-config if it points to this package
322 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
323 SUM1
=`md5sum
%{_bindir}/%{wxconfigname} | cut
-c
0-32`
324 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
325 if test "x$SUM1"
= "x$SUM2"
; then
326 rm -f
%{_bindir}/wx
-config
332 %defattr(-,root
,root
)
333 %doc COPYING.LIB
*.txt
336 %{_libdir}/libwx_%{portname}*_core
*.so.
*
337 %{_libdir}/libwx_%{portname}*_html
*.so.
*
338 %{_libdir}/libwx_%{portname}*_adv
*.so.
*
340 %{_libdir}/libwx_%{portname}*_dbgrid
*.so.
*
343 %files devel
-f core
-headers.files
344 %defattr(-,root
,root
)
345 %{_libdir}/libwx_%{portname}*_core
*.so
346 %{_libdir}/libwx_%{portname}*_html
*.so
347 %{_libdir}/libwx_%{portname}*_adv
*.so
349 %{_libdir}/libwx_%{portname}*_dbgrid
*.so
351 %{_libdir}/libwx_%{portname}*_gl
*.so
354 %{_bindir}/%{wxconfigname}
357 %defattr(-,root
,root
)
358 %{_libdir}/libwx_%{portname}*_gl
*.so.
*
361 %defattr (-,root
,root
)
362 %{_libdir}/libwx_gtk
*.a
365 %defattr(-,root
,root
)
366 %{_libdir}/libwx_%{portname}*_animate
*.so.
*
367 %{_libdir}/libwx_%{portname}*_deprecated
*.so.
*
368 %{_libdir}/libwx_%{portname}*_fl
*.so.
*
369 %{_libdir}/libwx_%{portname}*_gizmos
*.so.
*
370 %{_libdir}/libwx_%{portname}*_mmedia
*.so.
*
371 %{_libdir}/libwx_%{portname}*_ogl
*.so.
*
372 %{_libdir}/libwx_%{portname}*_plot
*.so.
*
373 %{_libdir}/libwx_%{portname}*_stc
*.so.
*
374 %{_libdir}/libwx_%{portname}*_svg
*.so.
*
375 %{_libdir}/libwx_%{portname}*_xrc
*.so.
*
378 %defattr(-,root
,root
)
380 %dir %{_includedir}/wx
/animate
381 %{_includedir}/wx
/animate
/*
382 %{_libdir}/libwx_%{portname}*_animate
*.so
384 %dir %{_includedir}/wx
/deprecated
385 %{_includedir}/wx
/deprecated
/*
386 %{_libdir}/libwx_%{portname}*_deprecated
*.so
388 %dir %{_includedir}/wx
/fl
389 %{_includedir}/wx
/fl
/*
390 %{_libdir}/libwx_%{portname}*_fl
*.so
392 %dir %{_includedir}/wx
/gizmos
393 %{_includedir}/wx
/gizmos
/*
394 %{_libdir}/libwx_%{portname}*_gizmos
*.so
396 %dir %{_includedir}/wx
/mmedia
397 %{_includedir}/wx
/mmedia
/*
398 %{_libdir}/libwx_%{portname}*_mmedia
*.so
400 %dir %{_includedir}/wx
/ogl
401 %{_includedir}/wx
/ogl
/*
402 %{_libdir}/libwx_%{portname}*_ogl
*.so
404 %dir %{_includedir}/wx
/plot
405 %{_includedir}/wx
/plot
/*
406 %{_libdir}/libwx_%{portname}*_plot
*.so
408 %dir %{_includedir}/wx
/stc
409 %{_includedir}/wx
/stc
/*
410 %{_libdir}/libwx_%{portname}*_stc
*.so
412 %dir %{_includedir}/wx
/svg
413 %{_includedir}/wx
/svg
/*
414 %{_libdir}/libwx_%{portname}*_svg
*.so
416 %dir %{_includedir}/wx
/xrc
417 %{_includedir}/wx
/xrc
/*
418 %{_libdir}/libwx_%{portname}*_xrc
*.so