added debugrpt.cpp and dbgrptg.cpp
[wxWidgets.git] / wxGTK.spec
1 %define pref /usr
2 %define ver 2.5.4
3 %define ver2 2.5
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 %if %{gtk2}
16 %define gtkver 2
17 %define portname gtk2
18 %else
19 %define gtkver 1.2
20 %define portname gtk
21 %endif
22
23 %if %{unicode}
24 %define name wx-%{portname}-unicode
25 %define wxbasename wx-base-unicode
26 %else
27 %define name wx-%{portname}
28 %define wxbasename wx-base
29 %endif
30
31 %if %{unicode}
32 %define wxconfigname %{portname}-unicode-release-%{ver2}
33 %define wxconfiglinkname wx%{portname}u-%{ver2}-config
34 %else
35 %define wxconfigname %{portname}-ansi-release-%{ver2}
36 %define wxconfiglinkname wx%{portname}-%{ver2}-config
37 %endif
38
39 Name: %{name}
40 Summary: The GTK+ %{gtkver} port of the wxWindows library
41 Version: %{ver}
42 Release: %{rel}
43 License: wxWindows Licence
44 Group: X11/Libraries
45 Source: wxGTK-%{ver}.tar.bz2
46 URL: http://www.wxwindows.org
47 Packager: Vadim Zeitlin <vadim@wxwindows.org>
48 Prefix: %{pref}
49 BuildRoot: /var/tmp/%{name}-root
50
51 # all packages providing an implementation of wxWindows library (regardless of
52 # the toolkit used) should provide the (virtual) wxwin package, this makes it
53 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
54 Provides: wxwin
55 Provides: wxGTK
56
57 # in addition, we should provide libwx_gtk as automatic generator only notices
58 # libwx_gtk-%{ver}-%{rel}
59 Provides: libwx_gtk.so
60 Provides: libwx_gtk-%{ver2}.so
61
62 Requires: %{wxbasename} = %{ver}
63
64 %description
65 wxWindows is a free C++ library for cross-platform GUI development.
66 With wxWindows, you can create applications for different GUIs (GTK+,
67 Motif/LessTif, MS Windows, Mac) from the same source code.
68
69 %package devel
70 Summary: The GTK+ %{gtkver} port of the wxWindows library
71 Group: X11/Libraries
72 Requires: %{name} = %{ver}
73 Requires: %{wxbasename}-devel = %{ver}
74 Provides: wxGTK-devel
75
76 %description devel
77 Header files for wxGTK, the GTK+ %{gtkver} port of the wxWindows library.
78
79 %package gl
80 Summary: The GTK+ %{gtkver} port of the wxWindows library, OpenGL add-on.
81 Group: X11/Libraries
82 Requires: %{name} = %{ver}
83
84 %description gl
85 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWindows library.
86
87 %package static
88 Summary: wxGTK static libraries
89 Group: Development/Libraries
90 Requires: %{wxbasename}-static
91
92 %description static
93 Static libraries for wxGTK. You need them if you want to link statically against wxGTK.
94
95 %package contrib
96 Summary: The GTK+ %{gtkver} port of the wxWindows library, contributed libraries.
97 Group: X11/Libraries
98 Requires: %{name} = %{ver}
99
100 %description contrib
101 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWindows library.
102
103 %package contrib-devel
104 Summary: The GTK+ %{gtkver} port of the wxWindows library
105 Group: X11/Libraries
106 Requires: %{name}-contrib = %{ver}
107 Requires: %{name}-devel = %{ver}
108
109 %description contrib-devel
110 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWindows library.
111
112 %prep
113 %setup -q -n wxGTK-%{ver}
114
115 %build
116 if [ "$SMP" != "" ]; then
117 export MAKE="make -j$SMP"
118 else
119 export MAKE="make"
120 fi
121
122 mkdir obj-shared
123 cd obj-shared
124 ../configure --prefix=%{pref} \
125 %if %{unicode}
126 --enable-unicode \
127 %else
128 --with-odbc \
129 %endif
130 %if ! %{gtk2}
131 --disable-gtk2 \
132 %endif
133 --with-opengl
134 $MAKE
135 cd contrib/src
136 $MAKE
137 cd ../../..
138
139 mkdir obj-static
140 cd obj-static
141 ../configure --prefix=%{pref} --disable-shared \
142 %if %{unicode}
143 --enable-unicode \
144 %else
145 --with-odbc \
146 %endif
147 %if ! %{gtk2}
148 --disable-gtk2 \
149 %endif
150 --with-opengl
151 $MAKE
152 cd ..
153
154 %install
155 rm -rf $RPM_BUILD_ROOT
156 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
157 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
158
159 # Remove headers that are part of wx-base-devel:
160
161 # --- wxBase headers list begins here ---
162 cat <<EOF >wxbase-headers-list
163 wx/afterstd.h
164 wx/app.h
165 wx/apptrait.h
166 wx/archive.h
167 wx/arrimpl.cpp
168 wx/arrstr.h
169 wx/beforestd.h
170 wx/buffer.h
171 wx/build.h
172 wx/chkconf.h
173 wx/clntdata.h
174 wx/cmdline.h
175 wx/confbase.h
176 wx/config.h
177 wx/containr.h
178 wx/datetime.h
179 wx/datetime.inl
180 wx/datstrm.h
181 wx/dde.h
182 wx/debug.h
183 wx/debugrpt.h
184 wx/defs.h
185 wx/dir.h
186 wx/dlimpexp.h
187 wx/dynarray.h
188 wx/dynlib.h
189 wx/dynload.h
190 wx/encconv.h
191 wx/event.h
192 wx/except.h
193 wx/features.h
194 wx/ffile.h
195 wx/file.h
196 wx/fileconf.h
197 wx/filefn.h
198 wx/filename.h
199 wx/filesys.h
200 wx/fontenc.h
201 wx/fontmap.h
202 wx/fs_mem.h
203 wx/fs_zip.h
204 wx/hash.h
205 wx/hashmap.h
206 wx/hashset.h
207 wx/html/forcelnk.h
208 wx/iconloc.h
209 wx/init.h
210 wx/intl.h
211 wx/iosfwrap.h
212 wx/ioswrap.h
213 wx/ipc.h
214 wx/ipcbase.h
215 wx/isql.h
216 wx/isqlext.h
217 wx/list.h
218 wx/listimpl.cpp
219 wx/log.h
220 wx/longlong.h
221 wx/math.h
222 wx/memconf.h
223 wx/memory.h
224 wx/memtext.h
225 wx/mimetype.h
226 wx/module.h
227 wx/msgout.h
228 wx/msgout.h
229 wx/mstream.h
230 wx/object.h
231 wx/platform.h
232 wx/process.h
233 wx/ptr_scpd.h
234 wx/regex.h
235 wx/scopeguard.h
236 wx/snglinst.h
237 wx/sstream.h
238 wx/stack.h
239 wx/stackwalk.h
240 wx/stdpaths.h
241 wx/stockitem.h
242 wx/stopwatch.h
243 wx/strconv.h
244 wx/stream.h
245 wx/string.h
246 wx/sysopt.h
247 wx/textbuf.h
248 wx/textfile.h
249 wx/thread.h
250 wx/thrimpl.cpp
251 wx/timer.h
252 wx/tokenzr.h
253 wx/txtstrm.h
254 wx/types.h
255 wx/uri.h
256 wx/utils.h
257 wx/variant.h
258 wx/vector.h
259 wx/version.h
260 wx/volume.h
261 wx/wfstream.h
262 wx/wx.h
263 wx/wxchar.h
264 wx/wxprec.h
265 wx/xti.h
266 wx/xtistrm.h
267 wx/zipstrm.h
268 wx/zstream.h
269 wx/msw/apptrait.h
270 wx/msw/apptbase.h
271 wx/msw/chkconf.h
272 wx/msw/crashrpt.h
273 wx/msw/dde.h
274 wx/msw/debughlp.h
275 wx/msw/gccpriv.h
276 wx/msw/mimetype.h
277 wx/msw/stackwalk.h
278 wx/msw/winundef.h
279 wx/msw/wrapcctl.h
280 wx/msw/wrapwin.h
281 wx/fs_inet.h
282 wx/gsocket.h
283 wx/protocol/file.h
284 wx/protocol/ftp.h
285 wx/protocol/http.h
286 wx/protocol/protocol.h
287 wx/sckaddr.h
288 wx/sckipc.h
289 wx/sckstrm.h
290 wx/socket.h
291 wx/url.h
292 wx/msw/gsockmsw.h
293 wx/xml/xml.h
294 wx/xtixml.h
295 wx/db.h
296 wx/dbkeyg.h
297 wx/dbtable.h
298 EOF
299 # --- wxBase headers list ends here ---
300 for f in `cat wxbase-headers-list` ; do
301 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-*/$f
302 done
303
304 # list of all core headers:
305 find $RPM_BUILD_ROOT/usr/include/wx-* -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
306
307 # contrib stuff:
308 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
309 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
310
311 # remove wxBase files so that RPM doesn't complain about unpackaged files:
312 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
313 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
314 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
315 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
316
317 %clean
318 rm -rf $RPM_BUILD_ROOT
319
320 %post
321 /sbin/ldconfig
322
323 %postun
324 /sbin/ldconfig
325
326 %post gl
327 /sbin/ldconfig
328
329 %postun gl
330 /sbin/ldconfig
331
332 %post devel
333 # link wx-config when you install RPM.
334 ln -sf %{_libdir}/wx/config/%{wxconfigname} %{_bindir}/wx-config
335 # link wx-config with explicit name.
336 ln -sf %{_libdir}/wx/config/%{wxconfigname} %{_bindir}/%{wxconfiglinkname}
337
338 %preun devel
339 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
340 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfigname} | cut -c 0-32`
341 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
342 if test "x$SUM1" = "x$SUM2" ; then
343 rm -f %{_bindir}/wx-config
344 fi
345 fi
346
347 rm -f %{_bindir}/%{wxconfiglinkname}
348
349 %files
350 %defattr(-,root,root)
351 %doc COPYING.LIB *.txt
352 %{_libdir}/libwx_%{portname}*_core*.so.*
353 %{_libdir}/libwx_%{portname}*_html*.so.*
354 %{_libdir}/libwx_%{portname}*_adv*.so.*
355 %{_libdir}/libwx_%{portname}*_media*.so.*
356 %if !%{unicode}
357 %{_libdir}/libwx_%{portname}*_dbgrid*.so.*
358 %endif
359
360 %files devel -f core-headers.files
361 %defattr(-,root,root)
362 %{_libdir}/libwx_%{portname}*_core*.so
363 %{_libdir}/libwx_%{portname}*_html*.so
364 %{_libdir}/libwx_%{portname}*_adv*.so
365 %{_libdir}/libwx_%{portname}*_media*.so
366 %if !%{unicode}
367 %{_libdir}/libwx_%{portname}*_dbgrid*.so
368 %endif
369 %{_libdir}/libwx_%{portname}*_gl*.so
370 %dir %{_libdir}/wx
371 %{_libdir}/wx/*
372
373 %files gl
374 %defattr(-,root,root)
375 %{_libdir}/libwx_%{portname}*_gl*.so.*
376
377 %files static
378 %defattr (-,root,root)
379 %{_libdir}/libwx_gtk*.a
380
381 %files contrib
382 %defattr(-,root,root)
383 %{_libdir}/libwx_%{portname}*_animate*.so.*
384 %{_libdir}/libwx_%{portname}*_deprecated*.so.*
385 %{_libdir}/libwx_%{portname}*_fl*.so.*
386 %{_libdir}/libwx_%{portname}*_gizmos*.so.*
387 %{_libdir}/libwx_%{portname}*_mmedia*.so.*
388 %{_libdir}/libwx_%{portname}*_ogl*.so.*
389 %{_libdir}/libwx_%{portname}*_plot*.so.*
390 %{_libdir}/libwx_%{portname}*_stc*.so.*
391 %{_libdir}/libwx_%{portname}*_svg*.so.*
392 %{_libdir}/libwx_%{portname}*_xrc*.so.*
393
394 %files contrib-devel
395 %defattr(-,root,root)
396 %{_bindir}/wxrc*
397 %dir %{_includedir}/wx-*/wx/animate
398 %{_includedir}/wx-*/wx/animate/*
399 %{_libdir}/libwx_%{portname}*_animate*.so
400
401 %dir %{_includedir}/wx-*/wx/deprecated
402 %{_includedir}/wx-*/wx/deprecated/*
403 %{_libdir}/libwx_%{portname}*_deprecated*.so
404
405 %dir %{_includedir}/wx-*/wx/fl
406 %{_includedir}/wx-*/wx/fl/*
407 %{_libdir}/libwx_%{portname}*_fl*.so
408
409 %dir %{_includedir}/wx-*/wx/gizmos
410 %{_includedir}/wx-*/wx/gizmos/*
411 %{_libdir}/libwx_%{portname}*_gizmos*.so
412
413 %dir %{_includedir}/wx-*/wx/mmedia
414 %{_includedir}/wx-*/wx/mmedia/*
415 %{_libdir}/libwx_%{portname}*_mmedia*.so
416
417 %dir %{_includedir}/wx-*/wx/ogl
418 %{_includedir}/wx-*/wx/ogl/*
419 %{_libdir}/libwx_%{portname}*_ogl*.so
420
421 %dir %{_includedir}/wx-*/wx/plot
422 %{_includedir}/wx-*/wx/plot/*
423 %{_libdir}/libwx_%{portname}*_plot*.so
424
425 %dir %{_includedir}/wx-*/wx/stc
426 %{_includedir}/wx-*/wx/stc/*
427 %{_libdir}/libwx_%{portname}*_stc*.so
428
429 %dir %{_includedir}/wx-*/wx/svg
430 %{_includedir}/wx-*/wx/svg/*
431 %{_libdir}/libwx_%{portname}*_svg*.so
432
433 %dir %{_includedir}/wx-*/wx/xrc
434 %{_includedir}/wx-*/wx/xrc/*
435 %{_libdir}/libwx_%{portname}*_xrc*.so