1 # RPM .spec file for wxMotif. Based on the .spec file for wxGTK
2 # (c) by Robert Roebling. Modifications (c) 2000/03 by Robert Fendt.
4 # Note that this is NOT a relocatable package
10 %define portname motif
11 %define name wx
-%{portname}
12 %define wxbasename wx
-base
13 %define wxconfigname wx
%{portname}-%{ver2}-config
15 Summary: The Motif
/Lesstif port of the wxWindows library
19 License: wxWindows Licence
21 Source: wxMOTIF
-%{ver}.tar.bz2
22 URL: http
://www.wxwindows.org
23 Packager: Robert Fendt
<rfendt@myokay.net
>
24 BuildRoot: /tmp
/wxmotif_root
26 # all packages providing an implementation of wxWindows library (regardless of
27 # the toolkit used) should provide the (virtual) wxwin package, this makes it
28 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
33 Requires: %{wxbasename} = %{ver}
36 wxWindows is a free C
++ library
for cross
-platform GUI development.
37 With wxWindows
, you can create applications
for different GUIs
(GTK
+,
38 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
41 Summary: The Motif
/Lesstif port of the wxWindows library
43 Requires: %{name} = %{ver}
44 Requires: %{wxbasename}-devel = %{ver}
47 Header files
for wxMotif
, the Motif
/Lesstif port of the wxWindows library.
50 Summary: The Motif
/Lesstif port of the wxWindows library
, OpenGL add
-on.
52 Requires: %{name} = %{ver}
55 OpenGL add
-on library
for wxMotif
, the Motif
/Lesstif port of the wxWindows library.
58 Summary: wxMotif static libraries
59 Group: Development
/Libraries
62 Static libraries
for wxMotif. You need them
if you want to link statically against wxMotif.
65 %setup -q
-n wxMOTIF
-%{ver}
68 if [ "$SMP"
!= ""
]; then
69 export MAKE
="
make -j$SMP"
76 ..
/configure
--prefix
=%{pref} --with
-odbc
--with
-opengl
--with
-motif
82 ..
/configure
--prefix
=%{pref} --disable
-shared
--with
-odbc
--with
-opengl
--with
-motif
87 rm -rf $RPM_BUILD_ROOT
88 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
89 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
91 # Remove headers that are part of wx-base-devel:
93 # --- wxBase headers list begins here ---
94 cat
<<EOF
>wxbase
-headers
-list
206 wx
/protocol
/protocol.h
219 # --- wxBase headers list ends here ---
220 for f
in `cat wxbase
-headers
-list`
; do
221 rm -f $RPM_BUILD_ROOT
%{_includedir}/$f
224 # list of all core headers:
225 find $RPM_BUILD_ROOT
/usr
/include
/wx
-type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
229 rm -rf $RPM_BUILD_ROOT
244 # Install wx-config if there isn't any
245 if test ! -f
%{_bindir}/wx
-config
; then
246 ln
-sf
%{wxconfigname} %{_bindir}/wx
-config
250 # Remove wx-config if it points to this package
251 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
252 SUM1
=`md5sum
%{_bindir}/%{wxconfigname} | cut
-c
0-32`
253 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
254 if test "x$SUM1"
= "x$SUM2"
; then
255 rm -f
%{_bindir}/wx
-config
261 %defattr(-,root
,root
)
262 %doc COPYING.LIB
*.txt
265 %{_libdir}/libwx_%{portname}*_core
*.so.
*
266 %{_libdir}/libwx_%{portname}*_html
*.so.
*
267 %{_libdir}/libwx_%{portname}*_adv
*.so.
*
268 %{_libdir}/libwx_%{portname}*_dbgrid
*.so.
*
270 %files devel
-f core
-headers.files
271 %defattr(-,root
,root
)
272 %{_libdir}/libwx_%{portname}*_core
*.so
273 %{_libdir}/libwx_%{portname}*_html
*.so
274 %{_libdir}/libwx_%{portname}*_adv
*.so
275 %{_libdir}/libwx_%{portname}*_dbgrid
*.so
276 %{_libdir}/libwx_%{portname}*_gl
*.so
279 %{_bindir}/%{wxconfigname}
282 %defattr(-,root
,root
)
283 %{_libdir}/libwx_%{portname}*_gl
*.so.
*
286 %defattr (-,root
,root
)
287 %{_libdir}/libwx_%{portname}*.a