made wxApp::argv an object convertible to either char** or wchar_t** for better compa...
[wxWidgets.git] / wxX11.spec
1 %define pref /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define portname x11univ
12
13 %if %{unicode}
14 %define wxbasename wx-base-unicode
15 %define name wx-%{portname}-unicode
16 %define wxconfig %{portname}-unicode-release-%{ver2}
17 %define wxconfiglink wx%{portname}u-%{ver2}-config
18 %else
19 %define wxbasename wx-base
20 %define name wx-%{portname}
21 %define wxconfig %{portname}-ansi-release-%{ver2}
22 %define wxconfiglink wx%{portname}-%{ver2}-config
23 %endif
24
25 Summary: The X11 port of the wxWidgets library
26 Name: %{name}
27 Version: %{ver}
28 Release: %{rel}
29 License: wxWindows Licence
30 Group: X11/Libraries
31 Source: wxX11-%{ver}.tar.bz2
32 URL: http://www.wxwidgets.org
33 Packager: Vadim Zeitlin <vadim@wxwindows.org>
34 Prefix: %{pref}
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
37
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
41 Provides: wxwin
42 Provides: wxX11
43
44 %description
45 wxWidgets is a free C++ library for cross-platform GUI development.
46 With wxWidgets, you can create applications for different GUIs (GTK+,
47 Motif/LessTif, MS Windows, Mac) from the same source code.
48
49 %package devel
50 Summary: The X11 port of the wxWidgets library
51 Group: X11/Libraries
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
54
55 %description devel
56 Header files for wxX11, the X11 port of the wxWidgets library.
57
58 %package gl
59 Summary: The X11 port of the wxWidgets library, OpenGL add-on.
60 Group: X11/Libraries
61 Requires: %{name} = %{ver}
62
63 %description gl
64 OpenGL add-on library for wxX11, the X11 port of the wxWidgets library.
65
66 %package static
67 Summary: wxX11 static libraries
68 Group: Development/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
71
72 %description static
73 Static libraries for wxX11. You need them if you want to link statically against wxX11.
74
75 %package contrib
76 Summary: Contrib libraries for wxX11.
77 Group: X11/Libraries
78 Requires: %{name} = %{ver}
79
80 %description contrib
81 Contributed libraries for wxX11.
82
83 %package contrib-devel
84 Summary: Contrib libraries for wxX11.
85 Group: X11/Libraries
86 Requires: %{name}-contrib = %{ver}
87 Requires: %{name}-devel = %{ver}
88
89 %description contrib-devel
90 Header files for contributed libraries for wxX11.
91
92 %prep
93 %setup -q -n wxX11-%{ver}
94
95 %build
96 if [ "$SMP" != "" ]; then
97 export MAKE="make -j$SMP"
98 else
99 export MAKE="make"
100 fi
101
102 mkdir obj-shared
103 cd obj-shared
104 ../configure --prefix=%{pref} --with-x11 \
105 %if %{unicode}
106 --enable-unicode \
107 %else
108 --disable-unicode \
109 %endif
110 $MAKE
111
112 cd contrib/src
113 $MAKE
114 cd ../../..
115
116 mkdir obj-static
117 cd obj-static
118 ../configure --prefix=%{pref} --with-x11 --disable-shared \
119 %if %{unicode}
120 --enable-unicode \
121 %else
122 --disable-unicode \
123 %endif
124 --with-opengl
125 $MAKE
126 cd ..
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
131 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
132
133 # Remove headers that are part of wx-base-devel:
134
135 # --- wxBase headers list begins here ---
136 cat <<EOF >wxbase-headers.files
137 wx/afterstd.h
138 wx/app.h
139 wx/apptrait.h
140 wx/archive.h
141 wx/arrimpl.cpp
142 wx/arrstr.h
143 wx/atomic.h
144 wx/base64.h
145 wx/beforestd.h
146 wx/buffer.h
147 wx/build.h
148 wx/chartype.h
149 wx/chkconf.h
150 wx/clntdata.h
151 wx/cmdargs.h
152 wx/cmdline.h
153 wx/confbase.h
154 wx/config.h
155 wx/convauto.h
156 wx/containr.h
157 wx/cpp.h
158 wx/crt.h
159 wx/datetime.h
160 wx/datstrm.h
161 wx/dde.h
162 wx/debug.h
163 wx/defs.h
164 wx/dir.h
165 wx/dlimpexp.h
166 wx/dynarray.h
167 wx/dynlib.h
168 wx/dynload.h
169 wx/encconv.h
170 wx/event.h
171 wx/except.h
172 wx/features.h
173 wx/flags.h
174 wx/ffile.h
175 wx/file.h
176 wx/fileconf.h
177 wx/filefn.h
178 wx/filename.h
179 wx/filesys.h
180 wx/fontenc.h
181 wx/fontmap.h
182 wx/fs_arc.h
183 wx/fs_filter.h
184 wx/fs_mem.h
185 wx/fs_zip.h
186 wx/hash.h
187 wx/hashmap.h
188 wx/hashset.h
189 wx/html/forcelnk.h
190 wx/iconloc.h
191 wx/init.h
192 wx/intl.h
193 wx/iosfwrap.h
194 wx/ioswrap.h
195 wx/ipc.h
196 wx/ipcbase.h
197 wx/link.h
198 wx/list.h
199 wx/listimpl.cpp
200 wx/log.h
201 wx/longlong.h
202 wx/math.h
203 wx/memconf.h
204 wx/memory.h
205 wx/memtext.h
206 wx/mimetype.h
207 wx/module.h
208 wx/msgout.h
209 wx/mstream.h
210 wx/object.h
211 wx/platform.h
212 wx/platinfo.h
213 wx/power.h
214 wx/process.h
215 wx/ptr_scpd.h
216 wx/recguard.h
217 wx/regex.h
218 wx/scopeguard.h
219 wx/snglinst.h
220 wx/sstream.h
221 wx/stack.h
222 wx/stackwalk.h
223 wx/stdpaths.h
224 wx/stockitem.h
225 wx/stopwatch.h
226 wx/strconv.h
227 wx/stream.h
228 wx/string.h
229 wx/stringimpl.h
230 wx/stringops.h
231 wx/strvararg.h
232 wx/sysopt.h
233 wx/tarstrm.h
234 wx/textbuf.h
235 wx/textfile.h
236 wx/thread.h
237 wx/thrimpl.cpp
238 wx/timer.h
239 wx/tokenzr.h
240 wx/txtstrm.h
241 wx/types.h
242 wx/unichar.h
243 wx/uri.h
244 wx/utils.h
245 wx/variant.h
246 wx/vector.h
247 wx/version.h
248 wx/volume.h
249 wx/wfstream.h
250 wx/wx.h
251 wx/wxchar.h
252 wx/wxcrt.h
253 wx/wxcrtbase.h
254 wx/wxcrtvararg.h
255 wx/wxprec.h
256 wx/xti.h
257 wx/xtistrm.h
258 wx/zipstrm.h
259 wx/zstream.h
260 wx/private/fdiodispatcher.h
261 wx/private/selectdispatcher.h
262 wx/unix/app.h
263 wx/unix/apptbase.h
264 wx/unix/apptrait.h
265 wx/unix/chkconf.h
266 wx/unix/execute.h
267 wx/unix/evtloop.h
268 wx/unix/mimetype.h
269 wx/unix/pipe.h
270 wx/unix/private.h
271 wx/unix/stackwalk.h
272 wx/unix/stdpaths.h
273 wx/fs_inet.h
274 wx/gsocket.h
275 wx/protocol/file.h
276 wx/protocol/ftp.h
277 wx/protocol/http.h
278 wx/protocol/protocol.h
279 wx/sckaddr.h
280 wx/sckipc.h
281 wx/sckstrm.h
282 wx/socket.h
283 wx/url.h
284 wx/unix/gsockunx.h
285 wx/xml/xml.h
286 wx/xtixml.h
287 EOF
288 # --- wxBase headers list ends here ---
289 for f in `cat wxbase-headers-list` ; do
290 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
291 done
292
293 # list of all core headers:
294 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
295
296 # contrib stuff:
297 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
298 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
299
300 # remove wxBase files so that RPM doesn't complain about unpackaged files:
301 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
302 %if %{unicode}
303 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
304 %endif
305 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
306 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
307
308 %clean
309 rm -rf $RPM_BUILD_ROOT
310
311 %post
312 /sbin/ldconfig
313
314 %postun
315 /sbin/ldconfig
316
317 %post devel
318 # link wx-config when you install RPM.
319 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
320 # link wx-config with explicit name.
321 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
322 /sbin/ldconfig
323
324 %postun devel
325 /sbin/ldconfig
326
327 %preun devel
328 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
329 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
330 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
331 if test "x$SUM1" = "x$SUM2" ; then
332 rm -f %{_bindir}/wx-config
333 fi
334 fi
335 rm -f %{_bindir}/%{wxconfiglink}
336
337 %post gl
338 /sbin/ldconfig
339
340 %postun gl
341 /sbin/ldconfig
342
343 %post contrib
344 /sbin/ldconfig
345
346 %postun contrib
347 /sbin/ldconfig
348
349 %post contrib-devel
350 /sbin/ldconfig
351
352 %postun contrib-devel
353 /sbin/ldconfig
354
355 %files
356 %defattr(-,root,root)
357 %doc COPYING.LIB *.txt
358 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
359 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
360 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
361 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
362 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
363 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
364
365
366 %files devel -f core-headers.files
367 %defattr(-,root,root)
368 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
369 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
370 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
371 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
372 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
373 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
374 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
375 %dir %{_libdir}/wx
376 %{_libdir}/wx/*
377 %{_bindir}/wxrc*
378
379 %files gl
380 %defattr(-,root,root)
381 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
382
383 %files static
384 %defattr (-,root,root)
385 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
386
387 %files contrib
388 %defattr(-,root,root)
389 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
390 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
391 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
392 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
393 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
394 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
395 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
396 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
397 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
398
399 %files contrib-devel
400 %defattr(-,root,root)
401 %dir %{_includedir}/wx-%{ver2}/wx/animate
402 %{_includedir}/wx-%{ver2}/wx/animate/*
403 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
404
405 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
406 %{_includedir}/wx-%{ver2}/wx/deprecated/*
407 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
408
409 %dir %{_includedir}/wx-%{ver2}/wx/fl
410 %{_includedir}/wx-%{ver2}/wx/fl/*
411 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
412
413 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
414 %{_includedir}/wx-%{ver2}/wx/gizmos/*
415 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
416
417 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
418 %{_includedir}/wx-%{ver2}/wx/mmedia/*
419 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
420
421 %dir %{_includedir}/wx-%{ver2}/wx/ogl
422 %{_includedir}/wx-%{ver2}/wx/ogl/*
423 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
424
425 %dir %{_includedir}/wx-%{ver2}/wx/plot
426 %{_includedir}/wx-%{ver2}/wx/plot/*
427 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
428
429 %dir %{_includedir}/wx-%{ver2}/wx/stc
430 %{_includedir}/wx-%{ver2}/wx/stc/*
431 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
432
433 %dir %{_includedir}/wx-%{ver2}/wx/svg
434 %{_includedir}/wx-%{ver2}/wx/svg/*
435 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so