]> git.saurik.com Git - wxWidgets.git/blob - wxGTK.spec
Updated the FAQ a little
[wxWidgets.git] / wxGTK.spec
1 # Note that this is NOT a relocatable package
2 %define pref /usr
3 %define ver 2.3.0
4 %define rel 0
5
6 Summary: The GTK+ 1.2 port of the wxWindows library
7 Name: wxGTK
8 Version: %{ver}
9 Release: %{rel}
10 Copyright: wxWindows Licence
11 Group: X11/Libraries
12 Source: wxGTK-%{ver}.tgz
13 URL: http://wxwindows.org
14 Packager: Robert Roebling <robert@roebling.de>
15
16 # all packages providing an implementation of wxWindows library (regardless of
17 # the toolkit used) should provide the (virtual) wxwin package, this makes it
18 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxqt..."
19 Provides: wxwin
20
21 %description
22 wxWindows is a free C++ library for cross-platform GUI development.
23 With wxWindows, you can create applications for different GUIs (GTK+,
24 Motif/LessTif, MS Windows, Mac) from the same source code.
25
26 %package devel
27 Summary: The GTK+ 1.2 port of the wxWindows library
28 Group: X11/Libraries
29 Requires: wxGTK
30
31 %description devel
32 Header files for wxGTK, the GTK+ 1.2 port of the wxWindows library.
33
34 %package gl
35 Summary: The GTK+ 1.2 port of the wxWindows library, OpenGl add-on.
36 Group: X11/Libraries
37 Requires: wxGTK
38
39 %description gl
40 OpenGl add-on library for wxGTK, the GTK+ 1.2 port of the wxWindows library.
41
42 %prep
43 %setup -n wxGTK
44 ./configure --prefix=%{pref} --enable-burnt_name --with-odbc --with-opengl
45
46 %build
47 if [ "$SMP" != "" ]; then
48 export MAKE="make -j$SMP"
49 else
50 export MAKE="make"
51 fi
52 $MAKE
53
54 %install
55 make install
56
57 %post
58 /sbin/ldconfig
59
60 %postun
61 /sbin/ldconfig
62
63 %files
64 %defattr (644, root, root, 755)
65 %doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
66 %dir %{pref}/share/wx
67 %{pref}/share/wx/*
68 %attr(755, -, -) %{pref}/lib/libwx_gtk.*
69 %attr(755, -, -) %{pref}/lib/libwx_gtk-2.2.*
70
71 %files devel
72 %defattr (644, root, root, 755)
73 %dir %{pref}/include/wx
74 %{pref}/include/wx/*
75 %dir %{pref}/lib/wx
76 %{pref}/lib/wx/*
77 %attr(755, -, -) %{pref}/bin/wxgtk-config
78 %attr(755, -, -) %{pref}/bin/wx-config
79
80 %files gl
81 %attr(755, -, -) %{pref}/lib/libwx_gtk_gl*