updated version to 2.8.1
[wxWidgets.git] / wxMotif.spec
1 %define pref /usr
2 %define ver 2.8.1
3 %define ver2 2.8
4 %define rel 1
5
6 %define portname motif
7 %define name wx-%{portname}
8 %define wxbasename wx-base
9
10 %define wxconfig %{portname}-ansi-release-%{ver2}
11 %define wxconfiglink wx%{portname}-%{ver2}-config
12
13 Summary: The Motif/Lesstif port of the wxWidgets library
14 Name: %{name}
15 Version: %{ver}
16 Release: %{rel}
17 License: wxWindows Licence
18 Group: X11/Libraries
19 Source: wxMotif-%{ver}.tar.bz2
20 URL: http://www.wxwidgets.org
21 Packager: wxWidgets developers <wx-dev@lists.wxwidgets.org>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
24
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
28 Provides: wxwin
29 Provides: wxMotif
30
31 %description
32 wxWidgets is a free C++ library for cross-platform GUI development.
33 With wxWidgets, you can create applications for different GUIs (GTK+,
34 Motif/LessTif, MS Windows, Mac) from the same source code.
35
36 %package devel
37 Summary: The Motif/Lesstif port of the wxWidgets library
38 Group: X11/Libraries
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
41
42 %description devel
43 Header files for wxMotif, the Motif/Lesstif port of the wxWidgets library.
44
45 %package gl
46 Summary: The Motif/Lesstif port of the wxWidgets library, OpenGL add-on.
47 Group: X11/Libraries
48 Requires: %{name} = %{ver}
49
50 %description gl
51 OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWidgets library.
52
53 %package static
54 Summary: wxMotif static libraries
55 Group: Development/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
58
59 %description static
60 Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
61
62 %package contrib
63 Summary: Contrib libraries for wxMotif
64 Group: X11/Libraries
65 Requires: %{name} = %{ver}
66
67 %description contrib
68 Contrib libraries for wxMotif
69
70 %package contrib-devel
71 Summary: Contrib libraries for wxMotif
72 Group: X11/Libraries
73 Requires: %{name}-contrib = %{ver}
74 Requires: %{name}-devel = %{ver}
75
76 %description contrib-devel
77 Header files for contributed libraries for wxMotif.
78
79 %prep
80 %setup -q -n wxMotif-%{ver}
81
82 %build
83 if [ "$SMP" != "" ]; then
84 export MAKE="make -j$SMP"
85 else
86 export MAKE="make"
87 fi
88
89 mkdir obj-shared
90 cd obj-shared
91 ../configure --prefix=%{pref} --with-motif --with-odbc --with-opengl
92 $MAKE
93
94 cd contrib/src
95 $MAKE
96 cd ../../..
97
98 mkdir obj-static
99 cd obj-static
100 ../configure --prefix=%{pref} --with-motif --disable-shared --with-odbc --with-opengl
101 $MAKE
102 cd ..
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
107 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
108
109 # Remove headers that are part of wx-base-devel:
110
111 # --- wxBase headers list begins here ---
112 cat <<EOF >wxbase-headers.files
113 wx/afterstd.h
114 wx/app.h
115 wx/apptrait.h
116 wx/archive.h
117 wx/arrimpl.cpp
118 wx/arrstr.h
119 wx/beforestd.h
120 wx/buffer.h
121 wx/build.h
122 wx/chkconf.h
123 wx/clntdata.h
124 wx/cmdline.h
125 wx/confbase.h
126 wx/config.h
127 wx/convauto.h
128 wx/containr.h
129 wx/cpp.h
130 wx/datetime.h
131 wx/datstrm.h
132 wx/dde.h
133 wx/debug.h
134 wx/defs.h
135 wx/dir.h
136 wx/dlimpexp.h
137 wx/dynarray.h
138 wx/dynlib.h
139 wx/dynload.h
140 wx/encconv.h
141 wx/event.h
142 wx/except.h
143 wx/features.h
144 wx/ffile.h
145 wx/file.h
146 wx/fileconf.h
147 wx/filefn.h
148 wx/filename.h
149 wx/filesys.h
150 wx/fontenc.h
151 wx/fontmap.h
152 wx/fs_arc.h
153 wx/fs_filter.h
154 wx/fs_mem.h
155 wx/fs_zip.h
156 wx/hash.h
157 wx/hashmap.h
158 wx/hashset.h
159 wx/html/forcelnk.h
160 wx/iconloc.h
161 wx/init.h
162 wx/intl.h
163 wx/iosfwrap.h
164 wx/ioswrap.h
165 wx/ipc.h
166 wx/ipcbase.h
167 wx/isql.h
168 wx/isqlext.h
169 wx/link.h
170 wx/list.h
171 wx/listimpl.cpp
172 wx/log.h
173 wx/longlong.h
174 wx/math.h
175 wx/memconf.h
176 wx/memory.h
177 wx/memtext.h
178 wx/mimetype.h
179 wx/module.h
180 wx/msgout.h
181 wx/mstream.h
182 wx/object.h
183 wx/platform.h
184 wx/platinfo.h
185 wx/power.h
186 wx/process.h
187 wx/ptr_scpd.h
188 wx/recguard.h
189 wx/regex.h
190 wx/scopeguard.h
191 wx/snglinst.h
192 wx/sstream.h
193 wx/stack.h
194 wx/stackwalk.h
195 wx/stdpaths.h
196 wx/stockitem.h
197 wx/stopwatch.h
198 wx/strconv.h
199 wx/stream.h
200 wx/string.h
201 wx/sysopt.h
202 wx/tarstrm.h
203 wx/textbuf.h
204 wx/textfile.h
205 wx/thread.h
206 wx/thrimpl.cpp
207 wx/timer.h
208 wx/tokenzr.h
209 wx/txtstrm.h
210 wx/types.h
211 wx/uri.h
212 wx/utils.h
213 wx/variant.h
214 wx/vector.h
215 wx/version.h
216 wx/volume.h
217 wx/wfstream.h
218 wx/wx.h
219 wx/wxchar.h
220 wx/wxprec.h
221 wx/xti.h
222 wx/xtistrm.h
223 wx/zipstrm.h
224 wx/zstream.h
225 wx/unix/apptbase.h
226 wx/unix/apptrait.h
227 wx/unix/execute.h
228 wx/unix/mimetype.h
229 wx/unix/pipe.h
230 wx/unix/private.h
231 wx/unix/stackwalk.h
232 wx/unix/stdpaths.h
233 wx/fs_inet.h
234 wx/gsocket.h
235 wx/protocol/file.h
236 wx/protocol/ftp.h
237 wx/protocol/http.h
238 wx/protocol/protocol.h
239 wx/sckaddr.h
240 wx/sckipc.h
241 wx/sckstrm.h
242 wx/socket.h
243 wx/url.h
244 wx/unix/gsockunx.h
245 wx/xml/xml.h
246 wx/xtixml.h
247 wx/db.h
248 wx/dbkeyg.h
249 wx/dbtable.h
250 EOF
251 # --- wxBase headers list ends here ---
252 for f in `cat wxbase-headers-list` ; do
253 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
254 done
255
256 # list of all core headers:
257 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
258
259 # contrib stuff:
260 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
261 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
262
263 # remove wxBase files so that RPM doesn't complain about unpackaged files:
264 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
265 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
266 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
267
268 %clean
269 rm -rf $RPM_BUILD_ROOT
270
271 %post
272 /sbin/ldconfig
273
274 %postun
275 /sbin/ldconfig
276
277 %post devel
278 # link wx-config when you install RPM.
279 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
280 # link wx-config with explicit name.
281 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
282 /sbin/ldconfig
283
284 %postun devel
285 /sbin/ldconfig
286
287 %preun devel
288 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
289 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
290 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
291 if test "x$SUM1" = "x$SUM2" ; then
292 rm -f %{_bindir}/wx-config
293 fi
294 fi
295 rm -f %{_bindir}/%{wxconfiglink}
296
297 %post gl
298 /sbin/ldconfig
299
300 %postun gl
301 /sbin/ldconfig
302
303 %post contrib
304 /sbin/ldconfig
305
306 %postun contrib
307 /sbin/ldconfig
308
309 %post contrib-devel
310 /sbin/ldconfig
311
312 %postun contrib-devel
313 /sbin/ldconfig
314
315 %files
316 %defattr(-,root,root)
317 %doc COPYING.LIB *.txt
318 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
319 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
320 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
321 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
322 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
323 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
324 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
325
326
327 %files devel -f core-headers.files
328 %defattr(-,root,root)
329 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
330 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
331 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
332 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
333 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
334 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
335 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
336 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
337 %dir %{_libdir}/wx
338 %{_libdir}/wx/*
339 %{_bindir}/wxrc*
340
341 %files gl
342 %defattr(-,root,root)
343 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
344
345 %files static
346 %defattr (-,root,root)
347 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
348
349 %files contrib
350 %defattr(-,root,root)
351 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
352 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
353 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
354 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
355 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
356 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
357 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
358 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
359 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
360
361 %files contrib-devel
362 %defattr(-,root,root)
363 %dir %{_includedir}/wx-%{ver2}/wx/animate
364 %{_includedir}/wx-%{ver2}/wx/animate/*
365 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
366
367 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
368 %{_includedir}/wx-%{ver2}/wx/deprecated/*
369 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
370
371 %dir %{_includedir}/wx-%{ver2}/wx/fl
372 %{_includedir}/wx-%{ver2}/wx/fl/*
373 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
374
375 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
376 %{_includedir}/wx-%{ver2}/wx/gizmos/*
377 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
378
379 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
380 %{_includedir}/wx-%{ver2}/wx/mmedia/*
381 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
382
383 %dir %{_includedir}/wx-%{ver2}/wx/ogl
384 %{_includedir}/wx-%{ver2}/wx/ogl/*
385 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
386
387 %dir %{_includedir}/wx-%{ver2}/wx/plot
388 %{_includedir}/wx-%{ver2}/wx/plot/*
389 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
390
391 %dir %{_includedir}/wx-%{ver2}/wx/stc
392 %{_includedir}/wx-%{ver2}/wx/stc/*
393 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
394
395 %dir %{_includedir}/wx-%{ver2}/wx/svg
396 %{_includedir}/wx-%{ver2}/wx/svg/*
397 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so