regenerated after version.bkl changes fixing -compatibility_version for Darwin
[wxWidgets.git] / wxX11.spec
1 %define pref /usr
2 %define ver 2.6.2
3 %define ver2 2.6
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define portname x11univ
12
13 %if %{unicode}
14 %define wxbasename wx-base-unicode
15 %define name wx-%{portname}-unicode
16 %define wxconfig %{portname}-unicode-release-%{ver2}
17 %define wxconfiglink wx%{portname}u-%{ver2}-config
18 %else
19 %define wxbasename wx-base
20 %define name wx-%{portname}
21 %define wxconfig %{portname}-ansi-release-%{ver2}
22 %define wxconfiglink wx%{portname}-%{ver2}-config
23 %endif
24
25 Summary: The X11 port of the wxWidgets library
26 Name: %{name}
27 Version: %{ver}
28 Release: %{rel}
29 License: wxWindows Licence
30 Group: X11/Libraries
31 Source: wxX11-%{ver}.tar.bz2
32 URL: http://www.wxwidgets.org
33 Packager: Vadim Zeitlin <vadim@wxwindows.org>
34 Prefix: %{pref}
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
37
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
41 Provides: wxwin
42 Provides: wxX11
43
44 %description
45 wxWidgets is a free C++ library for cross-platform GUI development.
46 With wxWidgets, you can create applications for different GUIs (GTK+,
47 Motif/LessTif, MS Windows, Mac) from the same source code.
48
49 %package devel
50 Summary: The X11 port of the wxWidgets library
51 Group: X11/Libraries
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
54
55 %description devel
56 Header files for wxX11, the X11 port of the wxWidgets library.
57
58 %package gl
59 Summary: The X11 port of the wxWidgets library, OpenGL add-on.
60 Group: X11/Libraries
61 Requires: %{name} = %{ver}
62
63 %description gl
64 OpenGL add-on library for wxX11, the X11 port of the wxWidgets library.
65
66 %package static
67 Summary: wxX11 static libraries
68 Group: Development/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
71
72 %description static
73 Static libraries for wxX11. You need them if you want to link statically against wxX11.
74
75 %package contrib
76 Summary: Contrib libraries for wxX11.
77 Group: X11/Libraries
78 Requires: %{name} = %{ver}
79
80 %description contrib
81 Contributed libraries for wxX11.
82
83 %package contrib-devel
84 Summary: Contrib libraries for wxX11.
85 Group: X11/Libraries
86 Requires: %{name}-contrib = %{ver}
87 Requires: %{name}-devel = %{ver}
88
89 %description contrib-devel
90 Header files for contributed libraries for wxX11.
91
92 %prep
93 %setup -q -n wxX11-%{ver}
94
95 %build
96 if [ "$SMP" != "" ]; then
97 export MAKE="make -j$SMP"
98 else
99 export MAKE="make"
100 fi
101
102 mkdir obj-shared
103 cd obj-shared
104 ../configure --prefix=%{pref} --with-x11 \
105 %if %{unicode}
106 --enable-unicode \
107 %else
108 --with-odbc \
109 %endif
110 --with-opengl
111 $MAKE
112
113 cd contrib/src
114 $MAKE
115 cd ../../..
116
117 mkdir obj-static
118 cd obj-static
119 ../configure --prefix=%{pref} --with-x11 --disable-shared \
120 %if %{unicode}
121 --enable-unicode \
122 %else
123 --with-odbc \
124 %endif
125 --with-opengl
126 $MAKE
127 cd ..
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
132 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
133
134 # Remove headers that are part of wx-base-devel:
135
136 # --- wxBase headers list begins here ---
137 cat <<EOF >wxbase-headers.files
138 wx/afterstd.h
139 wx/app.h
140 wx/apptrait.h
141 wx/archive.h
142 wx/arrimpl.cpp
143 wx/arrstr.h
144 wx/beforestd.h
145 wx/buffer.h
146 wx/build.h
147 wx/chkconf.h
148 wx/clntdata.h
149 wx/cmdline.h
150 wx/confbase.h
151 wx/config.h
152 wx/containr.h
153 wx/datetime.h
154 wx/datstrm.h
155 wx/dde.h
156 wx/debug.h
157 wx/defs.h
158 wx/dir.h
159 wx/dlimpexp.h
160 wx/dynarray.h
161 wx/dynlib.h
162 wx/dynload.h
163 wx/encconv.h
164 wx/event.h
165 wx/except.h
166 wx/features.h
167 wx/ffile.h
168 wx/file.h
169 wx/fileconf.h
170 wx/filefn.h
171 wx/filename.h
172 wx/filesys.h
173 wx/fontenc.h
174 wx/fontmap.h
175 wx/fs_mem.h
176 wx/fs_zip.h
177 wx/hash.h
178 wx/hashmap.h
179 wx/hashset.h
180 wx/html/forcelnk.h
181 wx/iconloc.h
182 wx/init.h
183 wx/intl.h
184 wx/iosfwrap.h
185 wx/ioswrap.h
186 wx/ipc.h
187 wx/ipcbase.h
188 wx/isql.h
189 wx/isqlext.h
190 wx/link.h
191 wx/list.h
192 wx/listimpl.cpp
193 wx/log.h
194 wx/longlong.h
195 wx/math.h
196 wx/memconf.h
197 wx/memory.h
198 wx/memtext.h
199 wx/mimetype.h
200 wx/module.h
201 wx/msgout.h
202 wx/mstream.h
203 wx/object.h
204 wx/platform.h
205 wx/process.h
206 wx/ptr_scpd.h
207 wx/recguard.h
208 wx/regex.h
209 wx/scopeguard.h
210 wx/snglinst.h
211 wx/sstream.h
212 wx/stack.h
213 wx/stackwalk.h
214 wx/stdpaths.h
215 wx/stockitem.h
216 wx/stopwatch.h
217 wx/strconv.h
218 wx/stream.h
219 wx/string.h
220 wx/sysopt.h
221 wx/textbuf.h
222 wx/textfile.h
223 wx/thread.h
224 wx/thrimpl.cpp
225 wx/timer.h
226 wx/tokenzr.h
227 wx/txtstrm.h
228 wx/types.h
229 wx/uri.h
230 wx/utils.h
231 wx/variant.h
232 wx/vector.h
233 wx/version.h
234 wx/volume.h
235 wx/wfstream.h
236 wx/wx.h
237 wx/wxchar.h
238 wx/wxprec.h
239 wx/xti.h
240 wx/xtistrm.h
241 wx/zipstrm.h
242 wx/zstream.h
243 wx/unix/apptbase.h
244 wx/unix/apptrait.h
245 wx/unix/execute.h
246 wx/unix/mimetype.h
247 wx/unix/pipe.h
248 wx/unix/private.h
249 wx/unix/stackwalk.h
250 wx/unix/stdpaths.h
251 wx/msw/apptrait.h
252 wx/msw/apptbase.h
253 wx/msw/chkconf.h
254 wx/msw/crashrpt.h
255 wx/msw/dde.h
256 wx/msw/debughlp.h
257 wx/msw/gccpriv.h
258 wx/msw/mimetype.h
259 wx/msw/stackwalk.h
260 wx/msw/stdpaths.h
261 wx/msw/winundef.h
262 wx/msw/wrapcctl.h
263 wx/msw/wrapcdlg.h
264 wx/msw/wrapwin.h
265 wx/unix/apptbase.h
266 wx/unix/apptrait.h
267 wx/unix/execute.h
268 wx/unix/mimetype.h
269 wx/unix/pipe.h
270 wx/unix/private.h
271 wx/unix/stackwalk.h
272 wx/unix/stdpaths.h
273 wx/mac/corefoundation/cfstring.h
274 wx/mac/corefoundation/hid.h
275 wx/mac/corefoundation/stdpaths.h
276 wx/palmos/apptbase.h
277 wx/palmos/apptrait.h
278 wx/palmos/chkconf.h
279 wx/palmos/mimetype.h
280 wx/palmos/stdpaths.h
281 wx/msdos/mimetype.h
282 wx/fs_inet.h
283 wx/gsocket.h
284 wx/protocol/file.h
285 wx/protocol/ftp.h
286 wx/protocol/http.h
287 wx/protocol/protocol.h
288 wx/sckaddr.h
289 wx/sckipc.h
290 wx/sckstrm.h
291 wx/socket.h
292 wx/url.h
293 wx/unix/gsockunx.h
294 wx/msw/gsockmsw.h
295 wx/unix/gsockunx.h
296 wx/unix/gsockunx.h
297 wx/mac/carbon/gsockmac.h
298 wx/xml/xml.h
299 wx/xtixml.h
300 wx/db.h
301 wx/dbkeyg.h
302 wx/dbtable.h
303 EOF
304 # --- wxBase headers list ends here ---
305 for f in `cat wxbase-headers-list` ; do
306 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
307 done
308
309 # list of all core headers:
310 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
311
312 # contrib stuff:
313 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
314 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
315
316 # remove wxBase files so that RPM doesn't complain about unpackaged files:
317 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
318 %if %{unicode}
319 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
320 %endif
321 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
322 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
323
324 %clean
325 rm -rf $RPM_BUILD_ROOT
326
327 %post
328 /sbin/ldconfig
329
330 %postun
331 /sbin/ldconfig
332
333 %post devel
334 # link wx-config when you install RPM.
335 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
336 # link wx-config with explicit name.
337 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
338 /sbin/ldconfig
339
340 %postun devel
341 /sbin/ldconfig
342
343 %preun devel
344 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
345 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
346 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
347 if test "x$SUM1" = "x$SUM2" ; then
348 rm -f %{_bindir}/wx-config
349 fi
350 fi
351 rm -f %{_bindir}/%{wxconfiglink}
352
353 %post gl
354 /sbin/ldconfig
355
356 %postun gl
357 /sbin/ldconfig
358
359 %post contrib
360 /sbin/ldconfig
361
362 %postun contrib
363 /sbin/ldconfig
364
365 %post contrib-devel
366 /sbin/ldconfig
367
368 %postun contrib-devel
369 /sbin/ldconfig
370
371 %files
372 %defattr(-,root,root)
373 %doc COPYING.LIB *.txt
374 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
375 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
376 %if !%{unicode}
377 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
378 %endif
379 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
380 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
381 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
382 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
383
384
385 %files devel -f core-headers.files
386 %defattr(-,root,root)
387 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
388 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
389 %if !%{unicode}
390 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
391 %endif
392 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
393 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
394 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
395 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
396 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
397 %dir %{_libdir}/wx
398 %{_libdir}/wx/*
399 %{_bindir}/wxrc*
400
401 %files gl
402 %defattr(-,root,root)
403 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
404
405 %files static
406 %defattr (-,root,root)
407 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
408
409 %files contrib
410 %defattr(-,root,root)
411 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
412 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
413 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
414 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
415 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
416 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
417 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
418 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
419 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
420
421 %files contrib-devel
422 %defattr(-,root,root)
423 %dir %{_includedir}/wx-%{ver2}/wx/animate
424 %{_includedir}/wx-%{ver2}/wx/animate/*
425 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
426
427 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
428 %{_includedir}/wx-%{ver2}/wx/deprecated/*
429 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
430
431 %dir %{_includedir}/wx-%{ver2}/wx/fl
432 %{_includedir}/wx-%{ver2}/wx/fl/*
433 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
434
435 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
436 %{_includedir}/wx-%{ver2}/wx/gizmos/*
437 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
438
439 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
440 %{_includedir}/wx-%{ver2}/wx/mmedia/*
441 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
442
443 %dir %{_includedir}/wx-%{ver2}/wx/ogl
444 %{_includedir}/wx-%{ver2}/wx/ogl/*
445 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
446
447 %dir %{_includedir}/wx-%{ver2}/wx/plot
448 %{_includedir}/wx-%{ver2}/wx/plot/*
449 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
450
451 %dir %{_includedir}/wx-%{ver2}/wx/stc
452 %{_includedir}/wx-%{ver2}/wx/stc/*
453 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
454
455 %dir %{_includedir}/wx-%{ver2}/wx/svg
456 %{_includedir}/wx-%{ver2}/wx/svg/*
457 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so