regenerated after version.bkl changes fixing -compatibility_version for Darwin
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /opt/gnome
2 %define ver 2.6.2
3 %define ver2 2.6
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfigstatic base-unicode-release-static-%{ver2}
46 %define wxbaseconfiglink wxbaseu-%{ver2}-config
47 %else
48 %define wxbasename wx-base-ansi
49 %define wxbaseconfig base-ansi-release-%{ver2}
50 %define wxbaseconfigstatic base-ansi-release-static-%{ver2}
51 %define wxbaseconfiglink wxbase-%{ver2}-config
52 %endif
53
54 Summary: The GTK+ %{gtkver} port of the wxWidgets library
55 Name: %{name}
56 Version: %{ver}
57 Release: %{rel}
58 License: wxWindows Licence
59 Group: X11/Libraries
60 Source: wxGTK-%{ver}.tar.gz
61 URL: http://www.wxwidgets.org
62 Packager: Vadim Zeitlin <vadim@wxwindows.org>
63 Prefix: %{_prefix}
64 BuildRoot: %{_tmppath}/%{name}-root
65 Requires: %{wxbasename} = %{ver}
66 %if %{portname} == gtk2
67 # BuildRequires: gtk+-2.0-devel
68 %else
69 # BuildRequires: gtk+-devel >= 1.2.0
70 %endif
71
72 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
73
74 # all packages providing an implementation of wxWidgets library (regardless of
75 # the toolkit used) should provide the (virtual) wxwin package, this makes it
76 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
77 Provides: wxwin
78 Provides: wxGTK
79
80 %description
81 wxWidgets is a free C++ library for cross-platform GUI development.
82 With wxWidgets, you can create applications for different GUIs (GTK+,
83 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
84
85 %package -n wx-i18n
86 Summary: The translations for the wxWidgets library.
87 Group: X11/Libraries
88
89 %description -n wx-i18n
90 The translations files for the wxWidgets library.
91
92 %package devel
93 Summary: The GTK+ %{gtkver} port of the wxWidgets library
94 Group: X11/Libraries
95 Requires: %{name} = %{ver}
96 Requires: %{wxbasename}-devel = %{ver}
97 Provides: wxGTK-devel
98
99 %description devel
100 The GTK+ %{gtkver} port of the wxWidgets library, header files.
101
102 %package gl
103 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
104 Group: X11/Libraries
105 Requires: %{name} = %{ver}
106 Provides: wxGTK-gl
107
108 %description gl
109 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
110
111 %package -n %{wxbasename}
112 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
113 Group: Development/Libraries
114 Provides: wxBase
115
116 %description -n %{wxbasename}
117 wxBase is a collection of C++ classes providing basic data structures (strings,
118 lists, arrays), portable wrappers around many OS-specific funstions (file
119 operations, time/date manipulations, threads, processes, sockets, shared
120 library loading) as well as other utility classes (streams, archive and
121 compression). wxBase currently supports Win32, most Unix variants (Linux,
122 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
123
124 %package -n %{wxbasename}-devel
125 Summary: wxBase library, header files.
126 Group: Development/Libraries
127 Provides: wxBase-devel
128
129 %description -n %{wxbasename}-devel
130 wxBase library - non-GUI support classes of the wxWidgets toolkit,
131 header files.
132
133 %package contrib
134 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
135 Group: X11/Libraries
136 Requires: %{name} = %{ver}
137
138 %description contrib
139 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
140
141 %package contrib-devel
142 Summary: The GTK+ %{gtkver} port of the wxWidgets library
143 Group: X11/Libraries
144 Requires: %{name}-contrib = %{ver}
145 Requires: %{name}-devel = %{ver}
146
147 %description contrib-devel
148 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
149
150 %prep
151 %setup -q -n wxGTK-%{ver}
152
153 %build
154 if [ "$SMP" != "" ]; then
155 export MAKE="make -j$SMP"
156 else
157 export MAKE="make"
158 fi
159
160 mkdir obj-shared-no-gui
161 cd obj-shared-no-gui
162 ../configure --prefix=%{_prefix} \
163 --disable-gui \
164 %if %{unicode}
165 --enable-unicode
166 %else
167 --disable-unicode
168 %endif
169 $MAKE
170 cd ..
171
172 mkdir obj-shared
173 cd obj-shared
174 ../configure --prefix=%{_prefix} \
175 %if ! %{gtk2}
176 --with-gtk=1 \
177 %else
178 --with-gtk=2 \
179 %endif
180 %if %{unicode}
181 --enable-unicode \
182 %else
183 --disable-unicode \
184 --with-odbc \
185 %endif
186 --with-opengl
187 $MAKE
188
189 cd contrib/src
190 $MAKE
191 cd ../../..
192
193 mkdir obj-static-no-gui
194 cd obj-static-no-gui
195 ../configure --prefix=%{_prefix} \
196 --disable-gui \
197 --disable-shared \
198 %if %{unicode}
199 --enable-unicode
200 %else
201 --disable-unicode
202 %endif
203 $MAKE
204 cd ..
205
206 mkdir obj-static
207 cd obj-static
208 ../configure --prefix=%{_prefix} \
209 %if ! %{gtk2}
210 --with-gtk=1 \
211 %else
212 --with-gtk=2 \
213 %endif
214 --disable-shared \
215 %if %{unicode}
216 --enable-unicode \
217 %else
218 --disable-unicode \
219 --with-odbc \
220 %endif
221 --with-opengl
222 $MAKE
223
224 cd contrib/src
225 $MAKE
226 cd ../../..
227
228 %install
229 rm -rf $RPM_BUILD_ROOT
230 (cd obj-static-no-gui; make DESTDIR=$RPM_BUILD_ROOT install)
231 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT install)
232 (cd obj-shared-no-gui; make DESTDIR=$RPM_BUILD_ROOT install)
233 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT install)
234
235 # --- wxBase headers list begins here ---
236 cat <<EOF >wxbase-headers.files
237 wx/afterstd.h
238 wx/app.h
239 wx/apptrait.h
240 wx/archive.h
241 wx/arrimpl.cpp
242 wx/arrstr.h
243 wx/beforestd.h
244 wx/buffer.h
245 wx/build.h
246 wx/chkconf.h
247 wx/clntdata.h
248 wx/cmdline.h
249 wx/confbase.h
250 wx/config.h
251 wx/containr.h
252 wx/datetime.h
253 wx/datstrm.h
254 wx/dde.h
255 wx/debug.h
256 wx/defs.h
257 wx/dir.h
258 wx/dlimpexp.h
259 wx/dynarray.h
260 wx/dynlib.h
261 wx/dynload.h
262 wx/encconv.h
263 wx/event.h
264 wx/except.h
265 wx/features.h
266 wx/ffile.h
267 wx/file.h
268 wx/fileconf.h
269 wx/filefn.h
270 wx/filename.h
271 wx/filesys.h
272 wx/fontenc.h
273 wx/fontmap.h
274 wx/fs_mem.h
275 wx/fs_zip.h
276 wx/hash.h
277 wx/hashmap.h
278 wx/hashset.h
279 wx/html/forcelnk.h
280 wx/iconloc.h
281 wx/init.h
282 wx/intl.h
283 wx/iosfwrap.h
284 wx/ioswrap.h
285 wx/ipc.h
286 wx/ipcbase.h
287 wx/isql.h
288 wx/isqlext.h
289 wx/link.h
290 wx/list.h
291 wx/listimpl.cpp
292 wx/log.h
293 wx/longlong.h
294 wx/math.h
295 wx/memconf.h
296 wx/memory.h
297 wx/memtext.h
298 wx/mimetype.h
299 wx/module.h
300 wx/msgout.h
301 wx/mstream.h
302 wx/object.h
303 wx/platform.h
304 wx/process.h
305 wx/ptr_scpd.h
306 wx/recguard.h
307 wx/regex.h
308 wx/scopeguard.h
309 wx/snglinst.h
310 wx/sstream.h
311 wx/stack.h
312 wx/stackwalk.h
313 wx/stdpaths.h
314 wx/stockitem.h
315 wx/stopwatch.h
316 wx/strconv.h
317 wx/stream.h
318 wx/string.h
319 wx/sysopt.h
320 wx/textbuf.h
321 wx/textfile.h
322 wx/thread.h
323 wx/thrimpl.cpp
324 wx/timer.h
325 wx/tokenzr.h
326 wx/txtstrm.h
327 wx/types.h
328 wx/uri.h
329 wx/utils.h
330 wx/variant.h
331 wx/vector.h
332 wx/version.h
333 wx/volume.h
334 wx/wfstream.h
335 wx/wx.h
336 wx/wxchar.h
337 wx/wxprec.h
338 wx/xti.h
339 wx/xtistrm.h
340 wx/zipstrm.h
341 wx/zstream.h
342 wx/unix/apptbase.h
343 wx/unix/apptrait.h
344 wx/unix/execute.h
345 wx/unix/mimetype.h
346 wx/unix/pipe.h
347 wx/unix/private.h
348 wx/unix/stackwalk.h
349 wx/unix/stdpaths.h
350 wx/msw/apptrait.h
351 wx/msw/apptbase.h
352 wx/msw/chkconf.h
353 wx/msw/crashrpt.h
354 wx/msw/dde.h
355 wx/msw/debughlp.h
356 wx/msw/gccpriv.h
357 wx/msw/mimetype.h
358 wx/msw/stackwalk.h
359 wx/msw/stdpaths.h
360 wx/msw/winundef.h
361 wx/msw/wrapcctl.h
362 wx/msw/wrapcdlg.h
363 wx/msw/wrapwin.h
364 wx/unix/apptbase.h
365 wx/unix/apptrait.h
366 wx/unix/execute.h
367 wx/unix/mimetype.h
368 wx/unix/pipe.h
369 wx/unix/private.h
370 wx/unix/stackwalk.h
371 wx/unix/stdpaths.h
372 wx/mac/corefoundation/cfstring.h
373 wx/mac/corefoundation/hid.h
374 wx/mac/corefoundation/stdpaths.h
375 wx/palmos/apptbase.h
376 wx/palmos/apptrait.h
377 wx/palmos/chkconf.h
378 wx/palmos/mimetype.h
379 wx/palmos/stdpaths.h
380 wx/msdos/mimetype.h
381 wx/fs_inet.h
382 wx/gsocket.h
383 wx/protocol/file.h
384 wx/protocol/ftp.h
385 wx/protocol/http.h
386 wx/protocol/protocol.h
387 wx/sckaddr.h
388 wx/sckipc.h
389 wx/sckstrm.h
390 wx/socket.h
391 wx/url.h
392 wx/unix/gsockunx.h
393 wx/msw/gsockmsw.h
394 wx/unix/gsockunx.h
395 wx/unix/gsockunx.h
396 wx/mac/carbon/gsockmac.h
397 wx/xml/xml.h
398 wx/xtixml.h
399 wx/db.h
400 wx/dbkeyg.h
401 wx/dbtable.h
402 EOF
403 # --- wxBase headers list ends here ---
404 cat <<EOF >wxbase-headers.paths
405 %{_includedir}/wx-%{ver2}/wx/afterstd.h
406 %{_includedir}/wx-%{ver2}/wx/app.h
407 %{_includedir}/wx-%{ver2}/wx/apptrait.h
408 %{_includedir}/wx-%{ver2}/wx/archive.h
409 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
410 %{_includedir}/wx-%{ver2}/wx/arrstr.h
411 %{_includedir}/wx-%{ver2}/wx/beforestd.h
412 %{_includedir}/wx-%{ver2}/wx/buffer.h
413 %{_includedir}/wx-%{ver2}/wx/build.h
414 %{_includedir}/wx-%{ver2}/wx/chkconf.h
415 %{_includedir}/wx-%{ver2}/wx/clntdata.h
416 %{_includedir}/wx-%{ver2}/wx/cmdline.h
417 %{_includedir}/wx-%{ver2}/wx/confbase.h
418 %{_includedir}/wx-%{ver2}/wx/config.h
419 %{_includedir}/wx-%{ver2}/wx/containr.h
420 %{_includedir}/wx-%{ver2}/wx/datetime.h
421 %{_includedir}/wx-%{ver2}/wx/datetime.inl
422 %{_includedir}/wx-%{ver2}/wx/datstrm.h
423 %{_includedir}/wx-%{ver2}/wx/dde.h
424 %{_includedir}/wx-%{ver2}/wx/debug.h
425 %{_includedir}/wx-%{ver2}/wx/defs.h
426 %{_includedir}/wx-%{ver2}/wx/dir.h
427 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
428 %{_includedir}/wx-%{ver2}/wx/dynarray.h
429 %{_includedir}/wx-%{ver2}/wx/dynlib.h
430 %{_includedir}/wx-%{ver2}/wx/dynload.h
431 %{_includedir}/wx-%{ver2}/wx/encconv.h
432 %{_includedir}/wx-%{ver2}/wx/event.h
433 %{_includedir}/wx-%{ver2}/wx/except.h
434 %{_includedir}/wx-%{ver2}/wx/features.h
435 %{_includedir}/wx-%{ver2}/wx/ffile.h
436 %{_includedir}/wx-%{ver2}/wx/file.h
437 %{_includedir}/wx-%{ver2}/wx/fileconf.h
438 %{_includedir}/wx-%{ver2}/wx/filefn.h
439 %{_includedir}/wx-%{ver2}/wx/filename.h
440 %{_includedir}/wx-%{ver2}/wx/filesys.h
441 %{_includedir}/wx-%{ver2}/wx/fontenc.h
442 %{_includedir}/wx-%{ver2}/wx/fontmap.h
443 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
444 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
445 %{_includedir}/wx-%{ver2}/wx/hash.h
446 %{_includedir}/wx-%{ver2}/wx/hashmap.h
447 %{_includedir}/wx-%{ver2}/wx/hashset.h
448 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
449 %{_includedir}/wx-%{ver2}/wx/iconloc.h
450 %{_includedir}/wx-%{ver2}/wx/init.h
451 %{_includedir}/wx-%{ver2}/wx/intl.h
452 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
453 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
454 %{_includedir}/wx-%{ver2}/wx/ipc.h
455 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
456 %{_includedir}/wx-%{ver2}/wx/isql.h
457 %{_includedir}/wx-%{ver2}/wx/isqlext.h
458 %{_includedir}/wx-%{ver2}/wx/list.h
459 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
460 %{_includedir}/wx-%{ver2}/wx/log.h
461 %{_includedir}/wx-%{ver2}/wx/longlong.h
462 %{_includedir}/wx-%{ver2}/wx/math.h
463 %{_includedir}/wx-%{ver2}/wx/memconf.h
464 %{_includedir}/wx-%{ver2}/wx/memory.h
465 %{_includedir}/wx-%{ver2}/wx/memtext.h
466 %{_includedir}/wx-%{ver2}/wx/mimetype.h
467 %{_includedir}/wx-%{ver2}/wx/module.h
468 %{_includedir}/wx-%{ver2}/wx/msgout.h
469 %{_includedir}/wx-%{ver2}/wx/mstream.h
470 %{_includedir}/wx-%{ver2}/wx/object.h
471 %{_includedir}/wx-%{ver2}/wx/platform.h
472 %{_includedir}/wx-%{ver2}/wx/process.h
473 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
474 %{_includedir}/wx-%{ver2}/wx/regex.h
475 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
476 %{_includedir}/wx-%{ver2}/wx/snglinst.h
477 %{_includedir}/wx-%{ver2}/wx/sstream.h
478 %{_includedir}/wx-%{ver2}/wx/stack.h
479 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
480 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
481 %{_includedir}/wx-%{ver2}/wx/stockitem.h
482 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
483 %{_includedir}/wx-%{ver2}/wx/strconv.h
484 %{_includedir}/wx-%{ver2}/wx/stream.h
485 %{_includedir}/wx-%{ver2}/wx/string.h
486 %{_includedir}/wx-%{ver2}/wx/sysopt.h
487 %{_includedir}/wx-%{ver2}/wx/textbuf.h
488 %{_includedir}/wx-%{ver2}/wx/textfile.h
489 %{_includedir}/wx-%{ver2}/wx/thread.h
490 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
491 %{_includedir}/wx-%{ver2}/wx/timer.h
492 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
493 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
494 %{_includedir}/wx-%{ver2}/wx/types.h
495 %{_includedir}/wx-%{ver2}/wx/uri.h
496 %{_includedir}/wx-%{ver2}/wx/utils.h
497 %{_includedir}/wx-%{ver2}/wx/variant.h
498 %{_includedir}/wx-%{ver2}/wx/vector.h
499 %{_includedir}/wx-%{ver2}/wx/version.h
500 %{_includedir}/wx-%{ver2}/wx/volume.h
501 %{_includedir}/wx-%{ver2}/wx/wfstream.h
502 %{_includedir}/wx-%{ver2}/wx/wx.h
503 %{_includedir}/wx-%{ver2}/wx/wxchar.h
504 %{_includedir}/wx-%{ver2}/wx/wxprec.h
505 %{_includedir}/wx-%{ver2}/wx/xti.h
506 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
507 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
508 %{_includedir}/wx-%{ver2}/wx/zstream.h
509 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
510 %{_includedir}/wx-%{ver2}/wx/gsocket.h
511 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
512 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
513 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
514 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
515 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
516 %{_includedir}/wx-%{ver2}/wx/sckipc.h
517 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
518 %{_includedir}/wx-%{ver2}/wx/socket.h
519 %{_includedir}/wx-%{ver2}/wx/url.h
520 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
521 %{_includedir}/wx-%{ver2}/wx/xtixml.h
522 %{_includedir}/wx-%{ver2}/wx/db.h
523 %{_includedir}/wx-%{ver2}/wx/dbkeyg.h
524 %{_includedir}/wx-%{ver2}/wx/dbtable.h
525 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
526 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
527 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
528 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
529 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
530 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
531 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
532 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
533 EOF
534 # --- wxBase headers list ends here ---
535
536 # temporarily remove base headers
537 mkdir $RPM_BUILD_ROOT/_save_dir
538 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
539 for f in `cat wxbase-headers.files` ; do
540 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
541 done
542 # list of all core headers:
543 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
544 # move base headers (actually all headers) back again
545 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
546 rm -rf $RPM_BUILD_ROOT/_save_dir
547
548 # contrib stuff:
549 (cd obj-shared/contrib/src; make DESTDIR=$RPM_BUILD_ROOT install)
550 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT install)
551
552 %clean
553 rm -rf $RPM_BUILD_ROOT
554
555 %post
556 /sbin/ldconfig
557
558 %postun
559 /sbin/ldconfig
560
561 %post devel
562 # link wx-config when you install RPM.
563 %if %{unicode}
564 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
565 %endif
566 # link wx-config with explicit name.
567 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
568 /sbin/ldconfig
569
570 %postun devel
571 /sbin/ldconfig
572
573 %preun devel
574 %if %{unicode}
575 rm -f %{_bindir}/wx-config
576 %endif
577 rm -f %{_bindir}/%{wxconfiglink}
578
579 %post -n %{wxbasename}
580 /sbin/ldconfig
581
582 %postun -n %{wxbasename}
583 /sbin/ldconfig
584
585 %post -n %{wxbasename}-devel
586 # link wx-config with explicit name.
587 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
588 /sbin/ldconfig
589
590 %postun -n %{wxbasename}-devel
591 /sbin/ldconfig
592
593 %preun -n %{wxbasename}-devel
594 rm -f %{_bindir}/%{wxbaseconfiglink}
595
596 %post gl
597 /sbin/ldconfig
598
599 %postun gl
600 /sbin/ldconfig
601
602 %post contrib
603 /sbin/ldconfig
604
605 %postun contrib
606 /sbin/ldconfig
607
608 %post contrib-devel
609 /sbin/ldconfig
610
611 %postun contrib-devel
612 /sbin/ldconfig
613
614 %files
615 %defattr(-,root,root)
616 %doc COPYING.LIB *.txt
617 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
618 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
619 %if !%{unicode}
620 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
621 %endif
622 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
623 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so.*
624 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
625 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
626
627 %files -n wx-i18n
628 %defattr(-,root,root)
629 %{_datadir}/locale/*/*/*
630
631 %files devel -f core-headers.files
632 %defattr(-,root,root)
633 # shared libs
634 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
635 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
636 %if !%{unicode}
637 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
638 %endif
639 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
640 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
641 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so
642 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
643 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
644 # static libs
645 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
646 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
647 %if !%{unicode}
648 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
649 %endif
650 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
651 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
652 %{_libdir}/libwx_%{buildname}_media-%{ver2}.a
653 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
654 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
655 %dir %{_libdir}/wx
656 %{_libdir}/wx/config/%{wxconfig}
657 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
658 %{_libdir}/wx/config/%{wxconfigstatic}
659 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
660 %{_bindir}/wxrc*
661
662 %files -n %{wxbasename}
663 %defattr(-,root,root)
664 %{_libdir}/libwx_base*-%{ver2}.so.*
665
666 %files -n %{wxbasename}-devel -f wxbase-headers.paths
667 %defattr (-,root,root)
668 %dir %{_includedir}/wx-%{ver2}
669 %{_libdir}/libwx_base*-%{ver2}.so
670 %{_libdir}/libwx_base*-%{ver2}.a
671 %if %{unicode}
672 %{_libdir}/libwxregexu-%{ver2}.a
673 %endif
674 %dir %{_libdir}/wx
675 %{_libdir}/wx/config/%{wxbaseconfig}
676 %{_libdir}/wx/include/%{wxbaseconfig}/wx/setup.h
677 %{_libdir}/wx/config/%{wxbaseconfigstatic}
678 %{_libdir}/wx/include/%{wxbaseconfigstatic}/wx/setup.h
679 %{_datadir}/aclocal/*.m4
680
681 %files gl
682 %defattr(-,root,root)
683 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
684
685 %files contrib
686 %defattr(-,root,root)
687 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
688 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
689 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
690 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
691 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
692 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
693 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
694 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
695 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
696 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
697
698 %files contrib-devel
699 %defattr(-,root,root)
700 %dir %{_includedir}/wx-%{ver2}/wx/animate
701 %{_includedir}/wx-%{ver2}/wx/animate/*
702 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
703
704 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
705 %{_includedir}/wx-%{ver2}/wx/deprecated/*
706 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
707
708 %dir %{_includedir}/wx-%{ver2}/wx/fl
709 %{_includedir}/wx-%{ver2}/wx/fl/*
710 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
711
712 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
713 %{_includedir}/wx-%{ver2}/wx/gizmos/*
714 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
715 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
716
717 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
718 %{_includedir}/wx-%{ver2}/wx/mmedia/*
719 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
720
721 %dir %{_includedir}/wx-%{ver2}/wx/ogl
722 %{_includedir}/wx-%{ver2}/wx/ogl/*
723 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
724
725 %dir %{_includedir}/wx-%{ver2}/wx/plot
726 %{_includedir}/wx-%{ver2}/wx/plot/*
727 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
728
729 %dir %{_includedir}/wx-%{ver2}/wx/stc
730 %{_includedir}/wx-%{ver2}/wx/stc/*
731 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
732
733 %dir %{_includedir}/wx-%{ver2}/wx/svg
734 %{_includedir}/wx-%{ver2}/wx/svg/*
735 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so