Baked files for 2.6.1
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /opt/gnome
2 %define ver 2.6.1
3 %define ver2 2.6
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfigstatic base-unicode-release-static-%{ver2}
46 %define wxbaseconfiglink wxbaseu-%{ver2}-config
47 %else
48 %define wxbasename wx-base-ansi
49 %define wxbaseconfig base-ansi-release-%{ver2}
50 %define wxbaseconfigstatic base-ansi-release-static-%{ver2}
51 %define wxbaseconfiglink wxbase-%{ver2}-config
52 %endif
53
54 Summary: The GTK+ %{gtkver} port of the wxWidgets library
55 Name: %{name}
56 Version: %{ver}
57 Release: %{rel}
58 License: wxWindows Licence
59 Group: X11/Libraries
60 Source: wxGTK-%{ver}.tar.gz
61 URL: http://www.wxwidgets.org
62 Packager: Vadim Zeitlin <vadim@wxwindows.org>
63 Prefix: %{_prefix}
64 BuildRoot: %{_tmppath}/%{name}-root
65 Requires: %{wxbasename} = %{ver}
66 %if %{portname} == gtk2
67 # BuildRequires: gtk+-2.0-devel
68 %else
69 # BuildRequires: gtk+-devel >= 1.2.0
70 %endif
71
72 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
73
74 # all packages providing an implementation of wxWidgets library (regardless of
75 # the toolkit used) should provide the (virtual) wxwin package, this makes it
76 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
77 Provides: wxwin
78 Provides: wxGTK
79
80 %description
81 wxWidgets is a free C++ library for cross-platform GUI development.
82 With wxWidgets, you can create applications for different GUIs (GTK+,
83 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
84
85 %package -n wx-i18n
86 Summary: The translations for the wxWidgets library.
87 Group: X11/Libraries
88
89 %description -n wx-i18n
90 The translations files for the wxWidgets library.
91
92 %package devel
93 Summary: The GTK+ %{gtkver} port of the wxWidgets library
94 Group: X11/Libraries
95 Requires: %{name} = %{ver}
96 Requires: %{wxbasename}-devel = %{ver}
97 Provides: wxGTK-devel
98
99 %description devel
100 The GTK+ %{gtkver} port of the wxWidgets library, header files.
101
102 %package gl
103 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
104 Group: X11/Libraries
105 Requires: %{name} = %{ver}
106 Provides: wxGTK-gl
107
108 %description gl
109 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
110
111 %package -n %{wxbasename}
112 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
113 Group: Development/Libraries
114 Provides: wxBase
115
116 %description -n %{wxbasename}
117 wxBase is a collection of C++ classes providing basic data structures (strings,
118 lists, arrays), portable wrappers around many OS-specific funstions (file
119 operations, time/date manipulations, threads, processes, sockets, shared
120 library loading) as well as other utility classes (streams, archive and
121 compression). wxBase currently supports Win32, most Unix variants (Linux,
122 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
123
124 %package -n %{wxbasename}-devel
125 Summary: wxBase library, header files.
126 Group: Development/Libraries
127 Provides: wxBase-devel
128
129 %description -n %{wxbasename}-devel
130 wxBase library - non-GUI support classes of the wxWidgets toolkit,
131 header files.
132
133 %package contrib
134 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
135 Group: X11/Libraries
136 Requires: %{name} = %{ver}
137
138 %description contrib
139 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
140
141 %package contrib-devel
142 Summary: The GTK+ %{gtkver} port of the wxWidgets library
143 Group: X11/Libraries
144 Requires: %{name}-contrib = %{ver}
145 Requires: %{name}-devel = %{ver}
146
147 %description contrib-devel
148 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
149
150 %prep
151 %setup -q -n wxGTK-%{ver}
152
153 %build
154 if [ "$SMP" != "" ]; then
155 export MAKE="make -j$SMP"
156 else
157 export MAKE="make"
158 fi
159
160 mkdir obj-shared-no-gui
161 cd obj-shared-no-gui
162 ../configure --prefix=%{_prefix} \
163 --disable-gui \
164 %if %{unicode}
165 --enable-unicode
166 %else
167 --disable-unicode
168 %endif
169 $MAKE
170 cd ..
171
172 mkdir obj-shared
173 cd obj-shared
174 ../configure --prefix=%{_prefix} \
175 %if ! %{gtk2}
176 --with-gtk=1 \
177 %else
178 --with-gtk=2 \
179 %endif
180 %if %{unicode}
181 --enable-unicode \
182 %else
183 --disable-unicode \
184 --with-odbc \
185 %endif
186 --with-opengl
187 $MAKE
188
189 cd contrib/src
190 $MAKE
191 cd ../../..
192
193 mkdir obj-static-no-gui
194 cd obj-static-no-gui
195 ../configure --prefix=%{_prefix} \
196 --disable-gui \
197 --disable-shared \
198 %if %{unicode}
199 --enable-unicode
200 %else
201 --disable-unicode
202 %endif
203 $MAKE
204 cd ..
205
206 mkdir obj-static
207 cd obj-static
208 ../configure --prefix=%{_prefix} \
209 %if ! %{gtk2}
210 --with-gtk=1 \
211 %else
212 --with-gtk=2 \
213 %endif
214 --disable-shared \
215 %if %{unicode}
216 --enable-unicode \
217 %else
218 --disable-unicode \
219 --with-odbc \
220 %endif
221 --with-opengl
222 $MAKE
223
224 cd contrib/src
225 $MAKE
226 cd ../../..
227
228 %install
229 rm -rf $RPM_BUILD_ROOT
230 (cd obj-static-no-gui; make DESTDIR=$RPM_BUILD_ROOT install)
231 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT install)
232 (cd obj-shared-no-gui; make DESTDIR=$RPM_BUILD_ROOT install)
233 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT install)
234
235 # --- wxBase headers list begins here ---
236 cat <<EOF >wxbase-headers-list
237 wx/afterstd.h
238 wx/app.h
239 wx/apptrait.h
240 wx/archive.h
241 wx/arrimpl.cpp
242 wx/arrstr.h
243 wx/beforestd.h
244 wx/buffer.h
245 wx/build.h
246 wx/chkconf.h
247 wx/clntdata.h
248 wx/cmdline.h
249 wx/confbase.h
250 wx/config.h
251 wx/containr.h
252 wx/datetime.h
253 wx/datstrm.h
254 wx/dde.h
255 wx/debug.h
256 wx/defs.h
257 wx/dir.h
258 wx/dlimpexp.h
259 wx/dynarray.h
260 wx/dynlib.h
261 wx/dynload.h
262 wx/encconv.h
263 wx/event.h
264 wx/except.h
265 wx/features.h
266 wx/ffile.h
267 wx/file.h
268 wx/fileconf.h
269 wx/filefn.h
270 wx/filename.h
271 wx/filesys.h
272 wx/fontenc.h
273 wx/fontmap.h
274 wx/fs_mem.h
275 wx/fs_zip.h
276 wx/hash.h
277 wx/hashmap.h
278 wx/hashset.h
279 wx/html/forcelnk.h
280 wx/iconloc.h
281 wx/init.h
282 wx/intl.h
283 wx/iosfwrap.h
284 wx/ioswrap.h
285 wx/ipc.h
286 wx/ipcbase.h
287 wx/isql.h
288 wx/isqlext.h
289 wx/list.h
290 wx/listimpl.cpp
291 wx/log.h
292 wx/longlong.h
293 wx/math.h
294 wx/memconf.h
295 wx/memory.h
296 wx/memtext.h
297 wx/mimetype.h
298 wx/module.h
299 wx/msgout.h
300 wx/msgout.h
301 wx/mstream.h
302 wx/object.h
303 wx/platform.h
304 wx/process.h
305 wx/ptr_scpd.h
306 wx/regex.h
307 wx/scopeguard.h
308 wx/snglinst.h
309 wx/sstream.h
310 wx/stack.h
311 wx/stackwalk.h
312 wx/stdpaths.h
313 wx/stockitem.h
314 wx/stopwatch.h
315 wx/strconv.h
316 wx/stream.h
317 wx/string.h
318 wx/sysopt.h
319 wx/textbuf.h
320 wx/textfile.h
321 wx/thread.h
322 wx/thrimpl.cpp
323 wx/timer.h
324 wx/tokenzr.h
325 wx/txtstrm.h
326 wx/types.h
327 wx/uri.h
328 wx/utils.h
329 wx/variant.h
330 wx/vector.h
331 wx/version.h
332 wx/volume.h
333 wx/wfstream.h
334 wx/wx.h
335 wx/wxchar.h
336 wx/wxprec.h
337 wx/xti.h
338 wx/xtistrm.h
339 wx/zipstrm.h
340 wx/zstream.h
341 wx/msw/apptrait.h
342 wx/msw/apptbase.h
343 wx/msw/chkconf.h
344 wx/msw/crashrpt.h
345 wx/msw/dde.h
346 wx/msw/debughlp.h
347 wx/msw/gccpriv.h
348 wx/msw/mimetype.h
349 wx/msw/stackwalk.h
350 wx/msw/stdpaths.h
351 wx/msw/winundef.h
352 wx/msw/wrapcctl.h
353 wx/msw/wrapcdlg.h
354 wx/msw/wrapwin.h
355 wx/fs_inet.h
356 wx/gsocket.h
357 wx/protocol/file.h
358 wx/protocol/ftp.h
359 wx/protocol/http.h
360 wx/protocol/protocol.h
361 wx/sckaddr.h
362 wx/sckipc.h
363 wx/sckstrm.h
364 wx/socket.h
365 wx/url.h
366 wx/msw/gsockmsw.h
367 wx/xml/xml.h
368 wx/xtixml.h
369 wx/db.h
370 wx/dbkeyg.h
371 wx/dbtable.h
372 EOF
373 # --- wxBase headers list ends here ---
374 cat <<EOF >wxbase-headers.paths
375 %{_includedir}/wx-%{ver2}/wx/afterstd.h
376 %{_includedir}/wx-%{ver2}/wx/app.h
377 %{_includedir}/wx-%{ver2}/wx/apptrait.h
378 %{_includedir}/wx-%{ver2}/wx/archive.h
379 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
380 %{_includedir}/wx-%{ver2}/wx/arrstr.h
381 %{_includedir}/wx-%{ver2}/wx/beforestd.h
382 %{_includedir}/wx-%{ver2}/wx/buffer.h
383 %{_includedir}/wx-%{ver2}/wx/build.h
384 %{_includedir}/wx-%{ver2}/wx/chkconf.h
385 %{_includedir}/wx-%{ver2}/wx/clntdata.h
386 %{_includedir}/wx-%{ver2}/wx/cmdline.h
387 %{_includedir}/wx-%{ver2}/wx/confbase.h
388 %{_includedir}/wx-%{ver2}/wx/config.h
389 %{_includedir}/wx-%{ver2}/wx/containr.h
390 %{_includedir}/wx-%{ver2}/wx/datetime.h
391 %{_includedir}/wx-%{ver2}/wx/datetime.inl
392 %{_includedir}/wx-%{ver2}/wx/datstrm.h
393 %{_includedir}/wx-%{ver2}/wx/dde.h
394 %{_includedir}/wx-%{ver2}/wx/debug.h
395 %{_includedir}/wx-%{ver2}/wx/defs.h
396 %{_includedir}/wx-%{ver2}/wx/dir.h
397 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
398 %{_includedir}/wx-%{ver2}/wx/dynarray.h
399 %{_includedir}/wx-%{ver2}/wx/dynlib.h
400 %{_includedir}/wx-%{ver2}/wx/dynload.h
401 %{_includedir}/wx-%{ver2}/wx/encconv.h
402 %{_includedir}/wx-%{ver2}/wx/event.h
403 %{_includedir}/wx-%{ver2}/wx/except.h
404 %{_includedir}/wx-%{ver2}/wx/features.h
405 %{_includedir}/wx-%{ver2}/wx/ffile.h
406 %{_includedir}/wx-%{ver2}/wx/file.h
407 %{_includedir}/wx-%{ver2}/wx/fileconf.h
408 %{_includedir}/wx-%{ver2}/wx/filefn.h
409 %{_includedir}/wx-%{ver2}/wx/filename.h
410 %{_includedir}/wx-%{ver2}/wx/filesys.h
411 %{_includedir}/wx-%{ver2}/wx/fontenc.h
412 %{_includedir}/wx-%{ver2}/wx/fontmap.h
413 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
414 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
415 %{_includedir}/wx-%{ver2}/wx/hash.h
416 %{_includedir}/wx-%{ver2}/wx/hashmap.h
417 %{_includedir}/wx-%{ver2}/wx/hashset.h
418 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
419 %{_includedir}/wx-%{ver2}/wx/iconloc.h
420 %{_includedir}/wx-%{ver2}/wx/init.h
421 %{_includedir}/wx-%{ver2}/wx/intl.h
422 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
423 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
424 %{_includedir}/wx-%{ver2}/wx/ipc.h
425 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
426 %{_includedir}/wx-%{ver2}/wx/isql.h
427 %{_includedir}/wx-%{ver2}/wx/isqlext.h
428 %{_includedir}/wx-%{ver2}/wx/list.h
429 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
430 %{_includedir}/wx-%{ver2}/wx/log.h
431 %{_includedir}/wx-%{ver2}/wx/longlong.h
432 %{_includedir}/wx-%{ver2}/wx/math.h
433 %{_includedir}/wx-%{ver2}/wx/memconf.h
434 %{_includedir}/wx-%{ver2}/wx/memory.h
435 %{_includedir}/wx-%{ver2}/wx/memtext.h
436 %{_includedir}/wx-%{ver2}/wx/mimetype.h
437 %{_includedir}/wx-%{ver2}/wx/module.h
438 %{_includedir}/wx-%{ver2}/wx/msgout.h
439 %{_includedir}/wx-%{ver2}/wx/mstream.h
440 %{_includedir}/wx-%{ver2}/wx/object.h
441 %{_includedir}/wx-%{ver2}/wx/platform.h
442 %{_includedir}/wx-%{ver2}/wx/process.h
443 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
444 %{_includedir}/wx-%{ver2}/wx/regex.h
445 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
446 %{_includedir}/wx-%{ver2}/wx/snglinst.h
447 %{_includedir}/wx-%{ver2}/wx/sstream.h
448 %{_includedir}/wx-%{ver2}/wx/stack.h
449 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
450 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
451 %{_includedir}/wx-%{ver2}/wx/stockitem.h
452 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
453 %{_includedir}/wx-%{ver2}/wx/strconv.h
454 %{_includedir}/wx-%{ver2}/wx/stream.h
455 %{_includedir}/wx-%{ver2}/wx/string.h
456 %{_includedir}/wx-%{ver2}/wx/sysopt.h
457 %{_includedir}/wx-%{ver2}/wx/textbuf.h
458 %{_includedir}/wx-%{ver2}/wx/textfile.h
459 %{_includedir}/wx-%{ver2}/wx/thread.h
460 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
461 %{_includedir}/wx-%{ver2}/wx/timer.h
462 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
463 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
464 %{_includedir}/wx-%{ver2}/wx/types.h
465 %{_includedir}/wx-%{ver2}/wx/uri.h
466 %{_includedir}/wx-%{ver2}/wx/utils.h
467 %{_includedir}/wx-%{ver2}/wx/variant.h
468 %{_includedir}/wx-%{ver2}/wx/vector.h
469 %{_includedir}/wx-%{ver2}/wx/version.h
470 %{_includedir}/wx-%{ver2}/wx/volume.h
471 %{_includedir}/wx-%{ver2}/wx/wfstream.h
472 %{_includedir}/wx-%{ver2}/wx/wx.h
473 %{_includedir}/wx-%{ver2}/wx/wxchar.h
474 %{_includedir}/wx-%{ver2}/wx/wxprec.h
475 %{_includedir}/wx-%{ver2}/wx/xti.h
476 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
477 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
478 %{_includedir}/wx-%{ver2}/wx/zstream.h
479 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
480 %{_includedir}/wx-%{ver2}/wx/gsocket.h
481 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
482 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
483 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
484 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
485 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
486 %{_includedir}/wx-%{ver2}/wx/sckipc.h
487 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
488 %{_includedir}/wx-%{ver2}/wx/socket.h
489 %{_includedir}/wx-%{ver2}/wx/url.h
490 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
491 %{_includedir}/wx-%{ver2}/wx/xtixml.h
492 %{_includedir}/wx-%{ver2}/wx/db.h
493 %{_includedir}/wx-%{ver2}/wx/dbkeyg.h
494 %{_includedir}/wx-%{ver2}/wx/dbtable.h
495 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
496 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
497 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
498 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
499 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
500 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
501 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
502 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
503 EOF
504 # --- wxBase headers list ends here ---
505
506 # temporarily remove base headers
507 mkdir $RPM_BUILD_ROOT/_save_dir
508 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
509 for f in `cat wxbase-headers.files` ; do
510 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
511 done
512 # list of all core headers:
513 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
514 # move base headers (actually all headers) back again
515 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
516 rm -rf $RPM_BUILD_ROOT/_save_dir
517
518 # contrib stuff:
519 (cd obj-shared/contrib/src; make DESTDIR=$RPM_BUILD_ROOT install)
520 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT install)
521
522 %clean
523 rm -rf $RPM_BUILD_ROOT
524
525 %post
526 /sbin/ldconfig
527
528 %postun
529 /sbin/ldconfig
530
531 %post devel
532 # link wx-config when you install RPM.
533 %if %{unicode}
534 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
535 %endif
536 # link wx-config with explicit name.
537 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
538 /sbin/ldconfig
539
540 %postun devel
541 /sbin/ldconfig
542
543 %preun devel
544 %if %{unicode}
545 rm -f %{_bindir}/wx-config
546 %endif
547 rm -f %{_bindir}/%{wxconfiglink}
548
549 %post -n %{wxbasename}
550 /sbin/ldconfig
551
552 %postun -n %{wxbasename}
553 /sbin/ldconfig
554
555 %post -n %{wxbasename}-devel
556 # link wx-config with explicit name.
557 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
558 /sbin/ldconfig
559
560 %postun -n %{wxbasename}-devel
561 /sbin/ldconfig
562
563 %preun -n %{wxbasename}-devel
564 rm -f %{_bindir}/%{wxbaseconfiglink}
565
566 %post gl
567 /sbin/ldconfig
568
569 %postun gl
570 /sbin/ldconfig
571
572 %post contrib
573 /sbin/ldconfig
574
575 %postun contrib
576 /sbin/ldconfig
577
578 %post contrib-devel
579 /sbin/ldconfig
580
581 %postun contrib-devel
582 /sbin/ldconfig
583
584 %files
585 %defattr(-,root,root)
586 %doc COPYING.LIB *.txt
587 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
588 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
589 %if !%{unicode}
590 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
591 %endif
592 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
593 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so.*
594 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
595 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
596
597 %files -n wx-i18n
598 %defattr(-,root,root)
599 %{_datadir}/locale/*/*/*
600
601 %files devel -f core-headers.files
602 %defattr(-,root,root)
603 # shared libs
604 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
605 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
606 %if !%{unicode}
607 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
608 %endif
609 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
610 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
611 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so
612 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
613 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
614 # static libs
615 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
616 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
617 %if !%{unicode}
618 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
619 %endif
620 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
621 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
622 %{_libdir}/libwx_%{buildname}_media-%{ver2}.a
623 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
624 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
625 %dir %{_libdir}/wx
626 %{_libdir}/wx/config/%{wxconfig}
627 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
628 %{_libdir}/wx/config/%{wxconfigstatic}
629 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
630 %{_bindir}/wxrc*
631
632 %files -n %{wxbasename}
633 %defattr(-,root,root)
634 %{_libdir}/libwx_base*-%{ver2}.so.*
635
636 %files -n %{wxbasename}-devel -f wxbase-headers.paths
637 %defattr (-,root,root)
638 %dir %{_includedir}/wx-%{ver2}
639 %{_libdir}/libwx_base*-%{ver2}.so
640 %{_libdir}/libwx_base*-%{ver2}.a
641 %if %{unicode}
642 %{_libdir}/libwxregexu-%{ver2}.a
643 %endif
644 %dir %{_libdir}/wx
645 %{_libdir}/wx/config/%{wxbaseconfig}
646 %{_libdir}/wx/include/%{wxbaseconfig}/wx/setup.h
647 %{_libdir}/wx/config/%{wxbaseconfigstatic}
648 %{_libdir}/wx/include/%{wxbaseconfigstatic}/wx/setup.h
649 %{_datadir}/aclocal/*.m4
650
651 %files gl
652 %defattr(-,root,root)
653 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
654
655 %files contrib
656 %defattr(-,root,root)
657 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
658 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
659 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
660 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
661 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
662 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
663 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
664 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
665 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
666 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
667
668 %files contrib-devel
669 %defattr(-,root,root)
670 %dir %{_includedir}/wx-%{ver2}/wx/animate
671 %{_includedir}/wx-%{ver2}/wx/animate/*
672 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
673
674 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
675 %{_includedir}/wx-%{ver2}/wx/deprecated/*
676 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
677
678 %dir %{_includedir}/wx-%{ver2}/wx/fl
679 %{_includedir}/wx-%{ver2}/wx/fl/*
680 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
681
682 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
683 %{_includedir}/wx-%{ver2}/wx/gizmos/*
684 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
685 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
686
687 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
688 %{_includedir}/wx-%{ver2}/wx/mmedia/*
689 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
690
691 %dir %{_includedir}/wx-%{ver2}/wx/ogl
692 %{_includedir}/wx-%{ver2}/wx/ogl/*
693 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
694
695 %dir %{_includedir}/wx-%{ver2}/wx/plot
696 %{_includedir}/wx-%{ver2}/wx/plot/*
697 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
698
699 %dir %{_includedir}/wx-%{ver2}/wx/stc
700 %{_includedir}/wx-%{ver2}/wx/stc/*
701 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
702
703 %dir %{_includedir}/wx-%{ver2}/wx/svg
704 %{_includedir}/wx-%{ver2}/wx/svg/*
705 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so