moved primitive string and string iterators operations to stringops.h/cpp files to...
[wxWidgets.git] / wxX11.spec
1 %define pref /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define portname x11univ
12
13 %if %{unicode}
14 %define wxbasename wx-base-unicode
15 %define name wx-%{portname}-unicode
16 %define wxconfig %{portname}-unicode-release-%{ver2}
17 %define wxconfiglink wx%{portname}u-%{ver2}-config
18 %else
19 %define wxbasename wx-base
20 %define name wx-%{portname}
21 %define wxconfig %{portname}-ansi-release-%{ver2}
22 %define wxconfiglink wx%{portname}-%{ver2}-config
23 %endif
24
25 Summary: The X11 port of the wxWidgets library
26 Name: %{name}
27 Version: %{ver}
28 Release: %{rel}
29 License: wxWindows Licence
30 Group: X11/Libraries
31 Source: wxX11-%{ver}.tar.bz2
32 URL: http://www.wxwidgets.org
33 Packager: Vadim Zeitlin <vadim@wxwindows.org>
34 Prefix: %{pref}
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
37
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
41 Provides: wxwin
42 Provides: wxX11
43
44 %description
45 wxWidgets is a free C++ library for cross-platform GUI development.
46 With wxWidgets, you can create applications for different GUIs (GTK+,
47 Motif/LessTif, MS Windows, Mac) from the same source code.
48
49 %package devel
50 Summary: The X11 port of the wxWidgets library
51 Group: X11/Libraries
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
54
55 %description devel
56 Header files for wxX11, the X11 port of the wxWidgets library.
57
58 %package gl
59 Summary: The X11 port of the wxWidgets library, OpenGL add-on.
60 Group: X11/Libraries
61 Requires: %{name} = %{ver}
62
63 %description gl
64 OpenGL add-on library for wxX11, the X11 port of the wxWidgets library.
65
66 %package static
67 Summary: wxX11 static libraries
68 Group: Development/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
71
72 %description static
73 Static libraries for wxX11. You need them if you want to link statically against wxX11.
74
75 %package contrib
76 Summary: Contrib libraries for wxX11.
77 Group: X11/Libraries
78 Requires: %{name} = %{ver}
79
80 %description contrib
81 Contributed libraries for wxX11.
82
83 %package contrib-devel
84 Summary: Contrib libraries for wxX11.
85 Group: X11/Libraries
86 Requires: %{name}-contrib = %{ver}
87 Requires: %{name}-devel = %{ver}
88
89 %description contrib-devel
90 Header files for contributed libraries for wxX11.
91
92 %prep
93 %setup -q -n wxX11-%{ver}
94
95 %build
96 if [ "$SMP" != "" ]; then
97 export MAKE="make -j$SMP"
98 else
99 export MAKE="make"
100 fi
101
102 mkdir obj-shared
103 cd obj-shared
104 ../configure --prefix=%{pref} --with-x11 \
105 %if %{unicode}
106 --enable-unicode \
107 %else
108 --with-odbc \
109 %endif
110 --with-opengl
111 $MAKE
112
113 cd contrib/src
114 $MAKE
115 cd ../../..
116
117 mkdir obj-static
118 cd obj-static
119 ../configure --prefix=%{pref} --with-x11 --disable-shared \
120 %if %{unicode}
121 --enable-unicode \
122 %else
123 --with-odbc \
124 %endif
125 --with-opengl
126 $MAKE
127 cd ..
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
132 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
133
134 # Remove headers that are part of wx-base-devel:
135
136 # --- wxBase headers list begins here ---
137 cat <<EOF >wxbase-headers.files
138 wx/afterstd.h
139 wx/app.h
140 wx/apptrait.h
141 wx/archive.h
142 wx/arrimpl.cpp
143 wx/arrstr.h
144 wx/beforestd.h
145 wx/buffer.h
146 wx/build.h
147 wx/chartype.h
148 wx/chkconf.h
149 wx/clntdata.h
150 wx/cmdline.h
151 wx/confbase.h
152 wx/config.h
153 wx/convauto.h
154 wx/containr.h
155 wx/cpp.h
156 wx/datetime.h
157 wx/datstrm.h
158 wx/dde.h
159 wx/debug.h
160 wx/defs.h
161 wx/dir.h
162 wx/dlimpexp.h
163 wx/dynarray.h
164 wx/dynlib.h
165 wx/dynload.h
166 wx/encconv.h
167 wx/event.h
168 wx/except.h
169 wx/features.h
170 wx/flags.h
171 wx/ffile.h
172 wx/file.h
173 wx/fileconf.h
174 wx/filefn.h
175 wx/filename.h
176 wx/filesys.h
177 wx/fontenc.h
178 wx/fontmap.h
179 wx/fs_arc.h
180 wx/fs_filter.h
181 wx/fs_mem.h
182 wx/fs_zip.h
183 wx/hash.h
184 wx/hashmap.h
185 wx/hashset.h
186 wx/html/forcelnk.h
187 wx/iconloc.h
188 wx/init.h
189 wx/intl.h
190 wx/iosfwrap.h
191 wx/ioswrap.h
192 wx/ipc.h
193 wx/ipcbase.h
194 wx/isql.h
195 wx/isqlext.h
196 wx/link.h
197 wx/list.h
198 wx/listimpl.cpp
199 wx/log.h
200 wx/longlong.h
201 wx/math.h
202 wx/memconf.h
203 wx/memory.h
204 wx/memtext.h
205 wx/mimetype.h
206 wx/module.h
207 wx/msgout.h
208 wx/mstream.h
209 wx/object.h
210 wx/platform.h
211 wx/platinfo.h
212 wx/power.h
213 wx/process.h
214 wx/ptr_scpd.h
215 wx/recguard.h
216 wx/regex.h
217 wx/scopeguard.h
218 wx/snglinst.h
219 wx/sstream.h
220 wx/stack.h
221 wx/stackwalk.h
222 wx/stdpaths.h
223 wx/stockitem.h
224 wx/stopwatch.h
225 wx/strconv.h
226 wx/stream.h
227 wx/string.h
228 wx/stringimpl.h
229 wx/stringops.h
230 wx/strvararg.h
231 wx/sysopt.h
232 wx/tarstrm.h
233 wx/textbuf.h
234 wx/textfile.h
235 wx/thread.h
236 wx/thrimpl.cpp
237 wx/timer.h
238 wx/tokenzr.h
239 wx/txtstrm.h
240 wx/types.h
241 wx/unichar.h
242 wx/uri.h
243 wx/utils.h
244 wx/variant.h
245 wx/vector.h
246 wx/version.h
247 wx/volume.h
248 wx/wfstream.h
249 wx/wx.h
250 wx/wxchar.h
251 wx/wxcrt.h
252 wx/wxcrtvararg.h
253 wx/wxprec.h
254 wx/xti.h
255 wx/xtistrm.h
256 wx/zipstrm.h
257 wx/zstream.h
258 wx/unix/apptbase.h
259 wx/unix/apptrait.h
260 wx/unix/execute.h
261 wx/unix/mimetype.h
262 wx/unix/pipe.h
263 wx/unix/private.h
264 wx/unix/stackwalk.h
265 wx/unix/stdpaths.h
266 wx/fs_inet.h
267 wx/gsocket.h
268 wx/protocol/file.h
269 wx/protocol/ftp.h
270 wx/protocol/http.h
271 wx/protocol/protocol.h
272 wx/sckaddr.h
273 wx/sckipc.h
274 wx/sckstrm.h
275 wx/socket.h
276 wx/url.h
277 wx/unix/gsockunx.h
278 wx/xml/xml.h
279 wx/xtixml.h
280 wx/db.h
281 wx/dbkeyg.h
282 wx/dbtable.h
283 EOF
284 # --- wxBase headers list ends here ---
285 for f in `cat wxbase-headers-list` ; do
286 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
287 done
288
289 # list of all core headers:
290 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
291
292 # contrib stuff:
293 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
294 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
295
296 # remove wxBase files so that RPM doesn't complain about unpackaged files:
297 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
298 %if %{unicode}
299 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
300 %endif
301 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
302 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
303
304 %clean
305 rm -rf $RPM_BUILD_ROOT
306
307 %post
308 /sbin/ldconfig
309
310 %postun
311 /sbin/ldconfig
312
313 %post devel
314 # link wx-config when you install RPM.
315 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
316 # link wx-config with explicit name.
317 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
318 /sbin/ldconfig
319
320 %postun devel
321 /sbin/ldconfig
322
323 %preun devel
324 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
325 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
326 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
327 if test "x$SUM1" = "x$SUM2" ; then
328 rm -f %{_bindir}/wx-config
329 fi
330 fi
331 rm -f %{_bindir}/%{wxconfiglink}
332
333 %post gl
334 /sbin/ldconfig
335
336 %postun gl
337 /sbin/ldconfig
338
339 %post contrib
340 /sbin/ldconfig
341
342 %postun contrib
343 /sbin/ldconfig
344
345 %post contrib-devel
346 /sbin/ldconfig
347
348 %postun contrib-devel
349 /sbin/ldconfig
350
351 %files
352 %defattr(-,root,root)
353 %doc COPYING.LIB *.txt
354 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
355 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
356 %if !%{unicode}
357 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
358 %endif
359 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
360 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
361 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
362 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
363
364
365 %files devel -f core-headers.files
366 %defattr(-,root,root)
367 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
368 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
369 %if !%{unicode}
370 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
371 %endif
372 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
373 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
374 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
375 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
376 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
377 %dir %{_libdir}/wx
378 %{_libdir}/wx/*
379 %{_bindir}/wxrc*
380
381 %files gl
382 %defattr(-,root,root)
383 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
384
385 %files static
386 %defattr (-,root,root)
387 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
388
389 %files contrib
390 %defattr(-,root,root)
391 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
392 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
393 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
394 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
395 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
396 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
397 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
398 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
399 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
400
401 %files contrib-devel
402 %defattr(-,root,root)
403 %dir %{_includedir}/wx-%{ver2}/wx/animate
404 %{_includedir}/wx-%{ver2}/wx/animate/*
405 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
406
407 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
408 %{_includedir}/wx-%{ver2}/wx/deprecated/*
409 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
410
411 %dir %{_includedir}/wx-%{ver2}/wx/fl
412 %{_includedir}/wx-%{ver2}/wx/fl/*
413 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
414
415 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
416 %{_includedir}/wx-%{ver2}/wx/gizmos/*
417 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
418
419 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
420 %{_includedir}/wx-%{ver2}/wx/mmedia/*
421 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
422
423 %dir %{_includedir}/wx-%{ver2}/wx/ogl
424 %{_includedir}/wx-%{ver2}/wx/ogl/*
425 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
426
427 %dir %{_includedir}/wx-%{ver2}/wx/plot
428 %{_includedir}/wx-%{ver2}/wx/plot/*
429 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
430
431 %dir %{_includedir}/wx-%{ver2}/wx/stc
432 %{_includedir}/wx-%{ver2}/wx/stc/*
433 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
434
435 %dir %{_includedir}/wx-%{ver2}/wx/svg
436 %{_includedir}/wx-%{ver2}/wx/svg/*
437 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so