Rebake after recguard.h added to bakefiles
[wxWidgets.git] / wxX11.spec
1 %define pref /usr
2 %define ver 2.6.2
3 %define ver2 2.6
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define portname x11univ
12
13 %if %{unicode}
14 %define wxbasename wx-base-unicode
15 %define name wx-%{portname}-unicode
16 %define wxconfig %{portname}-unicode-release-%{ver2}
17 %define wxconfiglink wx%{portname}u-%{ver2}-config
18 %else
19 %define wxbasename wx-base
20 %define name wx-%{portname}
21 %define wxconfig %{portname}-ansi-release-%{ver2}
22 %define wxconfiglink wx%{portname}-%{ver2}-config
23 %endif
24
25 Summary: The X11 port of the wxWidgets library
26 Name: %{name}
27 Version: %{ver}
28 Release: %{rel}
29 License: wxWindows Licence
30 Group: X11/Libraries
31 Source: wxX11-%{ver}.tar.bz2
32 URL: http://www.wxwidgets.org
33 Packager: Vadim Zeitlin <vadim@wxwindows.org>
34 Prefix: %{pref}
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
37
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
41 Provides: wxwin
42 Provides: wxX11
43
44 %description
45 wxWidgets is a free C++ library for cross-platform GUI development.
46 With wxWidgets, you can create applications for different GUIs (GTK+,
47 Motif/LessTif, MS Windows, Mac) from the same source code.
48
49 %package devel
50 Summary: The X11 port of the wxWidgets library
51 Group: X11/Libraries
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
54
55 %description devel
56 Header files for wxX11, the X11 port of the wxWidgets library.
57
58 %package gl
59 Summary: The X11 port of the wxWidgets library, OpenGL add-on.
60 Group: X11/Libraries
61 Requires: %{name} = %{ver}
62
63 %description gl
64 OpenGL add-on library for wxX11, the X11 port of the wxWidgets library.
65
66 %package static
67 Summary: wxX11 static libraries
68 Group: Development/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
71
72 %description static
73 Static libraries for wxX11. You need them if you want to link statically against wxX11.
74
75 %package contrib
76 Summary: Contrib libraries for wxX11.
77 Group: X11/Libraries
78 Requires: %{name} = %{ver}
79
80 %description contrib
81 Contributed libraries for wxX11.
82
83 %package contrib-devel
84 Summary: Contrib libraries for wxX11.
85 Group: X11/Libraries
86 Requires: %{name}-contrib = %{ver}
87 Requires: %{name}-devel = %{ver}
88
89 %description contrib-devel
90 Header files for contributed libraries for wxX11.
91
92 %prep
93 %setup -q -n wxX11-%{ver}
94
95 %build
96 if [ "$SMP" != "" ]; then
97 export MAKE="make -j$SMP"
98 else
99 export MAKE="make"
100 fi
101
102 mkdir obj-shared
103 cd obj-shared
104 ../configure --prefix=%{pref} --with-x11 \
105 %if %{unicode}
106 --enable-unicode \
107 %else
108 --with-odbc \
109 %endif
110 --with-opengl
111 $MAKE
112
113 cd contrib/src
114 $MAKE
115 cd ../../..
116
117 mkdir obj-static
118 cd obj-static
119 ../configure --prefix=%{pref} --with-x11 --disable-shared \
120 %if %{unicode}
121 --enable-unicode \
122 %else
123 --with-odbc \
124 %endif
125 --with-opengl
126 $MAKE
127 cd ..
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
132 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
133
134 # Remove headers that are part of wx-base-devel:
135
136 # --- wxBase headers list begins here ---
137 cat <<EOF >wxbase-headers.files
138 wx/afterstd.h
139 wx/app.h
140 wx/apptrait.h
141 wx/archive.h
142 wx/arrimpl.cpp
143 wx/arrstr.h
144 wx/beforestd.h
145 wx/buffer.h
146 wx/build.h
147 wx/chkconf.h
148 wx/clntdata.h
149 wx/cmdline.h
150 wx/confbase.h
151 wx/config.h
152 wx/containr.h
153 wx/datetime.h
154 wx/datstrm.h
155 wx/dde.h
156 wx/debug.h
157 wx/defs.h
158 wx/dir.h
159 wx/dlimpexp.h
160 wx/dynarray.h
161 wx/dynlib.h
162 wx/dynload.h
163 wx/encconv.h
164 wx/event.h
165 wx/except.h
166 wx/features.h
167 wx/ffile.h
168 wx/file.h
169 wx/fileconf.h
170 wx/filefn.h
171 wx/filename.h
172 wx/filesys.h
173 wx/fontenc.h
174 wx/fontmap.h
175 wx/fs_mem.h
176 wx/fs_zip.h
177 wx/hash.h
178 wx/hashmap.h
179 wx/hashset.h
180 wx/html/forcelnk.h
181 wx/iconloc.h
182 wx/init.h
183 wx/intl.h
184 wx/iosfwrap.h
185 wx/ioswrap.h
186 wx/ipc.h
187 wx/ipcbase.h
188 wx/isql.h
189 wx/isqlext.h
190 wx/list.h
191 wx/listimpl.cpp
192 wx/log.h
193 wx/longlong.h
194 wx/math.h
195 wx/memconf.h
196 wx/memory.h
197 wx/memtext.h
198 wx/mimetype.h
199 wx/module.h
200 wx/msgout.h
201 wx/mstream.h
202 wx/object.h
203 wx/platform.h
204 wx/process.h
205 wx/ptr_scpd.h
206 wx/recguard.h
207 wx/regex.h
208 wx/scopeguard.h
209 wx/snglinst.h
210 wx/sstream.h
211 wx/stack.h
212 wx/stackwalk.h
213 wx/stdpaths.h
214 wx/stockitem.h
215 wx/stopwatch.h
216 wx/strconv.h
217 wx/stream.h
218 wx/string.h
219 wx/sysopt.h
220 wx/textbuf.h
221 wx/textfile.h
222 wx/thread.h
223 wx/thrimpl.cpp
224 wx/timer.h
225 wx/tokenzr.h
226 wx/txtstrm.h
227 wx/types.h
228 wx/uri.h
229 wx/utils.h
230 wx/variant.h
231 wx/vector.h
232 wx/version.h
233 wx/volume.h
234 wx/wfstream.h
235 wx/wx.h
236 wx/wxchar.h
237 wx/wxprec.h
238 wx/xti.h
239 wx/xtistrm.h
240 wx/zipstrm.h
241 wx/zstream.h
242 wx/unix/apptbase.h
243 wx/unix/apptrait.h
244 wx/unix/execute.h
245 wx/unix/mimetype.h
246 wx/unix/pipe.h
247 wx/unix/stackwalk.h
248 wx/unix/stdpaths.h
249 wx/fs_inet.h
250 wx/gsocket.h
251 wx/protocol/file.h
252 wx/protocol/ftp.h
253 wx/protocol/http.h
254 wx/protocol/protocol.h
255 wx/sckaddr.h
256 wx/sckipc.h
257 wx/sckstrm.h
258 wx/socket.h
259 wx/url.h
260 wx/unix/gsockunx.h
261 wx/xml/xml.h
262 wx/xtixml.h
263 wx/db.h
264 wx/dbkeyg.h
265 wx/dbtable.h
266 EOF
267 # --- wxBase headers list ends here ---
268 for f in `cat wxbase-headers-list` ; do
269 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
270 done
271
272 # list of all core headers:
273 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
274
275 # contrib stuff:
276 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
277 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
278
279 # remove wxBase files so that RPM doesn't complain about unpackaged files:
280 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
281 %if %{unicode}
282 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
283 %endif
284 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
285 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
286
287 %clean
288 rm -rf $RPM_BUILD_ROOT
289
290 %post
291 /sbin/ldconfig
292
293 %postun
294 /sbin/ldconfig
295
296 %post devel
297 # link wx-config when you install RPM.
298 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
299 # link wx-config with explicit name.
300 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
301 /sbin/ldconfig
302
303 %postun devel
304 /sbin/ldconfig
305
306 %preun devel
307 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
308 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
309 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
310 if test "x$SUM1" = "x$SUM2" ; then
311 rm -f %{_bindir}/wx-config
312 fi
313 fi
314 rm -f %{_bindir}/%{wxconfiglink}
315
316 %post gl
317 /sbin/ldconfig
318
319 %postun gl
320 /sbin/ldconfig
321
322 %post contrib
323 /sbin/ldconfig
324
325 %postun contrib
326 /sbin/ldconfig
327
328 %post contrib-devel
329 /sbin/ldconfig
330
331 %postun contrib-devel
332 /sbin/ldconfig
333
334 %files
335 %defattr(-,root,root)
336 %doc COPYING.LIB *.txt
337 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
338 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
339 %if !%{unicode}
340 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
341 %endif
342 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
343 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
344 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
345 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
346
347
348 %files devel -f core-headers.files
349 %defattr(-,root,root)
350 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
351 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
352 %if !%{unicode}
353 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
354 %endif
355 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
356 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
357 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
358 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
359 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
360 %dir %{_libdir}/wx
361 %{_libdir}/wx/*
362 %{_bindir}/wxrc*
363
364 %files gl
365 %defattr(-,root,root)
366 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
367
368 %files static
369 %defattr (-,root,root)
370 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
371
372 %files contrib
373 %defattr(-,root,root)
374 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
375 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
376 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
377 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
378 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
379 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
380 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
381 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
382 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
383
384 %files contrib-devel
385 %defattr(-,root,root)
386 %dir %{_includedir}/wx-%{ver2}/wx/animate
387 %{_includedir}/wx-%{ver2}/wx/animate/*
388 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
389
390 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
391 %{_includedir}/wx-%{ver2}/wx/deprecated/*
392 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
393
394 %dir %{_includedir}/wx-%{ver2}/wx/fl
395 %{_includedir}/wx-%{ver2}/wx/fl/*
396 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
397
398 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
399 %{_includedir}/wx-%{ver2}/wx/gizmos/*
400 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
401
402 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
403 %{_includedir}/wx-%{ver2}/wx/mmedia/*
404 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
405
406 %dir %{_includedir}/wx-%{ver2}/wx/ogl
407 %{_includedir}/wx-%{ver2}/wx/ogl/*
408 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
409
410 %dir %{_includedir}/wx-%{ver2}/wx/plot
411 %{_includedir}/wx-%{ver2}/wx/plot/*
412 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
413
414 %dir %{_includedir}/wx-%{ver2}/wx/stc
415 %{_includedir}/wx-%{ver2}/wx/stc/*
416 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
417
418 %dir %{_includedir}/wx-%{ver2}/wx/svg
419 %{_includedir}/wx-%{ver2}/wx/svg/*
420 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so