Rebake after recguard.h added to bakefiles
[wxWidgets.git] / wxMotif.spec
1 %define pref /usr
2 %define ver 2.6.2
3 %define ver2 2.6
4 %define rel 1
5
6 %define portname motif
7 %define name wx-%{portname}
8 %define wxbasename wx-base
9
10 %define wxconfig %{portname}-ansi-release-%{ver2}
11 %define wxconfiglink wx%{portname}-%{ver2}-config
12
13 Summary: The Motif/Lesstif port of the wxWidgets library
14 Name: %{name}
15 Version: %{ver}
16 Release: %{rel}
17 License: wxWindows Licence
18 Group: X11/Libraries
19 Source: wxMotif-%{ver}.tar.bz2
20 URL: http://www.wxwidgets.org
21 Packager: wxWidgets developers <wx-dev@lists.wxwidgets.org>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
24
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
28 Provides: wxwin
29 Provides: wxMotif
30
31 %description
32 wxWidgets is a free C++ library for cross-platform GUI development.
33 With wxWidgets, you can create applications for different GUIs (GTK+,
34 Motif/LessTif, MS Windows, Mac) from the same source code.
35
36 %package devel
37 Summary: The Motif/Lesstif port of the wxWidgets library
38 Group: X11/Libraries
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
41
42 %description devel
43 Header files for wxMotif, the Motif/Lesstif port of the wxWidgets library.
44
45 %package gl
46 Summary: The Motif/Lesstif port of the wxWidgets library, OpenGL add-on.
47 Group: X11/Libraries
48 Requires: %{name} = %{ver}
49
50 %description gl
51 OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWidgets library.
52
53 %package static
54 Summary: wxMotif static libraries
55 Group: Development/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
58
59 %description static
60 Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
61
62 %package contrib
63 Summary: Contrib libraries for wxMotif
64 Group: X11/Libraries
65 Requires: %{name} = %{ver}
66
67 %description contrib
68 Contrib libraries for wxMotif
69
70 %package contrib-devel
71 Summary: Contrib libraries for wxMotif
72 Group: X11/Libraries
73 Requires: %{name}-contrib = %{ver}
74 Requires: %{name}-devel = %{ver}
75
76 %description contrib-devel
77 Header files for contributed libraries for wxMotif.
78
79 %prep
80 %setup -q -n wxMotif-%{ver}
81
82 %build
83 if [ "$SMP" != "" ]; then
84 export MAKE="make -j$SMP"
85 else
86 export MAKE="make"
87 fi
88
89 mkdir obj-shared
90 cd obj-shared
91 ../configure --prefix=%{pref} --with-motif --with-odbc --with-opengl
92 $MAKE
93
94 cd contrib/src
95 $MAKE
96 cd ../../..
97
98 mkdir obj-static
99 cd obj-static
100 ../configure --prefix=%{pref} --with-motif --disable-shared --with-odbc --with-opengl
101 $MAKE
102 cd ..
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
107 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
108
109 # Remove headers that are part of wx-base-devel:
110
111 # --- wxBase headers list begins here ---
112 cat <<EOF >wxbase-headers.files
113 wx/afterstd.h
114 wx/app.h
115 wx/apptrait.h
116 wx/archive.h
117 wx/arrimpl.cpp
118 wx/arrstr.h
119 wx/beforestd.h
120 wx/buffer.h
121 wx/build.h
122 wx/chkconf.h
123 wx/clntdata.h
124 wx/cmdline.h
125 wx/confbase.h
126 wx/config.h
127 wx/containr.h
128 wx/datetime.h
129 wx/datstrm.h
130 wx/dde.h
131 wx/debug.h
132 wx/defs.h
133 wx/dir.h
134 wx/dlimpexp.h
135 wx/dynarray.h
136 wx/dynlib.h
137 wx/dynload.h
138 wx/encconv.h
139 wx/event.h
140 wx/except.h
141 wx/features.h
142 wx/ffile.h
143 wx/file.h
144 wx/fileconf.h
145 wx/filefn.h
146 wx/filename.h
147 wx/filesys.h
148 wx/fontenc.h
149 wx/fontmap.h
150 wx/fs_mem.h
151 wx/fs_zip.h
152 wx/hash.h
153 wx/hashmap.h
154 wx/hashset.h
155 wx/html/forcelnk.h
156 wx/iconloc.h
157 wx/init.h
158 wx/intl.h
159 wx/iosfwrap.h
160 wx/ioswrap.h
161 wx/ipc.h
162 wx/ipcbase.h
163 wx/isql.h
164 wx/isqlext.h
165 wx/list.h
166 wx/listimpl.cpp
167 wx/log.h
168 wx/longlong.h
169 wx/math.h
170 wx/memconf.h
171 wx/memory.h
172 wx/memtext.h
173 wx/mimetype.h
174 wx/module.h
175 wx/msgout.h
176 wx/mstream.h
177 wx/object.h
178 wx/platform.h
179 wx/process.h
180 wx/ptr_scpd.h
181 wx/recguard.h
182 wx/regex.h
183 wx/scopeguard.h
184 wx/snglinst.h
185 wx/sstream.h
186 wx/stack.h
187 wx/stackwalk.h
188 wx/stdpaths.h
189 wx/stockitem.h
190 wx/stopwatch.h
191 wx/strconv.h
192 wx/stream.h
193 wx/string.h
194 wx/sysopt.h
195 wx/textbuf.h
196 wx/textfile.h
197 wx/thread.h
198 wx/thrimpl.cpp
199 wx/timer.h
200 wx/tokenzr.h
201 wx/txtstrm.h
202 wx/types.h
203 wx/uri.h
204 wx/utils.h
205 wx/variant.h
206 wx/vector.h
207 wx/version.h
208 wx/volume.h
209 wx/wfstream.h
210 wx/wx.h
211 wx/wxchar.h
212 wx/wxprec.h
213 wx/xti.h
214 wx/xtistrm.h
215 wx/zipstrm.h
216 wx/zstream.h
217 wx/unix/apptbase.h
218 wx/unix/apptrait.h
219 wx/unix/execute.h
220 wx/unix/mimetype.h
221 wx/unix/pipe.h
222 wx/unix/stackwalk.h
223 wx/unix/stdpaths.h
224 wx/fs_inet.h
225 wx/gsocket.h
226 wx/protocol/file.h
227 wx/protocol/ftp.h
228 wx/protocol/http.h
229 wx/protocol/protocol.h
230 wx/sckaddr.h
231 wx/sckipc.h
232 wx/sckstrm.h
233 wx/socket.h
234 wx/url.h
235 wx/unix/gsockunx.h
236 wx/xml/xml.h
237 wx/xtixml.h
238 wx/db.h
239 wx/dbkeyg.h
240 wx/dbtable.h
241 EOF
242 # --- wxBase headers list ends here ---
243 for f in `cat wxbase-headers-list` ; do
244 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
245 done
246
247 # list of all core headers:
248 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
249
250 # contrib stuff:
251 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
252 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
253
254 # remove wxBase files so that RPM doesn't complain about unpackaged files:
255 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
256 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
257 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
258
259 %clean
260 rm -rf $RPM_BUILD_ROOT
261
262 %post
263 /sbin/ldconfig
264
265 %postun
266 /sbin/ldconfig
267
268 %post devel
269 # link wx-config when you install RPM.
270 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
271 # link wx-config with explicit name.
272 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
273 /sbin/ldconfig
274
275 %postun devel
276 /sbin/ldconfig
277
278 %preun devel
279 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
280 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
281 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
282 if test "x$SUM1" = "x$SUM2" ; then
283 rm -f %{_bindir}/wx-config
284 fi
285 fi
286 rm -f %{_bindir}/%{wxconfiglink}
287
288 %post gl
289 /sbin/ldconfig
290
291 %postun gl
292 /sbin/ldconfig
293
294 %post contrib
295 /sbin/ldconfig
296
297 %postun contrib
298 /sbin/ldconfig
299
300 %post contrib-devel
301 /sbin/ldconfig
302
303 %postun contrib-devel
304 /sbin/ldconfig
305
306 %files
307 %defattr(-,root,root)
308 %doc COPYING.LIB *.txt
309 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
310 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
311 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
312 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
313 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
314 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
315 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
316
317
318 %files devel -f core-headers.files
319 %defattr(-,root,root)
320 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
321 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
322 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
323 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
324 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
325 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
326 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
327 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
328 %dir %{_libdir}/wx
329 %{_libdir}/wx/*
330 %{_bindir}/wxrc*
331
332 %files gl
333 %defattr(-,root,root)
334 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
335
336 %files static
337 %defattr (-,root,root)
338 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
339
340 %files contrib
341 %defattr(-,root,root)
342 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
343 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
344 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
345 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
346 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
347 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
348 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
349 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
350 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
351
352 %files contrib-devel
353 %defattr(-,root,root)
354 %dir %{_includedir}/wx-%{ver2}/wx/animate
355 %{_includedir}/wx-%{ver2}/wx/animate/*
356 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
357
358 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
359 %{_includedir}/wx-%{ver2}/wx/deprecated/*
360 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
361
362 %dir %{_includedir}/wx-%{ver2}/wx/fl
363 %{_includedir}/wx-%{ver2}/wx/fl/*
364 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
365
366 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
367 %{_includedir}/wx-%{ver2}/wx/gizmos/*
368 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
369
370 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
371 %{_includedir}/wx-%{ver2}/wx/mmedia/*
372 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
373
374 %dir %{_includedir}/wx-%{ver2}/wx/ogl
375 %{_includedir}/wx-%{ver2}/wx/ogl/*
376 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
377
378 %dir %{_includedir}/wx-%{ver2}/wx/plot
379 %{_includedir}/wx-%{ver2}/wx/plot/*
380 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
381
382 %dir %{_includedir}/wx-%{ver2}/wx/stc
383 %{_includedir}/wx-%{ver2}/wx/stc/*
384 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
385
386 %dir %{_includedir}/wx-%{ver2}/wx/svg
387 %{_includedir}/wx-%{ver2}/wx/svg/*
388 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so