Rebake after recguard.h added to bakefiles
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /opt/gnome
2 %define ver 2.6.2
3 %define ver2 2.6
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfigstatic base-unicode-release-static-%{ver2}
46 %define wxbaseconfiglink wxbaseu-%{ver2}-config
47 %else
48 %define wxbasename wx-base-ansi
49 %define wxbaseconfig base-ansi-release-%{ver2}
50 %define wxbaseconfigstatic base-ansi-release-static-%{ver2}
51 %define wxbaseconfiglink wxbase-%{ver2}-config
52 %endif
53
54 Summary: The GTK+ %{gtkver} port of the wxWidgets library
55 Name: %{name}
56 Version: %{ver}
57 Release: %{rel}
58 License: wxWindows Licence
59 Group: X11/Libraries
60 Source: wxGTK-%{ver}.tar.gz
61 URL: http://www.wxwidgets.org
62 Packager: Vadim Zeitlin <vadim@wxwindows.org>
63 Prefix: %{_prefix}
64 BuildRoot: %{_tmppath}/%{name}-root
65 Requires: %{wxbasename} = %{ver}
66 %if %{portname} == gtk2
67 # BuildRequires: gtk+-2.0-devel
68 %else
69 # BuildRequires: gtk+-devel >= 1.2.0
70 %endif
71
72 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
73
74 # all packages providing an implementation of wxWidgets library (regardless of
75 # the toolkit used) should provide the (virtual) wxwin package, this makes it
76 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
77 Provides: wxwin
78 Provides: wxGTK
79
80 %description
81 wxWidgets is a free C++ library for cross-platform GUI development.
82 With wxWidgets, you can create applications for different GUIs (GTK+,
83 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
84
85 %package -n wx-i18n
86 Summary: The translations for the wxWidgets library.
87 Group: X11/Libraries
88
89 %description -n wx-i18n
90 The translations files for the wxWidgets library.
91
92 %package devel
93 Summary: The GTK+ %{gtkver} port of the wxWidgets library
94 Group: X11/Libraries
95 Requires: %{name} = %{ver}
96 Requires: %{wxbasename}-devel = %{ver}
97 Provides: wxGTK-devel
98
99 %description devel
100 The GTK+ %{gtkver} port of the wxWidgets library, header files.
101
102 %package gl
103 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
104 Group: X11/Libraries
105 Requires: %{name} = %{ver}
106 Provides: wxGTK-gl
107
108 %description gl
109 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
110
111 %package -n %{wxbasename}
112 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
113 Group: Development/Libraries
114 Provides: wxBase
115
116 %description -n %{wxbasename}
117 wxBase is a collection of C++ classes providing basic data structures (strings,
118 lists, arrays), portable wrappers around many OS-specific funstions (file
119 operations, time/date manipulations, threads, processes, sockets, shared
120 library loading) as well as other utility classes (streams, archive and
121 compression). wxBase currently supports Win32, most Unix variants (Linux,
122 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
123
124 %package -n %{wxbasename}-devel
125 Summary: wxBase library, header files.
126 Group: Development/Libraries
127 Provides: wxBase-devel
128
129 %description -n %{wxbasename}-devel
130 wxBase library - non-GUI support classes of the wxWidgets toolkit,
131 header files.
132
133 %package contrib
134 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
135 Group: X11/Libraries
136 Requires: %{name} = %{ver}
137
138 %description contrib
139 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
140
141 %package contrib-devel
142 Summary: The GTK+ %{gtkver} port of the wxWidgets library
143 Group: X11/Libraries
144 Requires: %{name}-contrib = %{ver}
145 Requires: %{name}-devel = %{ver}
146
147 %description contrib-devel
148 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
149
150 %prep
151 %setup -q -n wxGTK-%{ver}
152
153 %build
154 if [ "$SMP" != "" ]; then
155 export MAKE="make -j$SMP"
156 else
157 export MAKE="make"
158 fi
159
160 mkdir obj-shared-no-gui
161 cd obj-shared-no-gui
162 ../configure --prefix=%{_prefix} \
163 --disable-gui \
164 %if %{unicode}
165 --enable-unicode
166 %else
167 --disable-unicode
168 %endif
169 $MAKE
170 cd ..
171
172 mkdir obj-shared
173 cd obj-shared
174 ../configure --prefix=%{_prefix} \
175 %if ! %{gtk2}
176 --with-gtk=1 \
177 %else
178 --with-gtk=2 \
179 %endif
180 %if %{unicode}
181 --enable-unicode \
182 %else
183 --disable-unicode \
184 --with-odbc \
185 %endif
186 --with-opengl
187 $MAKE
188
189 cd contrib/src
190 $MAKE
191 cd ../../..
192
193 mkdir obj-static-no-gui
194 cd obj-static-no-gui
195 ../configure --prefix=%{_prefix} \
196 --disable-gui \
197 --disable-shared \
198 %if %{unicode}
199 --enable-unicode
200 %else
201 --disable-unicode
202 %endif
203 $MAKE
204 cd ..
205
206 mkdir obj-static
207 cd obj-static
208 ../configure --prefix=%{_prefix} \
209 %if ! %{gtk2}
210 --with-gtk=1 \
211 %else
212 --with-gtk=2 \
213 %endif
214 --disable-shared \
215 %if %{unicode}
216 --enable-unicode \
217 %else
218 --disable-unicode \
219 --with-odbc \
220 %endif
221 --with-opengl
222 $MAKE
223
224 cd contrib/src
225 $MAKE
226 cd ../../..
227
228 %install
229 rm -rf $RPM_BUILD_ROOT
230 (cd obj-static-no-gui; make DESTDIR=$RPM_BUILD_ROOT install)
231 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT install)
232 (cd obj-shared-no-gui; make DESTDIR=$RPM_BUILD_ROOT install)
233 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT install)
234
235 # --- wxBase headers list begins here ---
236 cat <<EOF >wxbase-headers.files
237 wx/afterstd.h
238 wx/app.h
239 wx/apptrait.h
240 wx/archive.h
241 wx/arrimpl.cpp
242 wx/arrstr.h
243 wx/beforestd.h
244 wx/buffer.h
245 wx/build.h
246 wx/chkconf.h
247 wx/clntdata.h
248 wx/cmdline.h
249 wx/confbase.h
250 wx/config.h
251 wx/containr.h
252 wx/datetime.h
253 wx/datstrm.h
254 wx/dde.h
255 wx/debug.h
256 wx/defs.h
257 wx/dir.h
258 wx/dlimpexp.h
259 wx/dynarray.h
260 wx/dynlib.h
261 wx/dynload.h
262 wx/encconv.h
263 wx/event.h
264 wx/except.h
265 wx/features.h
266 wx/ffile.h
267 wx/file.h
268 wx/fileconf.h
269 wx/filefn.h
270 wx/filename.h
271 wx/filesys.h
272 wx/fontenc.h
273 wx/fontmap.h
274 wx/fs_mem.h
275 wx/fs_zip.h
276 wx/hash.h
277 wx/hashmap.h
278 wx/hashset.h
279 wx/html/forcelnk.h
280 wx/iconloc.h
281 wx/init.h
282 wx/intl.h
283 wx/iosfwrap.h
284 wx/ioswrap.h
285 wx/ipc.h
286 wx/ipcbase.h
287 wx/isql.h
288 wx/isqlext.h
289 wx/list.h
290 wx/listimpl.cpp
291 wx/log.h
292 wx/longlong.h
293 wx/math.h
294 wx/memconf.h
295 wx/memory.h
296 wx/memtext.h
297 wx/mimetype.h
298 wx/module.h
299 wx/msgout.h
300 wx/mstream.h
301 wx/object.h
302 wx/platform.h
303 wx/process.h
304 wx/ptr_scpd.h
305 wx/recguard.h
306 wx/regex.h
307 wx/scopeguard.h
308 wx/snglinst.h
309 wx/sstream.h
310 wx/stack.h
311 wx/stackwalk.h
312 wx/stdpaths.h
313 wx/stockitem.h
314 wx/stopwatch.h
315 wx/strconv.h
316 wx/stream.h
317 wx/string.h
318 wx/sysopt.h
319 wx/textbuf.h
320 wx/textfile.h
321 wx/thread.h
322 wx/thrimpl.cpp
323 wx/timer.h
324 wx/tokenzr.h
325 wx/txtstrm.h
326 wx/types.h
327 wx/uri.h
328 wx/utils.h
329 wx/variant.h
330 wx/vector.h
331 wx/version.h
332 wx/volume.h
333 wx/wfstream.h
334 wx/wx.h
335 wx/wxchar.h
336 wx/wxprec.h
337 wx/xti.h
338 wx/xtistrm.h
339 wx/zipstrm.h
340 wx/zstream.h
341 wx/unix/apptbase.h
342 wx/unix/apptrait.h
343 wx/unix/execute.h
344 wx/unix/mimetype.h
345 wx/unix/pipe.h
346 wx/unix/stackwalk.h
347 wx/unix/stdpaths.h
348 wx/fs_inet.h
349 wx/gsocket.h
350 wx/protocol/file.h
351 wx/protocol/ftp.h
352 wx/protocol/http.h
353 wx/protocol/protocol.h
354 wx/sckaddr.h
355 wx/sckipc.h
356 wx/sckstrm.h
357 wx/socket.h
358 wx/url.h
359 wx/unix/gsockunx.h
360 wx/xml/xml.h
361 wx/xtixml.h
362 wx/db.h
363 wx/dbkeyg.h
364 wx/dbtable.h
365 EOF
366 # --- wxBase headers list ends here ---
367 cat <<EOF >wxbase-headers.paths
368 %{_includedir}/wx-%{ver2}/wx/afterstd.h
369 %{_includedir}/wx-%{ver2}/wx/app.h
370 %{_includedir}/wx-%{ver2}/wx/apptrait.h
371 %{_includedir}/wx-%{ver2}/wx/archive.h
372 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
373 %{_includedir}/wx-%{ver2}/wx/arrstr.h
374 %{_includedir}/wx-%{ver2}/wx/beforestd.h
375 %{_includedir}/wx-%{ver2}/wx/buffer.h
376 %{_includedir}/wx-%{ver2}/wx/build.h
377 %{_includedir}/wx-%{ver2}/wx/chkconf.h
378 %{_includedir}/wx-%{ver2}/wx/clntdata.h
379 %{_includedir}/wx-%{ver2}/wx/cmdline.h
380 %{_includedir}/wx-%{ver2}/wx/confbase.h
381 %{_includedir}/wx-%{ver2}/wx/config.h
382 %{_includedir}/wx-%{ver2}/wx/containr.h
383 %{_includedir}/wx-%{ver2}/wx/datetime.h
384 %{_includedir}/wx-%{ver2}/wx/datetime.inl
385 %{_includedir}/wx-%{ver2}/wx/datstrm.h
386 %{_includedir}/wx-%{ver2}/wx/dde.h
387 %{_includedir}/wx-%{ver2}/wx/debug.h
388 %{_includedir}/wx-%{ver2}/wx/defs.h
389 %{_includedir}/wx-%{ver2}/wx/dir.h
390 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
391 %{_includedir}/wx-%{ver2}/wx/dynarray.h
392 %{_includedir}/wx-%{ver2}/wx/dynlib.h
393 %{_includedir}/wx-%{ver2}/wx/dynload.h
394 %{_includedir}/wx-%{ver2}/wx/encconv.h
395 %{_includedir}/wx-%{ver2}/wx/event.h
396 %{_includedir}/wx-%{ver2}/wx/except.h
397 %{_includedir}/wx-%{ver2}/wx/features.h
398 %{_includedir}/wx-%{ver2}/wx/ffile.h
399 %{_includedir}/wx-%{ver2}/wx/file.h
400 %{_includedir}/wx-%{ver2}/wx/fileconf.h
401 %{_includedir}/wx-%{ver2}/wx/filefn.h
402 %{_includedir}/wx-%{ver2}/wx/filename.h
403 %{_includedir}/wx-%{ver2}/wx/filesys.h
404 %{_includedir}/wx-%{ver2}/wx/fontenc.h
405 %{_includedir}/wx-%{ver2}/wx/fontmap.h
406 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
407 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
408 %{_includedir}/wx-%{ver2}/wx/hash.h
409 %{_includedir}/wx-%{ver2}/wx/hashmap.h
410 %{_includedir}/wx-%{ver2}/wx/hashset.h
411 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
412 %{_includedir}/wx-%{ver2}/wx/iconloc.h
413 %{_includedir}/wx-%{ver2}/wx/init.h
414 %{_includedir}/wx-%{ver2}/wx/intl.h
415 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
416 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
417 %{_includedir}/wx-%{ver2}/wx/ipc.h
418 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
419 %{_includedir}/wx-%{ver2}/wx/isql.h
420 %{_includedir}/wx-%{ver2}/wx/isqlext.h
421 %{_includedir}/wx-%{ver2}/wx/list.h
422 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
423 %{_includedir}/wx-%{ver2}/wx/log.h
424 %{_includedir}/wx-%{ver2}/wx/longlong.h
425 %{_includedir}/wx-%{ver2}/wx/math.h
426 %{_includedir}/wx-%{ver2}/wx/memconf.h
427 %{_includedir}/wx-%{ver2}/wx/memory.h
428 %{_includedir}/wx-%{ver2}/wx/memtext.h
429 %{_includedir}/wx-%{ver2}/wx/mimetype.h
430 %{_includedir}/wx-%{ver2}/wx/module.h
431 %{_includedir}/wx-%{ver2}/wx/msgout.h
432 %{_includedir}/wx-%{ver2}/wx/mstream.h
433 %{_includedir}/wx-%{ver2}/wx/object.h
434 %{_includedir}/wx-%{ver2}/wx/platform.h
435 %{_includedir}/wx-%{ver2}/wx/process.h
436 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
437 %{_includedir}/wx-%{ver2}/wx/regex.h
438 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
439 %{_includedir}/wx-%{ver2}/wx/snglinst.h
440 %{_includedir}/wx-%{ver2}/wx/sstream.h
441 %{_includedir}/wx-%{ver2}/wx/stack.h
442 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
443 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
444 %{_includedir}/wx-%{ver2}/wx/stockitem.h
445 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
446 %{_includedir}/wx-%{ver2}/wx/strconv.h
447 %{_includedir}/wx-%{ver2}/wx/stream.h
448 %{_includedir}/wx-%{ver2}/wx/string.h
449 %{_includedir}/wx-%{ver2}/wx/sysopt.h
450 %{_includedir}/wx-%{ver2}/wx/textbuf.h
451 %{_includedir}/wx-%{ver2}/wx/textfile.h
452 %{_includedir}/wx-%{ver2}/wx/thread.h
453 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
454 %{_includedir}/wx-%{ver2}/wx/timer.h
455 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
456 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
457 %{_includedir}/wx-%{ver2}/wx/types.h
458 %{_includedir}/wx-%{ver2}/wx/uri.h
459 %{_includedir}/wx-%{ver2}/wx/utils.h
460 %{_includedir}/wx-%{ver2}/wx/variant.h
461 %{_includedir}/wx-%{ver2}/wx/vector.h
462 %{_includedir}/wx-%{ver2}/wx/version.h
463 %{_includedir}/wx-%{ver2}/wx/volume.h
464 %{_includedir}/wx-%{ver2}/wx/wfstream.h
465 %{_includedir}/wx-%{ver2}/wx/wx.h
466 %{_includedir}/wx-%{ver2}/wx/wxchar.h
467 %{_includedir}/wx-%{ver2}/wx/wxprec.h
468 %{_includedir}/wx-%{ver2}/wx/xti.h
469 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
470 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
471 %{_includedir}/wx-%{ver2}/wx/zstream.h
472 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
473 %{_includedir}/wx-%{ver2}/wx/gsocket.h
474 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
475 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
476 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
477 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
478 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
479 %{_includedir}/wx-%{ver2}/wx/sckipc.h
480 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
481 %{_includedir}/wx-%{ver2}/wx/socket.h
482 %{_includedir}/wx-%{ver2}/wx/url.h
483 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
484 %{_includedir}/wx-%{ver2}/wx/xtixml.h
485 %{_includedir}/wx-%{ver2}/wx/db.h
486 %{_includedir}/wx-%{ver2}/wx/dbkeyg.h
487 %{_includedir}/wx-%{ver2}/wx/dbtable.h
488 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
489 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
490 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
491 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
492 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
493 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
494 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
495 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
496 EOF
497 # --- wxBase headers list ends here ---
498
499 # temporarily remove base headers
500 mkdir $RPM_BUILD_ROOT/_save_dir
501 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
502 for f in `cat wxbase-headers.files` ; do
503 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
504 done
505 # list of all core headers:
506 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
507 # move base headers (actually all headers) back again
508 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
509 rm -rf $RPM_BUILD_ROOT/_save_dir
510
511 # contrib stuff:
512 (cd obj-shared/contrib/src; make DESTDIR=$RPM_BUILD_ROOT install)
513 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT install)
514
515 %clean
516 rm -rf $RPM_BUILD_ROOT
517
518 %post
519 /sbin/ldconfig
520
521 %postun
522 /sbin/ldconfig
523
524 %post devel
525 # link wx-config when you install RPM.
526 %if %{unicode}
527 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
528 %endif
529 # link wx-config with explicit name.
530 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
531 /sbin/ldconfig
532
533 %postun devel
534 /sbin/ldconfig
535
536 %preun devel
537 %if %{unicode}
538 rm -f %{_bindir}/wx-config
539 %endif
540 rm -f %{_bindir}/%{wxconfiglink}
541
542 %post -n %{wxbasename}
543 /sbin/ldconfig
544
545 %postun -n %{wxbasename}
546 /sbin/ldconfig
547
548 %post -n %{wxbasename}-devel
549 # link wx-config with explicit name.
550 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
551 /sbin/ldconfig
552
553 %postun -n %{wxbasename}-devel
554 /sbin/ldconfig
555
556 %preun -n %{wxbasename}-devel
557 rm -f %{_bindir}/%{wxbaseconfiglink}
558
559 %post gl
560 /sbin/ldconfig
561
562 %postun gl
563 /sbin/ldconfig
564
565 %post contrib
566 /sbin/ldconfig
567
568 %postun contrib
569 /sbin/ldconfig
570
571 %post contrib-devel
572 /sbin/ldconfig
573
574 %postun contrib-devel
575 /sbin/ldconfig
576
577 %files
578 %defattr(-,root,root)
579 %doc COPYING.LIB *.txt
580 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
581 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
582 %if !%{unicode}
583 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
584 %endif
585 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
586 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so.*
587 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
588 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
589
590 %files -n wx-i18n
591 %defattr(-,root,root)
592 %{_datadir}/locale/*/*/*
593
594 %files devel -f core-headers.files
595 %defattr(-,root,root)
596 # shared libs
597 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
598 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
599 %if !%{unicode}
600 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
601 %endif
602 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
603 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
604 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so
605 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
606 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
607 # static libs
608 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
609 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
610 %if !%{unicode}
611 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
612 %endif
613 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
614 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
615 %{_libdir}/libwx_%{buildname}_media-%{ver2}.a
616 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
617 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
618 %dir %{_libdir}/wx
619 %{_libdir}/wx/config/%{wxconfig}
620 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
621 %{_libdir}/wx/config/%{wxconfigstatic}
622 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
623 %{_bindir}/wxrc*
624
625 %files -n %{wxbasename}
626 %defattr(-,root,root)
627 %{_libdir}/libwx_base*-%{ver2}.so.*
628
629 %files -n %{wxbasename}-devel -f wxbase-headers.paths
630 %defattr (-,root,root)
631 %dir %{_includedir}/wx-%{ver2}
632 %{_libdir}/libwx_base*-%{ver2}.so
633 %{_libdir}/libwx_base*-%{ver2}.a
634 %if %{unicode}
635 %{_libdir}/libwxregexu-%{ver2}.a
636 %endif
637 %dir %{_libdir}/wx
638 %{_libdir}/wx/config/%{wxbaseconfig}
639 %{_libdir}/wx/include/%{wxbaseconfig}/wx/setup.h
640 %{_libdir}/wx/config/%{wxbaseconfigstatic}
641 %{_libdir}/wx/include/%{wxbaseconfigstatic}/wx/setup.h
642 %{_datadir}/aclocal/*.m4
643
644 %files gl
645 %defattr(-,root,root)
646 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
647
648 %files contrib
649 %defattr(-,root,root)
650 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
651 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
652 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
653 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
654 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
655 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
656 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
657 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
658 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
659 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
660
661 %files contrib-devel
662 %defattr(-,root,root)
663 %dir %{_includedir}/wx-%{ver2}/wx/animate
664 %{_includedir}/wx-%{ver2}/wx/animate/*
665 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
666
667 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
668 %{_includedir}/wx-%{ver2}/wx/deprecated/*
669 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
670
671 %dir %{_includedir}/wx-%{ver2}/wx/fl
672 %{_includedir}/wx-%{ver2}/wx/fl/*
673 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
674
675 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
676 %{_includedir}/wx-%{ver2}/wx/gizmos/*
677 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
678 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
679
680 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
681 %{_includedir}/wx-%{ver2}/wx/mmedia/*
682 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
683
684 %dir %{_includedir}/wx-%{ver2}/wx/ogl
685 %{_includedir}/wx-%{ver2}/wx/ogl/*
686 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
687
688 %dir %{_includedir}/wx-%{ver2}/wx/plot
689 %{_includedir}/wx-%{ver2}/wx/plot/*
690 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
691
692 %dir %{_includedir}/wx-%{ver2}/wx/stc
693 %{_includedir}/wx-%{ver2}/wx/stc/*
694 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
695
696 %dir %{_includedir}/wx-%{ver2}/wx/svg
697 %{_includedir}/wx-%{ver2}/wx/svg/*
698 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so