1 # RPM .spec file for wxMotif. Based on the .spec file for wxGTK
2 # (c) by Robert Roebling. Modifications (c) 2000/03 by Robert Fendt.
4 # Note that this is NOT a relocatable package
10 Summary: The Motif
/Lesstif port of the wxWindows library
14 Copyright: wxWindows Licence
16 Source: wxMOTIF
-%{ver}.tar.bz2
17 URL: http
://www.wxwindows.org
18 Packager: Robert Fendt
<rfendt@myokay.net
>
19 BuildRoot: /tmp
/wxmotif_root
21 # all packages providing an implementation of wxWindows library (regardless of
22 # the toolkit used) should provide the (virtual) wxwin package, this makes it
23 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
27 wxWindows is a free C
++ library
for cross
-platform GUI development.
28 With wxWindows
, you can create applications
for different GUIs
(GTK
+,
29 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
32 Summary: The Motif
/Lesstif port of the wxWindows library
37 Header files
for wxMotif
, the Motif
/Lesstif port of the wxWindows library.
40 Summary: The Motif
/Lesstif port of the wxWindows library
, OpenGl add
-on.
45 OpenGl add
-on library
for wxMotif
, the Motif
/Lesstif port of the wxWindows library.
49 .
/configure
--prefix
=%{pref} --enable-soname
--with
-odbc
--with
-opengl
--with
-motif
52 if [ "$SMP"
!= ""
]; then
53 export MAKE
="
make -j$SMP"
58 (cd locale
; make allmo
)
61 rm -rf $RPM_BUILD_ROOT
62 make prefix
=$RPM_BUILD_ROOT
%{pref} install
65 rm -rf $RPM_BUILD_ROOT
80 # Install wx-config if there isn't any
81 if test ! -f
%{_bindir}/wx
-config
; then
82 ln
-sf wxmotif
-%{ver2}-config %{_bindir}/wx
-config
86 # Remove wx-config if it points to this package
87 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
88 SUM1
=`md5sum
%{_bindir}/wxmotif-%{ver2}-config | cut
-c
0-32`
89 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
90 if test "x$SUM1"
= "x$SUM2"
; then
91 rm -f
%{_bindir}/wx
-config
97 %defattr (-,root
,root
)
98 %doc COPYING.LIB
*.txt
101 %{_datadir}/locale
/*/*/*.mo
102 %{_libdir}/libwx_motif-%{ver2}*.so.
*
105 %defattr (-,root
,root
)
106 %{_libdir}/libwx_motif-%{ver2}*.so
107 %dir %{_includedir}/wx
111 %{_bindir}/wxmotif-%{ver2}-config
114 %defattr(-,root
,root
)
115 %{_libdir}/libwx_motif_gl
*