6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
13 %define name wx
-%{portname}-unicode
14 %define wxbasename wx
-base
-unicode
16 %define name wx
-%{portname}
17 %define wxbasename wx
-base
21 %define wxconfigname wx
%{portname}univu-%{ver2}-config
23 %define wxconfigname wx
%{portname}univ-%{ver2}-config
26 Summary: The X11 port of the wxWindows library
30 License: wxWindows Licence
32 Source: wxX11
-%{ver}.tar.bz2
33 URL: http
://www.wxwindows.org
34 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
36 BuildRoot: /var
/tmp
/%{name}-root
38 # all packages providing an implementation of wxWindows library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
43 # in addition, we should provide libwx_gtk as automatic generator only notices
44 # libwx_gtk-%{ver}-%{rel}
45 Provides: libwx_x11.so
46 Provides: libwx_x11
-%{ver2}.so
49 Requires: %{wxbasename} = %{ver}
52 wxWindows is a free C
++ library
for cross
-platform GUI development.
53 With wxWindows
, you can create applications
for different GUIs
(GTK
+,
54 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
57 Summary: The X11 port of the wxWindows library
59 Requires: %{name} = %{ver}
60 Requires: %{wxbasename}-devel = %{ver}
63 Header files
for wxX11
, the X11 port of the wxWindows library.
66 Summary: The X11 port of the wxWindows library
, OpenGL add
-on.
68 Requires: %{name} = %{ver}
71 OpenGL add
-on library
for wxX11
, the X11 port of the wxWindows library.
74 Summary: wxX11 static libraries
75 Group: Development
/Libraries
78 Static libraries
for wxX11. You need them
if you want to link statically against wxX11.
81 Summary: Contrib libraries
for wxX11.
83 Requires: %{name} = %{ver}
86 Contributed libraries
for wxX11.
88 %package contrib
-devel
89 Summary: Contrib libraries
for wxX11.
91 Requires: %{name}-contrib = %{ver}
92 Requires: %{name}-devel = %{ver}
94 %description contrib
-devel
95 Header files
for contributed libraries
for wxX11.
98 %setup -q
-n wxX11
-%{ver}
101 if [ "$SMP"
!= ""
]; then
102 export MAKE
="
make -j$SMP"
109 ..
/configure
--prefix
=%{pref} --with
-x11 \
123 ..
/configure
--prefix
=%{pref} --with
-x11
--disable
-shared \
134 rm -rf $RPM_BUILD_ROOT
135 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
136 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
138 # Remove headers that are part of wx-base-devel:
140 # --- wxBase headers list begins here ---
141 cat
<<EOF
>wxbase
-headers
-list
264 wx
/protocol
/protocol.h
277 # --- wxBase headers list ends here ---
278 for f
in `cat wxbase
-headers
-list`
; do
279 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx
-*/$f
282 # list of all core headers:
283 find $RPM_BUILD_ROOT
/usr
/include
/wx
-type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
286 (cd obj
-shared
/contrib
/src
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
287 (cd obj
-shared
/utils
/wxrc
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
289 # remove wxBase files so that RPM doesn't complain about unpackaged files:
290 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwx_base
*
291 rm -f $RPM_BUILD_ROOT
%{_datadir}/aclocal
/*
292 rm -f $RPM_BUILD_ROOT
%{_datadir}/locale
/*/*/*
295 rm -rf $RPM_BUILD_ROOT
311 %defattr(-,root
,root
)
312 %doc COPYING.LIB
*.txt
313 %{_libdir}/libwx_%{portname}*_core
*.so.
*
314 %{_libdir}/libwx_%{portname}*_html
*.so.
*
315 %{_libdir}/libwx_%{portname}*_adv
*.so.
*
317 %{_libdir}/libwx_%{portname}*_dbgrid
*.so.
*
320 %files devel
-f core
-headers.files
321 %defattr(-,root
,root
)
322 %{_libdir}/libwx_%{portname}*_core
*.so
323 %{_libdir}/libwx_%{portname}*_html
*.so
324 %{_libdir}/libwx_%{portname}*_adv
*.so
326 %{_libdir}/libwx_%{portname}*_dbgrid
*.so
328 %{_libdir}/libwx_%{portname}*_gl
*.so
331 %{_bindir}/%{wxconfigname}
334 %defattr(-,root
,root
)
335 %{_libdir}/libwx_%{portname}*_gl
*.so.
*
338 %defattr (-,root
,root
)
339 %{_libdir}/libwx_%{portname}*.a
342 %defattr(-,root
,root
)
343 %{_libdir}/libwx_%{portname}*_animate
*.so.
*
344 %{_libdir}/libwx_%{portname}*_deprecated
*.so.
*
345 %{_libdir}/libwx_%{portname}*_fl
*.so.
*
346 %{_libdir}/libwx_%{portname}*_gizmos
*.so.
*
347 %{_libdir}/libwx_%{portname}*_mmedia
*.so.
*
348 %{_libdir}/libwx_%{portname}*_ogl
*.so.
*
349 %{_libdir}/libwx_%{portname}*_plot
*.so.
*
350 %{_libdir}/libwx_%{portname}*_stc
*.so.
*
351 %{_libdir}/libwx_%{portname}*_svg
*.so.
*
352 %{_libdir}/libwx_%{portname}*_xrc
*.so.
*
355 %defattr(-,root
,root
)
357 %dir %{_includedir}/wx
-*/wx
/animate
358 %{_includedir}/wx
-*/wx
/animate
/*
359 %{_libdir}/libwx_%{portname}*_animate
*.so
361 %dir %{_includedir}/wx
-*/wx
/deprecated
362 %{_includedir}/wx
-*/wx
/deprecated
/*
363 %{_libdir}/libwx_%{portname}*_deprecated
*.so
365 %dir %{_includedir}/wx
-*/wx
/fl
366 %{_includedir}/wx
-*/wx
/fl
/*
367 %{_libdir}/libwx_%{portname}*_fl
*.so
369 %dir %{_includedir}/wx
-*/wx
/gizmos
370 %{_includedir}/wx
-*/wx
/gizmos
/*
371 %{_libdir}/libwx_%{portname}*_gizmos
*.so
373 %dir %{_includedir}/wx
-*/wx
/mmedia
374 %{_includedir}/wx
-*/wx
/mmedia
/*
375 %{_libdir}/libwx_%{portname}*_mmedia
*.so
377 %dir %{_includedir}/wx
-*/wx
/ogl
378 %{_includedir}/wx
-*/wx
/ogl
/*
379 %{_libdir}/libwx_%{portname}*_ogl
*.so
381 %dir %{_includedir}/wx
-*/wx
/plot
382 %{_includedir}/wx
-*/wx
/plot
/*
383 %{_libdir}/libwx_%{portname}*_plot
*.so
385 %dir %{_includedir}/wx
-*/wx
/stc
386 %{_includedir}/wx
-*/wx
/stc
/*
387 %{_libdir}/libwx_%{portname}*_stc
*.so
389 %dir %{_includedir}/wx
-*/wx
/svg
390 %{_includedir}/wx
-*/wx
/svg
/*
391 %{_libdir}/libwx_%{portname}*_svg
*.so
393 %dir %{_includedir}/wx
-*/wx
/xrc
394 %{_includedir}/wx
-*/wx
/xrc
/*
395 %{_libdir}/libwx_%{portname}*_xrc
*.so