6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
24 %define name wx
-%{portname}-unicode
25 %define wxbasename wx
-base
-unicode
27 %define name wx
-%{portname}
28 %define wxbasename wx
-base
32 %define wxconfigname wx
%{portname}u-%{ver2}-config
34 %define wxconfigname wx
%{portname}-%{ver2}-config
38 Summary: The GTK
+ %{gtkver} port of the wxWindows library
41 License: wxWindows Licence
43 Source: wxGTK
-%{ver}.tar.bz2
44 URL: http
://www.wxwindows.org
45 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
47 BuildRoot: /var
/tmp
/%{name}-root
49 # all packages providing an implementation of wxWindows library (regardless of
50 # the toolkit used) should provide the (virtual) wxwin package, this makes it
51 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
55 # in addition, we should provide libwx_gtk as automatic generator only notices
56 # libwx_gtk-%{ver}-%{rel}
57 Provides: libwx_gtk.so
58 Provides: libwx_gtk
-%{ver2}.so
60 Requires: %{wxbasename} = %{ver}
61 BuildRequires
: %{wxbasename}-devel = %{ver}
64 wxWindows is a free C
++ library
for cross
-platform GUI development.
65 With wxWindows
, you can create applications
for different GUIs
(GTK
+,
66 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
69 Summary: The GTK
+ %{gtkver} port of the wxWindows library
71 Requires: %{name} = %{ver}
72 Requires: %{wxbasename}-devel = %{ver}
76 Header files
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
79 Summary: The GTK
+ %{gtkver} port of the wxWindows library
, OpenGL add
-on.
81 Requires: %{name} = %{ver}
84 OpenGL add
-on library
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
87 Summary: wxGTK static libraries
88 Group: Development
/Libraries
89 Requires: %{wxbasename}-static
92 Static libraries
for wxGTK. You need them
if you want to link statically against wxGTK.
95 Summary: The GTK
+ %{gtkver} port of the wxWindows library
, contributed libraries.
97 Requires: %{name} = %{ver}
100 Contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
102 %package contrib
-devel
103 Summary: The GTK
+ %{gtkver} port of the wxWindows library
105 Requires: %{name}-contrib = %{ver}
106 Requires: %{name}-devel = %{ver}
108 %description contrib
-devel
109 Header files
for contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
112 %setup -q
-n wxGTK
-%{ver}
115 if [ "$SMP"
!= ""
]; then
116 export MAKE
="
make -j$SMP"
123 ..
/configure
--prefix
=%{pref} \
140 ..
/configure
--prefix
=%{pref} --disable
-shared \
154 rm -rf $RPM_BUILD_ROOT
155 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
156 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
158 # Remove headers that are part of wx-base-devel:
161 for f
in `rpm
-ql
%{wxbasename}-devel | sed
-e 's
,\
(.
*\
),.\
1,g'`
; do
162 if test -f $f
; then rm -f $f
; fi
166 # list of all core headers:
167 find $RPM_BUILD_ROOT
/usr
/include
/wx
-type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
170 (cd obj
-shared
/contrib
/src
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
171 (cd obj
-shared
/contrib
/utils
/wxrc
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
174 rm -rf $RPM_BUILD_ROOT
189 # Install wx-config if there isn't any
190 if test ! -f
%{_bindir}/wx
-config
; then
191 ln
-sf
%{wxconfigname} %{_bindir}/wx
-config
195 # Remove wx-config if it points to this package
196 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
197 SUM1
=`md5sum
%{_bindir}/%{wxconfigname} | cut
-c
0-32`
198 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
199 if test "x$SUM1"
= "x$SUM2"
; then
200 rm -f
%{_bindir}/wx
-config
206 %defattr(-,root
,root
)
207 %doc COPYING.LIB
*.txt
210 %{_libdir}/libwx_%{portname}*_core
*.so.
*
211 %{_libdir}/libwx_%{portname}*_html
*.so.
*
212 %{_libdir}/libwx_%{portname}*_adv
*.so.
*
214 %{_libdir}/libwx_%{portname}*_dbgrid
*.so.
*
217 %files devel
-f core
-headers.files
218 %defattr(-,root
,root
)
219 %{_libdir}/libwx_%{portname}*_core
*.so
220 %{_libdir}/libwx_%{portname}*_html
*.so
221 %{_libdir}/libwx_%{portname}*_adv
*.so
223 %{_libdir}/libwx_%{portname}*_dbgrid
*.so
225 %{_libdir}/libwx_%{portname}*_gl
*.so
228 %{_bindir}/%{wxconfigname}
231 %defattr(-,root
,root
)
232 %{_libdir}/libwx_%{portname}*_gl
*.so.
*
235 %defattr (-,root
,root
)
236 %{_libdir}/libwx_gtk
*.a
239 %defattr(-,root
,root
)
240 %{_libdir}/libwx_%{portname}*_animate
*.so.
*
241 %{_libdir}/libwx_%{portname}*_deprecated
*.so.
*
242 %{_libdir}/libwx_%{portname}*_fl
*.so.
*
243 %{_libdir}/libwx_%{portname}*_gizmos
*.so.
*
244 %{_libdir}/libwx_%{portname}*_mmedia
*.so.
*
245 %{_libdir}/libwx_%{portname}*_ogl
*.so.
*
246 %{_libdir}/libwx_%{portname}*_plot
*.so.
*
247 %{_libdir}/libwx_%{portname}*_stc
*.so.
*
248 %{_libdir}/libwx_%{portname}*_svg
*.so.
*
249 %{_libdir}/libwx_%{portname}*_xrc
*.so.
*
252 %defattr(-,root
,root
)
254 %dir %{_includedir}/wx
/animate
255 %{_includedir}/wx
/animate
/*
256 %{_libdir}/libwx_%{portname}*_animate
*.so
258 %dir %{_includedir}/wx
/deprecated
259 %{_includedir}/wx
/deprecated
/*
260 %{_libdir}/libwx_%{portname}*_deprecated
*.so
262 %dir %{_includedir}/wx
/fl
263 %{_includedir}/wx
/fl
/*
264 %{_libdir}/libwx_%{portname}*_fl
*.so
266 %dir %{_includedir}/wx
/gizmos
267 %{_includedir}/wx
/gizmos
/*
268 %{_libdir}/libwx_%{portname}*_gizmos
*.so
270 %dir %{_includedir}/wx
/mmedia
271 %{_includedir}/wx
/mmedia
/*
272 %{_libdir}/libwx_%{portname}*_mmedia
*.so
274 %dir %{_includedir}/wx
/ogl
275 %{_includedir}/wx
/ogl
/*
276 %{_libdir}/libwx_%{portname}*_ogl
*.so
278 %dir %{_includedir}/wx
/plot
279 %{_includedir}/wx
/plot
/*
280 %{_libdir}/libwx_%{portname}*_plot
*.so
282 %dir %{_includedir}/wx
/stc
283 %{_includedir}/wx
/stc
/*
284 %{_libdir}/libwx_%{portname}*_stc
*.so
286 %dir %{_includedir}/wx
/svg
287 %{_includedir}/wx
/svg
/*
288 %{_libdir}/libwx_%{portname}*_svg
*.so
290 %dir %{_includedir}/wx
/xrc
291 %{_includedir}/wx
/xrc
/*
292 %{_libdir}/libwx_%{portname}*_xrc
*.so