Fix crash when auto-sizing a wxDataViewCtrl column.
[wxWidgets.git] / wxMotif.spec
1 %define pref /usr
2 %define ver 3.0.0
3 %define ver2 3.0
4 %define rel 1
5
6 %define portname motif
7 %define name wx-%{portname}
8 %define wxbasename wx-base
9
10 %define wxconfig %{portname}-ansi-%{ver2}
11 %define wxconfiglink wx%{portname}-%{ver2}-config
12
13 Summary: The Motif/Lesstif port of the wxWidgets library
14 Name: %{name}
15 Version: %{ver}
16 Release: %{rel}
17 License: wxWindows Licence
18 Group: X11/Libraries
19 Source: wxMotif-%{ver}.tar.bz2
20 URL: http://www.wxwidgets.org
21 Packager: wxWidgets developers <wx-dev@lists.wxwidgets.org>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
24
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
28 Provides: wxwin
29 Provides: wxMotif
30
31 %description
32 wxWidgets is a free C++ library for cross-platform GUI development.
33 With wxWidgets, you can create applications for different GUIs (GTK+,
34 Motif/LessTif, MS Windows, Mac) from the same source code.
35
36 %package devel
37 Summary: The Motif/Lesstif port of the wxWidgets library
38 Group: X11/Libraries
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
41
42 %description devel
43 Header files for wxMotif, the Motif/Lesstif port of the wxWidgets library.
44
45 %package gl
46 Summary: The Motif/Lesstif port of the wxWidgets library, OpenGL add-on.
47 Group: X11/Libraries
48 Requires: %{name} = %{ver}
49
50 %description gl
51 OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWidgets library.
52
53 %package static
54 Summary: wxMotif static libraries
55 Group: Development/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
58
59 %description static
60 Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
61
62 %prep
63 %setup -q -n wxMotif-%{ver}
64
65 %build
66 if [ "$SMP" != "" ]; then
67 export MAKE="make -j$SMP"
68 else
69 export MAKE="make"
70 fi
71
72 mkdir obj-shared
73 cd obj-shared
74 ../configure --prefix=%{pref} --with-motif --with-opengl
75 $MAKE
76 cd ..
77
78 mkdir obj-static
79 cd obj-static
80 ../configure --prefix=%{pref} --with-motif --disable-shared --with-opengl
81 $MAKE
82 cd ..
83
84 %install
85 rm -rf $RPM_BUILD_ROOT
86 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
87 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
88
89 # Remove headers that are part of wx-base-devel:
90
91 # --- wxBase headers list begins here ---
92 cat <<EOF >wxbase-headers.files
93 wx/afterstd.h
94 wx/any.h
95 wx/anystr.h
96 wx/app.h
97 wx/apptrait.h
98 wx/archive.h
99 wx/arrimpl.cpp
100 wx/arrstr.h
101 wx/atomic.h
102 wx/base64.h
103 wx/beforestd.h
104 wx/buffer.h
105 wx/build.h
106 wx/chartype.h
107 wx/checkeddelete.h
108 wx/chkconf.h
109 wx/clntdata.h
110 wx/cmdargs.h
111 wx/cmdline.h
112 wx/compiler.h
113 wx/confbase.h
114 wx/config.h
115 wx/convauto.h
116 wx/containr.h
117 wx/cpp.h
118 wx/crt.h
119 wx/datetime.h
120 wx/datstrm.h
121 wx/dde.h
122 wx/debug.h
123 wx/defs.h
124 wx/dir.h
125 wx/dlimpexp.h
126 wx/dlist.h
127 wx/dynarray.h
128 wx/dynlib.h
129 wx/dynload.h
130 wx/encconv.h
131 wx/event.h
132 wx/eventfilter.h
133 wx/evtloop.h
134 wx/except.h
135 wx/features.h
136 wx/flags.h
137 wx/ffile.h
138 wx/file.h
139 wx/fileconf.h
140 wx/filefn.h
141 wx/filename.h
142 wx/filesys.h
143 wx/fontenc.h
144 wx/fontmap.h
145 wx/fs_arc.h
146 wx/fs_filter.h
147 wx/fs_mem.h
148 wx/fs_zip.h
149 wx/hash.h
150 wx/hashmap.h
151 wx/hashset.h
152 wx/html/forcelnk.h
153 wx/iconloc.h
154 wx/init.h
155 wx/intl.h
156 wx/iosfwrap.h
157 wx/ioswrap.h
158 wx/ipc.h
159 wx/ipcbase.h
160 wx/kbdstate.h
161 wx/language.h
162 wx/link.h
163 wx/list.h
164 wx/listimpl.cpp
165 wx/log.h
166 wx/longlong.h
167 wx/math.h
168 wx/memconf.h
169 wx/memory.h
170 wx/memtext.h
171 wx/mimetype.h
172 wx/module.h
173 wx/mousestate.h
174 wx/msgout.h
175 wx/msgqueue.h
176 wx/mstream.h
177 wx/numformatter.h
178 wx/object.h
179 wx/platform.h
180 wx/platinfo.h
181 wx/power.h
182 wx/process.h
183 wx/ptr_scpd.h
184 wx/ptr_shrd.h
185 wx/recguard.h
186 wx/regex.h
187 wx/rtti.h
188 wx/scopedarray.h
189 wx/scopedptr.h
190 wx/scopeguard.h
191 wx/sharedptr.h
192 wx/snglinst.h
193 wx/sstream.h
194 wx/stack.h
195 wx/stackwalk.h
196 wx/stdpaths.h
197 wx/stdstream.h
198 wx/stockitem.h
199 wx/stopwatch.h
200 wx/strconv.h
201 wx/stream.h
202 wx/string.h
203 wx/stringimpl.h
204 wx/stringops.h
205 wx/strvararg.h
206 wx/sysopt.h
207 wx/tarstrm.h
208 wx/textbuf.h
209 wx/textfile.h
210 wx/thread.h
211 wx/thrimpl.cpp
212 wx/time.h
213 wx/timer.h
214 wx/tls.h
215 wx/tokenzr.h
216 wx/tracker.h
217 wx/translation.h
218 wx/txtstrm.h
219 wx/typeinfo.h
220 wx/types.h
221 wx/unichar.h
222 wx/uri.h
223 wx/ustring.h
224 wx/utils.h
225 wx/variant.h
226 wx/vector.h
227 wx/version.h
228 wx/versioninfo.h
229 wx/volume.h
230 wx/weakref.h
231 wx/wfstream.h
232 wx/wx.h
233 wx/wxchar.h
234 wx/wxcrt.h
235 wx/wxcrtbase.h
236 wx/wxcrtvararg.h
237 wx/wxprec.h
238 wx/xlocale.h
239 wx/xti.h
240 wx/xti2.h
241 wx/xtistrm.h
242 wx/xtictor.h
243 wx/xtihandler.h
244 wx/xtiprop.h
245 wx/xtitypes.h
246 wx/zipstrm.h
247 wx/zstream.h
248 wx/meta/convertible.h
249 wx/meta/if.h
250 wx/meta/implicitconversion.h
251 wx/meta/int2type.h
252 wx/meta/movable.h
253 wx/meta/pod.h
254 wx/meta/removeref.h
255 wx/fswatcher.h
256 wx/generic/fswatcher.h
257 wx/unix/app.h
258 wx/unix/apptbase.h
259 wx/unix/apptrait.h
260 wx/unix/chkconf.h
261 wx/unix/evtloop.h
262 wx/unix/evtloopsrc.h
263 wx/unix/pipe.h
264 wx/unix/stdpaths.h
265 wx/unix/stackwalk.h
266 wx/unix/tls.h
267 wx/unix/fswatcher_kqueue.h
268 wx/unix/execute.h
269 wx/unix/mimetype.h
270 wx/unix/fswatcher_inotify.h
271 wx/fs_inet.h
272 wx/protocol/file.h
273 wx/protocol/ftp.h
274 wx/protocol/http.h
275 wx/protocol/log.h
276 wx/protocol/protocol.h
277 wx/sckaddr.h
278 wx/sckipc.h
279 wx/sckstrm.h
280 wx/socket.h
281 wx/url.h
282 wx/xml/xml.h
283 wx/xtixml.h
284 EOF
285 # --- wxBase headers list ends here ---
286 for f in `cat wxbase-headers-list` ; do
287 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
288 done
289
290 # list of all core headers:
291 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
292
293 # remove wxBase files so that RPM doesn't complain about unpackaged files:
294 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
295 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
296 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
297
298 %clean
299 rm -rf $RPM_BUILD_ROOT
300
301 %post
302 /sbin/ldconfig
303
304 %postun
305 /sbin/ldconfig
306
307 %post devel
308 # link wx-config when you install RPM.
309 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
310 # link wx-config with explicit name.
311 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
312 /sbin/ldconfig
313
314 %postun devel
315 /sbin/ldconfig
316
317 %preun devel
318 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
319 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
320 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
321 if test "x$SUM1" = "x$SUM2" ; then
322 rm -f %{_bindir}/wx-config
323 fi
324 fi
325 rm -f %{_bindir}/%{wxconfiglink}
326
327 %post gl
328 /sbin/ldconfig
329
330 %postun gl
331 /sbin/ldconfig
332
333 %files
334 %defattr(-,root,root)
335 %doc COPYING.LIB *.txt
336 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
337 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
338 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
339 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
340 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
341 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
342
343
344 %files devel -f core-headers.files
345 %defattr(-,root,root)
346 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
347 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
348 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
349 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
350 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
351 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
352 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
353 %dir %{_libdir}/wx
354 %{_libdir}/wx/*
355 %{_bindir}/wxrc*
356
357 %files gl
358 %defattr(-,root,root)
359 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
360
361 %files static
362 %defattr (-,root,root)
363 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
364