7 %define name wx
-%{portname}
8 %define wxbasename wx
-base
10 %define wxconfig
%{portname}-ansi-%{ver2}
11 %define wxconfiglink wx
%{portname}-%{ver2}-config
13 Summary: The Motif
/Lesstif port of the wxWidgets library
17 License: wxWindows Licence
19 Source: wxMotif
-%{ver}.tar.bz2
20 URL: http
://www.wxwidgets.org
21 Packager: wxWidgets developers
<wx
-dev@lists.wxwidgets.org
>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
32 wxWidgets is a free C
++ library
for cross
-platform GUI development.
33 With wxWidgets
, you can create applications
for different GUIs
(GTK
+,
34 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
37 Summary: The Motif
/Lesstif port of the wxWidgets library
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
43 Header files
for wxMotif
, the Motif
/Lesstif port of the wxWidgets library.
46 Summary: The Motif
/Lesstif port of the wxWidgets library
, OpenGL add
-on.
48 Requires: %{name} = %{ver}
51 OpenGL add
-on library
for wxMotif
, the Motif
/Lesstif port of the wxWidgets library.
54 Summary: wxMotif static libraries
55 Group: Development
/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
60 Static libraries
for wxMotif. You need them
if you want to link statically against wxMotif.
63 %setup -q
-n wxMotif
-%{ver}
66 if [ "$SMP"
!= ""
]; then
67 export MAKE
="
make -j$SMP"
74 ..
/configure
--prefix
=%{pref} --with
-motif
--with
-opengl
80 ..
/configure
--prefix
=%{pref} --with
-motif
--disable
-shared
--with
-opengl
85 rm -rf $RPM_BUILD_ROOT
86 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
87 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
89 # Remove headers that are part of wx-base-devel:
91 # --- wxBase headers list begins here ---
92 cat
<<EOF
>wxbase
-headers.files
248 wx
/meta
/convertible.h
250 wx
/meta
/implicitconversion.h
256 wx
/generic
/fswatcher.h
267 wx
/unix
/fswatcher_kqueue.h
270 wx
/unix
/fswatcher_inotify.h
276 wx
/protocol
/protocol.h
285 # --- wxBase headers list ends here ---
286 for f
in `cat wxbase
-headers
-list`
; do
287 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2}/$f
290 # list of all core headers:
291 find $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} -type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
293 # remove wxBase files so that RPM doesn't complain about unpackaged files:
294 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwx_base
*
295 rm -f $RPM_BUILD_ROOT
%{_datadir}/aclocal
/*
296 rm -f $RPM_BUILD_ROOT
%{_datadir}/locale
/*/*/*
299 rm -rf $RPM_BUILD_ROOT
308 # link wx-config when you install RPM.
309 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx
-config
310 # link wx-config with explicit name.
311 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
318 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
319 SUM1
=`md5sum
%{_libdir}/wx/config/%{wxconfig} | cut
-c
0-32`
320 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
321 if test "x$SUM1"
= "x$SUM2"
; then
322 rm -f
%{_bindir}/wx
-config
325 rm -f
%{_bindir}/%{wxconfiglink}
334 %defattr(-,root
,root
)
335 %doc COPYING.LIB
*.txt
336 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.
*
337 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.
*
338 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.
*
339 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.
*
340 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.
*
341 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.
*
344 %files devel
-f core
-headers.files
345 %defattr(-,root
,root
)
346 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
347 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
348 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
349 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
350 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
351 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
352 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
358 %defattr(-,root
,root
)
359 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.
*
362 %defattr (-,root
,root
)
363 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a