Add wxFilterFSHandler.
[wxWidgets.git] / wxMotif.spec
1 %define pref /usr
2 %define ver 2.7.0
3 %define ver2 2.7
4 %define rel 1
5
6 %define portname motif
7 %define name wx-%{portname}
8 %define wxbasename wx-base
9
10 %define wxconfig %{portname}-ansi-release-%{ver2}
11 %define wxconfiglink wx%{portname}-%{ver2}-config
12
13 Summary: The Motif/Lesstif port of the wxWidgets library
14 Name: %{name}
15 Version: %{ver}
16 Release: %{rel}
17 License: wxWindows Licence
18 Group: X11/Libraries
19 Source: wxMotif-%{ver}.tar.bz2
20 URL: http://www.wxwidgets.org
21 Packager: wxWidgets developers <wx-dev@lists.wxwidgets.org>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
24
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
28 Provides: wxwin
29 Provides: wxMotif
30
31 %description
32 wxWidgets is a free C++ library for cross-platform GUI development.
33 With wxWidgets, you can create applications for different GUIs (GTK+,
34 Motif/LessTif, MS Windows, Mac) from the same source code.
35
36 %package devel
37 Summary: The Motif/Lesstif port of the wxWidgets library
38 Group: X11/Libraries
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
41
42 %description devel
43 Header files for wxMotif, the Motif/Lesstif port of the wxWidgets library.
44
45 %package gl
46 Summary: The Motif/Lesstif port of the wxWidgets library, OpenGL add-on.
47 Group: X11/Libraries
48 Requires: %{name} = %{ver}
49
50 %description gl
51 OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWidgets library.
52
53 %package static
54 Summary: wxMotif static libraries
55 Group: Development/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
58
59 %description static
60 Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
61
62 %package contrib
63 Summary: Contrib libraries for wxMotif
64 Group: X11/Libraries
65 Requires: %{name} = %{ver}
66
67 %description contrib
68 Contrib libraries for wxMotif
69
70 %package contrib-devel
71 Summary: Contrib libraries for wxMotif
72 Group: X11/Libraries
73 Requires: %{name}-contrib = %{ver}
74 Requires: %{name}-devel = %{ver}
75
76 %description contrib-devel
77 Header files for contributed libraries for wxMotif.
78
79 %prep
80 %setup -q -n wxMotif-%{ver}
81
82 %build
83 if [ "$SMP" != "" ]; then
84 export MAKE="make -j$SMP"
85 else
86 export MAKE="make"
87 fi
88
89 mkdir obj-shared
90 cd obj-shared
91 ../configure --prefix=%{pref} --with-motif --with-odbc --with-opengl
92 $MAKE
93
94 cd contrib/src
95 $MAKE
96 cd ../../..
97
98 mkdir obj-static
99 cd obj-static
100 ../configure --prefix=%{pref} --with-motif --disable-shared --with-odbc --with-opengl
101 $MAKE
102 cd ..
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
107 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
108
109 # Remove headers that are part of wx-base-devel:
110
111 # --- wxBase headers list begins here ---
112 cat <<EOF >wxbase-headers.files
113 wx/afterstd.h
114 wx/app.h
115 wx/apptrait.h
116 wx/archive.h
117 wx/arrimpl.cpp
118 wx/arrstr.h
119 wx/beforestd.h
120 wx/buffer.h
121 wx/build.h
122 wx/chkconf.h
123 wx/clntdata.h
124 wx/cmdline.h
125 wx/confbase.h
126 wx/config.h
127 wx/convauto.h
128 wx/containr.h
129 wx/cpp.h
130 wx/datetime.h
131 wx/datstrm.h
132 wx/dde.h
133 wx/debug.h
134 wx/defs.h
135 wx/dir.h
136 wx/dlimpexp.h
137 wx/dynarray.h
138 wx/dynlib.h
139 wx/dynload.h
140 wx/encconv.h
141 wx/event.h
142 wx/except.h
143 wx/features.h
144 wx/ffile.h
145 wx/file.h
146 wx/fileback.h
147 wx/fileconf.h
148 wx/filefn.h
149 wx/filename.h
150 wx/filesys.h
151 wx/fontenc.h
152 wx/fontmap.h
153 wx/fs_filter.h
154 wx/fs_mem.h
155 wx/fs_zip.h
156 wx/hash.h
157 wx/hashmap.h
158 wx/hashset.h
159 wx/html/forcelnk.h
160 wx/iconloc.h
161 wx/init.h
162 wx/intl.h
163 wx/iosfwrap.h
164 wx/ioswrap.h
165 wx/ipc.h
166 wx/ipcbase.h
167 wx/isql.h
168 wx/isqlext.h
169 wx/link.h
170 wx/list.h
171 wx/listimpl.cpp
172 wx/log.h
173 wx/longlong.h
174 wx/math.h
175 wx/memconf.h
176 wx/memory.h
177 wx/memtext.h
178 wx/mimetype.h
179 wx/module.h
180 wx/msgout.h
181 wx/mstream.h
182 wx/object.h
183 wx/platform.h
184 wx/platinfo.h
185 wx/power.h
186 wx/process.h
187 wx/ptr_scpd.h
188 wx/recguard.h
189 wx/regex.h
190 wx/scopeguard.h
191 wx/snglinst.h
192 wx/sstream.h
193 wx/stack.h
194 wx/stackwalk.h
195 wx/stdpaths.h
196 wx/stockitem.h
197 wx/stopwatch.h
198 wx/strconv.h
199 wx/stream.h
200 wx/string.h
201 wx/sysopt.h
202 wx/textbuf.h
203 wx/textfile.h
204 wx/thread.h
205 wx/thrimpl.cpp
206 wx/timer.h
207 wx/tokenzr.h
208 wx/txtstrm.h
209 wx/types.h
210 wx/uri.h
211 wx/utils.h
212 wx/variant.h
213 wx/vector.h
214 wx/version.h
215 wx/volume.h
216 wx/wfstream.h
217 wx/wx.h
218 wx/wxchar.h
219 wx/wxprec.h
220 wx/xti.h
221 wx/xtistrm.h
222 wx/zipstrm.h
223 wx/zstream.h
224 wx/unix/apptbase.h
225 wx/unix/apptrait.h
226 wx/unix/execute.h
227 wx/unix/mimetype.h
228 wx/unix/pipe.h
229 wx/unix/private.h
230 wx/unix/stackwalk.h
231 wx/unix/stdpaths.h
232 wx/fs_inet.h
233 wx/gsocket.h
234 wx/protocol/file.h
235 wx/protocol/ftp.h
236 wx/protocol/http.h
237 wx/protocol/protocol.h
238 wx/sckaddr.h
239 wx/sckipc.h
240 wx/sckstrm.h
241 wx/socket.h
242 wx/url.h
243 wx/unix/gsockunx.h
244 wx/xml/xml.h
245 wx/xtixml.h
246 wx/db.h
247 wx/dbkeyg.h
248 wx/dbtable.h
249 EOF
250 # --- wxBase headers list ends here ---
251 for f in `cat wxbase-headers-list` ; do
252 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
253 done
254
255 # list of all core headers:
256 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
257
258 # contrib stuff:
259 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
260 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
261
262 # remove wxBase files so that RPM doesn't complain about unpackaged files:
263 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
264 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
265 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
266
267 %clean
268 rm -rf $RPM_BUILD_ROOT
269
270 %post
271 /sbin/ldconfig
272
273 %postun
274 /sbin/ldconfig
275
276 %post devel
277 # link wx-config when you install RPM.
278 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
279 # link wx-config with explicit name.
280 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
281 /sbin/ldconfig
282
283 %postun devel
284 /sbin/ldconfig
285
286 %preun devel
287 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
288 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
289 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
290 if test "x$SUM1" = "x$SUM2" ; then
291 rm -f %{_bindir}/wx-config
292 fi
293 fi
294 rm -f %{_bindir}/%{wxconfiglink}
295
296 %post gl
297 /sbin/ldconfig
298
299 %postun gl
300 /sbin/ldconfig
301
302 %post contrib
303 /sbin/ldconfig
304
305 %postun contrib
306 /sbin/ldconfig
307
308 %post contrib-devel
309 /sbin/ldconfig
310
311 %postun contrib-devel
312 /sbin/ldconfig
313
314 %files
315 %defattr(-,root,root)
316 %doc COPYING.LIB *.txt
317 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
318 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
319 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
320 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
321 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
322 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
323 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
324
325
326 %files devel -f core-headers.files
327 %defattr(-,root,root)
328 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
329 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
330 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
331 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
332 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
333 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
334 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
335 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
336 %dir %{_libdir}/wx
337 %{_libdir}/wx/*
338 %{_bindir}/wxrc*
339
340 %files gl
341 %defattr(-,root,root)
342 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
343
344 %files static
345 %defattr (-,root,root)
346 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
347
348 %files contrib
349 %defattr(-,root,root)
350 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
351 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
352 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
353 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
354 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
355 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
356 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
357 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
358 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
359
360 %files contrib-devel
361 %defattr(-,root,root)
362 %dir %{_includedir}/wx-%{ver2}/wx/animate
363 %{_includedir}/wx-%{ver2}/wx/animate/*
364 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
365
366 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
367 %{_includedir}/wx-%{ver2}/wx/deprecated/*
368 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
369
370 %dir %{_includedir}/wx-%{ver2}/wx/fl
371 %{_includedir}/wx-%{ver2}/wx/fl/*
372 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
373
374 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
375 %{_includedir}/wx-%{ver2}/wx/gizmos/*
376 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
377
378 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
379 %{_includedir}/wx-%{ver2}/wx/mmedia/*
380 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
381
382 %dir %{_includedir}/wx-%{ver2}/wx/ogl
383 %{_includedir}/wx-%{ver2}/wx/ogl/*
384 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
385
386 %dir %{_includedir}/wx-%{ver2}/wx/plot
387 %{_includedir}/wx-%{ver2}/wx/plot/*
388 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
389
390 %dir %{_includedir}/wx-%{ver2}/wx/stc
391 %{_includedir}/wx-%{ver2}/wx/stc/*
392 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
393
394 %dir %{_includedir}/wx-%{ver2}/wx/svg
395 %{_includedir}/wx-%{ver2}/wx/svg/*
396 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so