Add wxFilterFSHandler.
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 2.7.0
3 %define ver2 2.7
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfiglink wxbaseu-%{ver2}-config
46 %else
47 %define wxbasename wx-base-ansi
48 %define wxbaseconfig base-ansi-release-%{ver2}
49 %define wxbaseconfiglink wxbase-%{ver2}-config
50 %endif
51
52 Summary: The GTK+ %{gtkver} port of the wxWidgets library
53 Name: %{name}
54 Version: %{ver}
55 Release: %{rel}
56 License: wxWindows Licence
57 Group: X11/Libraries
58 Source: wxGTK-%{ver}.tar.bz2
59 URL: http://www.wxwidgets.org
60 Packager: Vadim Zeitlin <vadim@wxwindows.org>
61 Prefix: %{_prefix}
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires: gtk+-2.0-devel
66 %else
67 BuildRequires: gtk+-devel >= 1.2.0
68 %endif
69
70 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
71
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
75 Provides: wxwin
76 Provides: wxGTK
77
78 %description
79 wxWidgets is a free C++ library for cross-platform GUI development.
80 With wxWidgets, you can create applications for different GUIs (GTK+,
81 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
82
83 %package -n wx-i18n
84 Summary: The translations for the wxWidgets library.
85 Group: X11/Libraries
86
87 %description -n wx-i18n
88 The translations files for the wxWidgets library.
89
90 %package devel
91 Summary: The GTK+ %{gtkver} port of the wxWidgets library
92 Group: X11/Libraries
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
95 Provides: wxGTK-devel
96
97 %description devel
98 The GTK+ %{gtkver} port of the wxWidgets library, header files.
99
100 %package gl
101 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
102 Group: X11/Libraries
103 Requires: %{name} = %{ver}
104 Provides: wxGTK-gl
105
106 %description gl
107 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
108
109 %package -n %{wxbasename}
110 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
111 Group: Development/Libraries
112 Provides: wxBase
113
114 %description -n %{wxbasename}
115 wxBase is a collection of C++ classes providing basic data structures (strings,
116 lists, arrays), portable wrappers around many OS-specific funstions (file
117 operations, time/date manipulations, threads, processes, sockets, shared
118 library loading) as well as other utility classes (streams, archive and
119 compression). wxBase currently supports Win32, most Unix variants (Linux,
120 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
121
122 %package -n %{wxbasename}-devel
123 Summary: wxBase library, header files.
124 Group: Development/Libraries
125 Provides: wxBase-devel
126
127 %description -n %{wxbasename}-devel
128 wxBase library - non-GUI support classes of the wxWidgets toolkit,
129 header files.
130
131 %package contrib
132 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
133 Group: X11/Libraries
134 Requires: %{name} = %{ver}
135
136 %description contrib
137 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
138
139 %package contrib-devel
140 Summary: The GTK+ %{gtkver} port of the wxWidgets library
141 Group: X11/Libraries
142 Requires: %{name}-contrib = %{ver}
143 Requires: %{name}-devel = %{ver}
144
145 %description contrib-devel
146 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
147
148 %prep
149 %setup -q -n wxGTK-%{ver}
150
151 %build
152 if [ "$SMP" != "" ]; then
153 export MAKE="make -j$SMP"
154 else
155 export MAKE="make"
156 fi
157
158 mkdir obj-shared
159 cd obj-shared
160 ../configure --prefix=%{_prefix} \
161 %if ! %{gtk2}
162 --with-gtk=1 \
163 %else
164 --with-gtk=2 \
165 %endif
166 %if %{unicode}
167 --enable-unicode \
168 %else
169 --disable-unicode \
170 --with-odbc \
171 %endif
172 --with-opengl
173 $MAKE
174
175 cd contrib/src
176 $MAKE
177 cd ../../..
178
179 mkdir obj-static
180 cd obj-static
181 ../configure --prefix=%{_prefix} \
182 %if ! %{gtk2}
183 --with-gtk=1 \
184 %else
185 --with-gtk=2 \
186 %endif
187 --disable-shared \
188 %if %{unicode}
189 --enable-unicode \
190 %else
191 --disable-unicode \
192 --with-odbc \
193 %endif
194 --with-opengl
195 $MAKE
196
197 cd contrib/src
198 $MAKE
199 cd ../../..
200
201 make -C locale allmo
202
203 %install
204 rm -rf $RPM_BUILD_ROOT
205 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
206 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
207
208 # --- wxBase headers list begins here ---
209 cat <<EOF >wxbase-headers.files
210 wx/afterstd.h
211 wx/app.h
212 wx/apptrait.h
213 wx/archive.h
214 wx/arrimpl.cpp
215 wx/arrstr.h
216 wx/beforestd.h
217 wx/buffer.h
218 wx/build.h
219 wx/chkconf.h
220 wx/clntdata.h
221 wx/cmdline.h
222 wx/confbase.h
223 wx/config.h
224 wx/convauto.h
225 wx/containr.h
226 wx/cpp.h
227 wx/datetime.h
228 wx/datstrm.h
229 wx/dde.h
230 wx/debug.h
231 wx/defs.h
232 wx/dir.h
233 wx/dlimpexp.h
234 wx/dynarray.h
235 wx/dynlib.h
236 wx/dynload.h
237 wx/encconv.h
238 wx/event.h
239 wx/except.h
240 wx/features.h
241 wx/ffile.h
242 wx/file.h
243 wx/fileback.h
244 wx/fileconf.h
245 wx/filefn.h
246 wx/filename.h
247 wx/filesys.h
248 wx/fontenc.h
249 wx/fontmap.h
250 wx/fs_filter.h
251 wx/fs_mem.h
252 wx/fs_zip.h
253 wx/hash.h
254 wx/hashmap.h
255 wx/hashset.h
256 wx/html/forcelnk.h
257 wx/iconloc.h
258 wx/init.h
259 wx/intl.h
260 wx/iosfwrap.h
261 wx/ioswrap.h
262 wx/ipc.h
263 wx/ipcbase.h
264 wx/isql.h
265 wx/isqlext.h
266 wx/link.h
267 wx/list.h
268 wx/listimpl.cpp
269 wx/log.h
270 wx/longlong.h
271 wx/math.h
272 wx/memconf.h
273 wx/memory.h
274 wx/memtext.h
275 wx/mimetype.h
276 wx/module.h
277 wx/msgout.h
278 wx/mstream.h
279 wx/object.h
280 wx/platform.h
281 wx/platinfo.h
282 wx/power.h
283 wx/process.h
284 wx/ptr_scpd.h
285 wx/recguard.h
286 wx/regex.h
287 wx/scopeguard.h
288 wx/snglinst.h
289 wx/sstream.h
290 wx/stack.h
291 wx/stackwalk.h
292 wx/stdpaths.h
293 wx/stockitem.h
294 wx/stopwatch.h
295 wx/strconv.h
296 wx/stream.h
297 wx/string.h
298 wx/sysopt.h
299 wx/textbuf.h
300 wx/textfile.h
301 wx/thread.h
302 wx/thrimpl.cpp
303 wx/timer.h
304 wx/tokenzr.h
305 wx/txtstrm.h
306 wx/types.h
307 wx/uri.h
308 wx/utils.h
309 wx/variant.h
310 wx/vector.h
311 wx/version.h
312 wx/volume.h
313 wx/wfstream.h
314 wx/wx.h
315 wx/wxchar.h
316 wx/wxprec.h
317 wx/xti.h
318 wx/xtistrm.h
319 wx/zipstrm.h
320 wx/zstream.h
321 wx/unix/apptbase.h
322 wx/unix/apptrait.h
323 wx/unix/execute.h
324 wx/unix/mimetype.h
325 wx/unix/pipe.h
326 wx/unix/private.h
327 wx/unix/stackwalk.h
328 wx/unix/stdpaths.h
329 wx/fs_inet.h
330 wx/gsocket.h
331 wx/protocol/file.h
332 wx/protocol/ftp.h
333 wx/protocol/http.h
334 wx/protocol/protocol.h
335 wx/sckaddr.h
336 wx/sckipc.h
337 wx/sckstrm.h
338 wx/socket.h
339 wx/url.h
340 wx/unix/gsockunx.h
341 wx/xml/xml.h
342 wx/xtixml.h
343 wx/db.h
344 wx/dbkeyg.h
345 wx/dbtable.h
346 EOF
347 # --- wxBase headers list ends here ---
348 cat <<EOF >wxbase-headers.paths
349 %{_includedir}/wx-%{ver2}/wx/afterstd.h
350 %{_includedir}/wx-%{ver2}/wx/app.h
351 %{_includedir}/wx-%{ver2}/wx/apptrait.h
352 %{_includedir}/wx-%{ver2}/wx/archive.h
353 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
354 %{_includedir}/wx-%{ver2}/wx/arrstr.h
355 %{_includedir}/wx-%{ver2}/wx/beforestd.h
356 %{_includedir}/wx-%{ver2}/wx/buffer.h
357 %{_includedir}/wx-%{ver2}/wx/build.h
358 %{_includedir}/wx-%{ver2}/wx/chkconf.h
359 %{_includedir}/wx-%{ver2}/wx/clntdata.h
360 %{_includedir}/wx-%{ver2}/wx/cmdline.h
361 %{_includedir}/wx-%{ver2}/wx/confbase.h
362 %{_includedir}/wx-%{ver2}/wx/config.h
363 %{_includedir}/wx-%{ver2}/wx/containr.h
364 %{_includedir}/wx-%{ver2}/wx/convauto.h
365 %{_includedir}/wx-%{ver2}/wx/datetime.h
366 %{_includedir}/wx-%{ver2}/wx/datstrm.h
367 %{_includedir}/wx-%{ver2}/wx/dde.h
368 %{_includedir}/wx-%{ver2}/wx/debug.h
369 %{_includedir}/wx-%{ver2}/wx/defs.h
370 %{_includedir}/wx-%{ver2}/wx/dir.h
371 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
372 %{_includedir}/wx-%{ver2}/wx/dynarray.h
373 %{_includedir}/wx-%{ver2}/wx/dynlib.h
374 %{_includedir}/wx-%{ver2}/wx/dynload.h
375 %{_includedir}/wx-%{ver2}/wx/encconv.h
376 %{_includedir}/wx-%{ver2}/wx/event.h
377 %{_includedir}/wx-%{ver2}/wx/except.h
378 %{_includedir}/wx-%{ver2}/wx/features.h
379 %{_includedir}/wx-%{ver2}/wx/ffile.h
380 %{_includedir}/wx-%{ver2}/wx/file.h
381 %{_includedir}/wx-%{ver2}/wx/fileconf.h
382 %{_includedir}/wx-%{ver2}/wx/filefn.h
383 %{_includedir}/wx-%{ver2}/wx/filename.h
384 %{_includedir}/wx-%{ver2}/wx/filesys.h
385 %{_includedir}/wx-%{ver2}/wx/fontenc.h
386 %{_includedir}/wx-%{ver2}/wx/fontmap.h
387 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
388 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
389 %{_includedir}/wx-%{ver2}/wx/hash.h
390 %{_includedir}/wx-%{ver2}/wx/hashmap.h
391 %{_includedir}/wx-%{ver2}/wx/hashset.h
392 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
393 %{_includedir}/wx-%{ver2}/wx/iconloc.h
394 %{_includedir}/wx-%{ver2}/wx/init.h
395 %{_includedir}/wx-%{ver2}/wx/intl.h
396 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
397 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
398 %{_includedir}/wx-%{ver2}/wx/ipc.h
399 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
400 %{_includedir}/wx-%{ver2}/wx/isql.h
401 %{_includedir}/wx-%{ver2}/wx/isqlext.h
402 %{_includedir}/wx-%{ver2}/wx/link.h
403 %{_includedir}/wx-%{ver2}/wx/list.h
404 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
405 %{_includedir}/wx-%{ver2}/wx/log.h
406 %{_includedir}/wx-%{ver2}/wx/longlong.h
407 %{_includedir}/wx-%{ver2}/wx/math.h
408 %{_includedir}/wx-%{ver2}/wx/memconf.h
409 %{_includedir}/wx-%{ver2}/wx/memory.h
410 %{_includedir}/wx-%{ver2}/wx/memtext.h
411 %{_includedir}/wx-%{ver2}/wx/mimetype.h
412 %{_includedir}/wx-%{ver2}/wx/module.h
413 %{_includedir}/wx-%{ver2}/wx/msgout.h
414 %{_includedir}/wx-%{ver2}/wx/mstream.h
415 %{_includedir}/wx-%{ver2}/wx/object.h
416 %{_includedir}/wx-%{ver2}/wx/platform.h
417 %{_includedir}/wx-%{ver2}/wx/power.h
418 %{_includedir}/wx-%{ver2}/wx/process.h
419 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
420 %{_includedir}/wx-%{ver2}/wx/recguard.h
421 %{_includedir}/wx-%{ver2}/wx/regex.h
422 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
423 %{_includedir}/wx-%{ver2}/wx/snglinst.h
424 %{_includedir}/wx-%{ver2}/wx/sstream.h
425 %{_includedir}/wx-%{ver2}/wx/stack.h
426 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
427 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
428 %{_includedir}/wx-%{ver2}/wx/stockitem.h
429 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
430 %{_includedir}/wx-%{ver2}/wx/strconv.h
431 %{_includedir}/wx-%{ver2}/wx/stream.h
432 %{_includedir}/wx-%{ver2}/wx/string.h
433 %{_includedir}/wx-%{ver2}/wx/sysopt.h
434 %{_includedir}/wx-%{ver2}/wx/textbuf.h
435 %{_includedir}/wx-%{ver2}/wx/textfile.h
436 %{_includedir}/wx-%{ver2}/wx/thread.h
437 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
438 %{_includedir}/wx-%{ver2}/wx/timer.h
439 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
440 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
441 %{_includedir}/wx-%{ver2}/wx/types.h
442 %{_includedir}/wx-%{ver2}/wx/uri.h
443 %{_includedir}/wx-%{ver2}/wx/utils.h
444 %{_includedir}/wx-%{ver2}/wx/variant.h
445 %{_includedir}/wx-%{ver2}/wx/vector.h
446 %{_includedir}/wx-%{ver2}/wx/version.h
447 %{_includedir}/wx-%{ver2}/wx/volume.h
448 %{_includedir}/wx-%{ver2}/wx/wfstream.h
449 %{_includedir}/wx-%{ver2}/wx/wx.h
450 %{_includedir}/wx-%{ver2}/wx/wxchar.h
451 %{_includedir}/wx-%{ver2}/wx/wxprec.h
452 %{_includedir}/wx-%{ver2}/wx/xti.h
453 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
454 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
455 %{_includedir}/wx-%{ver2}/wx/zstream.h
456 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
457 %{_includedir}/wx-%{ver2}/wx/gsocket.h
458 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
459 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
460 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
461 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
462 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
463 %{_includedir}/wx-%{ver2}/wx/sckipc.h
464 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
465 %{_includedir}/wx-%{ver2}/wx/socket.h
466 %{_includedir}/wx-%{ver2}/wx/url.h
467 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
468 %{_includedir}/wx-%{ver2}/wx/xtixml.h
469 %{_includedir}/wx-%{ver2}/wx/db.h
470 %{_includedir}/wx-%{ver2}/wx/dbkeyg.h
471 %{_includedir}/wx-%{ver2}/wx/dbtable.h
472 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
473 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
474 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
475 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
476 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
477 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
478 %{_includedir}/wx-%{ver2}/wx/unix/private.h
479 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
480 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
481 EOF
482 # --- wxBase headers list ends here ---
483
484 # temporarily remove base headers
485 mkdir $RPM_BUILD_ROOT/_save_dir
486 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
487 for f in `cat wxbase-headers.files` ; do
488 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
489 done
490 # list of all core headers:
491 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
492 # move base headers (actually all headers) back again
493 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
494 rm -rf $RPM_BUILD_ROOT/_save_dir
495
496 # contrib stuff:
497 (cd obj-static/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
498 (cd obj-shared/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
499
500 # utils:
501 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
502
503 # wx-config link is created during package installation, remove it for now
504 rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
505
506 %clean
507 rm -rf $RPM_BUILD_ROOT
508
509 %post
510 /sbin/ldconfig
511
512 %postun
513 /sbin/ldconfig
514
515 %post devel
516 # link wx-config when you install RPM.
517 %if %{unicode}
518 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
519 %endif
520 # link wx-config with explicit name.
521 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
522 /sbin/ldconfig
523
524 %postun devel
525 /sbin/ldconfig
526
527 %preun devel
528 %if %{unicode}
529 rm -f %{_bindir}/wx-config
530 %endif
531 rm -f %{_bindir}/%{wxconfiglink}
532
533 %post -n %{wxbasename}
534 /sbin/ldconfig
535
536 %postun -n %{wxbasename}
537 /sbin/ldconfig
538
539 %post -n %{wxbasename}-devel
540 # link wx-config with explicit name.
541 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
542 /sbin/ldconfig
543
544 %postun -n %{wxbasename}-devel
545 /sbin/ldconfig
546
547 %preun -n %{wxbasename}-devel
548 rm -f %{_bindir}/%{wxbaseconfiglink}
549
550 %post gl
551 /sbin/ldconfig
552
553 %postun gl
554 /sbin/ldconfig
555
556 %post contrib
557 /sbin/ldconfig
558
559 %postun contrib
560 /sbin/ldconfig
561
562 %post contrib-devel
563 /sbin/ldconfig
564
565 %postun contrib-devel
566 /sbin/ldconfig
567
568 %files
569 %defattr(-,root,root)
570 %doc COPYING.LIB *.txt
571 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
572 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
573 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
574 %if !%{unicode}
575 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
576 %endif
577 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
578 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
579 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
580 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
581 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
582
583 %files -n wx-i18n
584 %defattr(-,root,root)
585 %{_datadir}/locale/*/LC_MESSAGES/*.mo
586
587 %files devel -f core-headers.files
588 %defattr(-,root,root)
589 # shared libs
590 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
591 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
592 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
593 %if !%{unicode}
594 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
595 %endif
596 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
597 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
598 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
599 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
600 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
601 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
602 # static libs
603 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
604 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
605 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
606 %if !%{unicode}
607 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
608 %endif
609 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
610 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
611 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
612 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
613 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
614 %dir %{_libdir}/wx
615 %{_libdir}/wx/config/%{wxconfig}
616 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
617 %{_libdir}/wx/config/%{wxconfigstatic}
618 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
619 %{_bindir}/wxrc*
620
621 %files -n %{wxbasename}
622 %defattr(-,root,root)
623 %{_libdir}/libwx_base*-%{ver2}.so.*
624
625 %files -n %{wxbasename}-devel -f wxbase-headers.paths
626 %defattr (-,root,root)
627 %dir %{_includedir}/wx-%{ver2}
628 %{_libdir}/libwx_base*-%{ver2}.so
629 %{_libdir}/libwx_base*-%{ver2}.a
630 %if %{unicode}
631 %{_libdir}/libwxregexu-%{ver2}.a
632 %endif
633 %dir %{_libdir}/wx
634 %{_datadir}/aclocal/*.m4
635 %{_datadir}/bakefile/presets/*
636
637 %files gl
638 %defattr(-,root,root)
639 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
640
641 %files contrib
642 %defattr(-,root,root)
643 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
644 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
645 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
646 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
647 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
648 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
649 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
650 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
651 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
652 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
653
654 # static libs
655 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
656 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
657 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
658 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
659 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
660 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
661 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
662 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
663 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
664 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
665
666 %files contrib-devel
667 %defattr(-,root,root)
668 %dir %{_includedir}/wx-%{ver2}/wx/animate
669 %{_includedir}/wx-%{ver2}/wx/animate/*
670 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
671
672 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
673 %{_includedir}/wx-%{ver2}/wx/deprecated/*
674 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
675
676 %dir %{_includedir}/wx-%{ver2}/wx/fl
677 %{_includedir}/wx-%{ver2}/wx/fl/*
678 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
679
680 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
681 %{_includedir}/wx-%{ver2}/wx/gizmos/*
682 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
683 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
684
685 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
686 %{_includedir}/wx-%{ver2}/wx/mmedia/*
687 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
688
689 %dir %{_includedir}/wx-%{ver2}/wx/ogl
690 %{_includedir}/wx-%{ver2}/wx/ogl/*
691 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
692
693 %dir %{_includedir}/wx-%{ver2}/wx/plot
694 %{_includedir}/wx-%{ver2}/wx/plot/*
695 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
696
697 %dir %{_includedir}/wx-%{ver2}/wx/stc
698 %{_includedir}/wx-%{ver2}/wx/stc/*
699 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
700
701 %dir %{_includedir}/wx-%{ver2}/wx/svg
702 %{_includedir}/wx-%{ver2}/wx/svg/*
703 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so