added wxPowerEvent; moved power functions stubs to common/powercmn.cpp
[wxWidgets.git] / wxX11.spec
1 %define pref /usr
2 %define ver 2.6.2
3 %define ver2 2.6
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define portname x11univ
12
13 %if %{unicode}
14 %define wxbasename wx-base-unicode
15 %define name wx-%{portname}-unicode
16 %define wxconfig %{portname}-unicode-release-%{ver2}
17 %define wxconfiglink wx%{portname}u-%{ver2}-config
18 %else
19 %define wxbasename wx-base
20 %define name wx-%{portname}
21 %define wxconfig %{portname}-ansi-release-%{ver2}
22 %define wxconfiglink wx%{portname}-%{ver2}-config
23 %endif
24
25 Summary: The X11 port of the wxWidgets library
26 Name: %{name}
27 Version: %{ver}
28 Release: %{rel}
29 License: wxWindows Licence
30 Group: X11/Libraries
31 Source: wxX11-%{ver}.tar.bz2
32 URL: http://www.wxwidgets.org
33 Packager: Vadim Zeitlin <vadim@wxwindows.org>
34 Prefix: %{pref}
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
37
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
41 Provides: wxwin
42 Provides: wxX11
43
44 %description
45 wxWidgets is a free C++ library for cross-platform GUI development.
46 With wxWidgets, you can create applications for different GUIs (GTK+,
47 Motif/LessTif, MS Windows, Mac) from the same source code.
48
49 %package devel
50 Summary: The X11 port of the wxWidgets library
51 Group: X11/Libraries
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
54
55 %description devel
56 Header files for wxX11, the X11 port of the wxWidgets library.
57
58 %package gl
59 Summary: The X11 port of the wxWidgets library, OpenGL add-on.
60 Group: X11/Libraries
61 Requires: %{name} = %{ver}
62
63 %description gl
64 OpenGL add-on library for wxX11, the X11 port of the wxWidgets library.
65
66 %package static
67 Summary: wxX11 static libraries
68 Group: Development/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
71
72 %description static
73 Static libraries for wxX11. You need them if you want to link statically against wxX11.
74
75 %package contrib
76 Summary: Contrib libraries for wxX11.
77 Group: X11/Libraries
78 Requires: %{name} = %{ver}
79
80 %description contrib
81 Contributed libraries for wxX11.
82
83 %package contrib-devel
84 Summary: Contrib libraries for wxX11.
85 Group: X11/Libraries
86 Requires: %{name}-contrib = %{ver}
87 Requires: %{name}-devel = %{ver}
88
89 %description contrib-devel
90 Header files for contributed libraries for wxX11.
91
92 %prep
93 %setup -q -n wxX11-%{ver}
94
95 %build
96 if [ "$SMP" != "" ]; then
97 export MAKE="make -j$SMP"
98 else
99 export MAKE="make"
100 fi
101
102 mkdir obj-shared
103 cd obj-shared
104 ../configure --prefix=%{pref} --with-x11 \
105 %if %{unicode}
106 --enable-unicode \
107 %else
108 --with-odbc \
109 %endif
110 --with-opengl
111 $MAKE
112
113 cd contrib/src
114 $MAKE
115 cd ../../..
116
117 mkdir obj-static
118 cd obj-static
119 ../configure --prefix=%{pref} --with-x11 --disable-shared \
120 %if %{unicode}
121 --enable-unicode \
122 %else
123 --with-odbc \
124 %endif
125 --with-opengl
126 $MAKE
127 cd ..
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
132 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
133
134 # Remove headers that are part of wx-base-devel:
135
136 # --- wxBase headers list begins here ---
137 cat <<EOF >wxbase-headers.files
138 wx/afterstd.h
139 wx/app.h
140 wx/apptrait.h
141 wx/archive.h
142 wx/arrimpl.cpp
143 wx/arrstr.h
144 wx/beforestd.h
145 wx/buffer.h
146 wx/build.h
147 wx/chkconf.h
148 wx/clntdata.h
149 wx/cmdline.h
150 wx/confbase.h
151 wx/config.h
152 wx/convauto.h
153 wx/containr.h
154 wx/datetime.h
155 wx/datstrm.h
156 wx/dde.h
157 wx/debug.h
158 wx/defs.h
159 wx/dir.h
160 wx/dlimpexp.h
161 wx/dynarray.h
162 wx/dynlib.h
163 wx/dynload.h
164 wx/encconv.h
165 wx/event.h
166 wx/except.h
167 wx/features.h
168 wx/ffile.h
169 wx/file.h
170 wx/fileconf.h
171 wx/filefn.h
172 wx/filename.h
173 wx/filesys.h
174 wx/fontenc.h
175 wx/fontmap.h
176 wx/fs_mem.h
177 wx/fs_zip.h
178 wx/hash.h
179 wx/hashmap.h
180 wx/hashset.h
181 wx/html/forcelnk.h
182 wx/iconloc.h
183 wx/init.h
184 wx/intl.h
185 wx/iosfwrap.h
186 wx/ioswrap.h
187 wx/ipc.h
188 wx/ipcbase.h
189 wx/isql.h
190 wx/isqlext.h
191 wx/link.h
192 wx/list.h
193 wx/listimpl.cpp
194 wx/log.h
195 wx/longlong.h
196 wx/math.h
197 wx/memconf.h
198 wx/memory.h
199 wx/memtext.h
200 wx/mimetype.h
201 wx/module.h
202 wx/msgout.h
203 wx/mstream.h
204 wx/object.h
205 wx/platform.h
206 wx/power.h
207 wx/process.h
208 wx/ptr_scpd.h
209 wx/recguard.h
210 wx/regex.h
211 wx/scopeguard.h
212 wx/snglinst.h
213 wx/sstream.h
214 wx/stack.h
215 wx/stackwalk.h
216 wx/stdpaths.h
217 wx/stockitem.h
218 wx/stopwatch.h
219 wx/strconv.h
220 wx/stream.h
221 wx/string.h
222 wx/sysopt.h
223 wx/textbuf.h
224 wx/textfile.h
225 wx/thread.h
226 wx/thrimpl.cpp
227 wx/timer.h
228 wx/tokenzr.h
229 wx/txtstrm.h
230 wx/types.h
231 wx/uri.h
232 wx/utils.h
233 wx/variant.h
234 wx/vector.h
235 wx/version.h
236 wx/volume.h
237 wx/wfstream.h
238 wx/wx.h
239 wx/wxchar.h
240 wx/wxprec.h
241 wx/xti.h
242 wx/xtistrm.h
243 wx/zipstrm.h
244 wx/zstream.h
245 wx/unix/apptbase.h
246 wx/unix/apptrait.h
247 wx/unix/execute.h
248 wx/unix/mimetype.h
249 wx/unix/pipe.h
250 wx/unix/private.h
251 wx/unix/stackwalk.h
252 wx/unix/stdpaths.h
253 wx/fs_inet.h
254 wx/gsocket.h
255 wx/protocol/file.h
256 wx/protocol/ftp.h
257 wx/protocol/http.h
258 wx/protocol/protocol.h
259 wx/sckaddr.h
260 wx/sckipc.h
261 wx/sckstrm.h
262 wx/socket.h
263 wx/url.h
264 wx/unix/gsockunx.h
265 wx/xml/xml.h
266 wx/xtixml.h
267 wx/db.h
268 wx/dbkeyg.h
269 wx/dbtable.h
270 EOF
271 # --- wxBase headers list ends here ---
272 for f in `cat wxbase-headers-list` ; do
273 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
274 done
275
276 # list of all core headers:
277 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
278
279 # contrib stuff:
280 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
281 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
282
283 # remove wxBase files so that RPM doesn't complain about unpackaged files:
284 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
285 %if %{unicode}
286 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
287 %endif
288 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
289 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
290
291 %clean
292 rm -rf $RPM_BUILD_ROOT
293
294 %post
295 /sbin/ldconfig
296
297 %postun
298 /sbin/ldconfig
299
300 %post devel
301 # link wx-config when you install RPM.
302 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
303 # link wx-config with explicit name.
304 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
305 /sbin/ldconfig
306
307 %postun devel
308 /sbin/ldconfig
309
310 %preun devel
311 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
312 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
313 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
314 if test "x$SUM1" = "x$SUM2" ; then
315 rm -f %{_bindir}/wx-config
316 fi
317 fi
318 rm -f %{_bindir}/%{wxconfiglink}
319
320 %post gl
321 /sbin/ldconfig
322
323 %postun gl
324 /sbin/ldconfig
325
326 %post contrib
327 /sbin/ldconfig
328
329 %postun contrib
330 /sbin/ldconfig
331
332 %post contrib-devel
333 /sbin/ldconfig
334
335 %postun contrib-devel
336 /sbin/ldconfig
337
338 %files
339 %defattr(-,root,root)
340 %doc COPYING.LIB *.txt
341 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
342 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
343 %if !%{unicode}
344 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
345 %endif
346 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
347 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
348 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
349 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
350
351
352 %files devel -f core-headers.files
353 %defattr(-,root,root)
354 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
355 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
356 %if !%{unicode}
357 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
358 %endif
359 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
360 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
361 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
362 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
363 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
364 %dir %{_libdir}/wx
365 %{_libdir}/wx/*
366 %{_bindir}/wxrc*
367
368 %files gl
369 %defattr(-,root,root)
370 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
371
372 %files static
373 %defattr (-,root,root)
374 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
375
376 %files contrib
377 %defattr(-,root,root)
378 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
379 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
380 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
381 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
382 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
383 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
384 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
385 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
386 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
387
388 %files contrib-devel
389 %defattr(-,root,root)
390 %dir %{_includedir}/wx-%{ver2}/wx/animate
391 %{_includedir}/wx-%{ver2}/wx/animate/*
392 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
393
394 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
395 %{_includedir}/wx-%{ver2}/wx/deprecated/*
396 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
397
398 %dir %{_includedir}/wx-%{ver2}/wx/fl
399 %{_includedir}/wx-%{ver2}/wx/fl/*
400 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
401
402 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
403 %{_includedir}/wx-%{ver2}/wx/gizmos/*
404 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
405
406 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
407 %{_includedir}/wx-%{ver2}/wx/mmedia/*
408 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
409
410 %dir %{_includedir}/wx-%{ver2}/wx/ogl
411 %{_includedir}/wx-%{ver2}/wx/ogl/*
412 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
413
414 %dir %{_includedir}/wx-%{ver2}/wx/plot
415 %{_includedir}/wx-%{ver2}/wx/plot/*
416 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
417
418 %dir %{_includedir}/wx-%{ver2}/wx/stc
419 %{_includedir}/wx-%{ver2}/wx/stc/*
420 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
421
422 %dir %{_includedir}/wx-%{ver2}/wx/svg
423 %{_includedir}/wx-%{ver2}/wx/svg/*
424 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so