Add wx/meta/removeref.h header defining wxRemoveRef<> helper.
[wxWidgets.git] / wxX11.spec
1 %define pref /usr
2 %define ver 2.9.5
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define portname x11univ
12
13 %if %{unicode}
14 %define wxbasename wx-base-unicode
15 %define name wx-%{portname}-unicode
16 %define wxconfig %{portname}-unicode-%{ver2}
17 %define wxconfiglink wx%{portname}u-%{ver2}-config
18 %else
19 %define wxbasename wx-base
20 %define name wx-%{portname}
21 %define wxconfig %{portname}-ansi-%{ver2}
22 %define wxconfiglink wx%{portname}-%{ver2}-config
23 %endif
24
25 Summary: The X11 port of the wxWidgets library
26 Name: %{name}
27 Version: %{ver}
28 Release: %{rel}
29 License: wxWindows Licence
30 Group: X11/Libraries
31 Source: wxX11-%{ver}.tar.bz2
32 URL: http://www.wxwidgets.org
33 Packager: Vadim Zeitlin <vadim@wxwindows.org>
34 Prefix: %{pref}
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
37
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
41 Provides: wxwin
42 Provides: wxX11
43
44 %description
45 wxWidgets is a free C++ library for cross-platform GUI development.
46 With wxWidgets, you can create applications for different GUIs (GTK+,
47 Motif/LessTif, MS Windows, Mac) from the same source code.
48
49 %package devel
50 Summary: The X11 port of the wxWidgets library
51 Group: X11/Libraries
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
54
55 %description devel
56 Header files for wxX11, the X11 port of the wxWidgets library.
57
58 %package gl
59 Summary: The X11 port of the wxWidgets library, OpenGL add-on.
60 Group: X11/Libraries
61 Requires: %{name} = %{ver}
62
63 %description gl
64 OpenGL add-on library for wxX11, the X11 port of the wxWidgets library.
65
66 %package static
67 Summary: wxX11 static libraries
68 Group: Development/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
71
72 %description static
73 Static libraries for wxX11. You need them if you want to link statically against wxX11.
74
75 %prep
76 %setup -q -n wxX11-%{ver}
77
78 %build
79 if [ "$SMP" != "" ]; then
80 export MAKE="make -j$SMP"
81 else
82 export MAKE="make"
83 fi
84
85 mkdir obj-shared
86 cd obj-shared
87 ../configure --prefix=%{pref} --with-x11 \
88 %if %{unicode}
89 --enable-unicode \
90 %else
91 --disable-unicode \
92 %endif
93 $MAKE
94 cd ..
95
96 mkdir obj-static
97 cd obj-static
98 ../configure --prefix=%{pref} --with-x11 --disable-shared \
99 %if %{unicode}
100 --enable-unicode \
101 %else
102 --disable-unicode \
103 %endif
104 --with-opengl
105 $MAKE
106 cd ..
107
108 %install
109 rm -rf $RPM_BUILD_ROOT
110 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
111 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
112
113 # Remove headers that are part of wx-base-devel:
114
115 # --- wxBase headers list begins here ---
116 cat <<EOF >wxbase-headers.files
117 wx/afterstd.h
118 wx/any.h
119 wx/anystr.h
120 wx/app.h
121 wx/apptrait.h
122 wx/archive.h
123 wx/arrimpl.cpp
124 wx/arrstr.h
125 wx/atomic.h
126 wx/base64.h
127 wx/beforestd.h
128 wx/buffer.h
129 wx/build.h
130 wx/chartype.h
131 wx/checkeddelete.h
132 wx/chkconf.h
133 wx/clntdata.h
134 wx/cmdargs.h
135 wx/cmdline.h
136 wx/confbase.h
137 wx/config.h
138 wx/convauto.h
139 wx/containr.h
140 wx/cpp.h
141 wx/crt.h
142 wx/datetime.h
143 wx/datstrm.h
144 wx/dde.h
145 wx/debug.h
146 wx/defs.h
147 wx/dir.h
148 wx/dlimpexp.h
149 wx/dlist.h
150 wx/dynarray.h
151 wx/dynlib.h
152 wx/dynload.h
153 wx/encconv.h
154 wx/event.h
155 wx/eventfilter.h
156 wx/evtloop.h
157 wx/except.h
158 wx/features.h
159 wx/flags.h
160 wx/ffile.h
161 wx/file.h
162 wx/fileconf.h
163 wx/filefn.h
164 wx/filename.h
165 wx/filesys.h
166 wx/fontenc.h
167 wx/fontmap.h
168 wx/fs_arc.h
169 wx/fs_filter.h
170 wx/fs_mem.h
171 wx/fs_zip.h
172 wx/hash.h
173 wx/hashmap.h
174 wx/hashset.h
175 wx/html/forcelnk.h
176 wx/iconloc.h
177 wx/init.h
178 wx/intl.h
179 wx/iosfwrap.h
180 wx/ioswrap.h
181 wx/ipc.h
182 wx/ipcbase.h
183 wx/kbdstate.h
184 wx/language.h
185 wx/link.h
186 wx/list.h
187 wx/listimpl.cpp
188 wx/log.h
189 wx/longlong.h
190 wx/math.h
191 wx/memconf.h
192 wx/memory.h
193 wx/memtext.h
194 wx/mimetype.h
195 wx/module.h
196 wx/mousestate.h
197 wx/msgout.h
198 wx/msgqueue.h
199 wx/mstream.h
200 wx/numformatter.h
201 wx/object.h
202 wx/platform.h
203 wx/platinfo.h
204 wx/power.h
205 wx/process.h
206 wx/ptr_scpd.h
207 wx/ptr_shrd.h
208 wx/recguard.h
209 wx/regex.h
210 wx/rtti.h
211 wx/scopedarray.h
212 wx/scopedptr.h
213 wx/scopeguard.h
214 wx/sharedptr.h
215 wx/snglinst.h
216 wx/sstream.h
217 wx/stack.h
218 wx/stackwalk.h
219 wx/stdpaths.h
220 wx/stdstream.h
221 wx/stockitem.h
222 wx/stopwatch.h
223 wx/strconv.h
224 wx/stream.h
225 wx/string.h
226 wx/stringimpl.h
227 wx/stringops.h
228 wx/strvararg.h
229 wx/sysopt.h
230 wx/tarstrm.h
231 wx/textbuf.h
232 wx/textfile.h
233 wx/thread.h
234 wx/thrimpl.cpp
235 wx/time.h
236 wx/timer.h
237 wx/tls.h
238 wx/tokenzr.h
239 wx/tracker.h
240 wx/translation.h
241 wx/txtstrm.h
242 wx/typeinfo.h
243 wx/types.h
244 wx/unichar.h
245 wx/uri.h
246 wx/ustring.h
247 wx/utils.h
248 wx/variant.h
249 wx/vector.h
250 wx/version.h
251 wx/versioninfo.h
252 wx/volume.h
253 wx/weakref.h
254 wx/wfstream.h
255 wx/wx.h
256 wx/wxchar.h
257 wx/wxcrt.h
258 wx/wxcrtbase.h
259 wx/wxcrtvararg.h
260 wx/wxprec.h
261 wx/xlocale.h
262 wx/xti.h
263 wx/xti2.h
264 wx/xtistrm.h
265 wx/xtictor.h
266 wx/xtihandler.h
267 wx/xtiprop.h
268 wx/xtitypes.h
269 wx/zipstrm.h
270 wx/zstream.h
271 wx/meta/convertible.h
272 wx/meta/if.h
273 wx/meta/implicitconversion.h
274 wx/meta/int2type.h
275 wx/meta/movable.h
276 wx/meta/pod.h
277 wx/meta/removeref.h
278 wx/fswatcher.h
279 wx/generic/fswatcher.h
280 wx/unix/app.h
281 wx/unix/apptbase.h
282 wx/unix/apptrait.h
283 wx/unix/chkconf.h
284 wx/unix/evtloop.h
285 wx/unix/evtloopsrc.h
286 wx/unix/pipe.h
287 wx/unix/stdpaths.h
288 wx/unix/stackwalk.h
289 wx/unix/tls.h
290 wx/unix/fswatcher_kqueue.h
291 wx/unix/execute.h
292 wx/unix/mimetype.h
293 wx/unix/fswatcher_inotify.h
294 wx/fs_inet.h
295 wx/protocol/file.h
296 wx/protocol/ftp.h
297 wx/protocol/http.h
298 wx/protocol/log.h
299 wx/protocol/protocol.h
300 wx/sckaddr.h
301 wx/sckipc.h
302 wx/sckstrm.h
303 wx/socket.h
304 wx/url.h
305 wx/xml/xml.h
306 wx/xtixml.h
307 EOF
308 # --- wxBase headers list ends here ---
309 for f in `cat wxbase-headers-list` ; do
310 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
311 done
312
313 # list of all core headers:
314 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
315
316 # remove wxBase files so that RPM doesn't complain about unpackaged files:
317 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
318 %if %{unicode}
319 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
320 %endif
321 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
322 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
323
324 %clean
325 rm -rf $RPM_BUILD_ROOT
326
327 %post
328 /sbin/ldconfig
329
330 %postun
331 /sbin/ldconfig
332
333 %post devel
334 # link wx-config when you install RPM.
335 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
336 # link wx-config with explicit name.
337 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
338 /sbin/ldconfig
339
340 %postun devel
341 /sbin/ldconfig
342
343 %preun devel
344 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
345 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
346 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
347 if test "x$SUM1" = "x$SUM2" ; then
348 rm -f %{_bindir}/wx-config
349 fi
350 fi
351 rm -f %{_bindir}/%{wxconfiglink}
352
353 %post gl
354 /sbin/ldconfig
355
356 %postun gl
357 /sbin/ldconfig
358
359 %files
360 %defattr(-,root,root)
361 %doc COPYING.LIB *.txt
362 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
363 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
364 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
365 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
366 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
367 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
368
369
370 %files devel -f core-headers.files
371 %defattr(-,root,root)
372 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
373 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
374 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
375 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
376 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
377 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
378 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
379 %dir %{_libdir}/wx
380 %{_libdir}/wx/*
381 %{_bindir}/wxrc*
382
383 %files gl
384 %defattr(-,root,root)
385 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
386
387 %files static
388 %defattr (-,root,root)
389 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
390