fixes for wxBase RPM
[wxWidgets.git] / wxBase.spec
1 %define pref /usr
2 %define ver 2.3.2
3 %define ver2 2.3
4 %define rel 1
5
6 Summary: wxBase library - non-GUI support classes of wxWindows toolkit
7 Name: wxBase
8 Version: %{ver}
9 Release: %{rel}
10 Copyright: wxWindows Licence
11 Group: Development/Libraries
12 Source: wxBase-%{ver}.tar.bz2
13 URL: http://www.wxwindows.org
14 Packager: Vadim Zeitlin <vadim@wxwindows.org>
15 Prefix: %{pref}
16 BuildRoot: /var/tmp/%{name}-root
17
18 %description
19 wxBase is a collection of C++ classes providing basic data structures (strings,
20 lists, arrays), powerful wxDateTime class for date manipulations, portable
21 wrappers around many OS-specific functions allowing to build the same program
22 under all supported folders, wxThread class for writing multithreaded programs
23 using either Win32 or POSIX threads and much more. wxBase currently supports
24 the following platforms: Win32, generic Unix (Linux, FreeBSD, Solaris, HP-UX,
25 ...) and BeOS.
26
27 %package devel
28 Summary: wxBase headers needed for developping with wxBase
29 Group: Development/Libraries
30 Requires: wxBase
31
32 %description devel
33 Header files for wxBase. You need them to develop programs using wxBase.
34
35 %prep
36 %setup -n wxBase-%{ver}
37 ./configure --prefix=%{pref} --enable-soname --disable-gui --disable-std_iostreams
38
39 %build
40 if [ "$SMP" != "" ]; then
41 export MAKE="make -j$SMP"
42 else
43 export MAKE="make"
44 fi
45 $MAKE
46 (cd locale; make allmo)
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50 make prefix=$RPM_BUILD_ROOT%{pref} install
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 /sbin/ldconfig
57
58 %postun
59 /sbin/ldconfig
60
61 %post devel
62 # Install wx-config if there isn't any
63 if test ! -f %{_bindir}/wx-config ; then
64 ln -sf wxbase-%{ver2}-config %{_bindir}/wx-config
65 fi
66
67 %preun devel
68 # Remove wx-config if it points to this package
69 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
70 SUM1=`md5sum %{_bindir}/wxbase-%{ver2}-config | cut -c 0-32`
71 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
72 if test "x$SUM1" = "x$SUM2" ; then
73 rm -f %{_bindir}/wx-config
74 fi
75 fi
76
77 %files
78 %defattr (-,root,root)
79 %doc COPYING.LIB *.txt
80 %{_libdir}/libwx_base*so.*
81 %{_datadir}/locale/*/*/*.mo
82
83 %files devel
84 %defattr (-,root,root)
85 %dir %{_includedir}/wx
86 %{_includedir}/wx/*
87 %{_libdir}/libwx_base*.so
88 %dir %{_libdir}/wx
89 %{_libdir}/wx/*
90 %{_bindir}/wxbase-%{ver2}-config
91