wx/tls.h belongs to base headers, not core (#10148)
[wxWidgets.git] / wxMotif.spec
1 %define pref /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 %define portname motif
7 %define name wx-%{portname}
8 %define wxbasename wx-base
9
10 %define wxconfig %{portname}-ansi-release-%{ver2}
11 %define wxconfiglink wx%{portname}-%{ver2}-config
12
13 Summary: The Motif/Lesstif port of the wxWidgets library
14 Name: %{name}
15 Version: %{ver}
16 Release: %{rel}
17 License: wxWindows Licence
18 Group: X11/Libraries
19 Source: wxMotif-%{ver}.tar.bz2
20 URL: http://www.wxwidgets.org
21 Packager: wxWidgets developers <wx-dev@lists.wxwidgets.org>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
24
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
28 Provides: wxwin
29 Provides: wxMotif
30
31 %description
32 wxWidgets is a free C++ library for cross-platform GUI development.
33 With wxWidgets, you can create applications for different GUIs (GTK+,
34 Motif/LessTif, MS Windows, Mac) from the same source code.
35
36 %package devel
37 Summary: The Motif/Lesstif port of the wxWidgets library
38 Group: X11/Libraries
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
41
42 %description devel
43 Header files for wxMotif, the Motif/Lesstif port of the wxWidgets library.
44
45 %package gl
46 Summary: The Motif/Lesstif port of the wxWidgets library, OpenGL add-on.
47 Group: X11/Libraries
48 Requires: %{name} = %{ver}
49
50 %description gl
51 OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWidgets library.
52
53 %package static
54 Summary: wxMotif static libraries
55 Group: Development/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
58
59 %description static
60 Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
61
62 %package contrib
63 Summary: Contrib libraries for wxMotif
64 Group: X11/Libraries
65 Requires: %{name} = %{ver}
66
67 %description contrib
68 Contrib libraries for wxMotif
69
70 %package contrib-devel
71 Summary: Contrib libraries for wxMotif
72 Group: X11/Libraries
73 Requires: %{name}-contrib = %{ver}
74 Requires: %{name}-devel = %{ver}
75
76 %description contrib-devel
77 Header files for contributed libraries for wxMotif.
78
79 %prep
80 %setup -q -n wxMotif-%{ver}
81
82 %build
83 if [ "$SMP" != "" ]; then
84 export MAKE="make -j$SMP"
85 else
86 export MAKE="make"
87 fi
88
89 mkdir obj-shared
90 cd obj-shared
91 ../configure --prefix=%{pref} --with-motif --with-opengl
92 $MAKE
93
94 cd contrib/src
95 $MAKE
96 cd ../../..
97
98 mkdir obj-static
99 cd obj-static
100 ../configure --prefix=%{pref} --with-motif --disable-shared --with-opengl
101 $MAKE
102 cd ..
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
107 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
108
109 # Remove headers that are part of wx-base-devel:
110
111 # --- wxBase headers list begins here ---
112 cat <<EOF >wxbase-headers.files
113 wx/afterstd.h
114 wx/app.h
115 wx/apptrait.h
116 wx/archive.h
117 wx/arrimpl.cpp
118 wx/arrstr.h
119 wx/atomic.h
120 wx/base64.h
121 wx/beforestd.h
122 wx/buffer.h
123 wx/build.h
124 wx/chartype.h
125 wx/chkconf.h
126 wx/clntdata.h
127 wx/cmdargs.h
128 wx/cmdline.h
129 wx/confbase.h
130 wx/config.h
131 wx/convauto.h
132 wx/containr.h
133 wx/cpp.h
134 wx/crt.h
135 wx/datetime.h
136 wx/datstrm.h
137 wx/dde.h
138 wx/debug.h
139 wx/defs.h
140 wx/dir.h
141 wx/dlimpexp.h
142 wx/dlist.h
143 wx/dynarray.h
144 wx/dynlib.h
145 wx/dynload.h
146 wx/encconv.h
147 wx/event.h
148 wx/except.h
149 wx/features.h
150 wx/flags.h
151 wx/ffile.h
152 wx/file.h
153 wx/fileconf.h
154 wx/filefn.h
155 wx/filename.h
156 wx/filesys.h
157 wx/fontenc.h
158 wx/fontmap.h
159 wx/fs_arc.h
160 wx/fs_filter.h
161 wx/fs_mem.h
162 wx/fs_zip.h
163 wx/hash.h
164 wx/hashmap.h
165 wx/hashset.h
166 wx/html/forcelnk.h
167 wx/iconloc.h
168 wx/init.h
169 wx/intl.h
170 wx/iosfwrap.h
171 wx/ioswrap.h
172 wx/ipc.h
173 wx/ipcbase.h
174 wx/kbdstate.h
175 wx/link.h
176 wx/list.h
177 wx/listimpl.cpp
178 wx/log.h
179 wx/longlong.h
180 wx/math.h
181 wx/memconf.h
182 wx/memory.h
183 wx/memtext.h
184 wx/mimetype.h
185 wx/module.h
186 wx/mousestate.h
187 wx/msgout.h
188 wx/mstream.h
189 wx/object.h
190 wx/platform.h
191 wx/platinfo.h
192 wx/power.h
193 wx/process.h
194 wx/ptr_scpd.h
195 wx/ptr_shrd.h
196 wx/recguard.h
197 wx/regex.h
198 wx/scopeguard.h
199 wx/snglinst.h
200 wx/sstream.h
201 wx/stack.h
202 wx/stackwalk.h
203 wx/stdpaths.h
204 wx/stockitem.h
205 wx/stopwatch.h
206 wx/strconv.h
207 wx/stream.h
208 wx/string.h
209 wx/stringimpl.h
210 wx/stringops.h
211 wx/strvararg.h
212 wx/sysopt.h
213 wx/tarstrm.h
214 wx/textbuf.h
215 wx/textfile.h
216 wx/thread.h
217 wx/thrimpl.cpp
218 wx/timer.h
219 wx/tls.h
220 wx/tokenzr.h
221 wx/tracker.h
222 wx/txtstrm.h
223 wx/types.h
224 wx/unichar.h
225 wx/uri.h
226 wx/ustring.h
227 wx/utils.h
228 wx/variant.h
229 wx/vector.h
230 wx/version.h
231 wx/volume.h
232 wx/weakref.h
233 wx/wfstream.h
234 wx/wx.h
235 wx/wxchar.h
236 wx/wxcrt.h
237 wx/wxcrtbase.h
238 wx/wxcrtvararg.h
239 wx/wxprec.h
240 wx/xlocale.h
241 wx/xti.h
242 wx/xtistrm.h
243 wx/zipstrm.h
244 wx/zstream.h
245 wx/meta/convertible.h
246 wx/meta/if.h
247 wx/meta/int2type.h
248 wx/meta/movable.h
249 wx/private/fdiodispatcher.h
250 wx/private/selectdispatcher.h
251 wx/unix/app.h
252 wx/unix/apptbase.h
253 wx/unix/apptrait.h
254 wx/unix/chkconf.h
255 wx/unix/evtloop.h
256 wx/unix/pipe.h
257 wx/unix/stdpaths.h
258 wx/unix/stackwalk.h
259 wx/unix/tls.h
260 wx/unix/execute.h
261 wx/unix/mimetype.h
262 wx/unix/private.h
263 wx/private/gsocketiohandler.h
264 wx/fs_inet.h
265 wx/gsocket.h
266 wx/protocol/file.h
267 wx/protocol/ftp.h
268 wx/protocol/http.h
269 wx/protocol/protocol.h
270 wx/sckaddr.h
271 wx/sckipc.h
272 wx/sckstrm.h
273 wx/socket.h
274 wx/url.h
275 wx/unix/gsockunx.h
276 wx/xml/xml.h
277 wx/xtixml.h
278 EOF
279 # --- wxBase headers list ends here ---
280 for f in `cat wxbase-headers-list` ; do
281 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
282 done
283
284 # list of all core headers:
285 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
286
287 # contrib stuff:
288 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
289 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
290
291 # remove wxBase files so that RPM doesn't complain about unpackaged files:
292 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
293 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
294 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
295
296 %clean
297 rm -rf $RPM_BUILD_ROOT
298
299 %post
300 /sbin/ldconfig
301
302 %postun
303 /sbin/ldconfig
304
305 %post devel
306 # link wx-config when you install RPM.
307 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
308 # link wx-config with explicit name.
309 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
310 /sbin/ldconfig
311
312 %postun devel
313 /sbin/ldconfig
314
315 %preun devel
316 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
317 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
318 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
319 if test "x$SUM1" = "x$SUM2" ; then
320 rm -f %{_bindir}/wx-config
321 fi
322 fi
323 rm -f %{_bindir}/%{wxconfiglink}
324
325 %post gl
326 /sbin/ldconfig
327
328 %postun gl
329 /sbin/ldconfig
330
331 %post contrib
332 /sbin/ldconfig
333
334 %postun contrib
335 /sbin/ldconfig
336
337 %post contrib-devel
338 /sbin/ldconfig
339
340 %postun contrib-devel
341 /sbin/ldconfig
342
343 %files
344 %defattr(-,root,root)
345 %doc COPYING.LIB *.txt
346 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
347 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
348 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
349 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
350 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
351 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
352
353
354 %files devel -f core-headers.files
355 %defattr(-,root,root)
356 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
357 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
358 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
359 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
360 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
361 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
362 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
363 %dir %{_libdir}/wx
364 %{_libdir}/wx/*
365 %{_bindir}/wxrc*
366
367 %files gl
368 %defattr(-,root,root)
369 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
370
371 %files static
372 %defattr (-,root,root)
373 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
374
375 %files contrib
376 %defattr(-,root,root)
377 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
378 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
379 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
380 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
381 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
382 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
383 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
384 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
385 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
386
387 %files contrib-devel
388 %defattr(-,root,root)
389 %dir %{_includedir}/wx-%{ver2}/wx/animate
390 %{_includedir}/wx-%{ver2}/wx/animate/*
391 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
392
393 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
394 %{_includedir}/wx-%{ver2}/wx/deprecated/*
395 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
396
397 %dir %{_includedir}/wx-%{ver2}/wx/fl
398 %{_includedir}/wx-%{ver2}/wx/fl/*
399 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
400
401 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
402 %{_includedir}/wx-%{ver2}/wx/gizmos/*
403 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
404
405 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
406 %{_includedir}/wx-%{ver2}/wx/mmedia/*
407 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
408
409 %dir %{_includedir}/wx-%{ver2}/wx/ogl
410 %{_includedir}/wx-%{ver2}/wx/ogl/*
411 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
412
413 %dir %{_includedir}/wx-%{ver2}/wx/plot
414 %{_includedir}/wx-%{ver2}/wx/plot/*
415 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
416
417 %dir %{_includedir}/wx-%{ver2}/wx/stc
418 %{_includedir}/wx-%{ver2}/wx/stc/*
419 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
420
421 %dir %{_includedir}/wx-%{ver2}/wx/svg
422 %{_includedir}/wx-%{ver2}/wx/svg/*
423 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so