6 # Configurable settings (use --with(out) unicode on rpmbuild command line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
12 %define name wx
-base
-unicode
13 %define wxconfig base
-unicode
-release
-%{ver2}
14 %define wxconfiglink wxbaseu
-%{ver2}-config
17 %define wxconfig base
-ansi
-release
-%{ver2}
18 %define wxconfiglink wxbase
-%{ver2}-config
21 Summary: wxBase library
- non
-GUI support classes of wxWidgets toolkit
25 License: wxWindows Licence
26 Group: Development
/Libraries
27 Source: wxBase
-%{ver}.tar.bz2
28 URL: http
://www.wxwidgets.org
29 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
31 BuildRoot: %{_tmppath}/%{name}-root
35 wxBase is a collection of C
++ classes providing basic data structures
(strings
,
36 lists
, arrays
), powerful wxDateTime class
for date manipulations
, portable
37 wrappers around many OS
-specific functions allowing to build the same program
38 under all supported folders
, wxThread class
for writing multithreaded programs
39 using either Win32 or POSIX threads and much more. wxBase currently supports
40 the following platforms
: Win32
, generic Unix
(Linux
, FreeBSD
, Solaris
, HP
-UX
,
44 Summary: wxBase headers needed
for developping with wxBase
45 Group: Development
/Libraries
46 Requires: %{name} = %{ver}
47 Provides: wxBase
-devel
50 Header files
for wxBase. You need them to develop programs using wxBase.
53 Summary: wxBase static libraries
54 Group: Development
/Libraries
55 Requires: %{name}-devel = %{ver}
58 Static libraries
for wxBase. You need them
if you want to link statically against wxBase.
61 %setup -q
-n wxBase
-%{ver}
64 if [ "$SMP"
!= ""
]; then
65 export MAKE
="
make -j$SMP"
72 ..
/configure
--prefix
=%{pref} --disable
-gui \
83 ..
/configure
--prefix
=%{pref} --disable
-gui
--disable
-shared \
93 rm -rf $RPM_BUILD_ROOT
94 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
95 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
100 rm -rf $RPM_BUILD_ROOT
109 # link wx-config when you install RPM.
110 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx
-config
111 # link wx-config with explicit name.
112 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
119 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
120 SUM1
=`md5sum
%{_libdir}/wx/config/%{wxconfig} | cut
-c
0-32`
121 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
122 if test "x$SUM1"
= "x$SUM2"
; then
123 rm -f
%{_bindir}/wx
-config
126 rm -f
%{_bindir}/%{wxconfiglink}
129 %defattr (-,root
,root
)
130 %doc COPYING.LIB
*.txt
131 %{_libdir}/libwx_base*-%{ver2}.so.
*
134 %defattr (-,root
,root
)
135 %dir %{_includedir}/wx-%{ver2}
136 %{_includedir}/wx-%{ver2}/*
137 %{_libdir}/libwx_base*-%{ver2}.so
140 %{_datadir}/aclocal
/*.m4
143 %defattr (-,root
,root
)