fix for w/o expat
[wxWidgets.git] / wxGTK_RR.spec
1 %define _prefix /opt/gnome
2 %define ver 2.6.0
3 %define ver2 2.6
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfigstatic base-unicode-release-static-%{ver2}
46 %define wxbaseconfiglink wxbaseu-%{ver2}-config
47 %else
48 %define wxbasename wx-base-ansi
49 %define wxbaseconfig base-ansi-release-%{ver2}
50 %define wxbaseconfigstatic base-ansi-release-static-%{ver2}
51 %define wxbaseconfiglink wxbase-%{ver2}-config
52 %endif
53
54 Summary: The GTK+ %{gtkver} port of the wxWidgets library
55 Name: %{name}
56 Version: %{ver}
57 Release: %{rel}
58 License: wxWindows Licence
59 Group: X11/Libraries
60 Source: wxGTK-%{ver}.tar.gz
61 URL: http://www.wxwidgets.org
62 Packager: Vadim Zeitlin <vadim@wxwindows.org>
63 Prefix: %{_prefix}
64 BuildRoot: %{_tmppath}/%{name}-root
65 Requires: %{wxbasename} = %{ver}
66 %if %{portname} == gtk2
67 # BuildRequires: gtk+-2.0-devel
68 %else
69 # BuildRequires: gtk+-devel >= 1.2.0
70 %endif
71
72 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
73
74 # all packages providing an implementation of wxWidgets library (regardless of
75 # the toolkit used) should provide the (virtual) wxwin package, this makes it
76 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
77 Provides: wxwin
78 Provides: wxGTK
79
80 %description
81 wxWidgets is a free C++ library for cross-platform GUI development.
82 With wxWidgets, you can create applications for different GUIs (GTK+,
83 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
84
85 %package devel
86 Summary: The GTK+ %{gtkver} port of the wxWidgets library
87 Group: X11/Libraries
88 Requires: %{name} = %{ver}
89 Requires: %{wxbasename}-devel = %{ver}
90 Provides: wxGTK-devel
91
92 %description devel
93 The GTK+ %{gtkver} port of the wxWidgets library, header files.
94
95 %package gl
96 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
97 Group: X11/Libraries
98 Requires: %{name} = %{ver}
99 Provides: wxGTK-gl
100
101 %description gl
102 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
103
104 %package -n %{wxbasename}
105 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
106 Group: Development/Libraries
107 Provides: wxBase
108
109 %description -n %{wxbasename}
110 wxBase is a collection of C++ classes providing basic data structures (strings,
111 lists, arrays), portable wrappers around many OS-specific funstions (file
112 operations, time/date manipulations, threads, processes, sockets, shared
113 library loading) as well as other utility classes (streams, archive and
114 compression). wxBase currently supports Win32, most Unix variants (Linux,
115 FreeBSD, Solaris, HP-UX) and MacOS X 10.3.
116
117 %package -n %{wxbasename}-devel
118 Summary: wxBase library, header files.
119 Group: Development/Libraries
120 Provides: wxBase-devel
121
122 %description -n %{wxbasename}-devel
123 wxBase library - non-GUI support classes of the wxWidgets toolkit,
124 header files.
125
126 %package contrib
127 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
128 Group: X11/Libraries
129 Requires: %{name} = %{ver}
130
131 %description contrib
132 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
133
134 %package contrib-devel
135 Summary: The GTK+ %{gtkver} port of the wxWidgets library
136 Group: X11/Libraries
137 Requires: %{name}-contrib = %{ver}
138 Requires: %{name}-devel = %{ver}
139
140 %description contrib-devel
141 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
142
143 %prep
144 %setup -q -n wxGTK-%{ver}
145
146 %build
147 if [ "$SMP" != "" ]; then
148 export MAKE="make -j$SMP"
149 else
150 export MAKE="make"
151 fi
152
153 mkdir obj-shared-no-gui
154 cd obj-shared-no-gui
155 ../configure --prefix=%{_prefix} \
156 --disable-gui \
157 %if %{unicode}
158 --enable-unicode
159 %else
160 --disable-unicode
161 %endif
162 $MAKE
163 cd ..
164
165 mkdir obj-shared
166 cd obj-shared
167 ../configure --prefix=%{_prefix} \
168 %if ! %{gtk2}
169 --disable-gtk2 \
170 %else
171 --enable-gtk2 \
172 %endif
173 %if %{unicode}
174 --enable-unicode \
175 %else
176 --disable-unicode \
177 --with-odbc \
178 %endif
179 --with-opengl
180 $MAKE
181
182 cd contrib/src
183 $MAKE
184 cd ../../..
185
186 mkdir obj-static-no-gui
187 cd obj-static-no-gui
188 ../configure --prefix=%{_prefix} \
189 --disable-gui \
190 --disable-shared \
191 %if %{unicode}
192 --enable-unicode
193 %else
194 --disable-unicode
195 %endif
196 $MAKE
197 cd ..
198
199 mkdir obj-static
200 cd obj-static
201 ../configure --prefix=%{_prefix} \
202 %if ! %{gtk2}
203 --disable-gtk2 \
204 %else
205 --enable-gtk2 \
206 %endif
207 --disable-shared \
208 %if %{unicode}
209 --enable-unicode \
210 %else
211 --disable-unicode \
212 --with-odbc \
213 %endif
214 --with-opengl
215 $MAKE
216
217 cd contrib/src
218 $MAKE
219 cd ../../..
220
221 %install
222 rm -rf $RPM_BUILD_ROOT
223 (cd obj-static-no-gui; make DESTDIR=$RPM_BUILD_ROOT install)
224 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT install)
225 (cd obj-shared-no-gui; make DESTDIR=$RPM_BUILD_ROOT install)
226 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT install)
227
228 # --- wxBase headers list begins here ---
229 cat <<EOF >wxbase-headers.files
230 wx/afterstd.h
231 wx/app.h
232 wx/apptrait.h
233 wx/archive.h
234 wx/arrimpl.cpp
235 wx/arrstr.h
236 wx/beforestd.h
237 wx/buffer.h
238 wx/build.h
239 wx/chkconf.h
240 wx/clntdata.h
241 wx/cmdline.h
242 wx/confbase.h
243 wx/config.h
244 wx/containr.h
245 wx/datetime.h
246 wx/datetime.inl
247 wx/datstrm.h
248 wx/dde.h
249 wx/debug.h
250 wx/defs.h
251 wx/dir.h
252 wx/dlimpexp.h
253 wx/dynarray.h
254 wx/dynlib.h
255 wx/dynload.h
256 wx/encconv.h
257 wx/event.h
258 wx/except.h
259 wx/features.h
260 wx/ffile.h
261 wx/file.h
262 wx/fileconf.h
263 wx/filefn.h
264 wx/filename.h
265 wx/filesys.h
266 wx/fontenc.h
267 wx/fontmap.h
268 wx/fs_mem.h
269 wx/fs_zip.h
270 wx/hash.h
271 wx/hashmap.h
272 wx/hashset.h
273 wx/html/forcelnk.h
274 wx/iconloc.h
275 wx/init.h
276 wx/intl.h
277 wx/iosfwrap.h
278 wx/ioswrap.h
279 wx/ipc.h
280 wx/ipcbase.h
281 wx/isql.h
282 wx/isqlext.h
283 wx/list.h
284 wx/listimpl.cpp
285 wx/log.h
286 wx/longlong.h
287 wx/math.h
288 wx/memconf.h
289 wx/memory.h
290 wx/memtext.h
291 wx/mimetype.h
292 wx/module.h
293 wx/msgout.h
294 wx/mstream.h
295 wx/object.h
296 wx/platform.h
297 wx/process.h
298 wx/ptr_scpd.h
299 wx/regex.h
300 wx/scopeguard.h
301 wx/snglinst.h
302 wx/sstream.h
303 wx/stack.h
304 wx/stackwalk.h
305 wx/stdpaths.h
306 wx/stockitem.h
307 wx/stopwatch.h
308 wx/strconv.h
309 wx/stream.h
310 wx/string.h
311 wx/sysopt.h
312 wx/textbuf.h
313 wx/textfile.h
314 wx/thread.h
315 wx/thrimpl.cpp
316 wx/timer.h
317 wx/tokenzr.h
318 wx/txtstrm.h
319 wx/types.h
320 wx/uri.h
321 wx/utils.h
322 wx/variant.h
323 wx/vector.h
324 wx/version.h
325 wx/volume.h
326 wx/wfstream.h
327 wx/wx.h
328 wx/wxchar.h
329 wx/wxprec.h
330 wx/xti.h
331 wx/xtistrm.h
332 wx/zipstrm.h
333 wx/zstream.h
334 wx/fs_inet.h
335 wx/gsocket.h
336 wx/protocol/file.h
337 wx/protocol/ftp.h
338 wx/protocol/http.h
339 wx/protocol/protocol.h
340 wx/sckaddr.h
341 wx/sckipc.h
342 wx/sckstrm.h
343 wx/socket.h
344 wx/url.h
345 wx/xml/xml.h
346 wx/xtixml.h
347 wx/db.h
348 wx/dbkeyg.h
349 wx/dbtable.h
350 wx/unix/apptbase.h
351 wx/unix/apptrait.h
352 wx/unix/execute.h
353 wx/unix/gsockunx.h
354 wx/unix/mimetype.h
355 wx/unix/pipe.h
356 wx/unix/stackwalk.h
357 wx/unix/stdpaths.h
358 EOF
359 # --- wxBase headers list ends here ---
360 cat <<EOF >wxbase-headers.paths
361 %{_includedir}/wx-%{ver2}/wx/afterstd.h
362 %{_includedir}/wx-%{ver2}/wx/app.h
363 %{_includedir}/wx-%{ver2}/wx/apptrait.h
364 %{_includedir}/wx-%{ver2}/wx/archive.h
365 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
366 %{_includedir}/wx-%{ver2}/wx/arrstr.h
367 %{_includedir}/wx-%{ver2}/wx/beforestd.h
368 %{_includedir}/wx-%{ver2}/wx/buffer.h
369 %{_includedir}/wx-%{ver2}/wx/build.h
370 %{_includedir}/wx-%{ver2}/wx/chkconf.h
371 %{_includedir}/wx-%{ver2}/wx/clntdata.h
372 %{_includedir}/wx-%{ver2}/wx/cmdline.h
373 %{_includedir}/wx-%{ver2}/wx/confbase.h
374 %{_includedir}/wx-%{ver2}/wx/config.h
375 %{_includedir}/wx-%{ver2}/wx/containr.h
376 %{_includedir}/wx-%{ver2}/wx/datetime.h
377 %{_includedir}/wx-%{ver2}/wx/datetime.inl
378 %{_includedir}/wx-%{ver2}/wx/datstrm.h
379 %{_includedir}/wx-%{ver2}/wx/dde.h
380 %{_includedir}/wx-%{ver2}/wx/debug.h
381 %{_includedir}/wx-%{ver2}/wx/defs.h
382 %{_includedir}/wx-%{ver2}/wx/dir.h
383 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
384 %{_includedir}/wx-%{ver2}/wx/dynarray.h
385 %{_includedir}/wx-%{ver2}/wx/dynlib.h
386 %{_includedir}/wx-%{ver2}/wx/dynload.h
387 %{_includedir}/wx-%{ver2}/wx/encconv.h
388 %{_includedir}/wx-%{ver2}/wx/event.h
389 %{_includedir}/wx-%{ver2}/wx/except.h
390 %{_includedir}/wx-%{ver2}/wx/features.h
391 %{_includedir}/wx-%{ver2}/wx/ffile.h
392 %{_includedir}/wx-%{ver2}/wx/file.h
393 %{_includedir}/wx-%{ver2}/wx/fileconf.h
394 %{_includedir}/wx-%{ver2}/wx/filefn.h
395 %{_includedir}/wx-%{ver2}/wx/filename.h
396 %{_includedir}/wx-%{ver2}/wx/filesys.h
397 %{_includedir}/wx-%{ver2}/wx/fontenc.h
398 %{_includedir}/wx-%{ver2}/wx/fontmap.h
399 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
400 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
401 %{_includedir}/wx-%{ver2}/wx/hash.h
402 %{_includedir}/wx-%{ver2}/wx/hashmap.h
403 %{_includedir}/wx-%{ver2}/wx/hashset.h
404 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
405 %{_includedir}/wx-%{ver2}/wx/iconloc.h
406 %{_includedir}/wx-%{ver2}/wx/init.h
407 %{_includedir}/wx-%{ver2}/wx/intl.h
408 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
409 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
410 %{_includedir}/wx-%{ver2}/wx/ipc.h
411 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
412 %{_includedir}/wx-%{ver2}/wx/isql.h
413 %{_includedir}/wx-%{ver2}/wx/isqlext.h
414 %{_includedir}/wx-%{ver2}/wx/list.h
415 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
416 %{_includedir}/wx-%{ver2}/wx/log.h
417 %{_includedir}/wx-%{ver2}/wx/longlong.h
418 %{_includedir}/wx-%{ver2}/wx/math.h
419 %{_includedir}/wx-%{ver2}/wx/memconf.h
420 %{_includedir}/wx-%{ver2}/wx/memory.h
421 %{_includedir}/wx-%{ver2}/wx/memtext.h
422 %{_includedir}/wx-%{ver2}/wx/mimetype.h
423 %{_includedir}/wx-%{ver2}/wx/module.h
424 %{_includedir}/wx-%{ver2}/wx/msgout.h
425 %{_includedir}/wx-%{ver2}/wx/mstream.h
426 %{_includedir}/wx-%{ver2}/wx/object.h
427 %{_includedir}/wx-%{ver2}/wx/platform.h
428 %{_includedir}/wx-%{ver2}/wx/process.h
429 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
430 %{_includedir}/wx-%{ver2}/wx/regex.h
431 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
432 %{_includedir}/wx-%{ver2}/wx/snglinst.h
433 %{_includedir}/wx-%{ver2}/wx/sstream.h
434 %{_includedir}/wx-%{ver2}/wx/stack.h
435 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
436 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
437 %{_includedir}/wx-%{ver2}/wx/stockitem.h
438 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
439 %{_includedir}/wx-%{ver2}/wx/strconv.h
440 %{_includedir}/wx-%{ver2}/wx/stream.h
441 %{_includedir}/wx-%{ver2}/wx/string.h
442 %{_includedir}/wx-%{ver2}/wx/sysopt.h
443 %{_includedir}/wx-%{ver2}/wx/textbuf.h
444 %{_includedir}/wx-%{ver2}/wx/textfile.h
445 %{_includedir}/wx-%{ver2}/wx/thread.h
446 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
447 %{_includedir}/wx-%{ver2}/wx/timer.h
448 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
449 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
450 %{_includedir}/wx-%{ver2}/wx/types.h
451 %{_includedir}/wx-%{ver2}/wx/uri.h
452 %{_includedir}/wx-%{ver2}/wx/utils.h
453 %{_includedir}/wx-%{ver2}/wx/variant.h
454 %{_includedir}/wx-%{ver2}/wx/vector.h
455 %{_includedir}/wx-%{ver2}/wx/version.h
456 %{_includedir}/wx-%{ver2}/wx/volume.h
457 %{_includedir}/wx-%{ver2}/wx/wfstream.h
458 %{_includedir}/wx-%{ver2}/wx/wx.h
459 %{_includedir}/wx-%{ver2}/wx/wxchar.h
460 %{_includedir}/wx-%{ver2}/wx/wxprec.h
461 %{_includedir}/wx-%{ver2}/wx/xti.h
462 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
463 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
464 %{_includedir}/wx-%{ver2}/wx/zstream.h
465 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
466 %{_includedir}/wx-%{ver2}/wx/gsocket.h
467 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
468 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
469 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
470 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
471 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
472 %{_includedir}/wx-%{ver2}/wx/sckipc.h
473 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
474 %{_includedir}/wx-%{ver2}/wx/socket.h
475 %{_includedir}/wx-%{ver2}/wx/url.h
476 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
477 %{_includedir}/wx-%{ver2}/wx/xtixml.h
478 %{_includedir}/wx-%{ver2}/wx/db.h
479 %{_includedir}/wx-%{ver2}/wx/dbkeyg.h
480 %{_includedir}/wx-%{ver2}/wx/dbtable.h
481 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
482 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
483 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
484 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
485 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
486 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
487 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
488 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
489 EOF
490 # --- wxBase headers list ends here ---
491
492 # temporarily remove base headers
493 mkdir $RPM_BUILD_ROOT/_save_dir
494 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
495 for f in `cat wxbase-headers.files` ; do
496 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
497 done
498 # list of all core headers:
499 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
500 # move base headers (actually all headers) back again
501 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
502 rm -rf $RPM_BUILD_ROOT/_save_dir
503
504 # contrib stuff:
505 (cd obj-shared/contrib/src; make DESTDIR=$RPM_BUILD_ROOT install)
506 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT install)
507
508 %clean
509 rm -rf $RPM_BUILD_ROOT
510
511 %post
512 /sbin/ldconfig
513
514 %postun
515 /sbin/ldconfig
516
517 %post devel
518 # link wx-config when you install RPM.
519 %if %{unicode}
520 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
521 %endif
522 # link wx-config with explicit name.
523 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
524 /sbin/ldconfig
525
526 %postun devel
527 /sbin/ldconfig
528
529 %preun devel
530 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
531 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
532 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
533 if test "x$SUM1" = "x$SUM2" ; then
534 rm -f %{_bindir}/wx-config
535 fi
536 fi
537 rm -f %{_bindir}/%{wxconfiglink}
538
539 %post -n %{wxbasename}
540 /sbin/ldconfig
541
542 %postun -n %{wxbasename}
543 /sbin/ldconfig
544
545 %post -n %{wxbasename}-devel
546 # link wx-config with explicit name.
547 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
548 /sbin/ldconfig
549
550 %postun -n %{wxbasename}-devel
551 /sbin/ldconfig
552
553 %preun -n %{wxbasename}-devel
554 rm -f %{_bindir}/%{wxbaseconfiglink}
555
556 %post gl
557 /sbin/ldconfig
558
559 %postun gl
560 /sbin/ldconfig
561
562 %post contrib
563 /sbin/ldconfig
564
565 %postun contrib
566 /sbin/ldconfig
567
568 %post contrib-devel
569 /sbin/ldconfig
570
571 %postun contrib-devel
572 /sbin/ldconfig
573
574 %files
575 %defattr(-,root,root)
576 %doc COPYING.LIB *.txt
577 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
578 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
579 %if !%{unicode}
580 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
581 %endif
582 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
583 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so.*
584 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
585 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
586
587
588 %files devel -f core-headers.files
589 %defattr(-,root,root)
590 # shared libs
591 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
592 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
593 %if !%{unicode}
594 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
595 %endif
596 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
597 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
598 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so
599 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
600 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
601 # static libs
602 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
603 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
604 %if !%{unicode}
605 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
606 %endif
607 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
608 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
609 %{_libdir}/libwx_%{buildname}_media-%{ver2}.a
610 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
611 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
612 %dir %{_libdir}/wx
613 %{_libdir}/wx/config/%{wxconfig}
614 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
615 %{_libdir}/wx/config/%{wxconfigstatic}
616 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
617 %{_bindir}/wxrc*
618
619 %files -n %{wxbasename}
620 %defattr(-,root,root)
621 %{_libdir}/libwx_base*-%{ver2}.so.*
622 #%{_datadir}/locale/*/*/*
623
624 %files -n %{wxbasename}-devel -f wxbase-headers.paths
625 %defattr (-,root,root)
626 %dir %{_includedir}/wx-%{ver2}
627 %{_libdir}/libwx_base*-%{ver2}.so
628 %{_libdir}/libwx_base*-%{ver2}.a
629 %if %{unicode}
630 %{_libdir}/libwxregexu-%{ver2}.a
631 %endif
632 %dir %{_libdir}/wx
633 %{_libdir}/wx/config/%{wxbaseconfig}
634 %{_libdir}/wx/include/%{wxbaseconfig}/wx/setup.h
635 %{_libdir}/wx/config/%{wxbaseconfigstatic}
636 %{_libdir}/wx/include/%{wxbaseconfigstatic}/wx/setup.h
637 %{_datadir}/aclocal/*.m4
638
639 %files gl
640 %defattr(-,root,root)
641 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
642
643 %files contrib
644 %defattr(-,root,root)
645 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
646 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
647 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
648 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
649 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
650 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
651 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
652 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
653 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
654 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
655
656 %files contrib-devel
657 %defattr(-,root,root)
658 %dir %{_includedir}/wx-%{ver2}/wx/animate
659 %{_includedir}/wx-%{ver2}/wx/animate/*
660 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
661
662 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
663 %{_includedir}/wx-%{ver2}/wx/deprecated/*
664 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
665
666 %dir %{_includedir}/wx-%{ver2}/wx/fl
667 %{_includedir}/wx-%{ver2}/wx/fl/*
668 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
669
670 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
671 %{_includedir}/wx-%{ver2}/wx/gizmos/*
672 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
673 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
674
675 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
676 %{_includedir}/wx-%{ver2}/wx/mmedia/*
677 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
678
679 %dir %{_includedir}/wx-%{ver2}/wx/ogl
680 %{_includedir}/wx-%{ver2}/wx/ogl/*
681 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
682
683 %dir %{_includedir}/wx-%{ver2}/wx/plot
684 %{_includedir}/wx-%{ver2}/wx/plot/*
685 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
686
687 %dir %{_includedir}/wx-%{ver2}/wx/stc
688 %{_includedir}/wx-%{ver2}/wx/stc/*
689 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
690
691 %dir %{_includedir}/wx-%{ver2}/wx/svg
692 %{_includedir}/wx-%{ver2}/wx/svg/*
693 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so