1 # RPM .spec file for wxMotif. Based on the .spec file for wxGTK
2 # (c) by Robert Roebling. Modifications (c) 2000/03 by Robert Fendt.
4 # Note that this is NOT a relocatable package
10 Summary: The Motif
/Lesstif port of the wxWindows library
14 Copyright: wxWindows Licence
16 Source: wxMOTIF
-%{ver}.tar.bz2
17 URL: http
://www.wxwindows.org
18 Packager: Robert Fendt
<rfendt@myokay.net
>
19 BuildRoot: /tmp
/wxmotif_root
21 # all packages providing an implementation of wxWindows library (regardless of
22 # the toolkit used) should provide the (virtual) wxwin package, this makes it
23 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
27 wxWindows is a free C
++ library
for cross
-platform GUI development.
28 With wxWindows
, you can create applications
for different GUIs
(GTK
+,
29 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
32 Summary: The Motif
/Lesstif port of the wxWindows library
34 Requires: wxMotif
= %{ver}
37 Header files
for wxMotif
, the Motif
/Lesstif port of the wxWindows library.
40 Summary: The Motif
/Lesstif port of the wxWindows library
, OpenGL add
-on.
42 Requires: wxMotif
= %{ver}
45 OpenGL add
-on library
for wxMotif
, the Motif
/Lesstif port of the wxWindows library.
48 Summary: wxMotif static libraries
49 Group: Development
/Libraries
52 Static libraries
for wxMotif. You need them
if you want to link statically against wxMotif.
56 %setup -n wxMOTIF
-%{ver}
59 if [ "$SMP"
!= ""
]; then
60 export MAKE
="
make -j$SMP"
67 ..
/configure
--prefix
=%{pref} --with
-odbc
--with
-opengl
--with
-motif
73 ..
/configure
--prefix
=%{pref} --disable
-shared
--with
-odbc
--with
-opengl
--with
-motif
78 rm -rf $RPM_BUILD_ROOT
79 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
80 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
85 rm -rf $RPM_BUILD_ROOT
100 # Install wx-config if there isn't any
101 if test ! -f
%{_bindir}/wx
-config
; then
102 ln
-sf wxmotif
-%{ver2}-config %{_bindir}/wx
-config
106 # Remove wx-config if it points to this package
107 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
108 SUM1
=`md5sum
%{_bindir}/wxmotif-%{ver2}-config | cut
-c
0-32`
109 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
110 if test "x$SUM1"
= "x$SUM2"
; then
111 rm -f
%{_bindir}/wx
-config
117 %defattr (-,root
,root
)
118 %doc COPYING.LIB
*.txt
121 %{_libdir}/libwx_motif-%{ver2}*.so.
*
124 %defattr (-,root
,root
)
125 %{_libdir}/libwx_motif-%{ver2}*.so
126 %dir %{_includedir}/wx
130 %{_bindir}/wxmotif-%{ver2}-config
131 %{_datadir}/aclocal
/*.m4
134 %defattr(-,root
,root
)
135 %{_libdir}/libwx_motif_gl
*
138 %defattr (-,root
,root
)