6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
13 %define name wx
-%{portname}-unicode
14 %define wxbasename wx
-base
-unicode
16 %define name wx
-%{portname}
17 %define wxbasename wx
-base
21 %define wxconfigname wx
%{portname}univu-%{ver2}-config
23 %define wxconfigname wx
%{portname}univ-%{ver2}-config
26 Summary: The X11 port of the wxWindows library
30 License: wxWindows Licence
32 Source: wxX11
-%{ver}.tar.bz2
33 URL: http
://www.wxwindows.org
34 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
36 BuildRoot: /var
/tmp
/%{name}-root
38 # all packages providing an implementation of wxWindows library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
43 # in addition, we should provide libwx_gtk as automatic generator only notices
44 # libwx_gtk-%{ver}-%{rel}
45 Provides: libwx_x11.so
46 Provides: libwx_x11
-%{ver2}.so
49 Requires: %{wxbasename} = %{ver}
52 wxWindows is a free C
++ library
for cross
-platform GUI development.
53 With wxWindows
, you can create applications
for different GUIs
(GTK
+,
54 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
57 Summary: The X11 port of the wxWindows library
59 Requires: %{name} = %{ver}
60 Requires: %{wxbasename}-devel = %{ver}
63 Header files
for wxX11
, the X11 port of the wxWindows library.
66 Summary: The X11 port of the wxWindows library
, OpenGL add
-on.
68 Requires: %{name} = %{ver}
71 OpenGL add
-on library
for wxX11
, the X11 port of the wxWindows library.
74 Summary: wxX11 static libraries
75 Group: Development
/Libraries
78 Static libraries
for wxX11. You need them
if you want to link statically against wxX11.
81 Summary: Contrib libraries
for wxX11.
83 Requires: %{name} = %{ver}
86 Contributed libraries
for wxX11.
88 %package contrib
-devel
89 Summary: Contrib libraries
for wxX11.
91 Requires: %{name}-contrib = %{ver}
92 Requires: %{name}-devel = %{ver}
94 %description contrib
-devel
95 Header files
for contributed libraries
for wxX11.
98 %setup -q
-n wxX11
-%{ver}
101 if [ "$SMP"
!= ""
]; then
102 export MAKE
="
make -j$SMP"
109 ..
/configure
--prefix
=%{pref} --with
-x11 \
123 ..
/configure
--prefix
=%{pref} --with
-x11
--disable
-shared \
134 rm -rf $RPM_BUILD_ROOT
135 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
136 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
138 # Remove headers that are part of wx-base-devel:
140 # --- wxBase headers list begins here ---
141 cat
<<EOF
>wxbase
-headers
-list
255 wx
/protocol
/protocol.h
268 # --- wxBase headers list ends here ---
269 for f
in `cat wxbase
-headers
-list`
; do
270 rm -f $RPM_BUILD_ROOT
%{_includedir}/$f
273 # list of all core headers:
274 find $RPM_BUILD_ROOT
/usr
/include
/wx
-type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
277 (cd obj
-shared
/contrib
/src
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
278 (cd obj
-shared
/contrib
/utils
/wxrc
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
280 # remove wxBase files so that RPM doesn't complain about unpackaged files:
281 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwx_base
*
282 rm -f $RPM_BUILD_ROOT
%{_datadir}/aclocal
/*
283 rm -f $RPM_BUILD_ROOT
%{_datadir}/locale
/*/*/*
286 rm -rf $RPM_BUILD_ROOT
301 # Install wx-config if there isn't any
302 if test ! -f
%{_bindir}/wx
-config
; then
303 ln
-sf
%{wxconfigname} %{_bindir}/wx
-config
307 # Remove wx-config if it points to this package
308 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
309 SUM1
=`md5sum
%{_bindir}/%{wxconfigname} | cut
-c
0-32`
310 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
311 if test "x$SUM1"
= "x$SUM2"
; then
312 rm -f
%{_bindir}/wx
-config
318 %defattr(-,root
,root
)
319 %doc COPYING.LIB
*.txt
322 %{_libdir}/libwx_%{portname}*_core
*.so.
*
323 %{_libdir}/libwx_%{portname}*_html
*.so.
*
324 %{_libdir}/libwx_%{portname}*_adv
*.so.
*
326 %{_libdir}/libwx_%{portname}*_dbgrid
*.so.
*
329 %files devel
-f core
-headers.files
330 %defattr(-,root
,root
)
331 %{_libdir}/libwx_%{portname}*_core
*.so
332 %{_libdir}/libwx_%{portname}*_html
*.so
333 %{_libdir}/libwx_%{portname}*_adv
*.so
335 %{_libdir}/libwx_%{portname}*_dbgrid
*.so
337 %{_libdir}/libwx_%{portname}*_gl
*.so
340 %{_bindir}/%{wxconfigname}
343 %defattr(-,root
,root
)
344 %{_libdir}/libwx_%{portname}*_gl
*.so.
*
347 %defattr (-,root
,root
)
348 %{_libdir}/libwx_%{portname}*.a
351 %defattr(-,root
,root
)
352 %{_libdir}/libwx_%{portname}*_animate
*.so.
*
353 %{_libdir}/libwx_%{portname}*_deprecated
*.so.
*
354 %{_libdir}/libwx_%{portname}*_fl
*.so.
*
355 %{_libdir}/libwx_%{portname}*_gizmos
*.so.
*
356 %{_libdir}/libwx_%{portname}*_mmedia
*.so.
*
357 %{_libdir}/libwx_%{portname}*_ogl
*.so.
*
358 %{_libdir}/libwx_%{portname}*_plot
*.so.
*
359 %{_libdir}/libwx_%{portname}*_stc
*.so.
*
360 %{_libdir}/libwx_%{portname}*_svg
*.so.
*
361 %{_libdir}/libwx_%{portname}*_xrc
*.so.
*
364 %defattr(-,root
,root
)
366 %dir %{_includedir}/wx
/animate
367 %{_includedir}/wx
/animate
/*
368 %{_libdir}/libwx_%{portname}*_animate
*.so
370 %dir %{_includedir}/wx
/deprecated
371 %{_includedir}/wx
/deprecated
/*
372 %{_libdir}/libwx_%{portname}*_deprecated
*.so
374 %dir %{_includedir}/wx
/fl
375 %{_includedir}/wx
/fl
/*
376 %{_libdir}/libwx_%{portname}*_fl
*.so
378 %dir %{_includedir}/wx
/gizmos
379 %{_includedir}/wx
/gizmos
/*
380 %{_libdir}/libwx_%{portname}*_gizmos
*.so
382 %dir %{_includedir}/wx
/mmedia
383 %{_includedir}/wx
/mmedia
/*
384 %{_libdir}/libwx_%{portname}*_mmedia
*.so
386 %dir %{_includedir}/wx
/ogl
387 %{_includedir}/wx
/ogl
/*
388 %{_libdir}/libwx_%{portname}*_ogl
*.so
390 %dir %{_includedir}/wx
/plot
391 %{_includedir}/wx
/plot
/*
392 %{_libdir}/libwx_%{portname}*_plot
*.so
394 %dir %{_includedir}/wx
/stc
395 %{_includedir}/wx
/stc
/*
396 %{_libdir}/libwx_%{portname}*_stc
*.so
398 %dir %{_includedir}/wx
/svg
399 %{_includedir}/wx
/svg
/*
400 %{_libdir}/libwx_%{portname}*_svg
*.so
402 %dir %{_includedir}/wx
/xrc
403 %{_includedir}/wx
/xrc
/*
404 %{_libdir}/libwx_%{portname}*_xrc
*.so