6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
24 %define name wx
-%{portname}-unicode
25 %define wxbasename wx
-base
-unicode
27 %define name wx
-%{portname}
28 %define wxbasename wx
-base
32 %define wxconfigname wx
%{portname}u-%{ver2}-config
34 %define wxconfigname wx
%{portname}-%{ver2}-config
38 Summary: The GTK
+ %{gtkver} port of the wxWindows library
41 License: wxWindows Licence
43 Source: wxGTK
-%{ver}.tar.bz2
44 URL: http
://www.wxwindows.org
45 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
47 BuildRoot: /var
/tmp
/%{name}-root
49 # all packages providing an implementation of wxWindows library (regardless of
50 # the toolkit used) should provide the (virtual) wxwin package, this makes it
51 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
55 # in addition, we should provide libwx_gtk as automatic generator only notices
56 # libwx_gtk-%{ver}-%{rel}
57 Provides: libwx_gtk.so
58 Provides: libwx_gtk
-%{ver2}.so
60 Requires: %{wxbasename} = %{ver}
63 wxWindows is a free C
++ library
for cross
-platform GUI development.
64 With wxWindows
, you can create applications
for different GUIs
(GTK
+,
65 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
68 Summary: The GTK
+ %{gtkver} port of the wxWindows library
70 Requires: %{name} = %{ver}
71 Requires: %{wxbasename}-devel = %{ver}
75 Header files
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
78 Summary: The GTK
+ %{gtkver} port of the wxWindows library
, OpenGL add
-on.
80 Requires: %{name} = %{ver}
83 OpenGL add
-on library
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
86 Summary: wxGTK static libraries
87 Group: Development
/Libraries
88 Requires: %{wxbasename}-static
91 Static libraries
for wxGTK. You need them
if you want to link statically against wxGTK.
94 Summary: The GTK
+ %{gtkver} port of the wxWindows library
, contributed libraries.
96 Requires: %{name} = %{ver}
99 Contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
101 %package contrib
-devel
102 Summary: The GTK
+ %{gtkver} port of the wxWindows library
104 Requires: %{name}-contrib = %{ver}
105 Requires: %{name}-devel = %{ver}
107 %description contrib
-devel
108 Header files
for contributed libraries
for wxGTK
, the GTK
+ %{gtkver} port of the wxWindows library.
111 %setup -q
-n wxGTK
-%{ver}
114 if [ "$SMP"
!= ""
]; then
115 export MAKE
="
make -j$SMP"
122 ..
/configure
--prefix
=%{pref} \
139 ..
/configure
--prefix
=%{pref} --disable
-shared \
153 rm -rf $RPM_BUILD_ROOT
154 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
155 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
157 # Remove headers that are part of wx-base-devel:
159 # --- wxBase headers list begins here ---
160 cat
<<EOF
>wxbase
-headers
-list
274 wx
/protocol
/protocol.h
287 # --- wxBase headers list ends here ---
288 for f
in `cat wxbase
-headers
-list`
; do
289 rm -f $RPM_BUILD_ROOT
%{_includedir}/$f
292 # list of all core headers:
293 find $RPM_BUILD_ROOT
/usr
/include
/wx
-type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
296 (cd obj
-shared
/contrib
/src
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
297 (cd obj
-shared
/contrib
/utils
/wxrc
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
299 # remove wxBase files so that RPM doesn't complain about unpackaged files:
300 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwx_base
*
301 rm -f $RPM_BUILD_ROOT
%{_datadir}/aclocal
/*
302 rm -f $RPM_BUILD_ROOT
%{_datadir}/locale
/*/*/*
305 rm -rf $RPM_BUILD_ROOT
320 # Install wx-config if there isn't any
321 if test ! -f
%{_bindir}/wx
-config
; then
322 ln
-sf
%{wxconfigname} %{_bindir}/wx
-config
326 # Remove wx-config if it points to this package
327 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
328 SUM1
=`md5sum
%{_bindir}/%{wxconfigname} | cut
-c
0-32`
329 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
330 if test "x$SUM1"
= "x$SUM2"
; then
331 rm -f
%{_bindir}/wx
-config
337 %defattr(-,root
,root
)
338 %doc COPYING.LIB
*.txt
341 %{_libdir}/libwx_%{portname}*_core
*.so.
*
342 %{_libdir}/libwx_%{portname}*_html
*.so.
*
343 %{_libdir}/libwx_%{portname}*_adv
*.so.
*
345 %{_libdir}/libwx_%{portname}*_dbgrid
*.so.
*
348 %files devel
-f core
-headers.files
349 %defattr(-,root
,root
)
350 %{_libdir}/libwx_%{portname}*_core
*.so
351 %{_libdir}/libwx_%{portname}*_html
*.so
352 %{_libdir}/libwx_%{portname}*_adv
*.so
354 %{_libdir}/libwx_%{portname}*_dbgrid
*.so
356 %{_libdir}/libwx_%{portname}*_gl
*.so
359 %{_bindir}/%{wxconfigname}
362 %defattr(-,root
,root
)
363 %{_libdir}/libwx_%{portname}*_gl
*.so.
*
366 %defattr (-,root
,root
)
367 %{_libdir}/libwx_gtk
*.a
370 %defattr(-,root
,root
)
371 %{_libdir}/libwx_%{portname}*_animate
*.so.
*
372 %{_libdir}/libwx_%{portname}*_deprecated
*.so.
*
373 %{_libdir}/libwx_%{portname}*_fl
*.so.
*
374 %{_libdir}/libwx_%{portname}*_gizmos
*.so.
*
375 %{_libdir}/libwx_%{portname}*_mmedia
*.so.
*
376 %{_libdir}/libwx_%{portname}*_ogl
*.so.
*
377 %{_libdir}/libwx_%{portname}*_plot
*.so.
*
378 %{_libdir}/libwx_%{portname}*_stc
*.so.
*
379 %{_libdir}/libwx_%{portname}*_svg
*.so.
*
380 %{_libdir}/libwx_%{portname}*_xrc
*.so.
*
383 %defattr(-,root
,root
)
385 %dir %{_includedir}/wx
/animate
386 %{_includedir}/wx
/animate
/*
387 %{_libdir}/libwx_%{portname}*_animate
*.so
389 %dir %{_includedir}/wx
/deprecated
390 %{_includedir}/wx
/deprecated
/*
391 %{_libdir}/libwx_%{portname}*_deprecated
*.so
393 %dir %{_includedir}/wx
/fl
394 %{_includedir}/wx
/fl
/*
395 %{_libdir}/libwx_%{portname}*_fl
*.so
397 %dir %{_includedir}/wx
/gizmos
398 %{_includedir}/wx
/gizmos
/*
399 %{_libdir}/libwx_%{portname}*_gizmos
*.so
401 %dir %{_includedir}/wx
/mmedia
402 %{_includedir}/wx
/mmedia
/*
403 %{_libdir}/libwx_%{portname}*_mmedia
*.so
405 %dir %{_includedir}/wx
/ogl
406 %{_includedir}/wx
/ogl
/*
407 %{_libdir}/libwx_%{portname}*_ogl
*.so
409 %dir %{_includedir}/wx
/plot
410 %{_includedir}/wx
/plot
/*
411 %{_libdir}/libwx_%{portname}*_plot
*.so
413 %dir %{_includedir}/wx
/stc
414 %{_includedir}/wx
/stc
/*
415 %{_libdir}/libwx_%{portname}*_stc
*.so
417 %dir %{_includedir}/wx
/svg
418 %{_includedir}/wx
/svg
/*
419 %{_libdir}/libwx_%{portname}*_svg
*.so
421 %dir %{_includedir}/wx
/xrc
422 %{_includedir}/wx
/xrc
/*
423 %{_libdir}/libwx_%{portname}*_xrc
*.so