]> git.saurik.com Git - wxWidgets.git/blob - wxMotif.spec
Corrected CVS commit clash; small doc changes (removed Windows 3.1 reference since
[wxWidgets.git] / wxMotif.spec
1 # RPM .spec file for wxMotif. Based on the .spec file for wxGTK
2 # (c) by Robert Roebling. Modifications (c) 2000/03 by Robert Fendt.
3
4 # Note that this is NOT a relocatable package
5 %define pref /usr
6 %define ver 2.3.2
7 %define ver2 2.3
8 %define rel 1
9
10 Summary: The Motif/Lesstif port of the wxWindows library
11 Name: wxMotif
12 Version: %{ver}
13 Release: %{rel}
14 Copyright: wxWindows Licence
15 Group: X11/Libraries
16 Source: wxMOTIF-%{ver}.tar.bz2
17 URL: http://www.wxwindows.org
18 Packager: Robert Fendt <rfendt@myokay.net>
19 BuildRoot: /tmp/wxmotif_root
20
21 # all packages providing an implementation of wxWindows library (regardless of
22 # the toolkit used) should provide the (virtual) wxwin package, this makes it
23 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
24 Provides: wxwin
25
26 %description
27 wxWindows is a free C++ library for cross-platform GUI development.
28 With wxWindows, you can create applications for different GUIs (GTK+,
29 Motif/LessTif, MS Windows, Mac) from the same source code.
30
31 %package devel
32 Summary: The Motif/Lesstif port of the wxWindows library
33 Group: X11/Libraries
34 Requires: wxMotif = %{ver}
35
36 %description devel
37 Header files for wxMotif, the Motif/Lesstif port of the wxWindows library.
38
39 %package gl
40 Summary: The Motif/Lesstif port of the wxWindows library, OpenGL add-on.
41 Group: X11/Libraries
42 Requires: wxMotif = %{ver}
43
44 %description gl
45 OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWindows library.
46
47 %package static
48 Summary: wxMotif static libraries
49 Group: Development/Libraries
50
51 %description static
52 Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
53
54
55 %prep
56 %setup -n wxMOTIF-%{ver}
57
58 %build
59 if [ "$SMP" != "" ]; then
60 export MAKE="make -j$SMP"
61 else
62 export MAKE="make"
63 fi
64
65 (cd locale; make allmo)
66
67 mkdir obj-shared
68 cd obj-shared
69 ../configure --prefix=%{pref} --enable-soname --with-odbc --with-opengl --with-motif
70 $MAKE
71 cd ..
72
73 mkdir obj-static
74 cd obj-static
75 ../configure --prefix=%{pref} --disable-shared --with-odbc --with-opengl --with-motif
76 $MAKE
77 cd ..
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
82 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
83
84 %find_lang wxstd
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %post
90 /sbin/ldconfig
91
92 %postun
93 /sbin/ldconfig
94
95 %post gl
96 /sbin/ldconfig
97
98 %postun gl
99 /sbin/ldconfig
100
101 %post devel
102 # Install wx-config if there isn't any
103 if test ! -f %{_bindir}/wx-config ; then
104 ln -sf wxmotif-%{ver2}-config %{_bindir}/wx-config
105 fi
106
107 %preun devel
108 # Remove wx-config if it points to this package
109 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
110 SUM1=`md5sum %{_bindir}/wxmotif-%{ver2}-config | cut -c 0-32`
111 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
112 if test "x$SUM1" = "x$SUM2" ; then
113 rm -f %{_bindir}/wx-config
114 fi
115 fi
116
117
118 %files -f wxstd.lang
119 %defattr (-,root,root)
120 %doc COPYING.LIB *.txt
121 %dir %{_datadir}/wx
122 %{_datadir}/wx/*
123 %{_libdir}/libwx_motif-%{ver2}*.so.*
124
125 %files devel
126 %defattr (-,root,root)
127 %{_libdir}/libwx_motif-%{ver2}*.so
128 %dir %{_includedir}/wx
129 %{_includedir}/wx/*
130 %dir %{_libdir}/wx
131 %{_libdir}/wx/*
132 %{_bindir}/wxmotif-%{ver2}-config
133 %{_datadir}/aclocal/*.m4
134
135 %files gl
136 %defattr(-,root,root)
137 %{_libdir}/libwx_motif_gl*
138
139 %files static
140 %defattr (-,root,root)
141 %{_libdir}/lib*.a