1 # RPM .spec file for wxMotif. Based on the .spec file for wxGTK
2 # (c) by Robert Roebling. Modifications (c) 2000/03 by Robert Fendt.
4 # Note that this is NOT a relocatable package
10 %define portname motif
11 %define name wx
-%{portname}
12 %define wxbasename wx
-base
13 %define wxconfigname wx
%{portname}-%{ver2}-config
15 Summary: The Motif
/Lesstif port of the wxWindows library
19 License: wxWindows Licence
21 Source: wxMOTIF
-%{ver}.tar.bz2
22 URL: http
://www.wxwindows.org
23 Packager: Robert Fendt
<rfendt@myokay.net
>
24 BuildRoot: /tmp
/wxmotif_root
26 # all packages providing an implementation of wxWindows library (regardless of
27 # the toolkit used) should provide the (virtual) wxwin package, this makes it
28 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
33 Requires: %{wxbasename} = %{ver}
34 BuildRequires
: %{wxbasename}-devel = %{ver}
37 wxWindows is a free C
++ library
for cross
-platform GUI development.
38 With wxWindows
, you can create applications
for different GUIs
(GTK
+,
39 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
42 Summary: The Motif
/Lesstif port of the wxWindows library
44 Requires: %{name} = %{ver}
45 Requires: %{wxbasename}-devel = %{ver}
48 Header files
for wxMotif
, the Motif
/Lesstif port of the wxWindows library.
51 Summary: The Motif
/Lesstif port of the wxWindows library
, OpenGL add
-on.
53 Requires: %{name} = %{ver}
56 OpenGL add
-on library
for wxMotif
, the Motif
/Lesstif port of the wxWindows library.
59 Summary: wxMotif static libraries
60 Group: Development
/Libraries
63 Static libraries
for wxMotif. You need them
if you want to link statically against wxMotif.
66 %setup -q
-n wxMOTIF
-%{ver}
69 if [ "$SMP"
!= ""
]; then
70 export MAKE
="
make -j$SMP"
77 ..
/configure
--prefix
=%{pref} --with
-odbc
--with
-opengl
--with
-motif
83 ..
/configure
--prefix
=%{pref} --disable
-shared
--with
-odbc
--with
-opengl
--with
-motif
88 rm -rf $RPM_BUILD_ROOT
89 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
90 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
92 # Remove headers that are part of wx-base-devel:
95 for f
in `rpm
-ql
%{wxbasename}-devel | sed
-e 's
,\
(.
*\
),.\
1,g'`
; do
96 if test -f $f
; then rm -f $f
; fi
100 # list of all core headers:
101 find $RPM_BUILD_ROOT
/usr
/include
/wx
-type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
105 rm -rf $RPM_BUILD_ROOT
120 # Install wx-config if there isn't any
121 if test ! -f
%{_bindir}/wx
-config
; then
122 ln
-sf
%{wxconfigname} %{_bindir}/wx
-config
126 # Remove wx-config if it points to this package
127 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
128 SUM1
=`md5sum
%{_bindir}/%{wxconfigname} | cut
-c
0-32`
129 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
130 if test "x$SUM1"
= "x$SUM2"
; then
131 rm -f
%{_bindir}/wx
-config
137 %defattr(-,root
,root
)
138 %doc COPYING.LIB
*.txt
141 %{_libdir}/libwx_%{portname}*_core
*.so.
*
142 %{_libdir}/libwx_%{portname}*_html
*.so.
*
143 %{_libdir}/libwx_%{portname}*_adv
*.so.
*
144 %{_libdir}/libwx_%{portname}*_dbgrid
*.so.
*
146 %files devel
-f core
-headers.files
147 %defattr(-,root
,root
)
148 %{_libdir}/libwx_%{portname}*_core
*.so
149 %{_libdir}/libwx_%{portname}*_html
*.so
150 %{_libdir}/libwx_%{portname}*_adv
*.so
151 %{_libdir}/libwx_%{portname}*_dbgrid
*.so
152 %{_libdir}/libwx_%{portname}*_gl
*.so
155 %{_bindir}/%{wxconfigname}
158 %defattr(-,root
,root
)
159 %{_libdir}/libwx_%{portname}*_gl
*.so.
*
162 %defattr (-,root
,root
)
163 %{_libdir}/libwx_%{portname}*.a