remove ODBC and DBgrid libraries
[wxWidgets.git] / wxMotif.spec
1 %define pref /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 %define portname motif
7 %define name wx-%{portname}
8 %define wxbasename wx-base
9
10 %define wxconfig %{portname}-ansi-release-%{ver2}
11 %define wxconfiglink wx%{portname}-%{ver2}-config
12
13 Summary: The Motif/Lesstif port of the wxWidgets library
14 Name: %{name}
15 Version: %{ver}
16 Release: %{rel}
17 License: wxWindows Licence
18 Group: X11/Libraries
19 Source: wxMotif-%{ver}.tar.bz2
20 URL: http://www.wxwidgets.org
21 Packager: wxWidgets developers <wx-dev@lists.wxwidgets.org>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
24
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
28 Provides: wxwin
29 Provides: wxMotif
30
31 %description
32 wxWidgets is a free C++ library for cross-platform GUI development.
33 With wxWidgets, you can create applications for different GUIs (GTK+,
34 Motif/LessTif, MS Windows, Mac) from the same source code.
35
36 %package devel
37 Summary: The Motif/Lesstif port of the wxWidgets library
38 Group: X11/Libraries
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
41
42 %description devel
43 Header files for wxMotif, the Motif/Lesstif port of the wxWidgets library.
44
45 %package gl
46 Summary: The Motif/Lesstif port of the wxWidgets library, OpenGL add-on.
47 Group: X11/Libraries
48 Requires: %{name} = %{ver}
49
50 %description gl
51 OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWidgets library.
52
53 %package static
54 Summary: wxMotif static libraries
55 Group: Development/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
58
59 %description static
60 Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
61
62 %package contrib
63 Summary: Contrib libraries for wxMotif
64 Group: X11/Libraries
65 Requires: %{name} = %{ver}
66
67 %description contrib
68 Contrib libraries for wxMotif
69
70 %package contrib-devel
71 Summary: Contrib libraries for wxMotif
72 Group: X11/Libraries
73 Requires: %{name}-contrib = %{ver}
74 Requires: %{name}-devel = %{ver}
75
76 %description contrib-devel
77 Header files for contributed libraries for wxMotif.
78
79 %prep
80 %setup -q -n wxMotif-%{ver}
81
82 %build
83 if [ "$SMP" != "" ]; then
84 export MAKE="make -j$SMP"
85 else
86 export MAKE="make"
87 fi
88
89 mkdir obj-shared
90 cd obj-shared
91 ../configure --prefix=%{pref} --with-motif --with-opengl
92 $MAKE
93
94 cd contrib/src
95 $MAKE
96 cd ../../..
97
98 mkdir obj-static
99 cd obj-static
100 ../configure --prefix=%{pref} --with-motif --disable-shared --with-opengl
101 $MAKE
102 cd ..
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
107 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
108
109 # Remove headers that are part of wx-base-devel:
110
111 # --- wxBase headers list begins here ---
112 cat <<EOF >wxbase-headers.files
113 wx/afterstd.h
114 wx/app.h
115 wx/apptrait.h
116 wx/archive.h
117 wx/arrimpl.cpp
118 wx/arrstr.h
119 wx/atomic.h
120 wx/base64.h
121 wx/beforestd.h
122 wx/buffer.h
123 wx/build.h
124 wx/chartype.h
125 wx/chkconf.h
126 wx/clntdata.h
127 wx/cmdline.h
128 wx/confbase.h
129 wx/config.h
130 wx/convauto.h
131 wx/containr.h
132 wx/cpp.h
133 wx/crt.h
134 wx/datetime.h
135 wx/datstrm.h
136 wx/dde.h
137 wx/debug.h
138 wx/defs.h
139 wx/dir.h
140 wx/dlimpexp.h
141 wx/dynarray.h
142 wx/dynlib.h
143 wx/dynload.h
144 wx/encconv.h
145 wx/event.h
146 wx/except.h
147 wx/features.h
148 wx/flags.h
149 wx/ffile.h
150 wx/file.h
151 wx/fileconf.h
152 wx/filefn.h
153 wx/filename.h
154 wx/filesys.h
155 wx/fontenc.h
156 wx/fontmap.h
157 wx/fs_arc.h
158 wx/fs_filter.h
159 wx/fs_mem.h
160 wx/fs_zip.h
161 wx/hash.h
162 wx/hashmap.h
163 wx/hashset.h
164 wx/html/forcelnk.h
165 wx/iconloc.h
166 wx/init.h
167 wx/intl.h
168 wx/iosfwrap.h
169 wx/ioswrap.h
170 wx/ipc.h
171 wx/ipcbase.h
172 wx/isql.h
173 wx/isqlext.h
174 wx/link.h
175 wx/list.h
176 wx/listimpl.cpp
177 wx/log.h
178 wx/longlong.h
179 wx/math.h
180 wx/memconf.h
181 wx/memory.h
182 wx/memtext.h
183 wx/mimetype.h
184 wx/module.h
185 wx/msgout.h
186 wx/mstream.h
187 wx/object.h
188 wx/platform.h
189 wx/platinfo.h
190 wx/power.h
191 wx/process.h
192 wx/ptr_scpd.h
193 wx/recguard.h
194 wx/regex.h
195 wx/scopeguard.h
196 wx/snglinst.h
197 wx/sstream.h
198 wx/stack.h
199 wx/stackwalk.h
200 wx/stdpaths.h
201 wx/stockitem.h
202 wx/stopwatch.h
203 wx/strconv.h
204 wx/stream.h
205 wx/string.h
206 wx/stringimpl.h
207 wx/stringops.h
208 wx/strvararg.h
209 wx/sysopt.h
210 wx/tarstrm.h
211 wx/textbuf.h
212 wx/textfile.h
213 wx/thread.h
214 wx/thrimpl.cpp
215 wx/timer.h
216 wx/tokenzr.h
217 wx/txtstrm.h
218 wx/types.h
219 wx/unichar.h
220 wx/uri.h
221 wx/utils.h
222 wx/variant.h
223 wx/vector.h
224 wx/version.h
225 wx/volume.h
226 wx/wfstream.h
227 wx/wx.h
228 wx/wxchar.h
229 wx/wxcrt.h
230 wx/wxcrtbase.h
231 wx/wxcrtvararg.h
232 wx/wxprec.h
233 wx/xti.h
234 wx/xtistrm.h
235 wx/zipstrm.h
236 wx/zstream.h
237 wx/private/fdiodispatcher.h
238 wx/private/selectdispatcher.h
239 wx/unix/app.h
240 wx/unix/apptbase.h
241 wx/unix/apptrait.h
242 wx/unix/chkconf.h
243 wx/unix/execute.h
244 wx/unix/evtloop.h
245 wx/unix/mimetype.h
246 wx/unix/pipe.h
247 wx/unix/private.h
248 wx/unix/stackwalk.h
249 wx/unix/stdpaths.h
250 wx/fs_inet.h
251 wx/gsocket.h
252 wx/protocol/file.h
253 wx/protocol/ftp.h
254 wx/protocol/http.h
255 wx/protocol/protocol.h
256 wx/sckaddr.h
257 wx/sckipc.h
258 wx/sckstrm.h
259 wx/socket.h
260 wx/url.h
261 wx/unix/gsockunx.h
262 wx/xml/xml.h
263 wx/xtixml.h
264 EOF
265 # --- wxBase headers list ends here ---
266 for f in `cat wxbase-headers-list` ; do
267 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
268 done
269
270 # list of all core headers:
271 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
272
273 # contrib stuff:
274 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
275 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
276
277 # remove wxBase files so that RPM doesn't complain about unpackaged files:
278 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
279 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
280 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
281
282 %clean
283 rm -rf $RPM_BUILD_ROOT
284
285 %post
286 /sbin/ldconfig
287
288 %postun
289 /sbin/ldconfig
290
291 %post devel
292 # link wx-config when you install RPM.
293 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
294 # link wx-config with explicit name.
295 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
296 /sbin/ldconfig
297
298 %postun devel
299 /sbin/ldconfig
300
301 %preun devel
302 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
303 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
304 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
305 if test "x$SUM1" = "x$SUM2" ; then
306 rm -f %{_bindir}/wx-config
307 fi
308 fi
309 rm -f %{_bindir}/%{wxconfiglink}
310
311 %post gl
312 /sbin/ldconfig
313
314 %postun gl
315 /sbin/ldconfig
316
317 %post contrib
318 /sbin/ldconfig
319
320 %postun contrib
321 /sbin/ldconfig
322
323 %post contrib-devel
324 /sbin/ldconfig
325
326 %postun contrib-devel
327 /sbin/ldconfig
328
329 %files
330 %defattr(-,root,root)
331 %doc COPYING.LIB *.txt
332 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
333 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
334 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
335 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
336 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
337 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
338
339
340 %files devel -f core-headers.files
341 %defattr(-,root,root)
342 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
343 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
344 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
345 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
346 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
347 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
348 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
349 %dir %{_libdir}/wx
350 %{_libdir}/wx/*
351 %{_bindir}/wxrc*
352
353 %files gl
354 %defattr(-,root,root)
355 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
356
357 %files static
358 %defattr (-,root,root)
359 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
360
361 %files contrib
362 %defattr(-,root,root)
363 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
364 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
365 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
366 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
367 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
368 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
369 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
370 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
371 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
372
373 %files contrib-devel
374 %defattr(-,root,root)
375 %dir %{_includedir}/wx-%{ver2}/wx/animate
376 %{_includedir}/wx-%{ver2}/wx/animate/*
377 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
378
379 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
380 %{_includedir}/wx-%{ver2}/wx/deprecated/*
381 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
382
383 %dir %{_includedir}/wx-%{ver2}/wx/fl
384 %{_includedir}/wx-%{ver2}/wx/fl/*
385 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
386
387 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
388 %{_includedir}/wx-%{ver2}/wx/gizmos/*
389 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
390
391 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
392 %{_includedir}/wx-%{ver2}/wx/mmedia/*
393 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
394
395 %dir %{_includedir}/wx-%{ver2}/wx/ogl
396 %{_includedir}/wx-%{ver2}/wx/ogl/*
397 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
398
399 %dir %{_includedir}/wx-%{ver2}/wx/plot
400 %{_includedir}/wx-%{ver2}/wx/plot/*
401 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
402
403 %dir %{_includedir}/wx-%{ver2}/wx/stc
404 %{_includedir}/wx-%{ver2}/wx/stc/*
405 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
406
407 %dir %{_includedir}/wx-%{ver2}/wx/svg
408 %{_includedir}/wx-%{ver2}/wx/svg/*
409 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so