]> git.saurik.com Git - wxWidgets.git/blob - wxMotif.spec
remove -lfoo.dll hack, it appears to be unnecessary after all.. don't ask.
[wxWidgets.git] / wxMotif.spec
1 # RPM .spec file for wxMotif. Based on the .spec file for wxGTK
2 # (c) by Robert Roebling. Modifications (c) 2000/03 by Robert Fendt.
3
4 # Note that this is NOT a relocatable package
5 %define pref /usr
6 %define ver 2.3.1
7 %define ver2 2.3
8 %define rel 1
9
10 Summary: The Motif/Lesstif port of the wxWindows library
11 Name: wxMotif
12 Version: %{ver}
13 Release: %{rel}
14 Copyright: wxWindows Licence
15 Group: X11/Libraries
16 Source: wxMotif-%{ver}.tgz
17 URL: http://www.wxwindows.org
18 Packager: Robert Fendt <rfendt@myokay.net>
19 BuildRoot: /tmp/wxmotif_root
20
21 # all packages providing an implementation of wxWindows library (regardless of
22 # the toolkit used) should provide the (virtual) wxwin package, this makes it
23 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
24 Provides: wxwin
25
26 %description
27 wxWindows is a free C++ library for cross-platform GUI development.
28 With wxWindows, you can create applications for different GUIs (GTK+,
29 Motif/LessTif, MS Windows, Mac) from the same source code.
30
31 %package devel
32 Summary: The Motif/Lesstif port of the wxWindows library
33 Group: X11/Libraries
34 Requires: wxMotif
35
36 %description devel
37 Header files for wxMotif, the Motif/Lesstif port of the wxWindows library.
38
39 %package gl
40 Summary: The Motif/Lesstif port of the wxWindows library, OpenGl add-on.
41 Group: X11/Libraries
42 Requires: wxMotif
43
44 %description gl
45 OpenGl add-on library for wxMotif, the Motif/Lesstif port of the wxWindows library.
46
47 %prep
48 %setup -n wxMotif
49 ./configure --prefix=%{pref} --enable-soname --with-odbc --with-opengl --with-motif
50
51 %build
52 if [ "$SMP" != "" ]; then
53 export MAKE="make -j$SMP"
54 else
55 export MAKE="make"
56 fi
57 $MAKE
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 make prefix=$RPM_BUILD_ROOT%{pref} install
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %post
67 /sbin/ldconfig
68
69 %postun
70 /sbin/ldconfig
71
72 %files
73 %defattr (644, root, root, 755)
74 %doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
75 %dir %{pref}/share/wx
76 %{pref}/share/wx/*
77 %attr(755, -, -) %{pref}/lib/libwx_motif-%{ver2}.*
78
79 %files devel
80 %defattr (644, root, root, 755)
81 %dir %{pref}/include/wx
82 %{pref}/include/wx/*
83 %dir %{pref}/lib/wx
84 %{pref}/lib/wx/*
85 %attr(755, -, -) %{pref}/bin/wxmotif-%{ver2}-config
86 %attr(755, -, -) %{pref}/bin/wx-config
87
88 %files gl
89 %attr(755, -, -) %{pref}/lib/libwx_motif_gl*