]> git.saurik.com Git - wxWidgets.git/blob - wxGTK.spec
remove -lfoo.dll hack, it appears to be unnecessary after all.. don't ask.
[wxWidgets.git] / wxGTK.spec
1 %define pref /usr
2 %define ver 2.3.2
3 %define ver2 2.3
4 %define rel 0
5
6 Summary: The GTK+ 1.2 port of the wxWindows library
7 Name: wxGTK
8 Version: %{ver}
9 Release: %{rel}
10 Copyright: wxWindows Licence
11 Group: X11/Libraries
12 Source: wxGTK-%{ver}.tar.bz2
13 URL: http://www.wxwindows.org
14 Packager: Vadim Zeitlin <vadim@wxwindows.org>
15 Prefix: %{pref}
16 BuildRoot: /var/tmp/%{name}-root
17
18 # all packages providing an implementation of wxWindows library (regardless of
19 # the toolkit used) should provide the (virtual) wxwin package, this makes it
20 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
21 Provides: wxwin
22
23 # in addition, we should provide libwx_gtk as automatic generator only notices
24 # libwx_gtk-%{ver}-%{rel}
25 Provides: libwx_gtk.so
26 Provides: libwx_gtk-%{ver2}.so
27
28 %description
29 wxWindows is a free C++ library for cross-platform GUI development.
30 With wxWindows, you can create applications for different GUIs (GTK+,
31 Motif/LessTif, MS Windows, Mac) from the same source code.
32
33 %package devel
34 Summary: The GTK+ 1.2 port of the wxWindows library
35 Group: X11/Libraries
36 Requires: wxGTK
37
38 %description devel
39 Header files for wxGTK, the GTK+ 1.2 port of the wxWindows library.
40
41 %package gl
42 Summary: The GTK+ 1.2 port of the wxWindows library, OpenGl add-on.
43 Group: X11/Libraries
44 Requires: wxGTK
45
46 %description gl
47 OpenGl add-on library for wxGTK, the GTK+ 1.2 port of the wxWindows library.
48
49 %prep
50 %setup -n wxGTK-%{ver}
51 ./configure --prefix=%{pref} --enable-soname --with-odbc --with-opengl
52
53 %build
54 if [ "$SMP" != "" ]; then
55 export MAKE="make -j$SMP"
56 else
57 export MAKE="make"
58 fi
59 $MAKE
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 make prefix=$RPM_BUILD_ROOT%{pref} install
64
65 %post
66 /sbin/ldconfig
67
68 %postun
69 /sbin/ldconfig
70
71 %files
72 %defattr(-, root, root)
73 %doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
74 %dir %{pref}/share/wx
75 %{pref}/share/wx/*
76 %attr(755, root, root) %{pref}/lib/libwx_gtk-%{ver2}.*
77
78 %files devel
79 %defattr(-,root,root)
80 %dir %{pref}/include/wx
81 %{pref}/include/wx/*
82 %dir %{pref}/lib/wx
83 %{pref}/lib/wx/*
84 %attr(755, root, root) %{pref}/bin/wxgtk-%{ver2}-config
85 %attr(755, root, root) %{pref}/bin/wx-config
86
87 %files gl
88 %attr(755, root, root) %{pref}/lib/libwx_gtk_gl*
89
90