6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
11 %define portname x11univ
14 %define wxbasename wx
-base
-unicode
15 %define name wx
-%{portname}-unicode
16 %define wxconfig
%{portname}-unicode-release-%{ver2}
17 %define wxconfiglink wx
%{portname}u-%{ver2}-config
19 %define wxbasename wx
-base
20 %define name wx
-%{portname}
21 %define wxconfig
%{portname}-ansi-release-%{ver2}
22 %define wxconfiglink wx
%{portname}-%{ver2}-config
25 Summary: The X11 port of the wxWidgets library
29 License: wxWindows Licence
31 Source: wxX11
-%{ver}.tar.bz2
32 URL: http
://www.wxwidgets.org
33 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
45 wxWidgets is a free C
++ library
for cross
-platform GUI development.
46 With wxWidgets
, you can create applications
for different GUIs
(GTK
+,
47 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
50 Summary: The X11 port of the wxWidgets library
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
56 Header files
for wxX11
, the X11 port of the wxWidgets library.
59 Summary: The X11 port of the wxWidgets library
, OpenGL add
-on.
61 Requires: %{name} = %{ver}
64 OpenGL add
-on library
for wxX11
, the X11 port of the wxWidgets library.
67 Summary: wxX11 static libraries
68 Group: Development
/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
73 Static libraries
for wxX11. You need them
if you want to link statically against wxX11.
76 %setup -q
-n wxX11
-%{ver}
79 if [ "$SMP"
!= ""
]; then
80 export MAKE
="
make -j$SMP"
87 ..
/configure
--prefix
=%{pref} --with
-x11 \
98 ..
/configure
--prefix
=%{pref} --with
-x11
--disable
-shared \
109 rm -rf $RPM_BUILD_ROOT
110 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
111 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
113 # Remove headers that are part of wx-base-devel:
115 # --- wxBase headers list begins here ---
116 cat
<<EOF
>wxbase
-headers.files
261 wx
/meta
/convertible.h
267 wx
/generic
/fswatcher.h
278 wx
/unix
/fswatcher_kqueue.h
281 wx
/unix
/fswatcher_inotify.h
287 wx
/protocol
/protocol.h
296 # --- wxBase headers list ends here ---
297 for f
in `cat wxbase
-headers
-list`
; do
298 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2}/$f
301 # list of all core headers:
302 find $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} -type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
304 # remove wxBase files so that RPM doesn't complain about unpackaged files:
305 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwx_base
*
307 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwxregexu-%{ver2}.a
309 rm -f $RPM_BUILD_ROOT
%{_datadir}/aclocal
/*
310 rm -f $RPM_BUILD_ROOT
%{_datadir}/locale
/*/*/*
313 rm -rf $RPM_BUILD_ROOT
322 # link wx-config when you install RPM.
323 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx
-config
324 # link wx-config with explicit name.
325 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
332 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
333 SUM1
=`md5sum
%{_libdir}/wx/config/%{wxconfig} | cut
-c
0-32`
334 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
335 if test "x$SUM1"
= "x$SUM2"
; then
336 rm -f
%{_bindir}/wx
-config
339 rm -f
%{_bindir}/%{wxconfiglink}
348 %defattr(-,root
,root
)
349 %doc COPYING.LIB
*.txt
350 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.
*
351 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.
*
352 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.
*
353 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.
*
354 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.
*
355 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.
*
358 %files devel
-f core
-headers.files
359 %defattr(-,root
,root
)
360 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
361 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
362 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
363 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
364 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
365 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
366 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
372 %defattr(-,root
,root
)
373 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.
*
376 %defattr (-,root
,root
)
377 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a