updates from photon3108@users.sf.net (patches 1173350, 1173440, 1173447 and
[wxWidgets.git] / wxX11.spec
1 %define pref /usr
2 %define ver 2.5.5
3 %define ver2 2.5
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define portname x11univ
12
13 %if %{unicode}
14 %define wxbasename wx-base-unicode
15 %define name wx-%{portname}-unicode
16 %define wxconfig %{portname}-unicode-release-%{ver2}
17 %define wxconfiglink wx%{portname}u-%{ver2}-config
18 %else
19 %define wxbasename wx-base
20 %define name wx-%{portname}
21 %define wxconfig %{portname}-ansi-release-%{ver2}
22 %define wxconfiglink wx%{portname}-%{ver2}-config
23 %endif
24
25 Summary: The X11 port of the wxWidgets library
26 Name: %{name}
27 Version: %{ver}
28 Release: %{rel}
29 License: wxWindows Licence
30 Group: X11/Libraries
31 Source: wxX11-%{ver}.tar.bz2
32 URL: http://www.wxwidgets.org
33 Packager: Vadim Zeitlin <vadim@wxwindows.org>
34 Prefix: %{pref}
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
37
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
41 Provides: wxwin
42 Provides: wxX11
43
44 %description
45 wxWidgets is a free C++ library for cross-platform GUI development.
46 With wxWidgets, you can create applications for different GUIs (GTK+,
47 Motif/LessTif, MS Windows, Mac) from the same source code.
48
49 %package devel
50 Summary: The X11 port of the wxWidgets library
51 Group: X11/Libraries
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
54
55 %description devel
56 Header files for wxX11, the X11 port of the wxWidgets library.
57
58 %package gl
59 Summary: The X11 port of the wxWidgets library, OpenGL add-on.
60 Group: X11/Libraries
61 Requires: %{name} = %{ver}
62
63 %description gl
64 OpenGL add-on library for wxX11, the X11 port of the wxWidgets library.
65
66 %package static
67 Summary: wxX11 static libraries
68 Group: Development/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
71
72 %description static
73 Static libraries for wxX11. You need them if you want to link statically against wxX11.
74
75 %package contrib
76 Summary: Contrib libraries for wxX11.
77 Group: X11/Libraries
78 Requires: %{name} = %{ver}
79
80 %description contrib
81 Contributed libraries for wxX11.
82
83 %package contrib-devel
84 Summary: Contrib libraries for wxX11.
85 Group: X11/Libraries
86 Requires: %{name}-contrib = %{ver}
87 Requires: %{name}-devel = %{ver}
88
89 %description contrib-devel
90 Header files for contributed libraries for wxX11.
91
92 %prep
93 %setup -q -n wxX11-%{ver}
94
95 %build
96 if [ "$SMP" != "" ]; then
97 export MAKE="make -j$SMP"
98 else
99 export MAKE="make"
100 fi
101
102 mkdir obj-shared
103 cd obj-shared
104 ../configure --prefix=%{pref} --with-x11 \
105 %if %{unicode}
106 --enable-unicode \
107 %else
108 --with-odbc \
109 %endif
110 --with-opengl
111 $MAKE
112
113 cd contrib/src
114 $MAKE
115 cd ../../..
116
117 mkdir obj-static
118 cd obj-static
119 ../configure --prefix=%{pref} --with-x11 --disable-shared \
120 %if %{unicode}
121 --enable-unicode \
122 %else
123 --with-odbc \
124 %endif
125 --with-opengl
126 $MAKE
127 cd ..
128
129 %install
130 rm -rf $RPM_BUILD_ROOT
131 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
132 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
133
134 # Remove headers that are part of wx-base-devel:
135
136 # --- wxBase headers list begins here ---
137 cat <<EOF >wxbase-headers-list
138 wx/afterstd.h
139 wx/app.h
140 wx/apptrait.h
141 wx/archive.h
142 wx/arrimpl.cpp
143 wx/arrstr.h
144 wx/beforestd.h
145 wx/buffer.h
146 wx/build.h
147 wx/chkconf.h
148 wx/clntdata.h
149 wx/cmdline.h
150 wx/confbase.h
151 wx/config.h
152 wx/containr.h
153 wx/datetime.h
154 wx/datetime.inl
155 wx/datstrm.h
156 wx/dde.h
157 wx/debug.h
158 wx/defs.h
159 wx/dir.h
160 wx/dlimpexp.h
161 wx/dynarray.h
162 wx/dynlib.h
163 wx/dynload.h
164 wx/encconv.h
165 wx/event.h
166 wx/except.h
167 wx/features.h
168 wx/ffile.h
169 wx/file.h
170 wx/fileconf.h
171 wx/filefn.h
172 wx/filename.h
173 wx/filesys.h
174 wx/fontenc.h
175 wx/fontmap.h
176 wx/fs_mem.h
177 wx/fs_zip.h
178 wx/hash.h
179 wx/hashmap.h
180 wx/hashset.h
181 wx/html/forcelnk.h
182 wx/iconloc.h
183 wx/init.h
184 wx/intl.h
185 wx/iosfwrap.h
186 wx/ioswrap.h
187 wx/ipc.h
188 wx/ipcbase.h
189 wx/isql.h
190 wx/isqlext.h
191 wx/list.h
192 wx/listimpl.cpp
193 wx/log.h
194 wx/longlong.h
195 wx/math.h
196 wx/memconf.h
197 wx/memory.h
198 wx/memtext.h
199 wx/mimetype.h
200 wx/module.h
201 wx/msgout.h
202 wx/msgout.h
203 wx/mstream.h
204 wx/object.h
205 wx/platform.h
206 wx/process.h
207 wx/ptr_scpd.h
208 wx/regex.h
209 wx/scopeguard.h
210 wx/snglinst.h
211 wx/sstream.h
212 wx/stack.h
213 wx/stackwalk.h
214 wx/stdpaths.h
215 wx/stockitem.h
216 wx/stopwatch.h
217 wx/strconv.h
218 wx/stream.h
219 wx/string.h
220 wx/sysopt.h
221 wx/textbuf.h
222 wx/textfile.h
223 wx/thread.h
224 wx/thrimpl.cpp
225 wx/timer.h
226 wx/tokenzr.h
227 wx/txtstrm.h
228 wx/types.h
229 wx/uri.h
230 wx/utils.h
231 wx/variant.h
232 wx/vector.h
233 wx/version.h
234 wx/volume.h
235 wx/wfstream.h
236 wx/wx.h
237 wx/wxchar.h
238 wx/wxprec.h
239 wx/xti.h
240 wx/xtistrm.h
241 wx/zipstrm.h
242 wx/zstream.h
243 wx/msw/apptrait.h
244 wx/msw/apptbase.h
245 wx/msw/chkconf.h
246 wx/msw/crashrpt.h
247 wx/msw/dde.h
248 wx/msw/debughlp.h
249 wx/msw/gccpriv.h
250 wx/msw/mimetype.h
251 wx/msw/stackwalk.h
252 wx/msw/winundef.h
253 wx/msw/wrapcctl.h
254 wx/msw/wrapcdlg.h
255 wx/msw/wrapwin.h
256 wx/fs_inet.h
257 wx/gsocket.h
258 wx/protocol/file.h
259 wx/protocol/ftp.h
260 wx/protocol/http.h
261 wx/protocol/protocol.h
262 wx/sckaddr.h
263 wx/sckipc.h
264 wx/sckstrm.h
265 wx/socket.h
266 wx/url.h
267 wx/msw/gsockmsw.h
268 wx/xml/xml.h
269 wx/xtixml.h
270 wx/db.h
271 wx/dbkeyg.h
272 wx/dbtable.h
273 EOF
274 # --- wxBase headers list ends here ---
275 for f in `cat wxbase-headers-list` ; do
276 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
277 done
278
279 # list of all core headers:
280 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
281
282 # contrib stuff:
283 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
284 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
285
286 # remove wxBase files so that RPM doesn't complain about unpackaged files:
287 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
288 %if %{unicode}
289 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
290 %endif
291 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
292 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
293
294 %clean
295 rm -rf $RPM_BUILD_ROOT
296
297 %post
298 /sbin/ldconfig
299
300 %postun
301 /sbin/ldconfig
302
303 %post devel
304 # link wx-config when you install RPM.
305 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
306 # link wx-config with explicit name.
307 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
308 /sbin/ldconfig
309
310 %postun devel
311 /sbin/ldconfig
312
313 %preun devel
314 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
315 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
316 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
317 if test "x$SUM1" = "x$SUM2" ; then
318 rm -f %{_bindir}/wx-config
319 fi
320 fi
321 rm -f %{_bindir}/%{wxconfiglink}
322
323 %post gl
324 /sbin/ldconfig
325
326 %postun gl
327 /sbin/ldconfig
328
329 %post contrib
330 /sbin/ldconfig
331
332 %postun contrib
333 /sbin/ldconfig
334
335 %post contrib-devel
336 /sbin/ldconfig
337
338 %postun contrib-devel
339 /sbin/ldconfig
340
341 %files
342 %defattr(-,root,root)
343 %doc COPYING.LIB *.txt
344 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
345 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
346 %if !%{unicode}
347 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.*
348 %endif
349 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
350 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
351 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
352 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
353
354
355 %files devel -f core-headers.files
356 %defattr(-,root,root)
357 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
358 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
359 %if !%{unicode}
360 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
361 %endif
362 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
363 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
364 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
365 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
366 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
367 %dir %{_libdir}/wx
368 %{_libdir}/wx/*
369 %{_bindir}/wxrc*
370
371 %files gl
372 %defattr(-,root,root)
373 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
374
375 %files static
376 %defattr (-,root,root)
377 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
378
379 %files contrib
380 %defattr(-,root,root)
381 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
382 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
383 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
384 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
385 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
386 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
387 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
388 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
389 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
390
391 %files contrib-devel
392 %defattr(-,root,root)
393 %dir %{_includedir}/wx-%{ver2}/wx/animate
394 %{_includedir}/wx-%{ver2}/wx/animate/*
395 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
396
397 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
398 %{_includedir}/wx-%{ver2}/wx/deprecated/*
399 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
400
401 %dir %{_includedir}/wx-%{ver2}/wx/fl
402 %{_includedir}/wx-%{ver2}/wx/fl/*
403 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
404
405 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
406 %{_includedir}/wx-%{ver2}/wx/gizmos/*
407 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
408
409 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
410 %{_includedir}/wx-%{ver2}/wx/mmedia/*
411 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
412
413 %dir %{_includedir}/wx-%{ver2}/wx/ogl
414 %{_includedir}/wx-%{ver2}/wx/ogl/*
415 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
416
417 %dir %{_includedir}/wx-%{ver2}/wx/plot
418 %{_includedir}/wx-%{ver2}/wx/plot/*
419 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
420
421 %dir %{_includedir}/wx-%{ver2}/wx/stc
422 %{_includedir}/wx-%{ver2}/wx/stc/*
423 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
424
425 %dir %{_includedir}/wx-%{ver2}/wx/svg
426 %{_includedir}/wx-%{ver2}/wx/svg/*
427 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so