Rebake after taskbar addition (apparently dlist.h commit didn't include rebake, so...
[wxWidgets.git] / wxX11.spec
1 %define pref /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define portname x11univ
12
13 %if %{unicode}
14 %define wxbasename wx-base-unicode
15 %define name wx-%{portname}-unicode
16 %define wxconfig %{portname}-unicode-release-%{ver2}
17 %define wxconfiglink wx%{portname}u-%{ver2}-config
18 %else
19 %define wxbasename wx-base
20 %define name wx-%{portname}
21 %define wxconfig %{portname}-ansi-release-%{ver2}
22 %define wxconfiglink wx%{portname}-%{ver2}-config
23 %endif
24
25 Summary: The X11 port of the wxWidgets library
26 Name: %{name}
27 Version: %{ver}
28 Release: %{rel}
29 License: wxWindows Licence
30 Group: X11/Libraries
31 Source: wxX11-%{ver}.tar.bz2
32 URL: http://www.wxwidgets.org
33 Packager: Vadim Zeitlin <vadim@wxwindows.org>
34 Prefix: %{pref}
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
37
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
41 Provides: wxwin
42 Provides: wxX11
43
44 %description
45 wxWidgets is a free C++ library for cross-platform GUI development.
46 With wxWidgets, you can create applications for different GUIs (GTK+,
47 Motif/LessTif, MS Windows, Mac) from the same source code.
48
49 %package devel
50 Summary: The X11 port of the wxWidgets library
51 Group: X11/Libraries
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
54
55 %description devel
56 Header files for wxX11, the X11 port of the wxWidgets library.
57
58 %package gl
59 Summary: The X11 port of the wxWidgets library, OpenGL add-on.
60 Group: X11/Libraries
61 Requires: %{name} = %{ver}
62
63 %description gl
64 OpenGL add-on library for wxX11, the X11 port of the wxWidgets library.
65
66 %package static
67 Summary: wxX11 static libraries
68 Group: Development/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
71
72 %description static
73 Static libraries for wxX11. You need them if you want to link statically against wxX11.
74
75 %package contrib
76 Summary: Contrib libraries for wxX11.
77 Group: X11/Libraries
78 Requires: %{name} = %{ver}
79
80 %description contrib
81 Contributed libraries for wxX11.
82
83 %package contrib-devel
84 Summary: Contrib libraries for wxX11.
85 Group: X11/Libraries
86 Requires: %{name}-contrib = %{ver}
87 Requires: %{name}-devel = %{ver}
88
89 %description contrib-devel
90 Header files for contributed libraries for wxX11.
91
92 %prep
93 %setup -q -n wxX11-%{ver}
94
95 %build
96 if [ "$SMP" != "" ]; then
97 export MAKE="make -j$SMP"
98 else
99 export MAKE="make"
100 fi
101
102 mkdir obj-shared
103 cd obj-shared
104 ../configure --prefix=%{pref} --with-x11 \
105 %if %{unicode}
106 --enable-unicode \
107 %else
108 --disable-unicode \
109 %endif
110 $MAKE
111
112 cd contrib/src
113 $MAKE
114 cd ../../..
115
116 mkdir obj-static
117 cd obj-static
118 ../configure --prefix=%{pref} --with-x11 --disable-shared \
119 %if %{unicode}
120 --enable-unicode \
121 %else
122 --disable-unicode \
123 %endif
124 --with-opengl
125 $MAKE
126 cd ..
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
131 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
132
133 # Remove headers that are part of wx-base-devel:
134
135 # --- wxBase headers list begins here ---
136 cat <<EOF >wxbase-headers.files
137 wx/afterstd.h
138 wx/app.h
139 wx/apptrait.h
140 wx/archive.h
141 wx/arrimpl.cpp
142 wx/arrstr.h
143 wx/atomic.h
144 wx/base64.h
145 wx/beforestd.h
146 wx/buffer.h
147 wx/build.h
148 wx/chartype.h
149 wx/chkconf.h
150 wx/clntdata.h
151 wx/cmdargs.h
152 wx/cmdline.h
153 wx/confbase.h
154 wx/config.h
155 wx/convauto.h
156 wx/containr.h
157 wx/cpp.h
158 wx/crt.h
159 wx/datetime.h
160 wx/datstrm.h
161 wx/dde.h
162 wx/debug.h
163 wx/defs.h
164 wx/dir.h
165 wx/dlimpexp.h
166 wx/dlist.h
167 wx/dynarray.h
168 wx/dynlib.h
169 wx/dynload.h
170 wx/encconv.h
171 wx/event.h
172 wx/except.h
173 wx/features.h
174 wx/flags.h
175 wx/ffile.h
176 wx/file.h
177 wx/fileconf.h
178 wx/filefn.h
179 wx/filename.h
180 wx/filesys.h
181 wx/fontenc.h
182 wx/fontmap.h
183 wx/fs_arc.h
184 wx/fs_filter.h
185 wx/fs_mem.h
186 wx/fs_zip.h
187 wx/hash.h
188 wx/hashmap.h
189 wx/hashset.h
190 wx/html/forcelnk.h
191 wx/iconloc.h
192 wx/init.h
193 wx/intl.h
194 wx/iosfwrap.h
195 wx/ioswrap.h
196 wx/ipc.h
197 wx/ipcbase.h
198 wx/link.h
199 wx/list.h
200 wx/listimpl.cpp
201 wx/log.h
202 wx/longlong.h
203 wx/math.h
204 wx/memconf.h
205 wx/memory.h
206 wx/memtext.h
207 wx/mimetype.h
208 wx/module.h
209 wx/msgout.h
210 wx/mstream.h
211 wx/object.h
212 wx/platform.h
213 wx/platinfo.h
214 wx/power.h
215 wx/process.h
216 wx/ptr_scpd.h
217 wx/ptr_shrd.h
218 wx/recguard.h
219 wx/regex.h
220 wx/scopeguard.h
221 wx/snglinst.h
222 wx/sstream.h
223 wx/stack.h
224 wx/stackwalk.h
225 wx/stdpaths.h
226 wx/stockitem.h
227 wx/stopwatch.h
228 wx/strconv.h
229 wx/stream.h
230 wx/string.h
231 wx/stringimpl.h
232 wx/stringops.h
233 wx/strvararg.h
234 wx/sysopt.h
235 wx/tarstrm.h
236 wx/textbuf.h
237 wx/textfile.h
238 wx/thread.h
239 wx/thrimpl.cpp
240 wx/timer.h
241 wx/tokenzr.h
242 wx/tracker.h
243 wx/txtstrm.h
244 wx/types.h
245 wx/unichar.h
246 wx/uri.h
247 wx/ustring.h
248 wx/utils.h
249 wx/variant.h
250 wx/vector.h
251 wx/version.h
252 wx/volume.h
253 wx/weakref.h
254 wx/wfstream.h
255 wx/wx.h
256 wx/wxchar.h
257 wx/wxcrt.h
258 wx/wxcrtbase.h
259 wx/wxcrtvararg.h
260 wx/wxprec.h
261 wx/xlocale.h
262 wx/xti.h
263 wx/xtistrm.h
264 wx/zipstrm.h
265 wx/zstream.h
266 wx/meta/convertible.h
267 wx/meta/if.h
268 wx/meta/int2type.h
269 wx/meta/movable.h
270 wx/private/fdiodispatcher.h
271 wx/private/selectdispatcher.h
272 wx/unix/app.h
273 wx/unix/apptbase.h
274 wx/unix/apptrait.h
275 wx/unix/chkconf.h
276 wx/unix/evtloop.h
277 wx/unix/pipe.h
278 wx/unix/stdpaths.h
279 wx/unix/stackwalk.h
280 wx/unix/tls.h
281 wx/unix/execute.h
282 wx/unix/mimetype.h
283 wx/unix/private.h
284 wx/private/gsocketiohandler.h
285 wx/fs_inet.h
286 wx/gsocket.h
287 wx/protocol/file.h
288 wx/protocol/ftp.h
289 wx/protocol/http.h
290 wx/protocol/protocol.h
291 wx/sckaddr.h
292 wx/sckipc.h
293 wx/sckstrm.h
294 wx/socket.h
295 wx/url.h
296 wx/unix/gsockunx.h
297 wx/xml/xml.h
298 wx/xtixml.h
299 EOF
300 # --- wxBase headers list ends here ---
301 for f in `cat wxbase-headers-list` ; do
302 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
303 done
304
305 # list of all core headers:
306 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
307
308 # contrib stuff:
309 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
310 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
311
312 # remove wxBase files so that RPM doesn't complain about unpackaged files:
313 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
314 %if %{unicode}
315 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
316 %endif
317 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
318 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
319
320 %clean
321 rm -rf $RPM_BUILD_ROOT
322
323 %post
324 /sbin/ldconfig
325
326 %postun
327 /sbin/ldconfig
328
329 %post devel
330 # link wx-config when you install RPM.
331 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
332 # link wx-config with explicit name.
333 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
334 /sbin/ldconfig
335
336 %postun devel
337 /sbin/ldconfig
338
339 %preun devel
340 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
341 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
342 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
343 if test "x$SUM1" = "x$SUM2" ; then
344 rm -f %{_bindir}/wx-config
345 fi
346 fi
347 rm -f %{_bindir}/%{wxconfiglink}
348
349 %post gl
350 /sbin/ldconfig
351
352 %postun gl
353 /sbin/ldconfig
354
355 %post contrib
356 /sbin/ldconfig
357
358 %postun contrib
359 /sbin/ldconfig
360
361 %post contrib-devel
362 /sbin/ldconfig
363
364 %postun contrib-devel
365 /sbin/ldconfig
366
367 %files
368 %defattr(-,root,root)
369 %doc COPYING.LIB *.txt
370 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
371 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
372 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
373 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
374 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
375 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
376
377
378 %files devel -f core-headers.files
379 %defattr(-,root,root)
380 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
381 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
382 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
383 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
384 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
385 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
386 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
387 %dir %{_libdir}/wx
388 %{_libdir}/wx/*
389 %{_bindir}/wxrc*
390
391 %files gl
392 %defattr(-,root,root)
393 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
394
395 %files static
396 %defattr (-,root,root)
397 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
398
399 %files contrib
400 %defattr(-,root,root)
401 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
402 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
403 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
404 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
405 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
406 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
407 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
408 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
409 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
410
411 %files contrib-devel
412 %defattr(-,root,root)
413 %dir %{_includedir}/wx-%{ver2}/wx/animate
414 %{_includedir}/wx-%{ver2}/wx/animate/*
415 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
416
417 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
418 %{_includedir}/wx-%{ver2}/wx/deprecated/*
419 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
420
421 %dir %{_includedir}/wx-%{ver2}/wx/fl
422 %{_includedir}/wx-%{ver2}/wx/fl/*
423 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
424
425 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
426 %{_includedir}/wx-%{ver2}/wx/gizmos/*
427 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
428
429 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
430 %{_includedir}/wx-%{ver2}/wx/mmedia/*
431 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
432
433 %dir %{_includedir}/wx-%{ver2}/wx/ogl
434 %{_includedir}/wx-%{ver2}/wx/ogl/*
435 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
436
437 %dir %{_includedir}/wx-%{ver2}/wx/plot
438 %{_includedir}/wx-%{ver2}/wx/plot/*
439 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
440
441 %dir %{_includedir}/wx-%{ver2}/wx/stc
442 %{_includedir}/wx-%{ver2}/wx/stc/*
443 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
444
445 %dir %{_includedir}/wx-%{ver2}/wx/svg
446 %{_includedir}/wx-%{ver2}/wx/svg/*
447 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so