Rebake after taskbar addition (apparently dlist.h commit didn't include rebake, so...
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfiglink wxbaseu-%{ver2}-config
46 %else
47 %define wxbasename wx-base-ansi
48 %define wxbaseconfig base-ansi-release-%{ver2}
49 %define wxbaseconfiglink wxbase-%{ver2}-config
50 %endif
51
52 Summary: The GTK+ %{gtkver} port of the wxWidgets library
53 Name: %{name}
54 Version: %{ver}
55 Release: %{rel}
56 License: wxWindows Licence
57 Group: X11/Libraries
58 Source: wxGTK-%{ver}.tar.bz2
59 URL: http://www.wxwidgets.org
60 Packager: Vadim Zeitlin <vadim@wxwindows.org>
61 Prefix: %{_prefix}
62 BuildRoot: %{_tmppath}/%{name}-root
63 Requires: %{wxbasename} = %{ver}
64 %if %{portname} == gtk2
65 BuildRequires: gtk+-2.0-devel
66 %else
67 BuildRequires: gtk+-devel >= 1.2.0
68 %endif
69
70 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
71
72 # all packages providing an implementation of wxWidgets library (regardless of
73 # the toolkit used) should provide the (virtual) wxwin package, this makes it
74 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
75 Provides: wxwin
76 Provides: wxGTK
77
78 %description
79 wxWidgets is a free C++ library for cross-platform GUI development.
80 With wxWidgets, you can create applications for different GUIs (GTK+,
81 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
82
83 %package -n wx-i18n
84 Summary: The translations for the wxWidgets library.
85 Group: X11/Libraries
86
87 %description -n wx-i18n
88 The translations files for the wxWidgets library.
89
90 %package devel
91 Summary: The GTK+ %{gtkver} port of the wxWidgets library
92 Group: X11/Libraries
93 Requires: %{name} = %{ver}
94 Requires: %{wxbasename}-devel = %{ver}
95 Provides: wxGTK-devel
96
97 %description devel
98 The GTK+ %{gtkver} port of the wxWidgets library, header files.
99
100 %package gl
101 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
102 Group: X11/Libraries
103 Requires: %{name} = %{ver}
104 Provides: wxGTK-gl
105
106 %description gl
107 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
108
109 %package -n %{wxbasename}
110 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
111 Group: Development/Libraries
112 Provides: wxBase
113
114 %description -n %{wxbasename}
115 wxBase is a collection of C++ classes providing basic data structures (strings,
116 lists, arrays), portable wrappers around many OS-specific funstions (file
117 operations, time/date manipulations, threads, processes, sockets, shared
118 library loading) as well as other utility classes (streams, archive and
119 compression). wxBase currently supports Win32, most Unix variants (Linux,
120 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
121
122 %package -n %{wxbasename}-devel
123 Summary: wxBase library, header files.
124 Group: Development/Libraries
125 Provides: wxBase-devel
126
127 %description -n %{wxbasename}-devel
128 wxBase library - non-GUI support classes of the wxWidgets toolkit,
129 header files.
130
131 %package contrib
132 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
133 Group: X11/Libraries
134 Requires: %{name} = %{ver}
135
136 %description contrib
137 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
138
139 %package contrib-devel
140 Summary: The GTK+ %{gtkver} port of the wxWidgets library
141 Group: X11/Libraries
142 Requires: %{name}-contrib = %{ver}
143 Requires: %{name}-devel = %{ver}
144
145 %description contrib-devel
146 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
147
148 %prep
149 %setup -q -n wxGTK-%{ver}
150
151 %build
152 if [ "$SMP" != "" ]; then
153 export MAKE="make -j$SMP"
154 else
155 export MAKE="make"
156 fi
157
158 mkdir obj-shared
159 cd obj-shared
160 ../configure --prefix=%{_prefix} \
161 %if ! %{gtk2}
162 --with-gtk=1 \
163 %else
164 --with-gtk=2 \
165 %endif
166 %if %{unicode}
167 --enable-unicode \
168 %else
169 --disable-unicode \
170 %endif
171 --with-opengl
172 $MAKE
173
174 cd contrib/src
175 $MAKE
176 cd ../../..
177
178 mkdir obj-static
179 cd obj-static
180 ../configure --prefix=%{_prefix} \
181 %if ! %{gtk2}
182 --with-gtk=1 \
183 %else
184 --with-gtk=2 \
185 %endif
186 --disable-shared \
187 %if %{unicode}
188 --enable-unicode \
189 %else
190 --disable-unicode \
191 %endif
192 --with-opengl
193 $MAKE
194
195 cd contrib/src
196 $MAKE
197 cd ../../..
198
199 make -C locale allmo
200
201 %install
202 rm -rf $RPM_BUILD_ROOT
203 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
204 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
205
206 # --- wxBase headers list begins here ---
207 cat <<EOF >wxbase-headers.files
208 wx/afterstd.h
209 wx/app.h
210 wx/apptrait.h
211 wx/archive.h
212 wx/arrimpl.cpp
213 wx/arrstr.h
214 wx/atomic.h
215 wx/base64.h
216 wx/beforestd.h
217 wx/buffer.h
218 wx/build.h
219 wx/chartype.h
220 wx/chkconf.h
221 wx/clntdata.h
222 wx/cmdargs.h
223 wx/cmdline.h
224 wx/confbase.h
225 wx/config.h
226 wx/convauto.h
227 wx/containr.h
228 wx/cpp.h
229 wx/crt.h
230 wx/datetime.h
231 wx/datstrm.h
232 wx/dde.h
233 wx/debug.h
234 wx/defs.h
235 wx/dir.h
236 wx/dlimpexp.h
237 wx/dlist.h
238 wx/dynarray.h
239 wx/dynlib.h
240 wx/dynload.h
241 wx/encconv.h
242 wx/event.h
243 wx/except.h
244 wx/features.h
245 wx/flags.h
246 wx/ffile.h
247 wx/file.h
248 wx/fileconf.h
249 wx/filefn.h
250 wx/filename.h
251 wx/filesys.h
252 wx/fontenc.h
253 wx/fontmap.h
254 wx/fs_arc.h
255 wx/fs_filter.h
256 wx/fs_mem.h
257 wx/fs_zip.h
258 wx/hash.h
259 wx/hashmap.h
260 wx/hashset.h
261 wx/html/forcelnk.h
262 wx/iconloc.h
263 wx/init.h
264 wx/intl.h
265 wx/iosfwrap.h
266 wx/ioswrap.h
267 wx/ipc.h
268 wx/ipcbase.h
269 wx/link.h
270 wx/list.h
271 wx/listimpl.cpp
272 wx/log.h
273 wx/longlong.h
274 wx/math.h
275 wx/memconf.h
276 wx/memory.h
277 wx/memtext.h
278 wx/mimetype.h
279 wx/module.h
280 wx/msgout.h
281 wx/mstream.h
282 wx/object.h
283 wx/platform.h
284 wx/platinfo.h
285 wx/power.h
286 wx/process.h
287 wx/ptr_scpd.h
288 wx/ptr_shrd.h
289 wx/recguard.h
290 wx/regex.h
291 wx/scopeguard.h
292 wx/snglinst.h
293 wx/sstream.h
294 wx/stack.h
295 wx/stackwalk.h
296 wx/stdpaths.h
297 wx/stockitem.h
298 wx/stopwatch.h
299 wx/strconv.h
300 wx/stream.h
301 wx/string.h
302 wx/stringimpl.h
303 wx/stringops.h
304 wx/strvararg.h
305 wx/sysopt.h
306 wx/tarstrm.h
307 wx/textbuf.h
308 wx/textfile.h
309 wx/thread.h
310 wx/thrimpl.cpp
311 wx/timer.h
312 wx/tokenzr.h
313 wx/tracker.h
314 wx/txtstrm.h
315 wx/types.h
316 wx/unichar.h
317 wx/uri.h
318 wx/ustring.h
319 wx/utils.h
320 wx/variant.h
321 wx/vector.h
322 wx/version.h
323 wx/volume.h
324 wx/weakref.h
325 wx/wfstream.h
326 wx/wx.h
327 wx/wxchar.h
328 wx/wxcrt.h
329 wx/wxcrtbase.h
330 wx/wxcrtvararg.h
331 wx/wxprec.h
332 wx/xlocale.h
333 wx/xti.h
334 wx/xtistrm.h
335 wx/zipstrm.h
336 wx/zstream.h
337 wx/meta/convertible.h
338 wx/meta/if.h
339 wx/meta/int2type.h
340 wx/meta/movable.h
341 wx/private/fdiodispatcher.h
342 wx/private/selectdispatcher.h
343 wx/unix/app.h
344 wx/unix/apptbase.h
345 wx/unix/apptrait.h
346 wx/unix/chkconf.h
347 wx/unix/evtloop.h
348 wx/unix/pipe.h
349 wx/unix/stdpaths.h
350 wx/unix/stackwalk.h
351 wx/unix/tls.h
352 wx/unix/execute.h
353 wx/unix/mimetype.h
354 wx/unix/private.h
355 wx/private/gsocketiohandler.h
356 wx/fs_inet.h
357 wx/gsocket.h
358 wx/protocol/file.h
359 wx/protocol/ftp.h
360 wx/protocol/http.h
361 wx/protocol/protocol.h
362 wx/sckaddr.h
363 wx/sckipc.h
364 wx/sckstrm.h
365 wx/socket.h
366 wx/url.h
367 wx/unix/gsockunx.h
368 wx/xml/xml.h
369 wx/xtixml.h
370 EOF
371 # --- wxBase headers list ends here ---
372 cat <<EOF >wxbase-headers.paths
373 %{_includedir}/wx-%{ver2}/wx/afterstd.h
374 %{_includedir}/wx-%{ver2}/wx/app.h
375 %{_includedir}/wx-%{ver2}/wx/apptrait.h
376 %{_includedir}/wx-%{ver2}/wx/archive.h
377 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
378 %{_includedir}/wx-%{ver2}/wx/arrstr.h
379 %{_includedir}/wx-%{ver2}/wx/beforestd.h
380 %{_includedir}/wx-%{ver2}/wx/buffer.h
381 %{_includedir}/wx-%{ver2}/wx/build.h
382 %{_includedir}/wx-%{ver2}/wx/chkconf.h
383 %{_includedir}/wx-%{ver2}/wx/clntdata.h
384 %{_includedir}/wx-%{ver2}/wx/cmdline.h
385 %{_includedir}/wx-%{ver2}/wx/confbase.h
386 %{_includedir}/wx-%{ver2}/wx/config.h
387 %{_includedir}/wx-%{ver2}/wx/containr.h
388 %{_includedir}/wx-%{ver2}/wx/convauto.h
389 %{_includedir}/wx-%{ver2}/wx/datetime.h
390 %{_includedir}/wx-%{ver2}/wx/datstrm.h
391 %{_includedir}/wx-%{ver2}/wx/dde.h
392 %{_includedir}/wx-%{ver2}/wx/debug.h
393 %{_includedir}/wx-%{ver2}/wx/defs.h
394 %{_includedir}/wx-%{ver2}/wx/dir.h
395 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
396 %{_includedir}/wx-%{ver2}/wx/dynarray.h
397 %{_includedir}/wx-%{ver2}/wx/dynlib.h
398 %{_includedir}/wx-%{ver2}/wx/dynload.h
399 %{_includedir}/wx-%{ver2}/wx/encconv.h
400 %{_includedir}/wx-%{ver2}/wx/event.h
401 %{_includedir}/wx-%{ver2}/wx/except.h
402 %{_includedir}/wx-%{ver2}/wx/features.h
403 %{_includedir}/wx-%{ver2}/wx/ffile.h
404 %{_includedir}/wx-%{ver2}/wx/file.h
405 %{_includedir}/wx-%{ver2}/wx/fileconf.h
406 %{_includedir}/wx-%{ver2}/wx/filefn.h
407 %{_includedir}/wx-%{ver2}/wx/filename.h
408 %{_includedir}/wx-%{ver2}/wx/filesys.h
409 %{_includedir}/wx-%{ver2}/wx/fontenc.h
410 %{_includedir}/wx-%{ver2}/wx/fontmap.h
411 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
412 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
413 %{_includedir}/wx-%{ver2}/wx/hash.h
414 %{_includedir}/wx-%{ver2}/wx/hashmap.h
415 %{_includedir}/wx-%{ver2}/wx/hashset.h
416 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
417 %{_includedir}/wx-%{ver2}/wx/iconloc.h
418 %{_includedir}/wx-%{ver2}/wx/init.h
419 %{_includedir}/wx-%{ver2}/wx/intl.h
420 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
421 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
422 %{_includedir}/wx-%{ver2}/wx/ipc.h
423 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
424 %{_includedir}/wx-%{ver2}/wx/isql.h
425 %{_includedir}/wx-%{ver2}/wx/isqlext.h
426 %{_includedir}/wx-%{ver2}/wx/link.h
427 %{_includedir}/wx-%{ver2}/wx/list.h
428 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
429 %{_includedir}/wx-%{ver2}/wx/log.h
430 %{_includedir}/wx-%{ver2}/wx/longlong.h
431 %{_includedir}/wx-%{ver2}/wx/math.h
432 %{_includedir}/wx-%{ver2}/wx/memconf.h
433 %{_includedir}/wx-%{ver2}/wx/memory.h
434 %{_includedir}/wx-%{ver2}/wx/memtext.h
435 %{_includedir}/wx-%{ver2}/wx/mimetype.h
436 %{_includedir}/wx-%{ver2}/wx/module.h
437 %{_includedir}/wx-%{ver2}/wx/msgout.h
438 %{_includedir}/wx-%{ver2}/wx/mstream.h
439 %{_includedir}/wx-%{ver2}/wx/object.h
440 %{_includedir}/wx-%{ver2}/wx/platform.h
441 %{_includedir}/wx-%{ver2}/wx/power.h
442 %{_includedir}/wx-%{ver2}/wx/process.h
443 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
444 %{_includedir}/wx-%{ver2}/wx/recguard.h
445 %{_includedir}/wx-%{ver2}/wx/regex.h
446 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
447 %{_includedir}/wx-%{ver2}/wx/snglinst.h
448 %{_includedir}/wx-%{ver2}/wx/sstream.h
449 %{_includedir}/wx-%{ver2}/wx/stack.h
450 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
451 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
452 %{_includedir}/wx-%{ver2}/wx/stockitem.h
453 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
454 %{_includedir}/wx-%{ver2}/wx/strconv.h
455 %{_includedir}/wx-%{ver2}/wx/stream.h
456 %{_includedir}/wx-%{ver2}/wx/string.h
457 %{_includedir}/wx-%{ver2}/wx/sysopt.h
458 %{_includedir}/wx-%{ver2}/wx/textbuf.h
459 %{_includedir}/wx-%{ver2}/wx/textfile.h
460 %{_includedir}/wx-%{ver2}/wx/thread.h
461 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
462 %{_includedir}/wx-%{ver2}/wx/timer.h
463 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
464 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
465 %{_includedir}/wx-%{ver2}/wx/types.h
466 %{_includedir}/wx-%{ver2}/wx/uri.h
467 %{_includedir}/wx-%{ver2}/wx/utils.h
468 %{_includedir}/wx-%{ver2}/wx/variant.h
469 %{_includedir}/wx-%{ver2}/wx/vector.h
470 %{_includedir}/wx-%{ver2}/wx/version.h
471 %{_includedir}/wx-%{ver2}/wx/volume.h
472 %{_includedir}/wx-%{ver2}/wx/wfstream.h
473 %{_includedir}/wx-%{ver2}/wx/wx.h
474 %{_includedir}/wx-%{ver2}/wx/wxchar.h
475 %{_includedir}/wx-%{ver2}/wx/wxprec.h
476 %{_includedir}/wx-%{ver2}/wx/xti.h
477 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
478 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
479 %{_includedir}/wx-%{ver2}/wx/zstream.h
480 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
481 %{_includedir}/wx-%{ver2}/wx/gsocket.h
482 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
483 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
484 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
485 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
486 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
487 %{_includedir}/wx-%{ver2}/wx/sckipc.h
488 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
489 %{_includedir}/wx-%{ver2}/wx/socket.h
490 %{_includedir}/wx-%{ver2}/wx/url.h
491 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
492 %{_includedir}/wx-%{ver2}/wx/xtixml.h
493 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
494 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
495 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
496 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
497 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
498 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
499 %{_includedir}/wx-%{ver2}/wx/unix/private.h
500 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
501 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
502 EOF
503 # --- wxBase headers list ends here ---
504
505 # temporarily remove base headers
506 mkdir $RPM_BUILD_ROOT/_save_dir
507 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
508 for f in `cat wxbase-headers.files` ; do
509 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
510 done
511 # list of all core headers:
512 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
513 # move base headers (actually all headers) back again
514 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
515 rm -rf $RPM_BUILD_ROOT/_save_dir
516
517 # contrib stuff:
518 (cd obj-static/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
519 (cd obj-shared/contrib; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
520
521 # utils:
522 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
523
524 # wx-config link is created during package installation, remove it for now
525 rm -f $RPM_BUILD_ROOT%{_bindir}/wx-config
526
527 %clean
528 rm -rf $RPM_BUILD_ROOT
529
530 %post
531 /sbin/ldconfig
532
533 %postun
534 /sbin/ldconfig
535
536 %post devel
537 # link wx-config when you install RPM.
538 %if %{unicode}
539 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
540 %endif
541 # link wx-config with explicit name.
542 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
543 /sbin/ldconfig
544
545 %postun devel
546 /sbin/ldconfig
547
548 %preun devel
549 %if %{unicode}
550 rm -f %{_bindir}/wx-config
551 %endif
552 rm -f %{_bindir}/%{wxconfiglink}
553
554 %post -n %{wxbasename}
555 /sbin/ldconfig
556
557 %postun -n %{wxbasename}
558 /sbin/ldconfig
559
560 %post -n %{wxbasename}-devel
561 # link wx-config with explicit name.
562 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
563 /sbin/ldconfig
564
565 %postun -n %{wxbasename}-devel
566 /sbin/ldconfig
567
568 %preun -n %{wxbasename}-devel
569 rm -f %{_bindir}/%{wxbaseconfiglink}
570
571 %post gl
572 /sbin/ldconfig
573
574 %postun gl
575 /sbin/ldconfig
576
577 %post contrib
578 /sbin/ldconfig
579
580 %postun contrib
581 /sbin/ldconfig
582
583 %post contrib-devel
584 /sbin/ldconfig
585
586 %postun contrib-devel
587 /sbin/ldconfig
588
589 %files
590 %defattr(-,root,root)
591 %doc COPYING.LIB *.txt
592 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
593 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so.*
594 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
595 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
596 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
597 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
598 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so.*
599 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
600
601 %files -n wx-i18n
602 %defattr(-,root,root)
603 %{_datadir}/locale/*/LC_MESSAGES/*.mo
604
605 %files devel -f core-headers.files
606 %defattr(-,root,root)
607 # shared libs
608 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
609 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.so
610 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
611 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
612 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
613 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
614 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
615 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.so
616 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
617 # static libs
618 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
619 %{_libdir}/libwx_%{buildname}_aui-%{ver2}.a
620 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
621 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
622 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
623 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
624 %{_libdir}/libwx_%{buildname}_richtext-%{ver2}.a
625 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
626 %dir %{_libdir}/wx
627 %{_libdir}/wx/config/%{wxconfig}
628 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
629 %{_libdir}/wx/config/%{wxconfigstatic}
630 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
631 %{_bindir}/wxrc*
632
633 %files -n %{wxbasename}
634 %defattr(-,root,root)
635 %{_libdir}/libwx_base*-%{ver2}.so.*
636
637 %files -n %{wxbasename}-devel -f wxbase-headers.paths
638 %defattr (-,root,root)
639 %dir %{_includedir}/wx-%{ver2}
640 %{_libdir}/libwx_base*-%{ver2}.so
641 %{_libdir}/libwx_base*-%{ver2}.a
642 %if %{unicode}
643 %{_libdir}/libwxregexu-%{ver2}.a
644 %endif
645 %dir %{_libdir}/wx
646 %{_datadir}/aclocal/*.m4
647 %{_datadir}/bakefile/presets/*
648
649 %files gl
650 %defattr(-,root,root)
651 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
652
653 %files contrib
654 %defattr(-,root,root)
655 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
656 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
657 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
658 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
659 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
660 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
661 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
662 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
663 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
664 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
665
666 # static libs
667 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.a
668 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.a
669 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.a
670 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.a
671 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.a
672 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.a
673 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.a
674 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.a
675 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.a
676 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.a
677
678 %files contrib-devel
679 %defattr(-,root,root)
680 %dir %{_includedir}/wx-%{ver2}/wx/animate
681 %{_includedir}/wx-%{ver2}/wx/animate/*
682 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
683
684 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
685 %{_includedir}/wx-%{ver2}/wx/deprecated/*
686 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
687
688 %dir %{_includedir}/wx-%{ver2}/wx/fl
689 %{_includedir}/wx-%{ver2}/wx/fl/*
690 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
691
692 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
693 %{_includedir}/wx-%{ver2}/wx/gizmos/*
694 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
695 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
696
697 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
698 %{_includedir}/wx-%{ver2}/wx/mmedia/*
699 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
700
701 %dir %{_includedir}/wx-%{ver2}/wx/ogl
702 %{_includedir}/wx-%{ver2}/wx/ogl/*
703 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
704
705 %dir %{_includedir}/wx-%{ver2}/wx/plot
706 %{_includedir}/wx-%{ver2}/wx/plot/*
707 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
708
709 %dir %{_includedir}/wx-%{ver2}/wx/stc
710 %{_includedir}/wx-%{ver2}/wx/stc/*
711 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
712
713 %dir %{_includedir}/wx-%{ver2}/wx/svg
714 %{_includedir}/wx-%{ver2}/wx/svg/*
715 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so