7 %define name wx
-%{portname}
8 %define wxbasename wx
-base
10 %define wxconfig
%{portname}-ansi-release-%{ver2}
11 %define wxconfiglink wx
%{portname}-%{ver2}-config
13 Summary: The Motif
/Lesstif port of the wxWidgets library
17 License: wxWindows Licence
19 Source: wxMotif
-%{ver}.tar.bz2
20 URL: http
://www.wxwidgets.org
21 Packager: wxWidgets developers
<wx
-dev@lists.wxwidgets.org
>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
32 wxWidgets is a free C
++ library
for cross
-platform GUI development.
33 With wxWidgets
, you can create applications
for different GUIs
(GTK
+,
34 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
37 Summary: The Motif
/Lesstif port of the wxWidgets library
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
43 Header files
for wxMotif
, the Motif
/Lesstif port of the wxWidgets library.
46 Summary: The Motif
/Lesstif port of the wxWidgets library
, OpenGL add
-on.
48 Requires: %{name} = %{ver}
51 OpenGL add
-on library
for wxMotif
, the Motif
/Lesstif port of the wxWidgets library.
54 Summary: wxMotif static libraries
55 Group: Development
/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
60 Static libraries
for wxMotif. You need them
if you want to link statically against wxMotif.
63 Summary: Contrib libraries
for wxMotif
65 Requires: %{name} = %{ver}
68 Contrib libraries
for wxMotif
70 %package contrib
-devel
71 Summary: Contrib libraries
for wxMotif
73 Requires: %{name}-contrib = %{ver}
74 Requires: %{name}-devel = %{ver}
76 %description contrib
-devel
77 Header files
for contributed libraries
for wxMotif.
80 %setup -q
-n wxMotif
-%{ver}
83 if [ "$SMP"
!= ""
]; then
84 export MAKE
="
make -j$SMP"
91 ..
/configure
--prefix
=%{pref} --with
-motif
--with
-opengl
100 ..
/configure
--prefix
=%{pref} --with
-motif
--disable
-shared
--with
-opengl
105 rm -rf $RPM_BUILD_ROOT
106 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
107 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
109 # Remove headers that are part of wx-base-devel:
111 # --- wxBase headers list begins here ---
112 cat
<<EOF
>wxbase
-headers.files
240 wx
/meta
/convertible.h
244 wx
/private
/fdiodispatcher.h
245 wx
/private
/selectdispatcher.h
257 wx
/private
/gsocketiohandler.h
263 wx
/protocol
/protocol.h
273 # --- wxBase headers list ends here ---
274 for f
in `cat wxbase
-headers
-list`
; do
275 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2}/$f
278 # list of all core headers:
279 find $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} -type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
282 (cd obj
-shared
/contrib
/src
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
283 (cd obj
-shared
/utils
/wxrc
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
285 # remove wxBase files so that RPM doesn't complain about unpackaged files:
286 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwx_base
*
287 rm -f $RPM_BUILD_ROOT
%{_datadir}/aclocal
/*
288 rm -f $RPM_BUILD_ROOT
%{_datadir}/locale
/*/*/*
291 rm -rf $RPM_BUILD_ROOT
300 # link wx-config when you install RPM.
301 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx
-config
302 # link wx-config with explicit name.
303 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
310 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
311 SUM1
=`md5sum
%{_libdir}/wx/config/%{wxconfig} | cut
-c
0-32`
312 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
313 if test "x$SUM1"
= "x$SUM2"
; then
314 rm -f
%{_bindir}/wx
-config
317 rm -f
%{_bindir}/%{wxconfiglink}
334 %postun contrib
-devel
338 %defattr(-,root
,root
)
339 %doc COPYING.LIB
*.txt
340 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.
*
341 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.
*
342 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.
*
343 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.
*
344 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.
*
345 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.
*
348 %files devel
-f core
-headers.files
349 %defattr(-,root
,root
)
350 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
351 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
352 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
353 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
354 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
355 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
356 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
362 %defattr(-,root
,root
)
363 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.
*
366 %defattr (-,root
,root
)
367 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
370 %defattr(-,root
,root
)
371 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.
*
372 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.
*
373 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.
*
374 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.
*
375 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.
*
376 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.
*
377 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.
*
378 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.
*
379 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.
*
382 %defattr(-,root
,root
)
383 %dir %{_includedir}/wx-%{ver2}/wx
/animate
384 %{_includedir}/wx-%{ver2}/wx
/animate
/*
385 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
387 %dir %{_includedir}/wx-%{ver2}/wx
/deprecated
388 %{_includedir}/wx-%{ver2}/wx
/deprecated
/*
389 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
391 %dir %{_includedir}/wx-%{ver2}/wx
/fl
392 %{_includedir}/wx-%{ver2}/wx
/fl
/*
393 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
395 %dir %{_includedir}/wx-%{ver2}/wx
/gizmos
396 %{_includedir}/wx-%{ver2}/wx
/gizmos
/*
397 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
399 %dir %{_includedir}/wx-%{ver2}/wx
/mmedia
400 %{_includedir}/wx-%{ver2}/wx
/mmedia
/*
401 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
403 %dir %{_includedir}/wx-%{ver2}/wx
/ogl
404 %{_includedir}/wx-%{ver2}/wx
/ogl
/*
405 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
407 %dir %{_includedir}/wx-%{ver2}/wx
/plot
408 %{_includedir}/wx-%{ver2}/wx
/plot
/*
409 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
411 %dir %{_includedir}/wx-%{ver2}/wx
/stc
412 %{_includedir}/wx-%{ver2}/wx
/stc
/*
413 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
415 %dir %{_includedir}/wx-%{ver2}/wx
/svg
416 %{_includedir}/wx-%{ver2}/wx
/svg
/*
417 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so