]> git.saurik.com Git - wxWidgets.git/blob - wxGTK.spec
added wxSockAddress copy ctor which, in particular, fixes Clone() and fixed its opera...
[wxWidgets.git] / wxGTK.spec
1 %define pref /usr
2 %define ver 2.3.2
3 %define ver2 2.3
4 %define rel 0
5
6 Summary: The GTK+ 1.2 port of the wxWindows library
7 Name: wxGTK
8 Version: %{ver}
9 Release: %{rel}
10 Copyright: wxWindows Licence
11 Group: X11/Libraries
12 Source: wxGTK-%{ver}.tar.bz2
13 URL: http://www.wxwindows.org
14 Packager: Vadim Zeitlin <vadim@wxwindows.org>
15 Prefix: %{pref}
16 BuildRoot: /var/tmp/%{name}-root
17
18 # all packages providing an implementation of wxWindows library (regardless of
19 # the toolkit used) should provide the (virtual) wxwin package, this makes it
20 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
21 Provides: wxwin
22
23 # in addition, we should provide libwx_gtk as automatic generator only notices
24 # libwx_gtk-%{ver}-%{rel}
25 Provides: libwx_gtk.so
26 Provides: libwx_gtk-%{ver2}.so
27
28 %description
29 wxWindows is a free C++ library for cross-platform GUI development.
30 With wxWindows, you can create applications for different GUIs (GTK+,
31 Motif/LessTif, MS Windows, Mac) from the same source code.
32
33 %package devel
34 Summary: The GTK+ 1.2 port of the wxWindows library
35 Group: X11/Libraries
36 Requires: wxGTK = %{ver}
37
38 %description devel
39 Header files for wxGTK, the GTK+ 1.2 port of the wxWindows library.
40
41 %package gl
42 Summary: The GTK+ 1.2 port of the wxWindows library, OpenGL add-on.
43 Group: X11/Libraries
44 Requires: wxGTK = %{ver}
45
46 %description gl
47 OpenGL add-on library for wxGTK, the GTK+ 1.2 port of the wxWindows library.
48
49 %package static
50 Summary: wxGTK static libraries
51 Group: Development/Libraries
52
53 %description static
54 Static libraries for wxGTK. You need them if you want to link statically against wxGTK.
55
56 %prep
57 %setup -n wxGTK-%{ver}
58
59 %build
60 if [ "$SMP" != "" ]; then
61 export MAKE="make -j$SMP"
62 else
63 export MAKE="make"
64 fi
65
66 (cd locale; make allmo)
67
68 mkdir obj-shared
69 cd obj-shared
70 ../configure --prefix=%{pref} --enable-soname --with-odbc --with-opengl
71 $MAKE
72 cd ..
73
74 mkdir obj-static
75 cd obj-static
76 ../configure --prefix=%{pref} --disable-shared --with-odbc --with-opengl
77 $MAKE
78 cd ..
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
83 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
84
85 %post
86 /sbin/ldconfig
87
88 %postun
89 /sbin/ldconfig
90
91 %post gl
92 /sbin/ldconfig
93
94 %postun gl
95 /sbin/ldconfig
96
97 %post devel
98 # Install wx-config if there isn't any
99 if test ! -f %{_bindir}/wx-config ; then
100 ln -sf wxgtk-%{ver2}-config %{_bindir}/wx-config
101 fi
102
103 %preun devel
104 # Remove wx-config if it points to this package
105 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
106 SUM1=`md5sum %{_bindir}/wxgtk-%{ver2}-config | cut -c 0-32`
107 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
108 if test "x$SUM1" = "x$SUM2" ; then
109 rm -f %{_bindir}/wx-config
110 fi
111 fi
112
113
114 %files
115 %defattr(-,root,root)
116 %doc COPYING.LIB *.txt
117 %dir %{_datadir}/wx
118 %{_datadir}/wx/*
119 %{_datadir}/locale/*/*/*.mo
120 %{_libdir}/libwx_gtk-%{ver2}*.so.*
121
122 %files devel
123 %defattr(-,root,root)
124 %{_libdir}/libwx_gtk-%{ver2}*.so
125 %dir %{_includedir}/wx
126 %{_includedir}/wx/*
127 %dir %{_libdir}/wx
128 %{_libdir}/wx/*
129 %{_bindir}/wxgtk-%{ver2}-config
130
131 %files gl
132 %defattr(-,root,root)
133 %{_libdir}/libwx_gtk_gl*
134
135 %files static
136 %defattr (-,root,root)
137 %{_libdir}/lib*.a