Added wxIsPod<>. Use it in wxAny instead of wxIsMovable<>.
[wxWidgets.git] / wxX11.spec
1 %define pref /usr
2 %define ver 2.9.1
3 %define ver2 2.9
4 %define rel 1
5
6 # Configurable settings (use --with(out) unicode on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define portname x11univ
12
13 %if %{unicode}
14 %define wxbasename wx-base-unicode
15 %define name wx-%{portname}-unicode
16 %define wxconfig %{portname}-unicode-release-%{ver2}
17 %define wxconfiglink wx%{portname}u-%{ver2}-config
18 %else
19 %define wxbasename wx-base
20 %define name wx-%{portname}
21 %define wxconfig %{portname}-ansi-release-%{ver2}
22 %define wxconfiglink wx%{portname}-%{ver2}-config
23 %endif
24
25 Summary: The X11 port of the wxWidgets library
26 Name: %{name}
27 Version: %{ver}
28 Release: %{rel}
29 License: wxWindows Licence
30 Group: X11/Libraries
31 Source: wxX11-%{ver}.tar.bz2
32 URL: http://www.wxwidgets.org
33 Packager: Vadim Zeitlin <vadim@wxwindows.org>
34 Prefix: %{pref}
35 BuildRoot: %{_tmppath}/%{name}-root
36 Requires: %{wxbasename} = %{ver}
37
38 # all packages providing an implementation of wxWidgets library (regardless of
39 # the toolkit used) should provide the (virtual) wxwin package, this makes it
40 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
41 Provides: wxwin
42 Provides: wxX11
43
44 %description
45 wxWidgets is a free C++ library for cross-platform GUI development.
46 With wxWidgets, you can create applications for different GUIs (GTK+,
47 Motif/LessTif, MS Windows, Mac) from the same source code.
48
49 %package devel
50 Summary: The X11 port of the wxWidgets library
51 Group: X11/Libraries
52 Requires: %{name} = %{ver}
53 Requires: %{wxbasename}-devel = %{ver}
54
55 %description devel
56 Header files for wxX11, the X11 port of the wxWidgets library.
57
58 %package gl
59 Summary: The X11 port of the wxWidgets library, OpenGL add-on.
60 Group: X11/Libraries
61 Requires: %{name} = %{ver}
62
63 %description gl
64 OpenGL add-on library for wxX11, the X11 port of the wxWidgets library.
65
66 %package static
67 Summary: wxX11 static libraries
68 Group: Development/Libraries
69 Requires: %{wxbasename}-static
70 Requires: %{name}-devel = %{ver}
71
72 %description static
73 Static libraries for wxX11. You need them if you want to link statically against wxX11.
74
75 %package contrib
76 Summary: Contrib libraries for wxX11.
77 Group: X11/Libraries
78 Requires: %{name} = %{ver}
79
80 %description contrib
81 Contributed libraries for wxX11.
82
83 %package contrib-devel
84 Summary: Contrib libraries for wxX11.
85 Group: X11/Libraries
86 Requires: %{name}-contrib = %{ver}
87 Requires: %{name}-devel = %{ver}
88
89 %description contrib-devel
90 Header files for contributed libraries for wxX11.
91
92 %prep
93 %setup -q -n wxX11-%{ver}
94
95 %build
96 if [ "$SMP" != "" ]; then
97 export MAKE="make -j$SMP"
98 else
99 export MAKE="make"
100 fi
101
102 mkdir obj-shared
103 cd obj-shared
104 ../configure --prefix=%{pref} --with-x11 \
105 %if %{unicode}
106 --enable-unicode \
107 %else
108 --disable-unicode \
109 %endif
110 $MAKE
111
112 cd contrib/src
113 $MAKE
114 cd ../../..
115
116 mkdir obj-static
117 cd obj-static
118 ../configure --prefix=%{pref} --with-x11 --disable-shared \
119 %if %{unicode}
120 --enable-unicode \
121 %else
122 --disable-unicode \
123 %endif
124 --with-opengl
125 $MAKE
126 cd ..
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
131 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
132
133 # Remove headers that are part of wx-base-devel:
134
135 # --- wxBase headers list begins here ---
136 cat <<EOF >wxbase-headers.files
137 wx/afterstd.h
138 wx/any.h
139 wx/anystr.h
140 wx/app.h
141 wx/apptrait.h
142 wx/archive.h
143 wx/arrimpl.cpp
144 wx/arrstr.h
145 wx/atomic.h
146 wx/base64.h
147 wx/beforestd.h
148 wx/buffer.h
149 wx/build.h
150 wx/chartype.h
151 wx/checkeddelete.h
152 wx/chkconf.h
153 wx/clntdata.h
154 wx/cmdargs.h
155 wx/cmdline.h
156 wx/confbase.h
157 wx/config.h
158 wx/convauto.h
159 wx/containr.h
160 wx/cpp.h
161 wx/crt.h
162 wx/datetime.h
163 wx/datstrm.h
164 wx/dde.h
165 wx/debug.h
166 wx/defs.h
167 wx/dir.h
168 wx/dlimpexp.h
169 wx/dlist.h
170 wx/dynarray.h
171 wx/dynlib.h
172 wx/dynload.h
173 wx/encconv.h
174 wx/event.h
175 wx/evtloop.h
176 wx/except.h
177 wx/features.h
178 wx/flags.h
179 wx/ffile.h
180 wx/file.h
181 wx/fileconf.h
182 wx/filefn.h
183 wx/filename.h
184 wx/filesys.h
185 wx/fontenc.h
186 wx/fontmap.h
187 wx/fs_arc.h
188 wx/fs_filter.h
189 wx/fs_mem.h
190 wx/fs_zip.h
191 wx/hash.h
192 wx/hashmap.h
193 wx/hashset.h
194 wx/html/forcelnk.h
195 wx/iconloc.h
196 wx/init.h
197 wx/intl.h
198 wx/iosfwrap.h
199 wx/ioswrap.h
200 wx/ipc.h
201 wx/ipcbase.h
202 wx/kbdstate.h
203 wx/language.h
204 wx/link.h
205 wx/list.h
206 wx/listimpl.cpp
207 wx/log.h
208 wx/longlong.h
209 wx/math.h
210 wx/memconf.h
211 wx/memory.h
212 wx/memtext.h
213 wx/mimetype.h
214 wx/module.h
215 wx/mousestate.h
216 wx/msgout.h
217 wx/msgqueue.h
218 wx/mstream.h
219 wx/object.h
220 wx/platform.h
221 wx/platinfo.h
222 wx/power.h
223 wx/process.h
224 wx/ptr_scpd.h
225 wx/ptr_shrd.h
226 wx/recguard.h
227 wx/regex.h
228 wx/scopedarray.h
229 wx/scopedptr.h
230 wx/scopeguard.h
231 wx/sharedptr.h
232 wx/snglinst.h
233 wx/sstream.h
234 wx/stack.h
235 wx/stackwalk.h
236 wx/stdpaths.h
237 wx/stdstream.h
238 wx/stockitem.h
239 wx/stopwatch.h
240 wx/strconv.h
241 wx/stream.h
242 wx/string.h
243 wx/stringimpl.h
244 wx/stringops.h
245 wx/strvararg.h
246 wx/sysopt.h
247 wx/tarstrm.h
248 wx/textbuf.h
249 wx/textfile.h
250 wx/thread.h
251 wx/thrimpl.cpp
252 wx/timer.h
253 wx/tls.h
254 wx/tokenzr.h
255 wx/tracker.h
256 wx/translation.h
257 wx/txtstrm.h
258 wx/typeinfo.h
259 wx/types.h
260 wx/unichar.h
261 wx/uri.h
262 wx/ustring.h
263 wx/utils.h
264 wx/variant.h
265 wx/vector.h
266 wx/version.h
267 wx/volume.h
268 wx/weakref.h
269 wx/wfstream.h
270 wx/wx.h
271 wx/wxchar.h
272 wx/wxcrt.h
273 wx/wxcrtbase.h
274 wx/wxcrtvararg.h
275 wx/wxprec.h
276 wx/xlocale.h
277 wx/xti.h
278 wx/xtistrm.h
279 wx/zipstrm.h
280 wx/zstream.h
281 wx/meta/convertible.h
282 wx/meta/if.h
283 wx/meta/int2type.h
284 wx/meta/movable.h
285 wx/meta/pod.h
286 wx/fswatcher.h
287 wx/generic/fswatcher.h
288 wx/unix/app.h
289 wx/unix/apptbase.h
290 wx/unix/apptrait.h
291 wx/unix/chkconf.h
292 wx/unix/evtloop.h
293 wx/unix/evtloopsrc.h
294 wx/unix/pipe.h
295 wx/unix/stdpaths.h
296 wx/unix/stackwalk.h
297 wx/unix/tls.h
298 wx/unix/fswatcher_kqueue.h
299 wx/unix/execute.h
300 wx/unix/mimetype.h
301 wx/unix/fswatcher_inotify.h
302 wx/fs_inet.h
303 wx/protocol/file.h
304 wx/protocol/ftp.h
305 wx/protocol/http.h
306 wx/protocol/log.h
307 wx/protocol/protocol.h
308 wx/sckaddr.h
309 wx/sckipc.h
310 wx/sckstrm.h
311 wx/socket.h
312 wx/url.h
313 wx/xml/xml.h
314 wx/xtixml.h
315 EOF
316 # --- wxBase headers list ends here ---
317 for f in `cat wxbase-headers-list` ; do
318 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
319 done
320
321 # list of all core headers:
322 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
323
324 # contrib stuff:
325 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
326 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
327
328 # remove wxBase files so that RPM doesn't complain about unpackaged files:
329 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
330 %if %{unicode}
331 rm -f $RPM_BUILD_ROOT%{_libdir}/libwxregexu-%{ver2}.a
332 %endif
333 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
334 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
335
336 %clean
337 rm -rf $RPM_BUILD_ROOT
338
339 %post
340 /sbin/ldconfig
341
342 %postun
343 /sbin/ldconfig
344
345 %post devel
346 # link wx-config when you install RPM.
347 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
348 # link wx-config with explicit name.
349 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
350 /sbin/ldconfig
351
352 %postun devel
353 /sbin/ldconfig
354
355 %preun devel
356 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
357 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
358 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
359 if test "x$SUM1" = "x$SUM2" ; then
360 rm -f %{_bindir}/wx-config
361 fi
362 fi
363 rm -f %{_bindir}/%{wxconfiglink}
364
365 %post gl
366 /sbin/ldconfig
367
368 %postun gl
369 /sbin/ldconfig
370
371 %post contrib
372 /sbin/ldconfig
373
374 %postun contrib
375 /sbin/ldconfig
376
377 %post contrib-devel
378 /sbin/ldconfig
379
380 %postun contrib-devel
381 /sbin/ldconfig
382
383 %files
384 %defattr(-,root,root)
385 %doc COPYING.LIB *.txt
386 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
387 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
388 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
389 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
390 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
391 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
392
393
394 %files devel -f core-headers.files
395 %defattr(-,root,root)
396 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
397 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
398 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
399 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
400 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
401 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
402 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
403 %dir %{_libdir}/wx
404 %{_libdir}/wx/*
405 %{_bindir}/wxrc*
406
407 %files gl
408 %defattr(-,root,root)
409 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
410
411 %files static
412 %defattr (-,root,root)
413 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
414
415 %files contrib
416 %defattr(-,root,root)
417 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
418 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
419 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
420 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
421 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
422 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
423 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
424 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
425 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
426
427 %files contrib-devel
428 %defattr(-,root,root)
429 %dir %{_includedir}/wx-%{ver2}/wx/animate
430 %{_includedir}/wx-%{ver2}/wx/animate/*
431 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
432
433 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
434 %{_includedir}/wx-%{ver2}/wx/deprecated/*
435 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
436
437 %dir %{_includedir}/wx-%{ver2}/wx/fl
438 %{_includedir}/wx-%{ver2}/wx/fl/*
439 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
440
441 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
442 %{_includedir}/wx-%{ver2}/wx/gizmos/*
443 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
444
445 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
446 %{_includedir}/wx-%{ver2}/wx/mmedia/*
447 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
448
449 %dir %{_includedir}/wx-%{ver2}/wx/ogl
450 %{_includedir}/wx-%{ver2}/wx/ogl/*
451 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
452
453 %dir %{_includedir}/wx-%{ver2}/wx/plot
454 %{_includedir}/wx-%{ver2}/wx/plot/*
455 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
456
457 %dir %{_includedir}/wx-%{ver2}/wx/stc
458 %{_includedir}/wx-%{ver2}/wx/stc/*
459 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
460
461 %dir %{_includedir}/wx-%{ver2}/wx/svg
462 %{_includedir}/wx-%{ver2}/wx/svg/*
463 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so