Added wxIsPod<>. Use it in wxAny instead of wxIsMovable<>.
[wxWidgets.git] / wxMotif.spec
1 %define pref /usr
2 %define ver 2.9.1
3 %define ver2 2.9
4 %define rel 1
5
6 %define portname motif
7 %define name wx-%{portname}
8 %define wxbasename wx-base
9
10 %define wxconfig %{portname}-ansi-release-%{ver2}
11 %define wxconfiglink wx%{portname}-%{ver2}-config
12
13 Summary: The Motif/Lesstif port of the wxWidgets library
14 Name: %{name}
15 Version: %{ver}
16 Release: %{rel}
17 License: wxWindows Licence
18 Group: X11/Libraries
19 Source: wxMotif-%{ver}.tar.bz2
20 URL: http://www.wxwidgets.org
21 Packager: wxWidgets developers <wx-dev@lists.wxwidgets.org>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
24
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
28 Provides: wxwin
29 Provides: wxMotif
30
31 %description
32 wxWidgets is a free C++ library for cross-platform GUI development.
33 With wxWidgets, you can create applications for different GUIs (GTK+,
34 Motif/LessTif, MS Windows, Mac) from the same source code.
35
36 %package devel
37 Summary: The Motif/Lesstif port of the wxWidgets library
38 Group: X11/Libraries
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
41
42 %description devel
43 Header files for wxMotif, the Motif/Lesstif port of the wxWidgets library.
44
45 %package gl
46 Summary: The Motif/Lesstif port of the wxWidgets library, OpenGL add-on.
47 Group: X11/Libraries
48 Requires: %{name} = %{ver}
49
50 %description gl
51 OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWidgets library.
52
53 %package static
54 Summary: wxMotif static libraries
55 Group: Development/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
58
59 %description static
60 Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
61
62 %package contrib
63 Summary: Contrib libraries for wxMotif
64 Group: X11/Libraries
65 Requires: %{name} = %{ver}
66
67 %description contrib
68 Contrib libraries for wxMotif
69
70 %package contrib-devel
71 Summary: Contrib libraries for wxMotif
72 Group: X11/Libraries
73 Requires: %{name}-contrib = %{ver}
74 Requires: %{name}-devel = %{ver}
75
76 %description contrib-devel
77 Header files for contributed libraries for wxMotif.
78
79 %prep
80 %setup -q -n wxMotif-%{ver}
81
82 %build
83 if [ "$SMP" != "" ]; then
84 export MAKE="make -j$SMP"
85 else
86 export MAKE="make"
87 fi
88
89 mkdir obj-shared
90 cd obj-shared
91 ../configure --prefix=%{pref} --with-motif --with-opengl
92 $MAKE
93
94 cd contrib/src
95 $MAKE
96 cd ../../..
97
98 mkdir obj-static
99 cd obj-static
100 ../configure --prefix=%{pref} --with-motif --disable-shared --with-opengl
101 $MAKE
102 cd ..
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
107 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
108
109 # Remove headers that are part of wx-base-devel:
110
111 # --- wxBase headers list begins here ---
112 cat <<EOF >wxbase-headers.files
113 wx/afterstd.h
114 wx/any.h
115 wx/anystr.h
116 wx/app.h
117 wx/apptrait.h
118 wx/archive.h
119 wx/arrimpl.cpp
120 wx/arrstr.h
121 wx/atomic.h
122 wx/base64.h
123 wx/beforestd.h
124 wx/buffer.h
125 wx/build.h
126 wx/chartype.h
127 wx/checkeddelete.h
128 wx/chkconf.h
129 wx/clntdata.h
130 wx/cmdargs.h
131 wx/cmdline.h
132 wx/confbase.h
133 wx/config.h
134 wx/convauto.h
135 wx/containr.h
136 wx/cpp.h
137 wx/crt.h
138 wx/datetime.h
139 wx/datstrm.h
140 wx/dde.h
141 wx/debug.h
142 wx/defs.h
143 wx/dir.h
144 wx/dlimpexp.h
145 wx/dlist.h
146 wx/dynarray.h
147 wx/dynlib.h
148 wx/dynload.h
149 wx/encconv.h
150 wx/event.h
151 wx/evtloop.h
152 wx/except.h
153 wx/features.h
154 wx/flags.h
155 wx/ffile.h
156 wx/file.h
157 wx/fileconf.h
158 wx/filefn.h
159 wx/filename.h
160 wx/filesys.h
161 wx/fontenc.h
162 wx/fontmap.h
163 wx/fs_arc.h
164 wx/fs_filter.h
165 wx/fs_mem.h
166 wx/fs_zip.h
167 wx/hash.h
168 wx/hashmap.h
169 wx/hashset.h
170 wx/html/forcelnk.h
171 wx/iconloc.h
172 wx/init.h
173 wx/intl.h
174 wx/iosfwrap.h
175 wx/ioswrap.h
176 wx/ipc.h
177 wx/ipcbase.h
178 wx/kbdstate.h
179 wx/language.h
180 wx/link.h
181 wx/list.h
182 wx/listimpl.cpp
183 wx/log.h
184 wx/longlong.h
185 wx/math.h
186 wx/memconf.h
187 wx/memory.h
188 wx/memtext.h
189 wx/mimetype.h
190 wx/module.h
191 wx/mousestate.h
192 wx/msgout.h
193 wx/msgqueue.h
194 wx/mstream.h
195 wx/object.h
196 wx/platform.h
197 wx/platinfo.h
198 wx/power.h
199 wx/process.h
200 wx/ptr_scpd.h
201 wx/ptr_shrd.h
202 wx/recguard.h
203 wx/regex.h
204 wx/scopedarray.h
205 wx/scopedptr.h
206 wx/scopeguard.h
207 wx/sharedptr.h
208 wx/snglinst.h
209 wx/sstream.h
210 wx/stack.h
211 wx/stackwalk.h
212 wx/stdpaths.h
213 wx/stdstream.h
214 wx/stockitem.h
215 wx/stopwatch.h
216 wx/strconv.h
217 wx/stream.h
218 wx/string.h
219 wx/stringimpl.h
220 wx/stringops.h
221 wx/strvararg.h
222 wx/sysopt.h
223 wx/tarstrm.h
224 wx/textbuf.h
225 wx/textfile.h
226 wx/thread.h
227 wx/thrimpl.cpp
228 wx/timer.h
229 wx/tls.h
230 wx/tokenzr.h
231 wx/tracker.h
232 wx/translation.h
233 wx/txtstrm.h
234 wx/typeinfo.h
235 wx/types.h
236 wx/unichar.h
237 wx/uri.h
238 wx/ustring.h
239 wx/utils.h
240 wx/variant.h
241 wx/vector.h
242 wx/version.h
243 wx/volume.h
244 wx/weakref.h
245 wx/wfstream.h
246 wx/wx.h
247 wx/wxchar.h
248 wx/wxcrt.h
249 wx/wxcrtbase.h
250 wx/wxcrtvararg.h
251 wx/wxprec.h
252 wx/xlocale.h
253 wx/xti.h
254 wx/xtistrm.h
255 wx/zipstrm.h
256 wx/zstream.h
257 wx/meta/convertible.h
258 wx/meta/if.h
259 wx/meta/int2type.h
260 wx/meta/movable.h
261 wx/meta/pod.h
262 wx/fswatcher.h
263 wx/generic/fswatcher.h
264 wx/unix/app.h
265 wx/unix/apptbase.h
266 wx/unix/apptrait.h
267 wx/unix/chkconf.h
268 wx/unix/evtloop.h
269 wx/unix/evtloopsrc.h
270 wx/unix/pipe.h
271 wx/unix/stdpaths.h
272 wx/unix/stackwalk.h
273 wx/unix/tls.h
274 wx/unix/fswatcher_kqueue.h
275 wx/unix/execute.h
276 wx/unix/mimetype.h
277 wx/unix/fswatcher_inotify.h
278 wx/fs_inet.h
279 wx/protocol/file.h
280 wx/protocol/ftp.h
281 wx/protocol/http.h
282 wx/protocol/log.h
283 wx/protocol/protocol.h
284 wx/sckaddr.h
285 wx/sckipc.h
286 wx/sckstrm.h
287 wx/socket.h
288 wx/url.h
289 wx/xml/xml.h
290 wx/xtixml.h
291 EOF
292 # --- wxBase headers list ends here ---
293 for f in `cat wxbase-headers-list` ; do
294 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
295 done
296
297 # list of all core headers:
298 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
299
300 # contrib stuff:
301 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
302 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
303
304 # remove wxBase files so that RPM doesn't complain about unpackaged files:
305 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
306 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
307 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
308
309 %clean
310 rm -rf $RPM_BUILD_ROOT
311
312 %post
313 /sbin/ldconfig
314
315 %postun
316 /sbin/ldconfig
317
318 %post devel
319 # link wx-config when you install RPM.
320 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
321 # link wx-config with explicit name.
322 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
323 /sbin/ldconfig
324
325 %postun devel
326 /sbin/ldconfig
327
328 %preun devel
329 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
330 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
331 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
332 if test "x$SUM1" = "x$SUM2" ; then
333 rm -f %{_bindir}/wx-config
334 fi
335 fi
336 rm -f %{_bindir}/%{wxconfiglink}
337
338 %post gl
339 /sbin/ldconfig
340
341 %postun gl
342 /sbin/ldconfig
343
344 %post contrib
345 /sbin/ldconfig
346
347 %postun contrib
348 /sbin/ldconfig
349
350 %post contrib-devel
351 /sbin/ldconfig
352
353 %postun contrib-devel
354 /sbin/ldconfig
355
356 %files
357 %defattr(-,root,root)
358 %doc COPYING.LIB *.txt
359 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
360 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
361 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
362 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
363 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
364 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
365
366
367 %files devel -f core-headers.files
368 %defattr(-,root,root)
369 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
370 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
371 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
372 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
373 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
374 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
375 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
376 %dir %{_libdir}/wx
377 %{_libdir}/wx/*
378 %{_bindir}/wxrc*
379
380 %files gl
381 %defattr(-,root,root)
382 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
383
384 %files static
385 %defattr (-,root,root)
386 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
387
388 %files contrib
389 %defattr(-,root,root)
390 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
391 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
392 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
393 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
394 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
395 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
396 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
397 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
398 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
399
400 %files contrib-devel
401 %defattr(-,root,root)
402 %dir %{_includedir}/wx-%{ver2}/wx/animate
403 %{_includedir}/wx-%{ver2}/wx/animate/*
404 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
405
406 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
407 %{_includedir}/wx-%{ver2}/wx/deprecated/*
408 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
409
410 %dir %{_includedir}/wx-%{ver2}/wx/fl
411 %{_includedir}/wx-%{ver2}/wx/fl/*
412 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
413
414 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
415 %{_includedir}/wx-%{ver2}/wx/gizmos/*
416 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
417
418 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
419 %{_includedir}/wx-%{ver2}/wx/mmedia/*
420 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
421
422 %dir %{_includedir}/wx-%{ver2}/wx/ogl
423 %{_includedir}/wx-%{ver2}/wx/ogl/*
424 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
425
426 %dir %{_includedir}/wx-%{ver2}/wx/plot
427 %{_includedir}/wx-%{ver2}/wx/plot/*
428 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
429
430 %dir %{_includedir}/wx-%{ver2}/wx/stc
431 %{_includedir}/wx-%{ver2}/wx/stc/*
432 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
433
434 %dir %{_includedir}/wx-%{ver2}/wx/svg
435 %{_includedir}/wx-%{ver2}/wx/svg/*
436 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so