don't build wxBase separately here, this is probably an artefact of monolithic build...
[wxWidgets.git] / wxGTK.spec
1 %define _prefix /usr
2 %define ver 2.7.0
3 %define ver2 2.7
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 1
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 1
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 # "buildname" needs to be e.g. gtk2ud for debug builds
16 %if %{gtk2}
17 %define gtkver 2
18 %define portname gtk2
19 %if %{unicode}
20 %define buildname gtk2u
21 %else
22 %define buildname gtk2
23 %endif
24 %else
25 %define gtkver 1.2
26 %define portname gtk
27 %define buildname gtk
28 %endif
29
30 %if %{unicode}
31 %define name wx-%{portname}-unicode
32 %define wxconfig %{portname}-unicode-release-%{ver2}
33 %define wxconfigstatic %{portname}-unicode-release-static-%{ver2}
34 %define wxconfiglink wx%{portname}u-%{ver2}-config
35 %else
36 %define name wx-%{portname}-ansi
37 %define wxconfig %{portname}-ansi-release-%{ver2}
38 %define wxconfigstatic %{portname}-ansi-release-static-%{ver2}
39 %define wxconfiglink wx%{portname}-%{ver2}-config
40 %endif
41
42 %if %{unicode}
43 %define wxbasename wx-base-unicode
44 %define wxbaseconfig base-unicode-release-%{ver2}
45 %define wxbaseconfigstatic base-unicode-release-static-%{ver2}
46 %define wxbaseconfiglink wxbaseu-%{ver2}-config
47 %else
48 %define wxbasename wx-base-ansi
49 %define wxbaseconfig base-ansi-release-%{ver2}
50 %define wxbaseconfigstatic base-ansi-release-static-%{ver2}
51 %define wxbaseconfiglink wxbase-%{ver2}-config
52 %endif
53
54 Summary: The GTK+ %{gtkver} port of the wxWidgets library
55 Name: %{name}
56 Version: %{ver}
57 Release: %{rel}
58 License: wxWindows Licence
59 Group: X11/Libraries
60 Source: wxGTK-%{ver}.tar.bz2
61 URL: http://www.wxwidgets.org
62 Packager: Vadim Zeitlin <vadim@wxwindows.org>
63 Prefix: %{_prefix}
64 BuildRoot: %{_tmppath}/%{name}-root
65 Requires: %{wxbasename} = %{ver}
66 %if %{portname} == gtk2
67 BuildRequires: gtk+-2.0-devel
68 %else
69 BuildRequires: gtk+-devel >= 1.2.0
70 %endif
71
72 BuildRequires: zlib-devel, libjpeg-devel, libpng-devel, libtiff-devel
73
74 # all packages providing an implementation of wxWidgets library (regardless of
75 # the toolkit used) should provide the (virtual) wxwin package, this makes it
76 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
77 Provides: wxwin
78 Provides: wxGTK
79
80 %description
81 wxWidgets is a free C++ library for cross-platform GUI development.
82 With wxWidgets, you can create applications for different GUIs (GTK+,
83 Motif, MS Windows, MacOS X, Windows CE, GPE) from the same source code.
84
85 %package -n wx-i18n
86 Summary: The translations for the wxWidgets library.
87 Group: X11/Libraries
88
89 %description -n wx-i18n
90 The translations files for the wxWidgets library.
91
92 %package devel
93 Summary: The GTK+ %{gtkver} port of the wxWidgets library
94 Group: X11/Libraries
95 Requires: %{name} = %{ver}
96 Requires: %{wxbasename}-devel = %{ver}
97 Provides: wxGTK-devel
98
99 %description devel
100 The GTK+ %{gtkver} port of the wxWidgets library, header files.
101
102 %package gl
103 Summary: The GTK+ %{gtkver} port of the wxWidgets library, OpenGL add-on.
104 Group: X11/Libraries
105 Requires: %{name} = %{ver}
106 Provides: wxGTK-gl
107
108 %description gl
109 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
110
111 %package -n %{wxbasename}
112 Summary: wxBase library - non-GUI support classes of the wxWidgets toolkit
113 Group: Development/Libraries
114 Provides: wxBase
115
116 %description -n %{wxbasename}
117 wxBase is a collection of C++ classes providing basic data structures (strings,
118 lists, arrays), portable wrappers around many OS-specific funstions (file
119 operations, time/date manipulations, threads, processes, sockets, shared
120 library loading) as well as other utility classes (streams, archive and
121 compression). wxBase currently supports Win32, most Unix variants (Linux,
122 FreeBSD, Solaris, HP-UX) and MacOS X (Carbon and Mach-0).
123
124 %package -n %{wxbasename}-devel
125 Summary: wxBase library, header files.
126 Group: Development/Libraries
127 Provides: wxBase-devel
128
129 %description -n %{wxbasename}-devel
130 wxBase library - non-GUI support classes of the wxWidgets toolkit,
131 header files.
132
133 %package contrib
134 Summary: The GTK+ %{gtkver} port of the wxWidgets library, contributed libraries.
135 Group: X11/Libraries
136 Requires: %{name} = %{ver}
137
138 %description contrib
139 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
140
141 %package contrib-devel
142 Summary: The GTK+ %{gtkver} port of the wxWidgets library
143 Group: X11/Libraries
144 Requires: %{name}-contrib = %{ver}
145 Requires: %{name}-devel = %{ver}
146
147 %description contrib-devel
148 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWidgets library.
149
150 %prep
151 %setup -q -n wxGTK-%{ver}
152
153 %build
154 if [ "$SMP" != "" ]; then
155 export MAKE="make -j$SMP"
156 else
157 export MAKE="make"
158 fi
159
160 mkdir obj-shared
161 cd obj-shared
162 ../configure --prefix=%{_prefix} \
163 %if ! %{gtk2}
164 --with-gtk=1 \
165 %else
166 --with-gtk=2 \
167 %endif
168 %if %{unicode}
169 --enable-unicode \
170 %else
171 --disable-unicode \
172 --with-odbc \
173 %endif
174 --with-opengl
175 $MAKE
176
177 cd contrib/src
178 $MAKE
179 cd ../../..
180
181 mkdir obj-static
182 cd obj-static
183 ../configure --prefix=%{_prefix} \
184 %if ! %{gtk2}
185 --with-gtk=1 \
186 %else
187 --with-gtk=2 \
188 %endif
189 --disable-shared \
190 %if %{unicode}
191 --enable-unicode \
192 %else
193 --disable-unicode \
194 --with-odbc \
195 %endif
196 --with-opengl
197 $MAKE
198
199 cd contrib/src
200 $MAKE
201 cd ../../..
202
203 %install
204 rm -rf $RPM_BUILD_ROOT
205 (cd obj-static; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
206 (cd obj-shared; make DESTDIR=$RPM_BUILD_ROOT prefix=%{_prefix} install)
207
208 # --- wxBase headers list begins here ---
209 cat <<EOF >wxbase-headers.files
210 wx/afterstd.h
211 wx/app.h
212 wx/apptrait.h
213 wx/archive.h
214 wx/arrimpl.cpp
215 wx/arrstr.h
216 wx/beforestd.h
217 wx/buffer.h
218 wx/build.h
219 wx/chkconf.h
220 wx/clntdata.h
221 wx/cmdline.h
222 wx/confbase.h
223 wx/config.h
224 wx/convauto.h
225 wx/containr.h
226 wx/datetime.h
227 wx/datstrm.h
228 wx/dde.h
229 wx/debug.h
230 wx/defs.h
231 wx/dir.h
232 wx/dlimpexp.h
233 wx/dynarray.h
234 wx/dynlib.h
235 wx/dynload.h
236 wx/encconv.h
237 wx/event.h
238 wx/except.h
239 wx/features.h
240 wx/ffile.h
241 wx/file.h
242 wx/fileconf.h
243 wx/filefn.h
244 wx/filename.h
245 wx/filesys.h
246 wx/fontenc.h
247 wx/fontmap.h
248 wx/fs_mem.h
249 wx/fs_zip.h
250 wx/hash.h
251 wx/hashmap.h
252 wx/hashset.h
253 wx/html/forcelnk.h
254 wx/iconloc.h
255 wx/init.h
256 wx/intl.h
257 wx/iosfwrap.h
258 wx/ioswrap.h
259 wx/ipc.h
260 wx/ipcbase.h
261 wx/isql.h
262 wx/isqlext.h
263 wx/link.h
264 wx/list.h
265 wx/listimpl.cpp
266 wx/log.h
267 wx/longlong.h
268 wx/math.h
269 wx/memconf.h
270 wx/memory.h
271 wx/memtext.h
272 wx/mimetype.h
273 wx/module.h
274 wx/msgout.h
275 wx/mstream.h
276 wx/object.h
277 wx/platform.h
278 wx/power.h
279 wx/process.h
280 wx/ptr_scpd.h
281 wx/recguard.h
282 wx/regex.h
283 wx/scopeguard.h
284 wx/snglinst.h
285 wx/sstream.h
286 wx/stack.h
287 wx/stackwalk.h
288 wx/stdpaths.h
289 wx/stockitem.h
290 wx/stopwatch.h
291 wx/strconv.h
292 wx/stream.h
293 wx/string.h
294 wx/sysopt.h
295 wx/textbuf.h
296 wx/textfile.h
297 wx/thread.h
298 wx/thrimpl.cpp
299 wx/timer.h
300 wx/tokenzr.h
301 wx/txtstrm.h
302 wx/types.h
303 wx/uri.h
304 wx/utils.h
305 wx/variant.h
306 wx/vector.h
307 wx/version.h
308 wx/volume.h
309 wx/wfstream.h
310 wx/wx.h
311 wx/wxchar.h
312 wx/wxprec.h
313 wx/xti.h
314 wx/xtistrm.h
315 wx/zipstrm.h
316 wx/zstream.h
317 wx/unix/apptbase.h
318 wx/unix/apptrait.h
319 wx/unix/execute.h
320 wx/unix/mimetype.h
321 wx/unix/pipe.h
322 wx/unix/private.h
323 wx/unix/stackwalk.h
324 wx/unix/stdpaths.h
325 wx/fs_inet.h
326 wx/gsocket.h
327 wx/protocol/file.h
328 wx/protocol/ftp.h
329 wx/protocol/http.h
330 wx/protocol/protocol.h
331 wx/sckaddr.h
332 wx/sckipc.h
333 wx/sckstrm.h
334 wx/socket.h
335 wx/url.h
336 wx/unix/gsockunx.h
337 wx/xml/xml.h
338 wx/xtixml.h
339 wx/db.h
340 wx/dbkeyg.h
341 wx/dbtable.h
342 EOF
343 # --- wxBase headers list ends here ---
344 cat <<EOF >wxbase-headers.paths
345 %{_includedir}/wx-%{ver2}/wx/afterstd.h
346 %{_includedir}/wx-%{ver2}/wx/app.h
347 %{_includedir}/wx-%{ver2}/wx/apptrait.h
348 %{_includedir}/wx-%{ver2}/wx/archive.h
349 %{_includedir}/wx-%{ver2}/wx/arrimpl.cpp
350 %{_includedir}/wx-%{ver2}/wx/arrstr.h
351 %{_includedir}/wx-%{ver2}/wx/beforestd.h
352 %{_includedir}/wx-%{ver2}/wx/buffer.h
353 %{_includedir}/wx-%{ver2}/wx/build.h
354 %{_includedir}/wx-%{ver2}/wx/chkconf.h
355 %{_includedir}/wx-%{ver2}/wx/clntdata.h
356 %{_includedir}/wx-%{ver2}/wx/cmdline.h
357 %{_includedir}/wx-%{ver2}/wx/confbase.h
358 %{_includedir}/wx-%{ver2}/wx/config.h
359 %{_includedir}/wx-%{ver2}/wx/containr.h
360 %{_includedir}/wx-%{ver2}/wx/datetime.h
361 %{_includedir}/wx-%{ver2}/wx/datstrm.h
362 %{_includedir}/wx-%{ver2}/wx/dde.h
363 %{_includedir}/wx-%{ver2}/wx/debug.h
364 %{_includedir}/wx-%{ver2}/wx/defs.h
365 %{_includedir}/wx-%{ver2}/wx/dir.h
366 %{_includedir}/wx-%{ver2}/wx/dlimpexp.h
367 %{_includedir}/wx-%{ver2}/wx/dynarray.h
368 %{_includedir}/wx-%{ver2}/wx/dynlib.h
369 %{_includedir}/wx-%{ver2}/wx/dynload.h
370 %{_includedir}/wx-%{ver2}/wx/encconv.h
371 %{_includedir}/wx-%{ver2}/wx/event.h
372 %{_includedir}/wx-%{ver2}/wx/except.h
373 %{_includedir}/wx-%{ver2}/wx/features.h
374 %{_includedir}/wx-%{ver2}/wx/ffile.h
375 %{_includedir}/wx-%{ver2}/wx/file.h
376 %{_includedir}/wx-%{ver2}/wx/fileconf.h
377 %{_includedir}/wx-%{ver2}/wx/filefn.h
378 %{_includedir}/wx-%{ver2}/wx/filename.h
379 %{_includedir}/wx-%{ver2}/wx/filesys.h
380 %{_includedir}/wx-%{ver2}/wx/fontenc.h
381 %{_includedir}/wx-%{ver2}/wx/fontmap.h
382 %{_includedir}/wx-%{ver2}/wx/fs_mem.h
383 %{_includedir}/wx-%{ver2}/wx/fs_zip.h
384 %{_includedir}/wx-%{ver2}/wx/hash.h
385 %{_includedir}/wx-%{ver2}/wx/hashmap.h
386 %{_includedir}/wx-%{ver2}/wx/hashset.h
387 %{_includedir}/wx-%{ver2}/wx/html/forcelnk.h
388 %{_includedir}/wx-%{ver2}/wx/iconloc.h
389 %{_includedir}/wx-%{ver2}/wx/init.h
390 %{_includedir}/wx-%{ver2}/wx/intl.h
391 %{_includedir}/wx-%{ver2}/wx/iosfwrap.h
392 %{_includedir}/wx-%{ver2}/wx/ioswrap.h
393 %{_includedir}/wx-%{ver2}/wx/ipc.h
394 %{_includedir}/wx-%{ver2}/wx/ipcbase.h
395 %{_includedir}/wx-%{ver2}/wx/isql.h
396 %{_includedir}/wx-%{ver2}/wx/isqlext.h
397 %{_includedir}/wx-%{ver2}/wx/list.h
398 %{_includedir}/wx-%{ver2}/wx/listimpl.cpp
399 %{_includedir}/wx-%{ver2}/wx/log.h
400 %{_includedir}/wx-%{ver2}/wx/longlong.h
401 %{_includedir}/wx-%{ver2}/wx/math.h
402 %{_includedir}/wx-%{ver2}/wx/memconf.h
403 %{_includedir}/wx-%{ver2}/wx/memory.h
404 %{_includedir}/wx-%{ver2}/wx/memtext.h
405 %{_includedir}/wx-%{ver2}/wx/mimetype.h
406 %{_includedir}/wx-%{ver2}/wx/module.h
407 %{_includedir}/wx-%{ver2}/wx/msgout.h
408 %{_includedir}/wx-%{ver2}/wx/mstream.h
409 %{_includedir}/wx-%{ver2}/wx/object.h
410 %{_includedir}/wx-%{ver2}/wx/platform.h
411 %{_includedir}/wx-%{ver2}/wx/process.h
412 %{_includedir}/wx-%{ver2}/wx/ptr_scpd.h
413 %{_includedir}/wx-%{ver2}/wx/regex.h
414 %{_includedir}/wx-%{ver2}/wx/scopeguard.h
415 %{_includedir}/wx-%{ver2}/wx/snglinst.h
416 %{_includedir}/wx-%{ver2}/wx/sstream.h
417 %{_includedir}/wx-%{ver2}/wx/stack.h
418 %{_includedir}/wx-%{ver2}/wx/stackwalk.h
419 %{_includedir}/wx-%{ver2}/wx/stdpaths.h
420 %{_includedir}/wx-%{ver2}/wx/stockitem.h
421 %{_includedir}/wx-%{ver2}/wx/stopwatch.h
422 %{_includedir}/wx-%{ver2}/wx/strconv.h
423 %{_includedir}/wx-%{ver2}/wx/stream.h
424 %{_includedir}/wx-%{ver2}/wx/string.h
425 %{_includedir}/wx-%{ver2}/wx/sysopt.h
426 %{_includedir}/wx-%{ver2}/wx/textbuf.h
427 %{_includedir}/wx-%{ver2}/wx/textfile.h
428 %{_includedir}/wx-%{ver2}/wx/thread.h
429 %{_includedir}/wx-%{ver2}/wx/thrimpl.cpp
430 %{_includedir}/wx-%{ver2}/wx/timer.h
431 %{_includedir}/wx-%{ver2}/wx/tokenzr.h
432 %{_includedir}/wx-%{ver2}/wx/txtstrm.h
433 %{_includedir}/wx-%{ver2}/wx/types.h
434 %{_includedir}/wx-%{ver2}/wx/uri.h
435 %{_includedir}/wx-%{ver2}/wx/utils.h
436 %{_includedir}/wx-%{ver2}/wx/variant.h
437 %{_includedir}/wx-%{ver2}/wx/vector.h
438 %{_includedir}/wx-%{ver2}/wx/version.h
439 %{_includedir}/wx-%{ver2}/wx/volume.h
440 %{_includedir}/wx-%{ver2}/wx/wfstream.h
441 %{_includedir}/wx-%{ver2}/wx/wx.h
442 %{_includedir}/wx-%{ver2}/wx/wxchar.h
443 %{_includedir}/wx-%{ver2}/wx/wxprec.h
444 %{_includedir}/wx-%{ver2}/wx/xti.h
445 %{_includedir}/wx-%{ver2}/wx/xtistrm.h
446 %{_includedir}/wx-%{ver2}/wx/zipstrm.h
447 %{_includedir}/wx-%{ver2}/wx/zstream.h
448 %{_includedir}/wx-%{ver2}/wx/fs_inet.h
449 %{_includedir}/wx-%{ver2}/wx/gsocket.h
450 %{_includedir}/wx-%{ver2}/wx/protocol/file.h
451 %{_includedir}/wx-%{ver2}/wx/protocol/ftp.h
452 %{_includedir}/wx-%{ver2}/wx/protocol/http.h
453 %{_includedir}/wx-%{ver2}/wx/protocol/protocol.h
454 %{_includedir}/wx-%{ver2}/wx/sckaddr.h
455 %{_includedir}/wx-%{ver2}/wx/sckipc.h
456 %{_includedir}/wx-%{ver2}/wx/sckstrm.h
457 %{_includedir}/wx-%{ver2}/wx/socket.h
458 %{_includedir}/wx-%{ver2}/wx/url.h
459 %{_includedir}/wx-%{ver2}/wx/xml/xml.h
460 %{_includedir}/wx-%{ver2}/wx/xtixml.h
461 %{_includedir}/wx-%{ver2}/wx/db.h
462 %{_includedir}/wx-%{ver2}/wx/dbkeyg.h
463 %{_includedir}/wx-%{ver2}/wx/dbtable.h
464 %{_includedir}/wx-%{ver2}/wx/unix/apptbase.h
465 %{_includedir}/wx-%{ver2}/wx/unix/apptrait.h
466 %{_includedir}/wx-%{ver2}/wx/unix/execute.h
467 %{_includedir}/wx-%{ver2}/wx/unix/gsockunx.h
468 %{_includedir}/wx-%{ver2}/wx/unix/mimetype.h
469 %{_includedir}/wx-%{ver2}/wx/unix/pipe.h
470 %{_includedir}/wx-%{ver2}/wx/unix/stackwalk.h
471 %{_includedir}/wx-%{ver2}/wx/unix/stdpaths.h
472 EOF
473 # --- wxBase headers list ends here ---
474
475 # temporarily remove base headers
476 mkdir $RPM_BUILD_ROOT/_save_dir
477 cp -r $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} $RPM_BUILD_ROOT/_save_dir
478 for f in `cat wxbase-headers.files` ; do
479 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
480 done
481 # list of all core headers:
482 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
483 # move base headers (actually all headers) back again
484 cp -f -r $RPM_BUILD_ROOT/_save_dir/* $RPM_BUILD_ROOT%{_includedir}
485 rm -rf $RPM_BUILD_ROOT/_save_dir
486
487 # contrib stuff:
488 (cd obj-shared/contrib/src; make DESTDIR=$RPM_BUILD_ROOT install)
489 (cd obj-shared/utils/wxrc; make DESTDIR=$RPM_BUILD_ROOT install)
490
491 %clean
492 rm -rf $RPM_BUILD_ROOT
493
494 %post
495 /sbin/ldconfig
496
497 %postun
498 /sbin/ldconfig
499
500 %post devel
501 # link wx-config when you install RPM.
502 %if %{unicode}
503 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
504 %endif
505 # link wx-config with explicit name.
506 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
507 /sbin/ldconfig
508
509 %postun devel
510 /sbin/ldconfig
511
512 %preun devel
513 %if %{unicode}
514 rm -f %{_bindir}/wx-config
515 %endif
516 rm -f %{_bindir}/%{wxconfiglink}
517
518 %post -n %{wxbasename}
519 /sbin/ldconfig
520
521 %postun -n %{wxbasename}
522 /sbin/ldconfig
523
524 %post -n %{wxbasename}-devel
525 # link wx-config with explicit name.
526 ln -sf %{_libdir}/wx/config/%{wxbaseconfig} %{_bindir}/%{wxbaseconfiglink}
527 /sbin/ldconfig
528
529 %postun -n %{wxbasename}-devel
530 /sbin/ldconfig
531
532 %preun -n %{wxbasename}-devel
533 rm -f %{_bindir}/%{wxbaseconfiglink}
534
535 %post gl
536 /sbin/ldconfig
537
538 %postun gl
539 /sbin/ldconfig
540
541 %post contrib
542 /sbin/ldconfig
543
544 %postun contrib
545 /sbin/ldconfig
546
547 %post contrib-devel
548 /sbin/ldconfig
549
550 %postun contrib-devel
551 /sbin/ldconfig
552
553 %files
554 %defattr(-,root,root)
555 %doc COPYING.LIB *.txt
556 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so.*
557 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so.*
558 %if !%{unicode}
559 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so.*
560 %endif
561 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so.*
562 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so.*
563 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so.*
564 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so.*
565
566 %files -n wx-i18n
567 %defattr(-,root,root)
568
569 %files devel -f core-headers.files
570 %defattr(-,root,root)
571 # shared libs
572 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.so
573 %{_libdir}/libwx_%{buildname}_core-%{ver2}.so
574 %if !%{unicode}
575 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.so
576 %endif
577 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so
578 %{_libdir}/libwx_%{buildname}_html-%{ver2}.so
579 %{_libdir}/libwx_%{buildname}_media-%{ver2}.so
580 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.so
581 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.so
582 # static libs
583 %{_libdir}/libwx_%{buildname}_adv-%{ver2}.a
584 %{_libdir}/libwx_%{buildname}_core-%{ver2}.a
585 %if !%{unicode}
586 %{_libdir}/libwx_%{buildname}_dbgrid-%{ver2}.a
587 %endif
588 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.a
589 %{_libdir}/libwx_%{buildname}_html-%{ver2}.a
590 %{_libdir}/libwx_%{buildname}_media-%{ver2}.a
591 %{_libdir}/libwx_%{buildname}_qa-%{ver2}.a
592 %{_libdir}/libwx_%{buildname}_xrc-%{ver2}.a
593 %dir %{_libdir}/wx
594 %{_libdir}/wx/config/%{wxconfig}
595 %{_libdir}/wx/include/%{wxconfig}/wx/setup.h
596 %{_libdir}/wx/config/%{wxconfigstatic}
597 %{_libdir}/wx/include/%{wxconfigstatic}/wx/setup.h
598 %{_bindir}/wxrc*
599
600 %files -n %{wxbasename}
601 %defattr(-,root,root)
602 %{_libdir}/libwx_base*-%{ver2}.so.*
603
604 %files -n %{wxbasename}-devel -f wxbase-headers.paths
605 %defattr (-,root,root)
606 %dir %{_includedir}/wx-%{ver2}
607 %{_libdir}/libwx_base*-%{ver2}.so
608 %{_libdir}/libwx_base*-%{ver2}.a
609 %if %{unicode}
610 %{_libdir}/libwxregexu-%{ver2}.a
611 %endif
612 %dir %{_libdir}/wx
613 %{_libdir}/wx/config/%{wxbaseconfig}
614 %{_libdir}/wx/include/%{wxbaseconfig}/wx/setup.h
615 %{_libdir}/wx/config/%{wxbaseconfigstatic}
616 %{_libdir}/wx/include/%{wxbaseconfigstatic}/wx/setup.h
617 %{_datadir}/aclocal/*.m4
618
619 %files gl
620 %defattr(-,root,root)
621 %{_libdir}/libwx_%{buildname}_gl-%{ver2}.so.*
622
623 %files contrib
624 %defattr(-,root,root)
625 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so.*
626 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so.*
627 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so.*
628 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so.*
629 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so.*
630 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so.*
631 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so.*
632 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so.*
633 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so.*
634 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so.*
635
636 %files contrib-devel
637 %defattr(-,root,root)
638 %dir %{_includedir}/wx-%{ver2}/wx/animate
639 %{_includedir}/wx-%{ver2}/wx/animate/*
640 %{_libdir}/libwx_%{buildname}_animate-%{ver2}.so
641
642 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
643 %{_includedir}/wx-%{ver2}/wx/deprecated/*
644 %{_libdir}/libwx_%{buildname}_deprecated-%{ver2}.so
645
646 %dir %{_includedir}/wx-%{ver2}/wx/fl
647 %{_includedir}/wx-%{ver2}/wx/fl/*
648 %{_libdir}/libwx_%{buildname}_fl-%{ver2}.so
649
650 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
651 %{_includedir}/wx-%{ver2}/wx/gizmos/*
652 %{_libdir}/libwx_%{buildname}_gizmos-%{ver2}.so
653 %{_libdir}/libwx_%{buildname}_gizmos_xrc-%{ver2}.so
654
655 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
656 %{_includedir}/wx-%{ver2}/wx/mmedia/*
657 %{_libdir}/libwx_%{buildname}_mmedia-%{ver2}.so
658
659 %dir %{_includedir}/wx-%{ver2}/wx/ogl
660 %{_includedir}/wx-%{ver2}/wx/ogl/*
661 %{_libdir}/libwx_%{buildname}_ogl-%{ver2}.so
662
663 %dir %{_includedir}/wx-%{ver2}/wx/plot
664 %{_includedir}/wx-%{ver2}/wx/plot/*
665 %{_libdir}/libwx_%{buildname}_plot-%{ver2}.so
666
667 %dir %{_includedir}/wx-%{ver2}/wx/stc
668 %{_includedir}/wx-%{ver2}/wx/stc/*
669 %{_libdir}/libwx_%{buildname}_stc-%{ver2}.so
670
671 %dir %{_includedir}/wx-%{ver2}/wx/svg
672 %{_includedir}/wx-%{ver2}/wx/svg/*
673 %{_libdir}/libwx_%{buildname}_svg-%{ver2}.so