7 %define name wx
-%{portname}
8 %define wxbasename wx
-base
10 %define wxconfig
%{portname}-ansi-release-%{ver2}
11 %define wxconfiglink wx
%{portname}-%{ver2}-config
13 Summary: The Motif
/Lesstif port of the wxWidgets library
17 License: wxWindows Licence
19 Source: wxMotif
-%{ver}.tar.bz2
20 URL: http
://www.wxwidgets.org
21 Packager: wxWidgets developers
<wx
-dev@lists.wxwidgets.org
>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
32 wxWidgets is a free C
++ library
for cross
-platform GUI development.
33 With wxWidgets
, you can create applications
for different GUIs
(GTK
+,
34 Motif
/LessTif
, MS Windows
, Mac
) from the same
source code.
37 Summary: The Motif
/Lesstif port of the wxWidgets library
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
43 Header files
for wxMotif
, the Motif
/Lesstif port of the wxWidgets library.
46 Summary: The Motif
/Lesstif port of the wxWidgets library
, OpenGL add
-on.
48 Requires: %{name} = %{ver}
51 OpenGL add
-on library
for wxMotif
, the Motif
/Lesstif port of the wxWidgets library.
54 Summary: wxMotif static libraries
55 Group: Development
/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
60 Static libraries
for wxMotif. You need them
if you want to link statically against wxMotif.
63 Summary: Contrib libraries
for wxMotif
65 Requires: %{name} = %{ver}
68 Contrib libraries
for wxMotif
70 %package contrib
-devel
71 Summary: Contrib libraries
for wxMotif
73 Requires: %{name}-contrib = %{ver}
74 Requires: %{name}-devel = %{ver}
76 %description contrib
-devel
77 Header files
for contributed libraries
for wxMotif.
80 %setup -q
-n wxMotif
-%{ver}
83 if [ "$SMP"
!= ""
]; then
84 export MAKE
="
make -j$SMP"
91 ..
/configure
--prefix
=%{pref} --with
-motif
--with
-odbc
--with
-opengl
100 ..
/configure
--prefix
=%{pref} --with
-motif
--disable
-shared
--with
-odbc
--with
-opengl
105 rm -rf $RPM_BUILD_ROOT
106 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
107 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
109 # Remove headers that are part of wx-base-devel:
111 # --- wxBase headers list begins here ---
112 cat
<<EOF
>wxbase
-headers.files
239 wx
/protocol
/protocol.h
252 # --- wxBase headers list ends here ---
253 for f
in `cat wxbase
-headers
-list`
; do
254 rm -f $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2}/$f
257 # list of all core headers:
258 find $RPM_BUILD_ROOT
%{_includedir}/wx-%{ver2} -type f | sed
-e "s
,$RPM_BUILD_ROOT
,,g"
>core
-headers.files
261 (cd obj
-shared
/contrib
/src
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
262 (cd obj
-shared
/utils
/wxrc
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
264 # remove wxBase files so that RPM doesn't complain about unpackaged files:
265 rm -f $RPM_BUILD_ROOT
%{_libdir}/libwx_base
*
266 rm -f $RPM_BUILD_ROOT
%{_datadir}/aclocal
/*
267 rm -f $RPM_BUILD_ROOT
%{_datadir}/locale
/*/*/*
270 rm -rf $RPM_BUILD_ROOT
279 # link wx-config when you install RPM.
280 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx
-config
281 # link wx-config with explicit name.
282 ln
-sf
%{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
289 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
290 SUM1
=`md5sum
%{_libdir}/wx/config/%{wxconfig} | cut
-c
0-32`
291 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
292 if test "x$SUM1"
= "x$SUM2"
; then
293 rm -f
%{_bindir}/wx
-config
296 rm -f
%{_bindir}/%{wxconfiglink}
313 %postun contrib
-devel
317 %defattr(-,root
,root
)
318 %doc COPYING.LIB
*.txt
319 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.
*
320 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.
*
321 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so.
*
322 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.
*
323 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.
*
324 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.
*
325 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.
*
328 %files devel
-f core
-headers.files
329 %defattr(-,root
,root
)
330 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
331 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
332 %{_libdir}/libwx_%{portname}*_dbgrid-%{ver2}.so
333 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
334 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
335 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
336 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
337 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
343 %defattr(-,root
,root
)
344 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.
*
347 %defattr (-,root
,root
)
348 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
351 %defattr(-,root
,root
)
352 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.
*
353 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.
*
354 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.
*
355 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.
*
356 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.
*
357 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.
*
358 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.
*
359 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.
*
360 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.
*
363 %defattr(-,root
,root
)
364 %dir %{_includedir}/wx-%{ver2}/wx
/animate
365 %{_includedir}/wx-%{ver2}/wx
/animate
/*
366 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
368 %dir %{_includedir}/wx-%{ver2}/wx
/deprecated
369 %{_includedir}/wx-%{ver2}/wx
/deprecated
/*
370 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
372 %dir %{_includedir}/wx-%{ver2}/wx
/fl
373 %{_includedir}/wx-%{ver2}/wx
/fl
/*
374 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
376 %dir %{_includedir}/wx-%{ver2}/wx
/gizmos
377 %{_includedir}/wx-%{ver2}/wx
/gizmos
/*
378 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
380 %dir %{_includedir}/wx-%{ver2}/wx
/mmedia
381 %{_includedir}/wx-%{ver2}/wx
/mmedia
/*
382 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
384 %dir %{_includedir}/wx-%{ver2}/wx
/ogl
385 %{_includedir}/wx-%{ver2}/wx
/ogl
/*
386 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
388 %dir %{_includedir}/wx-%{ver2}/wx
/plot
389 %{_includedir}/wx-%{ver2}/wx
/plot
/*
390 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
392 %dir %{_includedir}/wx-%{ver2}/wx
/stc
393 %{_includedir}/wx-%{ver2}/wx
/stc
/*
394 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
396 %dir %{_includedir}/wx-%{ver2}/wx
/svg
397 %{_includedir}/wx-%{ver2}/wx
/svg
/*
398 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so