]> git.saurik.com Git - wxWidgets.git/blob - wxGTK.spec
compilation fix
[wxWidgets.git] / wxGTK.spec
1 %define pref /usr
2 %define ver 2.5.3
3 %define ver2 2.5
4 %define rel 1
5
6 # Configurable settings (use --with(out) {unicode,gtk2} on rpmbuild cmd line):
7 %define unicode 0
8 %{?_with_unicode: %{expand: %%define unicode 1}}
9 %{?_without_unicode: %{expand: %%define unicode 0}}
10
11 %define gtk2 0
12 %{?_with_gtk2: %{expand: %%define gtk2 1}}
13 %{?_without_gtk2: %{expand: %%define gtk2 0}}
14
15 %if %{gtk2}
16 %define gtkver 2
17 %define portname gtk2
18 %else
19 %define gtkver 1.2
20 %define portname gtk
21 %endif
22
23 %if %{unicode}
24 %define name wx-%{portname}-unicode
25 %define wxbasename wx-base-unicode
26 %else
27 %define name wx-%{portname}
28 %define wxbasename wx-base
29 %endif
30
31 %if %{unicode}
32 %define wxconfigname wx%{portname}u-%{ver2}-config
33 %else
34 %define wxconfigname wx%{portname}-%{ver2}-config
35 %endif
36
37 Name: %{name}
38 Summary: The GTK+ %{gtkver} port of the wxWindows library
39 Version: %{ver}
40 Release: %{rel}
41 License: wxWindows Licence
42 Group: X11/Libraries
43 Source: wxGTK-%{ver}.tar.bz2
44 URL: http://www.wxwindows.org
45 Packager: Vadim Zeitlin <vadim@wxwindows.org>
46 Prefix: %{pref}
47 BuildRoot: /var/tmp/%{name}-root
48
49 # all packages providing an implementation of wxWindows library (regardless of
50 # the toolkit used) should provide the (virtual) wxwin package, this makes it
51 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
52 Provides: wxwin
53 Provides: wxGTK
54
55 # in addition, we should provide libwx_gtk as automatic generator only notices
56 # libwx_gtk-%{ver}-%{rel}
57 Provides: libwx_gtk.so
58 Provides: libwx_gtk-%{ver2}.so
59
60 Requires: %{wxbasename} = %{ver}
61
62 %description
63 wxWindows is a free C++ library for cross-platform GUI development.
64 With wxWindows, you can create applications for different GUIs (GTK+,
65 Motif/LessTif, MS Windows, Mac) from the same source code.
66
67 %package devel
68 Summary: The GTK+ %{gtkver} port of the wxWindows library
69 Group: X11/Libraries
70 Requires: %{name} = %{ver}
71 Requires: %{wxbasename}-devel = %{ver}
72 Provides: wxGTK-devel
73
74 %description devel
75 Header files for wxGTK, the GTK+ %{gtkver} port of the wxWindows library.
76
77 %package gl
78 Summary: The GTK+ %{gtkver} port of the wxWindows library, OpenGL add-on.
79 Group: X11/Libraries
80 Requires: %{name} = %{ver}
81
82 %description gl
83 OpenGL add-on library for wxGTK, the GTK+ %{gtkver} port of the wxWindows library.
84
85 %package static
86 Summary: wxGTK static libraries
87 Group: Development/Libraries
88 Requires: %{wxbasename}-static
89
90 %description static
91 Static libraries for wxGTK. You need them if you want to link statically against wxGTK.
92
93 %package contrib
94 Summary: The GTK+ %{gtkver} port of the wxWindows library, contributed libraries.
95 Group: X11/Libraries
96 Requires: %{name} = %{ver}
97
98 %description contrib
99 Contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWindows library.
100
101 %package contrib-devel
102 Summary: The GTK+ %{gtkver} port of the wxWindows library
103 Group: X11/Libraries
104 Requires: %{name}-contrib = %{ver}
105 Requires: %{name}-devel = %{ver}
106
107 %description contrib-devel
108 Header files for contributed libraries for wxGTK, the GTK+ %{gtkver} port of the wxWindows library.
109
110 %prep
111 %setup -q -n wxGTK-%{ver}
112
113 %build
114 if [ "$SMP" != "" ]; then
115 export MAKE="make -j$SMP"
116 else
117 export MAKE="make"
118 fi
119
120 mkdir obj-shared
121 cd obj-shared
122 ../configure --prefix=%{pref} \
123 %if %{unicode}
124 --enable-unicode \
125 %else
126 --with-odbc \
127 %endif
128 %if %{gtk2}
129 --enable-gtk2 \
130 %endif
131 --with-opengl
132 $MAKE
133 cd contrib/src
134 $MAKE
135 cd ../../..
136
137 mkdir obj-static
138 cd obj-static
139 ../configure --prefix=%{pref} --disable-shared \
140 %if %{unicode}
141 --enable-unicode \
142 %else
143 --with-odbc \
144 %endif
145 %if %{gtk2}
146 --enable-gtk2 \
147 %endif
148 --with-opengl
149 $MAKE
150 cd ..
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
155 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
156
157 # Remove headers that are part of wx-base-devel:
158
159 # --- wxBase headers list begins here ---
160 cat <<EOF >wxbase-headers-list
161 wx/afterstd.h
162 wx/app.h
163 wx/apptrait.h
164 wx/archive.h
165 wx/arrimpl.cpp
166 wx/arrstr.h
167 wx/beforestd.h
168 wx/buffer.h
169 wx/build.h
170 wx/chkconf.h
171 wx/clntdata.h
172 wx/cmdline.h
173 wx/confbase.h
174 wx/config.h
175 wx/containr.h
176 wx/datetime.h
177 wx/datetime.inl
178 wx/datstrm.h
179 wx/dde.h
180 wx/debug.h
181 wx/defs.h
182 wx/dir.h
183 wx/dlimpexp.h
184 wx/dynarray.h
185 wx/dynlib.h
186 wx/dynload.h
187 wx/encconv.h
188 wx/event.h
189 wx/except.h
190 wx/features.h
191 wx/ffile.h
192 wx/file.h
193 wx/fileconf.h
194 wx/filefn.h
195 wx/filename.h
196 wx/filesys.h
197 wx/fontenc.h
198 wx/fontmap.h
199 wx/fs_mem.h
200 wx/fs_zip.h
201 wx/hash.h
202 wx/hashmap.h
203 wx/hashset.h
204 wx/iconloc.h
205 wx/init.h
206 wx/intl.h
207 wx/iosfwrap.h
208 wx/ioswrap.h
209 wx/ipc.h
210 wx/ipcbase.h
211 wx/isql.h
212 wx/isqlext.h
213 wx/list.h
214 wx/listimpl.cpp
215 wx/log.h
216 wx/longlong.h
217 wx/math.h
218 wx/memconf.h
219 wx/memory.h
220 wx/memtext.h
221 wx/mimetype.h
222 wx/module.h
223 wx/msgout.h
224 wx/msgout.h
225 wx/mstream.h
226 wx/object.h
227 wx/platform.h
228 wx/process.h
229 wx/ptr_scpd.h
230 wx/regex.h
231 wx/scopeguard.h
232 wx/snglinst.h
233 wx/sstream.h
234 wx/stack.h
235 wx/stackwalk.h
236 wx/stdpaths.h
237 wx/stockitem.h
238 wx/stopwatch.h
239 wx/strconv.h
240 wx/stream.h
241 wx/string.h
242 wx/sysopt.h
243 wx/textbuf.h
244 wx/textfile.h
245 wx/thread.h
246 wx/thrimpl.cpp
247 wx/timer.h
248 wx/tokenzr.h
249 wx/txtstrm.h
250 wx/types.h
251 wx/uri.h
252 wx/utils.h
253 wx/variant.h
254 wx/vector.h
255 wx/version.h
256 wx/volume.h
257 wx/wfstream.h
258 wx/wx.h
259 wx/wxchar.h
260 wx/wxprec.h
261 wx/xti.h
262 wx/xtistrm.h
263 wx/zipstrm.h
264 wx/zstream.h
265 wx/msw/apptrait.h
266 wx/msw/apptbase.h
267 wx/msw/chkconf.h
268 wx/msw/crashrpt.h
269 wx/msw/dde.h
270 wx/msw/debughlp.h
271 wx/msw/gccpriv.h
272 wx/msw/mimetype.h
273 wx/msw/stackwalk.h
274 wx/msw/winundef.h
275 wx/msw/wrapcctl.h
276 wx/msw/wrapwin.h
277 wx/fs_inet.h
278 wx/gsocket.h
279 wx/protocol/file.h
280 wx/protocol/ftp.h
281 wx/protocol/http.h
282 wx/protocol/protocol.h
283 wx/sckaddr.h
284 wx/sckipc.h
285 wx/sckstrm.h
286 wx/socket.h
287 wx/url.h
288 wx/msw/gsockmsw.h
289 wx/xml/xml.h
290 wx/xtixml.h
291 wx/db.h
292 wx/dbkeyg.h
293 wx/dbtable.h
294 EOF
295 # --- wxBase headers list ends here ---
296 for f in `cat wxbase-headers-list` ; do
297 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-*/$f
298 done
299
300 # list of all core headers:
301 find $RPM_BUILD_ROOT/usr/include/wx -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
302
303 # contrib stuff:
304 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
305 (cd obj-shared/contrib/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
306
307 # remove wxBase files so that RPM doesn't complain about unpackaged files:
308 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
309 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
310 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
311
312 %clean
313 rm -rf $RPM_BUILD_ROOT
314
315 %post
316 /sbin/ldconfig
317
318 %postun
319 /sbin/ldconfig
320
321 %post gl
322 /sbin/ldconfig
323
324 %postun gl
325 /sbin/ldconfig
326
327
328 %files
329 %defattr(-,root,root)
330 %doc COPYING.LIB *.txt
331 %dir %{_datadir}/wx
332 %{_datadir}/wx/*
333 %{_libdir}/libwx_%{portname}*_core*.so.*
334 %{_libdir}/libwx_%{portname}*_html*.so.*
335 %{_libdir}/libwx_%{portname}*_adv*.so.*
336 %if !%{unicode}
337 %{_libdir}/libwx_%{portname}*_dbgrid*.so.*
338 %endif
339
340 %files devel -f core-headers.files
341 %defattr(-,root,root)
342 %{_libdir}/libwx_%{portname}*_core*.so
343 %{_libdir}/libwx_%{portname}*_html*.so
344 %{_libdir}/libwx_%{portname}*_adv*.so
345 %if !%{unicode}
346 %{_libdir}/libwx_%{portname}*_dbgrid*.so
347 %endif
348 %{_libdir}/libwx_%{portname}*_gl*.so
349 %dir %{_libdir}/wx
350 %{_libdir}/wx/*
351 %{_bindir}/%{wxconfigname}
352
353 %files gl
354 %defattr(-,root,root)
355 %{_libdir}/libwx_%{portname}*_gl*.so.*
356
357 %files static
358 %defattr (-,root,root)
359 %{_libdir}/libwx_gtk*.a
360
361 %files contrib
362 %defattr(-,root,root)
363 %{_libdir}/libwx_%{portname}*_animate*.so.*
364 %{_libdir}/libwx_%{portname}*_deprecated*.so.*
365 %{_libdir}/libwx_%{portname}*_fl*.so.*
366 %{_libdir}/libwx_%{portname}*_gizmos*.so.*
367 %{_libdir}/libwx_%{portname}*_mmedia*.so.*
368 %{_libdir}/libwx_%{portname}*_ogl*.so.*
369 %{_libdir}/libwx_%{portname}*_plot*.so.*
370 %{_libdir}/libwx_%{portname}*_stc*.so.*
371 %{_libdir}/libwx_%{portname}*_svg*.so.*
372 %{_libdir}/libwx_%{portname}*_xrc*.so.*
373
374 %files contrib-devel
375 %defattr(-,root,root)
376 %{_bindir}/wxrc
377 %dir %{_includedir}/wx-*/wx/animate
378 %{_includedir}/wx-*/wx/animate/*
379 %{_libdir}/libwx_%{portname}*_animate*.so
380
381 %dir %{_includedir}/wx-*/wx/deprecated
382 %{_includedir}/wx-*/wx/deprecated/*
383 %{_libdir}/libwx_%{portname}*_deprecated*.so
384
385 %dir %{_includedir}/wx-*/wx/fl
386 %{_includedir}/wx-*/wx/fl/*
387 %{_libdir}/libwx_%{portname}*_fl*.so
388
389 %dir %{_includedir}/wx-*/wx/gizmos
390 %{_includedir}/wx-*/wx/gizmos/*
391 %{_libdir}/libwx_%{portname}*_gizmos*.so
392
393 %dir %{_includedir}/wx-*/wx/mmedia
394 %{_includedir}/wx-*/wx/mmedia/*
395 %{_libdir}/libwx_%{portname}*_mmedia*.so
396
397 %dir %{_includedir}/wx-*/wx/ogl
398 %{_includedir}/wx-*/wx/ogl/*
399 %{_libdir}/libwx_%{portname}*_ogl*.so
400
401 %dir %{_includedir}/wx-*/wx/plot
402 %{_includedir}/wx-*/wx/plot/*
403 %{_libdir}/libwx_%{portname}*_plot*.so
404
405 %dir %{_includedir}/wx-*/wx/stc
406 %{_includedir}/wx-*/wx/stc/*
407 %{_libdir}/libwx_%{portname}*_stc*.so
408
409 %dir %{_includedir}/wx-*/wx/svg
410 %{_includedir}/wx-*/wx/svg/*
411 %{_libdir}/libwx_%{portname}*_svg*.so
412
413 %dir %{_includedir}/wx-*/wx/xrc
414 %{_includedir}/wx-*/wx/xrc/*
415 %{_libdir}/libwx_%{portname}*_xrc*.so