added wxProtocolLog class for logging network requests/responses (closes #7464)
[wxWidgets.git] / wxMotif.spec
1 %define pref /usr
2 %define ver 2.9.0
3 %define ver2 2.9
4 %define rel 1
5
6 %define portname motif
7 %define name wx-%{portname}
8 %define wxbasename wx-base
9
10 %define wxconfig %{portname}-ansi-release-%{ver2}
11 %define wxconfiglink wx%{portname}-%{ver2}-config
12
13 Summary: The Motif/Lesstif port of the wxWidgets library
14 Name: %{name}
15 Version: %{ver}
16 Release: %{rel}
17 License: wxWindows Licence
18 Group: X11/Libraries
19 Source: wxMotif-%{ver}.tar.bz2
20 URL: http://www.wxwidgets.org
21 Packager: wxWidgets developers <wx-dev@lists.wxwidgets.org>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
24
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
28 Provides: wxwin
29 Provides: wxMotif
30
31 %description
32 wxWidgets is a free C++ library for cross-platform GUI development.
33 With wxWidgets, you can create applications for different GUIs (GTK+,
34 Motif/LessTif, MS Windows, Mac) from the same source code.
35
36 %package devel
37 Summary: The Motif/Lesstif port of the wxWidgets library
38 Group: X11/Libraries
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
41
42 %description devel
43 Header files for wxMotif, the Motif/Lesstif port of the wxWidgets library.
44
45 %package gl
46 Summary: The Motif/Lesstif port of the wxWidgets library, OpenGL add-on.
47 Group: X11/Libraries
48 Requires: %{name} = %{ver}
49
50 %description gl
51 OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWidgets library.
52
53 %package static
54 Summary: wxMotif static libraries
55 Group: Development/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
58
59 %description static
60 Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
61
62 %package contrib
63 Summary: Contrib libraries for wxMotif
64 Group: X11/Libraries
65 Requires: %{name} = %{ver}
66
67 %description contrib
68 Contrib libraries for wxMotif
69
70 %package contrib-devel
71 Summary: Contrib libraries for wxMotif
72 Group: X11/Libraries
73 Requires: %{name}-contrib = %{ver}
74 Requires: %{name}-devel = %{ver}
75
76 %description contrib-devel
77 Header files for contributed libraries for wxMotif.
78
79 %prep
80 %setup -q -n wxMotif-%{ver}
81
82 %build
83 if [ "$SMP" != "" ]; then
84 export MAKE="make -j$SMP"
85 else
86 export MAKE="make"
87 fi
88
89 mkdir obj-shared
90 cd obj-shared
91 ../configure --prefix=%{pref} --with-motif --with-opengl
92 $MAKE
93
94 cd contrib/src
95 $MAKE
96 cd ../../..
97
98 mkdir obj-static
99 cd obj-static
100 ../configure --prefix=%{pref} --with-motif --disable-shared --with-opengl
101 $MAKE
102 cd ..
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
107 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
108
109 # Remove headers that are part of wx-base-devel:
110
111 # --- wxBase headers list begins here ---
112 cat <<EOF >wxbase-headers.files
113 wx/afterstd.h
114 wx/app.h
115 wx/apptrait.h
116 wx/archive.h
117 wx/arrimpl.cpp
118 wx/arrstr.h
119 wx/atomic.h
120 wx/base64.h
121 wx/beforestd.h
122 wx/buffer.h
123 wx/build.h
124 wx/chartype.h
125 wx/checkeddelete.h
126 wx/chkconf.h
127 wx/clntdata.h
128 wx/cmdargs.h
129 wx/cmdline.h
130 wx/confbase.h
131 wx/config.h
132 wx/convauto.h
133 wx/containr.h
134 wx/cpp.h
135 wx/crt.h
136 wx/datetime.h
137 wx/datstrm.h
138 wx/dde.h
139 wx/debug.h
140 wx/defs.h
141 wx/dir.h
142 wx/dlimpexp.h
143 wx/dlist.h
144 wx/dynarray.h
145 wx/dynlib.h
146 wx/dynload.h
147 wx/encconv.h
148 wx/event.h
149 wx/except.h
150 wx/features.h
151 wx/flags.h
152 wx/ffile.h
153 wx/file.h
154 wx/fileconf.h
155 wx/filefn.h
156 wx/filename.h
157 wx/filesys.h
158 wx/fontenc.h
159 wx/fontmap.h
160 wx/fs_arc.h
161 wx/fs_filter.h
162 wx/fs_mem.h
163 wx/fs_zip.h
164 wx/hash.h
165 wx/hashmap.h
166 wx/hashset.h
167 wx/html/forcelnk.h
168 wx/iconloc.h
169 wx/init.h
170 wx/intl.h
171 wx/iosfwrap.h
172 wx/ioswrap.h
173 wx/ipc.h
174 wx/ipcbase.h
175 wx/kbdstate.h
176 wx/link.h
177 wx/list.h
178 wx/listimpl.cpp
179 wx/log.h
180 wx/longlong.h
181 wx/math.h
182 wx/memconf.h
183 wx/memory.h
184 wx/memtext.h
185 wx/mimetype.h
186 wx/module.h
187 wx/mousestate.h
188 wx/msgout.h
189 wx/mstream.h
190 wx/object.h
191 wx/platform.h
192 wx/platinfo.h
193 wx/power.h
194 wx/process.h
195 wx/ptr_scpd.h
196 wx/ptr_shrd.h
197 wx/recguard.h
198 wx/regex.h
199 wx/scopedarray.h
200 wx/scopedptr.h
201 wx/scopeguard.h
202 wx/sharedptr.h
203 wx/snglinst.h
204 wx/sstream.h
205 wx/stack.h
206 wx/stackwalk.h
207 wx/stdpaths.h
208 wx/stockitem.h
209 wx/stopwatch.h
210 wx/strconv.h
211 wx/stream.h
212 wx/string.h
213 wx/stringimpl.h
214 wx/stringops.h
215 wx/strvararg.h
216 wx/sysopt.h
217 wx/tarstrm.h
218 wx/textbuf.h
219 wx/textfile.h
220 wx/thread.h
221 wx/thrimpl.cpp
222 wx/timer.h
223 wx/tls.h
224 wx/tokenzr.h
225 wx/tracker.h
226 wx/txtstrm.h
227 wx/types.h
228 wx/unichar.h
229 wx/uri.h
230 wx/ustring.h
231 wx/utils.h
232 wx/variant.h
233 wx/vector.h
234 wx/version.h
235 wx/volume.h
236 wx/weakref.h
237 wx/wfstream.h
238 wx/wx.h
239 wx/wxchar.h
240 wx/wxcrt.h
241 wx/wxcrtbase.h
242 wx/wxcrtvararg.h
243 wx/wxprec.h
244 wx/xlocale.h
245 wx/xti.h
246 wx/xtistrm.h
247 wx/zipstrm.h
248 wx/zstream.h
249 wx/meta/convertible.h
250 wx/meta/if.h
251 wx/meta/int2type.h
252 wx/meta/movable.h
253 wx/unix/app.h
254 wx/unix/apptbase.h
255 wx/unix/apptrait.h
256 wx/unix/chkconf.h
257 wx/unix/evtloop.h
258 wx/unix/pipe.h
259 wx/unix/stdpaths.h
260 wx/unix/stackwalk.h
261 wx/unix/tls.h
262 wx/unix/execute.h
263 wx/unix/mimetype.h
264 wx/fs_inet.h
265 wx/protocol/file.h
266 wx/protocol/ftp.h
267 wx/protocol/http.h
268 wx/protocol/log.h
269 wx/protocol/protocol.h
270 wx/sckaddr.h
271 wx/sckipc.h
272 wx/sckstrm.h
273 wx/socket.h
274 wx/url.h
275 wx/xml/xml.h
276 wx/xtixml.h
277 EOF
278 # --- wxBase headers list ends here ---
279 for f in `cat wxbase-headers-list` ; do
280 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
281 done
282
283 # list of all core headers:
284 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
285
286 # contrib stuff:
287 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
288 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
289
290 # remove wxBase files so that RPM doesn't complain about unpackaged files:
291 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
292 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
293 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
294
295 %clean
296 rm -rf $RPM_BUILD_ROOT
297
298 %post
299 /sbin/ldconfig
300
301 %postun
302 /sbin/ldconfig
303
304 %post devel
305 # link wx-config when you install RPM.
306 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
307 # link wx-config with explicit name.
308 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
309 /sbin/ldconfig
310
311 %postun devel
312 /sbin/ldconfig
313
314 %preun devel
315 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
316 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
317 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
318 if test "x$SUM1" = "x$SUM2" ; then
319 rm -f %{_bindir}/wx-config
320 fi
321 fi
322 rm -f %{_bindir}/%{wxconfiglink}
323
324 %post gl
325 /sbin/ldconfig
326
327 %postun gl
328 /sbin/ldconfig
329
330 %post contrib
331 /sbin/ldconfig
332
333 %postun contrib
334 /sbin/ldconfig
335
336 %post contrib-devel
337 /sbin/ldconfig
338
339 %postun contrib-devel
340 /sbin/ldconfig
341
342 %files
343 %defattr(-,root,root)
344 %doc COPYING.LIB *.txt
345 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
346 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
347 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
348 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
349 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
350 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
351
352
353 %files devel -f core-headers.files
354 %defattr(-,root,root)
355 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
356 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
357 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
358 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
359 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
360 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
361 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
362 %dir %{_libdir}/wx
363 %{_libdir}/wx/*
364 %{_bindir}/wxrc*
365
366 %files gl
367 %defattr(-,root,root)
368 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
369
370 %files static
371 %defattr (-,root,root)
372 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
373
374 %files contrib
375 %defattr(-,root,root)
376 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
377 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
378 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
379 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
380 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
381 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
382 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
383 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
384 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
385
386 %files contrib-devel
387 %defattr(-,root,root)
388 %dir %{_includedir}/wx-%{ver2}/wx/animate
389 %{_includedir}/wx-%{ver2}/wx/animate/*
390 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
391
392 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
393 %{_includedir}/wx-%{ver2}/wx/deprecated/*
394 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
395
396 %dir %{_includedir}/wx-%{ver2}/wx/fl
397 %{_includedir}/wx-%{ver2}/wx/fl/*
398 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
399
400 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
401 %{_includedir}/wx-%{ver2}/wx/gizmos/*
402 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
403
404 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
405 %{_includedir}/wx-%{ver2}/wx/mmedia/*
406 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
407
408 %dir %{_includedir}/wx-%{ver2}/wx/ogl
409 %{_includedir}/wx-%{ver2}/wx/ogl/*
410 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
411
412 %dir %{_includedir}/wx-%{ver2}/wx/plot
413 %{_includedir}/wx-%{ver2}/wx/plot/*
414 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
415
416 %dir %{_includedir}/wx-%{ver2}/wx/stc
417 %{_includedir}/wx-%{ver2}/wx/stc/*
418 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
419
420 %dir %{_includedir}/wx-%{ver2}/wx/svg
421 %{_includedir}/wx-%{ver2}/wx/svg/*
422 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so