6 Summary: wxBase library
- non
-GUI support classes of wxWindows toolkit
10 Copyright: wxWindows Licence
11 Group: Development
/Libraries
12 Source: wxBase
-%{ver}.tar.bz2
13 URL: http
://www.wxwindows.org
14 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
16 BuildRoot: /var
/tmp
/%{name}-root
19 wxBase is a collection of C
++ classes providing basic data structures
(strings
,
20 lists
, arrays
), powerful wxDateTime class
for date manipulations
, portable
21 wrappers around many OS
-specific functions allowing to build the same program
22 under all supported folders
, wxThread class
for writing multithreaded programs
23 using either Win32 or POSIX threads and much more. wxBase currently supports
24 the following platforms
: Win32
, generic Unix
(Linux
, FreeBSD
, Solaris
, HP
-UX
,
28 Summary: wxBase headers needed
for developping with wxBase
29 Group: Development
/Libraries
33 Header files
for wxBase. You need them to develop programs using wxBase.
36 %setup -n wxBase
-%{ver}
37 .
/configure
--prefix
=%{pref} --enable-soname
--disable
-gui
--disable
-std_iostreams
40 if [ "$SMP"
!= ""
]; then
41 export MAKE
="
make -j$SMP"
46 (cd locale
; make allmo
)
49 rm -rf $RPM_BUILD_ROOT
50 make prefix
=$RPM_BUILD_ROOT
%{pref} install
53 rm -rf $RPM_BUILD_ROOT
62 # Install wx-config if there isn't any
63 if test ! -f
%{_bindir}/wx
-config
; then
64 ln
-sf wxbase
-%{ver2}-config %{_bindir}/wx
-config
68 # Remove wx-config if it points to this package
69 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
70 SUM1
=`md5sum
%{_bindir}/wxbase-%{ver2}-config | cut
-c
0-32`
71 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
72 if test "x$SUM1"
= "x$SUM2"
; then
73 rm -f
%{_bindir}/wx
-config
78 %defattr (-,root
,root
)
79 %doc COPYING.LIB
*.txt
80 %{_libdir}/libwx_base
*so.
*
81 %{_datadir}/locale
/*/*/*.mo
84 %defattr (-,root
,root
)
85 %dir %{_includedir}/wx
87 %{_libdir}/libwx_base
*.so
90 %{_bindir}/wxbase-%{ver2}-config