Updated version numbers to 2.3.1
[wxWidgets.git] / wxWINE.spec
1 # Note that this is NOT a relocatable package
2 %define pref /usr
3 %define ver 2.3.1
4 %define rel 1
5
6 Summary: The WINE port of the wxWindows library
7 Name: wxWINE
8 Version: %{ver}
9 Release: %{rel}
10 Copyright: wxWindows Licence
11 Group: X11/Libraries
12 Source: ftp://wesley.informatik.uni-freiburg.de/pub/linux/wxxt/source/wxWINE-2.1.0-b8.tgz
13 URL: http://wesley.informatik.uni-freiburg.de/~wxxt/docs.html
14 Packager: Robert Roebling <roebling@ruf.uni-freiburg.de>
15 BuildRoot: /tmp/wxwine_root
16
17 # all packages providing an implementation of wxWindows library (regardless of
18 # the toolkit used) should provide the (virtual) wxwin package, this makes it
19 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxqt..."
20 Provides: wxwin
21
22 %description
23 wxWindows is a free C++ library for cross-platform GUI development.
24 With wxWindows, you can create applications for different GUIs (GTK+,
25 Motif/LessTif, MS Windows, Mac) from the same source code.
26
27 %prep
28 %setup -n wxWINE
29 ./configure --prefix=%{pref}
30
31 %build
32 make
33
34 %install
35 rm -rf $RPM_BUILD_ROOT
36 make prefix=$RPM_BUILD_ROOT%{pref} install
37
38 %clean
39 rm -rf $RPM_BUILD_ROOT
40
41 %post
42 /sbin/ldconfig
43
44 %postun
45 /sbin/ldconfig
46
47 %files
48 %defattr (644, root, root, 755)
49 %doc COPYING.LIB INSTALL.txt LICENCE.txt README.txt SYMBOLS.txt TODO.txt
50 %dir %{pref}/include/wx
51 %{pref}/include/wx/*
52 %dir %{pref}/lib/wx
53 %{pref}/lib/wx/*
54 %dir %{pref}/share/wx
55 %{pref}/share/wx/*
56 %attr(755, -, -) %{pref}/lib/libwx_msw*
57 %attr(755, -, -) %{pref}/bin/wx-config
58