6 Summary: wxBase library
- non
-GUI support classes of wxWindows toolkit
10 Copyright: wxWindows Licence
11 Group: Development
/Libraries
12 Source: wxBase
-%{ver}.tar.bz2
13 URL: http
://www.wxwindows.org
14 Packager: Vadim Zeitlin
<vadim@wxwindows.org
>
16 BuildRoot: /var
/tmp
/%{name}-root
19 wxBase is a collection of C
++ classes providing basic data structures
(strings
,
20 lists
, arrays
), powerful wxDateTime class
for date manipulations
, portable
21 wrappers around many OS
-specific functions allowing to build the same program
22 under all supported folders
, wxThread class
for writing multithreaded programs
23 using either Win32 or POSIX threads and much more. wxBase currently supports
24 the following platforms
: Win32
, generic Unix
(Linux
, FreeBSD
, Solaris
, HP
-UX
,
28 Summary: wxBase headers needed
for developping with wxBase
29 Group: Development
/Libraries
30 Requires: wxBase
= %{ver}
33 Header files
for wxBase. You need them to develop programs using wxBase.
36 Summary: wxBase static libraries
37 Group: Development
/Libraries
40 Static libraries
for wxBase. You need them
if you want to link statically against wxBase.
43 %setup -n wxBase
-%{ver}
46 if [ "$SMP"
!= ""
]; then
47 export MAKE
="
make -j$SMP"
52 (cd locale
; make allmo
)
56 ..
/configure
--prefix
=%{pref} --enable-soname
--disable
-gui
--disable
-std_iostreams
62 ..
/configure
--prefix
=%{pref} --disable
-shared
--disable
-gui
--disable
-std_iostreams
67 rm -rf $RPM_BUILD_ROOT
68 (cd obj
-static
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
69 (cd obj
-shared
; make prefix
=$RPM_BUILD_ROOT
%{pref} install)
74 rm -rf $RPM_BUILD_ROOT
83 # Install wx-config if there isn't any
84 if test ! -f
%{_bindir}/wx
-config
; then
85 ln
-sf wxbase
-%{ver2}-config %{_bindir}/wx
-config
89 # Remove wx-config if it points to this package
90 if test -f
%{_bindir}/wx
-config
-a
-f
/usr
/bin
/md5sum
; then
91 SUM1
=`md5sum
%{_bindir}/wxbase-%{ver2}-config | cut
-c
0-32`
92 SUM2
=`md5sum
%{_bindir}/wx
-config | cut
-c
0-32`
93 if test "x$SUM1"
= "x$SUM2"
; then
94 rm -f
%{_bindir}/wx
-config
99 %defattr (-,root
,root
)
100 %doc COPYING.LIB
*.txt
101 %{_libdir}/libwx_base
*so.
*
104 %defattr (-,root
,root
)
105 %dir %{_includedir}/wx
107 %{_libdir}/libwx_base
*.so
110 %{_bindir}/wxbase-%{ver2}-config
111 %{_datadir}/aclocal
/*.m4
114 %defattr (-,root
,root
)