Move wx/evtloop.h from GUI_CMN_HDR to BASE_CMN_HDR in files.bkl.
[wxWidgets.git] / wxMotif.spec
1 %define pref /usr
2 %define ver 2.9.1
3 %define ver2 2.9
4 %define rel 1
5
6 %define portname motif
7 %define name wx-%{portname}
8 %define wxbasename wx-base
9
10 %define wxconfig %{portname}-ansi-release-%{ver2}
11 %define wxconfiglink wx%{portname}-%{ver2}-config
12
13 Summary: The Motif/Lesstif port of the wxWidgets library
14 Name: %{name}
15 Version: %{ver}
16 Release: %{rel}
17 License: wxWindows Licence
18 Group: X11/Libraries
19 Source: wxMotif-%{ver}.tar.bz2
20 URL: http://www.wxwidgets.org
21 Packager: wxWidgets developers <wx-dev@lists.wxwidgets.org>
22 BuildRoot: %{_tmppath}/%{name}-root
23 Requires: %{wxbasename} = %{ver}
24
25 # all packages providing an implementation of wxWidgets library (regardless of
26 # the toolkit used) should provide the (virtual) wxwin package, this makes it
27 # possible to require wxwin instead of requiring "wxgtk or wxmotif or wxuniv..."
28 Provides: wxwin
29 Provides: wxMotif
30
31 %description
32 wxWidgets is a free C++ library for cross-platform GUI development.
33 With wxWidgets, you can create applications for different GUIs (GTK+,
34 Motif/LessTif, MS Windows, Mac) from the same source code.
35
36 %package devel
37 Summary: The Motif/Lesstif port of the wxWidgets library
38 Group: X11/Libraries
39 Requires: %{name} = %{ver}
40 Requires: %{wxbasename}-devel = %{ver}
41
42 %description devel
43 Header files for wxMotif, the Motif/Lesstif port of the wxWidgets library.
44
45 %package gl
46 Summary: The Motif/Lesstif port of the wxWidgets library, OpenGL add-on.
47 Group: X11/Libraries
48 Requires: %{name} = %{ver}
49
50 %description gl
51 OpenGL add-on library for wxMotif, the Motif/Lesstif port of the wxWidgets library.
52
53 %package static
54 Summary: wxMotif static libraries
55 Group: Development/Libraries
56 Requires: %{wxbasename}-static
57 Requires: %{name}-devel = %{ver}
58
59 %description static
60 Static libraries for wxMotif. You need them if you want to link statically against wxMotif.
61
62 %package contrib
63 Summary: Contrib libraries for wxMotif
64 Group: X11/Libraries
65 Requires: %{name} = %{ver}
66
67 %description contrib
68 Contrib libraries for wxMotif
69
70 %package contrib-devel
71 Summary: Contrib libraries for wxMotif
72 Group: X11/Libraries
73 Requires: %{name}-contrib = %{ver}
74 Requires: %{name}-devel = %{ver}
75
76 %description contrib-devel
77 Header files for contributed libraries for wxMotif.
78
79 %prep
80 %setup -q -n wxMotif-%{ver}
81
82 %build
83 if [ "$SMP" != "" ]; then
84 export MAKE="make -j$SMP"
85 else
86 export MAKE="make"
87 fi
88
89 mkdir obj-shared
90 cd obj-shared
91 ../configure --prefix=%{pref} --with-motif --with-opengl
92 $MAKE
93
94 cd contrib/src
95 $MAKE
96 cd ../../..
97
98 mkdir obj-static
99 cd obj-static
100 ../configure --prefix=%{pref} --with-motif --disable-shared --with-opengl
101 $MAKE
102 cd ..
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 (cd obj-static; make prefix=$RPM_BUILD_ROOT%{pref} install)
107 (cd obj-shared; make prefix=$RPM_BUILD_ROOT%{pref} install)
108
109 # Remove headers that are part of wx-base-devel:
110
111 # --- wxBase headers list begins here ---
112 cat <<EOF >wxbase-headers.files
113 wx/afterstd.h
114 wx/any.h
115 wx/anystr.h
116 wx/app.h
117 wx/apptrait.h
118 wx/archive.h
119 wx/arrimpl.cpp
120 wx/arrstr.h
121 wx/atomic.h
122 wx/base64.h
123 wx/beforestd.h
124 wx/buffer.h
125 wx/build.h
126 wx/chartype.h
127 wx/checkeddelete.h
128 wx/chkconf.h
129 wx/clntdata.h
130 wx/cmdargs.h
131 wx/cmdline.h
132 wx/confbase.h
133 wx/config.h
134 wx/convauto.h
135 wx/containr.h
136 wx/cpp.h
137 wx/crt.h
138 wx/datetime.h
139 wx/datstrm.h
140 wx/dde.h
141 wx/debug.h
142 wx/defs.h
143 wx/dir.h
144 wx/dlimpexp.h
145 wx/dlist.h
146 wx/dynarray.h
147 wx/dynlib.h
148 wx/dynload.h
149 wx/encconv.h
150 wx/event.h
151 wx/evtloop.h
152 wx/except.h
153 wx/features.h
154 wx/flags.h
155 wx/ffile.h
156 wx/file.h
157 wx/fileconf.h
158 wx/filefn.h
159 wx/filename.h
160 wx/filesys.h
161 wx/fontenc.h
162 wx/fontmap.h
163 wx/fs_arc.h
164 wx/fs_filter.h
165 wx/fs_mem.h
166 wx/fs_zip.h
167 wx/hash.h
168 wx/hashmap.h
169 wx/hashset.h
170 wx/html/forcelnk.h
171 wx/iconloc.h
172 wx/init.h
173 wx/intl.h
174 wx/iosfwrap.h
175 wx/ioswrap.h
176 wx/ipc.h
177 wx/ipcbase.h
178 wx/kbdstate.h
179 wx/link.h
180 wx/list.h
181 wx/listimpl.cpp
182 wx/log.h
183 wx/longlong.h
184 wx/math.h
185 wx/memconf.h
186 wx/memory.h
187 wx/memtext.h
188 wx/mimetype.h
189 wx/module.h
190 wx/mousestate.h
191 wx/msgout.h
192 wx/mstream.h
193 wx/object.h
194 wx/platform.h
195 wx/platinfo.h
196 wx/power.h
197 wx/process.h
198 wx/ptr_scpd.h
199 wx/ptr_shrd.h
200 wx/recguard.h
201 wx/regex.h
202 wx/scopedarray.h
203 wx/scopedptr.h
204 wx/scopeguard.h
205 wx/sharedptr.h
206 wx/snglinst.h
207 wx/sstream.h
208 wx/stack.h
209 wx/stackwalk.h
210 wx/stdpaths.h
211 wx/stdstream.h
212 wx/stockitem.h
213 wx/stopwatch.h
214 wx/strconv.h
215 wx/stream.h
216 wx/string.h
217 wx/stringimpl.h
218 wx/stringops.h
219 wx/strvararg.h
220 wx/sysopt.h
221 wx/tarstrm.h
222 wx/textbuf.h
223 wx/textfile.h
224 wx/thread.h
225 wx/thrimpl.cpp
226 wx/timer.h
227 wx/tls.h
228 wx/tokenzr.h
229 wx/tracker.h
230 wx/txtstrm.h
231 wx/typeinfo.h
232 wx/types.h
233 wx/unichar.h
234 wx/uri.h
235 wx/ustring.h
236 wx/utils.h
237 wx/variant.h
238 wx/vector.h
239 wx/version.h
240 wx/volume.h
241 wx/weakref.h
242 wx/wfstream.h
243 wx/wx.h
244 wx/wxchar.h
245 wx/wxcrt.h
246 wx/wxcrtbase.h
247 wx/wxcrtvararg.h
248 wx/wxprec.h
249 wx/xlocale.h
250 wx/xti.h
251 wx/xtistrm.h
252 wx/zipstrm.h
253 wx/zstream.h
254 wx/meta/convertible.h
255 wx/meta/if.h
256 wx/meta/int2type.h
257 wx/meta/movable.h
258 wx/fswatcher.h
259 wx/generic/fswatcher.h
260 wx/unix/app.h
261 wx/unix/apptbase.h
262 wx/unix/apptrait.h
263 wx/unix/chkconf.h
264 wx/unix/evtloop.h
265 wx/unix/evtloopsrc.h
266 wx/unix/pipe.h
267 wx/unix/stdpaths.h
268 wx/unix/stackwalk.h
269 wx/unix/tls.h
270 wx/unix/fswatcher_kqueue.h
271 wx/unix/execute.h
272 wx/unix/mimetype.h
273 wx/unix/fswatcher_inotify.h
274 wx/fs_inet.h
275 wx/protocol/file.h
276 wx/protocol/ftp.h
277 wx/protocol/http.h
278 wx/protocol/log.h
279 wx/protocol/protocol.h
280 wx/sckaddr.h
281 wx/sckipc.h
282 wx/sckstrm.h
283 wx/socket.h
284 wx/url.h
285 wx/xml/xml.h
286 wx/xtixml.h
287 EOF
288 # --- wxBase headers list ends here ---
289 for f in `cat wxbase-headers-list` ; do
290 rm -f $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2}/$f
291 done
292
293 # list of all core headers:
294 find $RPM_BUILD_ROOT%{_includedir}/wx-%{ver2} -type f | sed -e "s,$RPM_BUILD_ROOT,,g" >core-headers.files
295
296 # contrib stuff:
297 (cd obj-shared/contrib/src; make prefix=$RPM_BUILD_ROOT%{pref} install)
298 (cd obj-shared/utils/wxrc; make prefix=$RPM_BUILD_ROOT%{pref} install)
299
300 # remove wxBase files so that RPM doesn't complain about unpackaged files:
301 rm -f $RPM_BUILD_ROOT%{_libdir}/libwx_base*
302 rm -f $RPM_BUILD_ROOT%{_datadir}/aclocal/*
303 rm -f $RPM_BUILD_ROOT%{_datadir}/locale/*/*/*
304
305 %clean
306 rm -rf $RPM_BUILD_ROOT
307
308 %post
309 /sbin/ldconfig
310
311 %postun
312 /sbin/ldconfig
313
314 %post devel
315 # link wx-config when you install RPM.
316 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/wx-config
317 # link wx-config with explicit name.
318 ln -sf %{_libdir}/wx/config/%{wxconfig} %{_bindir}/%{wxconfiglink}
319 /sbin/ldconfig
320
321 %postun devel
322 /sbin/ldconfig
323
324 %preun devel
325 if test -f %{_bindir}/wx-config -a -f /usr/bin/md5sum ; then
326 SUM1=`md5sum %{_libdir}/wx/config/%{wxconfig} | cut -c 0-32`
327 SUM2=`md5sum %{_bindir}/wx-config | cut -c 0-32`
328 if test "x$SUM1" = "x$SUM2" ; then
329 rm -f %{_bindir}/wx-config
330 fi
331 fi
332 rm -f %{_bindir}/%{wxconfiglink}
333
334 %post gl
335 /sbin/ldconfig
336
337 %postun gl
338 /sbin/ldconfig
339
340 %post contrib
341 /sbin/ldconfig
342
343 %postun contrib
344 /sbin/ldconfig
345
346 %post contrib-devel
347 /sbin/ldconfig
348
349 %postun contrib-devel
350 /sbin/ldconfig
351
352 %files
353 %defattr(-,root,root)
354 %doc COPYING.LIB *.txt
355 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so.*
356 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so.*
357 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so.*
358 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so.*
359 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so.*
360 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so.*
361
362
363 %files devel -f core-headers.files
364 %defattr(-,root,root)
365 %{_libdir}/libwx_%{portname}*_adv-%{ver2}.so
366 %{_libdir}/libwx_%{portname}*_core-%{ver2}.so
367 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so
368 %{_libdir}/libwx_%{portname}*_html-%{ver2}.so
369 %{_libdir}/libwx_%{portname}*_media-%{ver2}.so
370 %{_libdir}/libwx_%{portname}*_qa-%{ver2}.so
371 %{_libdir}/libwx_%{portname}*_xrc-%{ver2}.so
372 %dir %{_libdir}/wx
373 %{_libdir}/wx/*
374 %{_bindir}/wxrc*
375
376 %files gl
377 %defattr(-,root,root)
378 %{_libdir}/libwx_%{portname}*_gl-%{ver2}.so.*
379
380 %files static
381 %defattr (-,root,root)
382 %{_libdir}/libwx_%{portname}*_*-%{ver2}.a
383
384 %files contrib
385 %defattr(-,root,root)
386 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so.*
387 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so.*
388 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so.*
389 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so.*
390 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so.*
391 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so.*
392 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so.*
393 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so.*
394 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so.*
395
396 %files contrib-devel
397 %defattr(-,root,root)
398 %dir %{_includedir}/wx-%{ver2}/wx/animate
399 %{_includedir}/wx-%{ver2}/wx/animate/*
400 %{_libdir}/libwx_%{portname}*_animate-%{ver2}.so
401
402 %dir %{_includedir}/wx-%{ver2}/wx/deprecated
403 %{_includedir}/wx-%{ver2}/wx/deprecated/*
404 %{_libdir}/libwx_%{portname}*_deprecated-%{ver2}.so
405
406 %dir %{_includedir}/wx-%{ver2}/wx/fl
407 %{_includedir}/wx-%{ver2}/wx/fl/*
408 %{_libdir}/libwx_%{portname}*_fl-%{ver2}.so
409
410 %dir %{_includedir}/wx-%{ver2}/wx/gizmos
411 %{_includedir}/wx-%{ver2}/wx/gizmos/*
412 %{_libdir}/libwx_%{portname}*_gizmos-%{ver2}.so
413
414 %dir %{_includedir}/wx-%{ver2}/wx/mmedia
415 %{_includedir}/wx-%{ver2}/wx/mmedia/*
416 %{_libdir}/libwx_%{portname}*_mmedia-%{ver2}.so
417
418 %dir %{_includedir}/wx-%{ver2}/wx/ogl
419 %{_includedir}/wx-%{ver2}/wx/ogl/*
420 %{_libdir}/libwx_%{portname}*_ogl-%{ver2}.so
421
422 %dir %{_includedir}/wx-%{ver2}/wx/plot
423 %{_includedir}/wx-%{ver2}/wx/plot/*
424 %{_libdir}/libwx_%{portname}*_plot-%{ver2}.so
425
426 %dir %{_includedir}/wx-%{ver2}/wx/stc
427 %{_includedir}/wx-%{ver2}/wx/stc/*
428 %{_libdir}/libwx_%{portname}*_stc-%{ver2}.so
429
430 %dir %{_includedir}/wx-%{ver2}/wx/svg
431 %{_includedir}/wx-%{ver2}/wx/svg/*
432 %{_libdir}/libwx_%{portname}*_svg-%{ver2}.so